From e1a3798497932675f7b2417b1dd6554d777d76e6 Mon Sep 17 00:00:00 2001
From: Thomas Woerner <twoerner@redhat.com>
Date: Tue, 11 Feb 2025 18:52:32 +0100
Subject: [PATCH] - Release 11.11, Support BIND 9.18   Resolves: RHEL-78925

---
 .gitignore           |  2 ++
 bind-dyndb-ldap.spec | 62 +++++++++++++++++++++++++++++---------------
 sources              |  4 +--
 3 files changed, 45 insertions(+), 23 deletions(-)

diff --git a/.gitignore b/.gitignore
index 853d520..cc3e2d7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -57,3 +57,5 @@ bind-dyndb-ldap-0.1.0b.tar.bz2
 /bind-dyndb-ldap-11.9.tar.bz2.asc
 /bind-dyndb-ldap-11.10.tar.bz2
 /bind-dyndb-ldap-11.10.tar.bz2.asc
+/bind-dyndb-ldap-11.11.tar.bz2
+/bind-dyndb-ldap-11.11.tar.bz2.asc
diff --git a/bind-dyndb-ldap.spec b/bind-dyndb-ldap.spec
index fab8914..bd3b6ed 100644
--- a/bind-dyndb-ldap.spec
+++ b/bind-dyndb-ldap.spec
@@ -1,7 +1,8 @@
 
 %define VERSION %{version}
 
-%define bind_version 32:9.16.16
+%define bind_name bind
+%define bind_version 32:9.18.33-2
 
 %if 0%{?fedora} >= 31 || 0%{?rhel} > 8
 %if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
@@ -18,8 +19,8 @@
 %endif
 
 Name:           bind-dyndb-ldap
-Version:        11.10
-Release:        28%{?dist}
+Version:        11.11
+Release:        1%{?dist}
 Summary:        LDAP back-end plug-in for BIND
 
 License:        GPLv2+
@@ -27,19 +28,34 @@ URL:            https://releases.pagure.org/bind-dyndb-ldap
 Source0:        https://releases.pagure.org/%{name}/%{name}-%{VERSION}.tar.bz2
 Source1:        https://releases.pagure.org/%{name}/%{name}-%{VERSION}.tar.bz2.asc
 
-# https://pagure.io/bind-dyndb-ldap/pull-request/217
-# https://pagure.io/bind-dyndb-ldap/c/00131b7b72daa953ab2bf5e6a4fd5508052debb0
-Patch1:         bind-dyndb-ldap-bind-9.18.10-db-options.patch
-# https://pagure.io/bind-dyndb-ldap/c/47902df23bf637e6c7ece67b928339e0fda58ae0
-Patch2:         bind-dyndb-ldap-bind-9.18.10-logs.patch
-# https://pagure.io/bind-dyndb-ldap/c/5dd2fefa0bc7cd7689004cec64304c3a02be9eab
-Patch3:         bind-dyndb-ldap-bind-9.18.10-staleok.patch
-Patch4: bind-dyndb-ldap-11.10-bind-9.18.11.patch
-Patch5: bind-dyndb-ldap-11.10-bind-9.18.13.patch
-# https://pagure.io/bind-dyndb-ldap/pull-request/226
-Patch6: bind-dyndb-ldap-11.10-bind-9.18.19.patch
+%if "%{bind_name}" != "bind" && 0%{?rhel} == 9
+Obsoletes: bind < 32:9.18
+Obsoletes: bind-chroot <= 32:9.18
+Obsoletes: bind-devel <= 32:9.18
+Obsoletes: bind-dlz-filesystem <= 32:9.18
+Obsoletes: bind-dlz-ldap <= 32:9.18
+Obsoletes: bind-dlz-mysql <= 32:9.18
+Obsoletes: bind-dlz-sqlite3 <= 32:9.18
+Obsoletes: bind-dnssec-doc <= 32:9.18
+Obsoletes: bind-dnssec-utils <= 32:9.18
+Obsoletes: bind-doc <= 32:9.18
+Obsoletes: bind-license <= 32:9.18
+Obsoletes: bind-libs <= 32:9.18
+Obsoletes: bind-utils <= 32:9.18
+Obsoletes: python3-bind <= 32:9.18
+%endif
+%if "%{bind_name}" != "bind9.18" && 0%{?rhel} > 9
+Obsoletes: bind9.18 <= 32:9.18
+Obsoletes: bind9.18-chroot <= 32:9.18
+Obsoletes: bind9.18-devel <= 32:9.18
+Obsoletes: bind9.18-dnssec-doc <= 32:9.18
+Obsoletes: bind9.18-dnssec-utils <= 32:9.18
+Obsoletes: bind9.18-doc <= 32:9.18
+Obsoletes: bind9.18-libs <= 32:9.18
+Obsoletes: bind9.18-utils <= 32:9.18
+%endif
 
-BuildRequires:  bind-devel >= %{bind_version}, bind-lite-devel >= %{bind_version}
+BuildRequires:  %{bind_name}-devel >= %{bind_version}, %{bind_name}-lite-devel >= %{bind_version}
 BuildRequires:  krb5-devel
 BuildRequires:  openldap-devel
 BuildRequires:  libuuid-devel
@@ -50,16 +66,16 @@ BuildRequires:  autoconf-archive
 Conflicts: bind9-next
 
 %if %{with bind_pkcs11}
-BuildRequires:  bind-pkcs11-devel >= %{bind_version}
+BuildRequires:  %{bind_name}-pkcs11-devel >= %{bind_version}
 BuildRequires: make
-Requires(pre): bind-pkcs11 >= %{bind_version}
-Requires: bind-pkcs11 >= %{bind_version}
-Requires: bind-pkcs11-utils >= %{bind_version}
+Requires(pre): %{bind_name}-pkcs11 >= %{bind_version}
+Requires: %{bind_name}-pkcs11 >= %{bind_version}
+Requires: %{bind_name}-pkcs11-utils >= %{bind_version}
 %else
 Requires: softhsm >= %{softhsm_version}
 Requires: %{openssl_pkcs11_name} >= %{openssl_pkcs11_version}
-Requires(pre): bind >= %{bind_version}
-Requires: bind >= %{bind_version}
+Requires(pre): %{bind_name} >= %{bind_version}
+Requires: %{bind_name} >= %{bind_version}
 %endif
 
 %description
@@ -137,6 +153,10 @@ sed -i.bak -e "$SEDSCRIPT" /etc/named.conf
 
 
 %changelog
+* Tue Feb 11 24 2025 Thomas Woerner <twoerner@redhat.com> - 11.11-1
+- Release 11.11, Support BIND 9.18
+  Resolves: RHEL-78925
+
 * Wed Nov 13 2024 Alexander Bokovoy <abokovoy@redhat.com> - 11.10-28
 - Replace dependency on openssl-pkcs11 by pkcs11-provider
 - Resolves: RHEL-30556
diff --git a/sources b/sources
index de3fcdc..5c8bee8 100644
--- a/sources
+++ b/sources
@@ -1,2 +1,2 @@
-SHA512 (bind-dyndb-ldap-11.10.tar.bz2) = bf63efe78a8d95d5a8647f35ec29696e3b5dddc2615b05b17b2024763eb2701c0ee6782ed8d7a443ec9278ae36390ffc3b87a87cf9391adfa6bd8f31508f1539
-SHA512 (bind-dyndb-ldap-11.10.tar.bz2.asc) = cf9436a34e3874734fbb8331572d230cae0362bbfc6229dbb7a23d9573be6824467af20ff639338d9cb0f6a646f559c0f65e3b7b7c13a3306f64300653cea45e
+SHA512 (bind-dyndb-ldap-11.11.tar.bz2) = c04792e05317e83eaddf08d751cc9887a0ecb13705c84399b3165790e23661a7b85f12c201cfb74aecf3f549b8053b6a87426d9f21431dd4bdce316b4ff835bb
+SHA512 (bind-dyndb-ldap-11.11.tar.bz2.asc) = 695b8af4de49f6f0b36ab06d22f609cddfd92fcc41958b396ab3d8cb4aa8e006e931388cb7339fc2306a705bcf8846660a03339dc79716e04e6ecdc0f1124b5e