Import rpm: 02a1b02c7f171125a91421af2fe57cca2c831b94
This commit is contained in:
commit
95c46f8919
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/bind-dyndb-ldap-11.6.tar.bz2
|
73
bind-dyndb-ldap-11.2-servestale.patch
Normal file
73
bind-dyndb-ldap-11.2-servestale.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From fecc0fd86f598807129ea9fa1e4e7b74cf2aba21 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Mensik <pemensik@redhat.com>
|
||||
Date: Mon, 11 Nov 2019 17:36:58 +0100
|
||||
Subject: [PATCH] Add support for servestale records
|
||||
|
||||
Serve-stale support includes two new database methods. Add wrapper into
|
||||
ldap database.
|
||||
---
|
||||
configure.ac | 5 +++++
|
||||
src/ldap_driver.c | 24 ++++++++++++++++++++++++
|
||||
2 files changed, 29 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index d05bad9..7997898 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -120,6 +120,11 @@ int main(void) {
|
||||
[AC_MSG_ERROR([Cross compiling is not supported.])]
|
||||
)
|
||||
|
||||
+dnl dns_db_setservestalettl() can be backported, detect support
|
||||
+AC_CHECK_LIB([dns], [dns_db_setservestalettl],
|
||||
+ [AC_DEFINE([HAVE_DNS_SERVESTALE], 1, [Define if dns library provides dns_db_setservestalettl])]
|
||||
+)
|
||||
+
|
||||
dnl Older autoconf (2.59, for example) doesn't define docdir
|
||||
[[ ! -n "$docdir" ]] && docdir='${datadir}/doc/${PACKAGE_TARNAME}'
|
||||
AC_SUBST([docdir])
|
||||
diff --git a/src/ldap_driver.c b/src/ldap_driver.c
|
||||
index b9161fe..dcf65d0 100644
|
||||
--- a/src/ldap_driver.c
|
||||
+++ b/src/ldap_driver.c
|
||||
@@ -823,6 +823,26 @@ nodefullname(dns_db_t *db, dns_dbnode_t *node, dns_name_t *name)
|
||||
return dns_db_nodefullname(ldapdb->rbtdb, node, name);
|
||||
}
|
||||
|
||||
+#ifdef HAVE_DNS_SERVESTALE
|
||||
+static isc_result_t
|
||||
+setservestalettl(dns_db_t *db, dns_ttl_t ttl) {
|
||||
+ ldapdb_t *ldapdb = (ldapdb_t *) db;
|
||||
+
|
||||
+ REQUIRE(VALID_LDAPDB(ldapdb));
|
||||
+
|
||||
+ return dns_db_setservestalettl(ldapdb->rbtdb, ttl);
|
||||
+}
|
||||
+
|
||||
+static isc_result_t
|
||||
+getservestalettl(dns_db_t *db, dns_ttl_t *ttl) {
|
||||
+ ldapdb_t *ldapdb = (ldapdb_t *) db;
|
||||
+
|
||||
+ REQUIRE(VALID_LDAPDB(ldapdb));
|
||||
+
|
||||
+ return dns_db_getservestalettl(ldapdb->rbtdb, ttl);
|
||||
+}
|
||||
+#endif
|
||||
+
|
||||
static dns_dbmethods_t ldapdb_methods = {
|
||||
attach,
|
||||
detach,
|
||||
@@ -869,6 +889,10 @@ static dns_dbmethods_t ldapdb_methods = {
|
||||
hashsize,
|
||||
nodefullname,
|
||||
NULL, // getsize method not implemented (related BZ1353563)
|
||||
+#ifdef HAVE_DNS_SERVESTALE
|
||||
+ setservestalettl,
|
||||
+ getservestalettl,
|
||||
+#endif
|
||||
};
|
||||
|
||||
isc_result_t ATTR_NONNULLS
|
||||
--
|
||||
2.20.1
|
||||
|
38
bind-dyndb-ldap-11.6-bind-9.16.10.patch
Normal file
38
bind-dyndb-ldap-11.6-bind-9.16.10.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From 2ddd4bf55e325071566aa1c78e3681c3239895da Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
||||
Date: Mon, 11 Jan 2021 21:39:25 +0100
|
||||
Subject: [PATCH] Add compatibility with BIND 9.16.10 API change
|
||||
|
||||
One parameter was added to function used internally by plugin. Nothing
|
||||
like -nsec3param auto is supported by LDAP plugin. It is safe to set
|
||||
resalt false always. Salt can be changed via LDAP, but has to be
|
||||
specified manually.
|
||||
---
|
||||
src/ldap_helper.c | 7 +++++++
|
||||
1 file changed, 7 insertions(+)
|
||||
|
||||
diff --git a/src/ldap_helper.c b/src/ldap_helper.c
|
||||
index a81a9d228..3b4ae5c67 100644
|
||||
--- a/src/ldap_helper.c
|
||||
+++ b/src/ldap_helper.c
|
||||
@@ -1792,10 +1792,17 @@ zone_master_reconfigure_nsec3param(settings_set_t *zone_settings,
|
||||
dns_rdatatype_nsec3param, origin, nsec3p_str,
|
||||
&nsec3p_rdata));
|
||||
CHECK(dns_rdata_tostruct(nsec3p_rdata, &nsec3p_rr, NULL));
|
||||
+#if LIBDNS_VERSION_MAJOR > 1609
|
||||
+ CHECK(dns_zone_setnsec3param(secure, nsec3p_rr.hash, nsec3p_rr.flags,
|
||||
+ nsec3p_rr.iterations,
|
||||
+ nsec3p_rr.salt_length, nsec3p_rr.salt,
|
||||
+ true, false));
|
||||
+#else
|
||||
CHECK(dns_zone_setnsec3param(secure, nsec3p_rr.hash, nsec3p_rr.flags,
|
||||
nsec3p_rr.iterations,
|
||||
nsec3p_rr.salt_length, nsec3p_rr.salt,
|
||||
true));
|
||||
+#endif
|
||||
|
||||
cleanup:
|
||||
if (nsec3p_rdata != NULL) {
|
||||
--
|
||||
2.26.2
|
||||
|
38
bind-dyndb-ldap-11.6-bind-9.16.11.patch
Normal file
38
bind-dyndb-ldap-11.6-bind-9.16.11.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From f4aec4d37447cc274b90c129ea15a008473ed02d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
||||
Date: Thu, 21 Jan 2021 17:30:54 +0100
|
||||
Subject: [PATCH] Yet another change to support BIND 9.16.11 API change
|
||||
|
||||
Another change with another release, new parameter is added again.
|
||||
Add another ifdef to keep compatibility with both versions.
|
||||
---
|
||||
src/zone.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/src/zone.c b/src/zone.c
|
||||
index d0b71b194..7ce1769b3 100644
|
||||
--- a/src/zone.c
|
||||
+++ b/src/zone.c
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <dns/zone.h>
|
||||
|
||||
#include "util.h"
|
||||
+#include "config.h"
|
||||
|
||||
/**
|
||||
* Write given diff to zone journal. Journal will be created
|
||||
@@ -61,7 +62,11 @@ zone_soaserial_updatetuple(dns_updatemethod_t method, dns_difftuple_t *soa_tuple
|
||||
REQUIRE(soa_tuple->rdata.type == dns_rdatatype_soa);
|
||||
|
||||
serial = dns_soa_getserial(&soa_tuple->rdata);
|
||||
+#if LIBDNS_VERSION_MAJOR >= 1611
|
||||
+ serial = dns_update_soaserial(serial, method, NULL);
|
||||
+#else
|
||||
serial = dns_update_soaserial(serial, method);
|
||||
+#endif
|
||||
dns_soa_setserial(serial, &soa_tuple->rdata);
|
||||
if (new_serial != NULL)
|
||||
*new_serial = serial;
|
||||
--
|
||||
2.26.2
|
||||
|
30
bind-dyndb-ldap-11.6-bind-9.16.9.patch
Normal file
30
bind-dyndb-ldap-11.6-bind-9.16.9.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 2a732bb03812878a9cc00d27d6c80f3993520626 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Mensik <pemensik@redhat.com>
|
||||
Date: Thu, 26 Nov 2020 17:31:21 +0100
|
||||
Subject: [PATCH] Support BIND 9.16.9
|
||||
|
||||
Two new functions were added to database interface. They are more
|
||||
related to caching server and not authoritative. Add just null pointers,
|
||||
returning not supporter error if used.
|
||||
---
|
||||
src/ldap_driver.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/ldap_driver.c b/src/ldap_driver.c
|
||||
index 2f6574ea5..c524b7cc5 100644
|
||||
--- a/src/ldap_driver.c
|
||||
+++ b/src/ldap_driver.c
|
||||
@@ -959,6 +959,10 @@ static dns_dbmethods_t ldapdb_methods = {
|
||||
setservestalettl,
|
||||
getservestalettl,
|
||||
#endif
|
||||
+#if LIBDNS_VERSION_MAJOR >= 1609
|
||||
+ NULL, /* setservestalerefresh */
|
||||
+ NULL, /* getservestalerefresh */
|
||||
+#endif
|
||||
#if LIBDNS_VERSION_MAJOR >= 1600
|
||||
NULL, /* setgluecachestats */
|
||||
#endif
|
||||
--
|
||||
2.26.2
|
||||
|
16
bind-dyndb-ldap-11.6.tar.bz2.asc
Normal file
16
bind-dyndb-ldap-11.6.tar.bz2.asc
Normal file
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCgAdFiEEhAodHH8+xLL+UwQ1RxniuKu/YhoFAl+7wQUACgkQRxniuKu/
|
||||
YhrK4Q/7B3njZOLSN1nor1ftoGGgXHvOvAGZTH+S0aI/u2bGfMIy3iT6NCcXZaVy
|
||||
LftvbYUKZ1zT92LYyTng7d8qgc8B7fmIAHPKye2uuxfPgwYkqdBLLKOMoAjbijjI
|
||||
P3Qkoee9bAF89wjnEnyfE9beJ9Vwe6PQLuCovIIauYEfhXjazOhSt7aDpYQ1X5Ui
|
||||
WyUKMhbO9WZ+TokW6wMTLGC8eCJdIJz0OXrROsLp6KZW4Y4wxf/zcU/XztDmEcOm
|
||||
DIeDir1ohp8xyssfBYr9tmamD+FzoU9+oR1+WjQav/pxFBqezzm7U3cvq9PrQ7SK
|
||||
Q5jpmeNOTvoUjnEMBW/AXPxth0yXVX3XlIYjhVX3R4r/ZXwmK1g6hqsT2kSbCvAS
|
||||
/DR7yfou2SQLuH1z6qs6vd+IdTYVpsHMBBdQtHSeZ5701fyJgIABI98oMMV/KplL
|
||||
bwfL/uhTPjuH1nett7h7NuINiVET0Yy63/CRicQs199ORGLVBaQ+AVCxj33m5NH/
|
||||
ggMKhA5VNmMSSvyI/TiytLbqhjw29kjRo4/vDEqv1co9fB2J2MBdTCtSF4gixB0n
|
||||
da/W6PnKiS45f0NdqpU5oUxLDTni+hYrQV1GXavdnx8lpnab9jlJO6vOZSCodSS+
|
||||
0eMJRH7knFDrY7EEjbUD7/pPZphPQUamvecmYhgn+La4SHkf2wA=
|
||||
=cGu/
|
||||
-----END PGP SIGNATURE-----
|
35
bind-dyndb-ldap-11.9-bind-9.16.17.patch
Normal file
35
bind-dyndb-ldap-11.9-bind-9.16.17.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From d7d3032de7f5d3dd3cffea6064549b63a9ad7d59 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20Men=C5=A1=C3=ADk?= <pemensik@redhat.com>
|
||||
Date: Thu, 17 Jun 2021 17:57:52 +0200
|
||||
Subject: [PATCH] Skip isc_bind9 check on BIND 9.16.17+
|
||||
|
||||
Reference variable refvar from dns_dyndbctx_t were removed. Removed was
|
||||
also flag requesting different namespace. Skip that check on last stable
|
||||
version, it should eval to false on all versions anyway.
|
||||
---
|
||||
src/ldap_driver.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/ldap_driver.c b/src/ldap_driver.c
|
||||
index e9f1005ee..5f9e00af1 100644
|
||||
--- a/src/ldap_driver.c
|
||||
+++ b/src/ldap_driver.c
|
||||
@@ -1156,6 +1156,7 @@ dyndb_init(isc_mem_t *mctx, const char *name, const char *parameters,
|
||||
RUNTIME_CHECK(isc_once_do(&library_init_once, library_init)
|
||||
== ISC_R_SUCCESS);
|
||||
|
||||
+#if LIBDNS_VERSION_MAJOR < 1617
|
||||
/*
|
||||
* Depending on how dlopen() was called, we may not have
|
||||
* access to named's global namespace, in which case we need
|
||||
@@ -1168,6 +1169,7 @@ dyndb_init(isc_mem_t *mctx, const char *name, const char *parameters,
|
||||
isc_hash_set_initializer(dctx->hashinit);
|
||||
log_debug(5, "registering library from dynamic ldap driver, %p != %p.", dctx->refvar, &isc_bind9);
|
||||
}
|
||||
+#endif
|
||||
|
||||
log_debug(2, "registering dynamic ldap driver for %s.", name);
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
483
bind-dyndb-ldap.spec
Normal file
483
bind-dyndb-ldap.spec
Normal file
@ -0,0 +1,483 @@
|
||||
%define VERSION %{version}
|
||||
|
||||
%define bind_version 32:9.11.26-1
|
||||
|
||||
%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
|
||||
%global openssl_pkcs11_version 0.4.10-2
|
||||
%global softhsm_version 2.6.0
|
||||
%else
|
||||
%global with_bind_pkcs11 1
|
||||
%endif
|
||||
|
||||
Name: bind-dyndb-ldap
|
||||
Version: 11.6
|
||||
Release: 3%{?dist}
|
||||
Summary: LDAP back-end plug-in for BIND
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: GPLv2+
|
||||
URL: https://releases.pagure.org/bind-dyndb-ldap
|
||||
Source0: https://releases.pagure.org/%{name}/%{name}-%{VERSION}.tar.bz2
|
||||
Source1: https://releases.pagure.org/%{name}/%{name}-%{VERSION}.tar.bz2.asc
|
||||
|
||||
BuildRequires: bind-devel >= %{bind_version}, bind-lite-devel >= %{bind_version}, bind-pkcs11-devel >= %{bind_version}
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: openldap-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: automake, autoconf, libtool
|
||||
|
||||
%if %{with bind_pkcs11}
|
||||
Requires: bind-pkcs11 >= %{bind_version}, bind-pkcs11-utils >= %{bind_version}
|
||||
%else
|
||||
Requires: softhsm >= %{softhsm_version}
|
||||
Requires: openssl-pkcs11 >= %{openssl_pkcs11_version}
|
||||
%endif
|
||||
|
||||
%description
|
||||
This package provides an LDAP back-end plug-in for BIND. It features
|
||||
support for dynamic updates and internal caching, to lift the load
|
||||
off of your LDAP server.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{VERSION}
|
||||
|
||||
%build
|
||||
autoreconf -fiv
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make install DESTDIR=%{buildroot}
|
||||
mkdir -m 770 -p %{buildroot}/%{_localstatedir}/named/dyndb-ldap
|
||||
|
||||
# Remove unwanted files
|
||||
rm %{buildroot}%{_libdir}/bind/ldap.la
|
||||
rm -r %{buildroot}%{_datadir}/doc/%{name}
|
||||
|
||||
|
||||
%post
|
||||
# Transform named.conf if it still has old-style API.
|
||||
PLATFORM=$(uname -m)
|
||||
|
||||
if [ $PLATFORM == "x86_64" ] ; then
|
||||
LIBPATH=/usr/lib64
|
||||
else
|
||||
LIBPATH=/usr/lib
|
||||
fi
|
||||
|
||||
# The following sed script:
|
||||
# - scopes the named.conf changes to dynamic-db
|
||||
# - replaces arg "name value" syntax with name "value"
|
||||
# - changes dynamic-db header to dyndb
|
||||
# - uses the new way the define path to the library
|
||||
# - removes no longer supported arguments (library, cache_ttl,
|
||||
# psearch, serial_autoincrement, zone_refresh)
|
||||
while read -r PATTERN
|
||||
do
|
||||
SEDSCRIPT+="$PATTERN"
|
||||
done <<EOF
|
||||
/^\s*dynamic-db/,/};/ {
|
||||
|
||||
s/\(\s*\)arg\s\+\(["']\)\([a-zA-Z_]\+\s\)/\1\3\2/g;
|
||||
|
||||
s/^dynamic-db/dyndb/;
|
||||
|
||||
s@\(dyndb "[^"]\+"\)@\1 "$LIBPATH/bind/ldap.so"@;
|
||||
s@\(dyndb '[^']\+'\)@\1 '$LIBPATH/bind/ldap.so'@;
|
||||
|
||||
/\s*library[^;]\+;/d;
|
||||
/\s*cache_ttl[^;]\+;/d;
|
||||
/\s*psearch[^;]\+;/d;
|
||||
/\s*serial_autoincrement[^;]\+;/d;
|
||||
/\s*zone_refresh[^;]\+;/d;
|
||||
}
|
||||
EOF
|
||||
|
||||
sed -i.bak -e "$SEDSCRIPT" /etc/named.conf
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc NEWS README.md COPYING doc/{example,schema}.ldif
|
||||
%dir %attr(770, root, named) %{_localstatedir}/named/dyndb-ldap
|
||||
%{_libdir}/bind/ldap.so
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 22 2021 Alexander Bokovoy <abokovoy@redhat.com> - 11.6-3
|
||||
- Rebuild against bind 9.11.36
|
||||
- Resolves: rhbz#2022762
|
||||
|
||||
* Thu Jan 07 2021 Rob Crittenden <rcritten@redhat.com> - 11.6-2
|
||||
- Rebuild against bind 9.11.26
|
||||
- Resolves: rhbz#1904612
|
||||
|
||||
* Mon Nov 23 2020 Alexander Bokovoy <abokovoy@redhat.com> - 11.6-1
|
||||
- New upstream release
|
||||
- Resolves: rhbz#1891735
|
||||
|
||||
* Mon Jun 08 2020 Alexander Bokovoy <abokovoy@redhat.com> - 11.3-1
|
||||
- New upstream release
|
||||
- Resolves: rhbz#1845211
|
||||
|
||||
* Mon May 11 2020 Alexander Bokovoy <abokovoy@redhat.com> - 11.2-4
|
||||
- Rebuild against bind 9.11.18
|
||||
Resolves: rhbz#1834264
|
||||
|
||||
* Wed Nov 27 2019 Alexander Bokovoy <abokovoy@redhat.com> - 11.2-3
|
||||
- Rebuild against bind 9.11.13
|
||||
Related: RHBZ#1762813
|
||||
|
||||
* Mon Nov 18 2019 Thomas Woerner <twoerner@redhat.com> - 11.2-2
|
||||
- Add support for serve-stale, detected on build time
|
||||
Patch by Petr Menšík <pemensik@redhat.com>
|
||||
Related: RHBZ#1762813
|
||||
|
||||
* Thu Nov 07 2019 Alexander Bokovoy <abokovoy@redhat.com> - 11.2-1
|
||||
- New upstream release
|
||||
- Support BIND9 9.11.11
|
||||
- Resolves: rhbz#1762813
|
||||
|
||||
* Fri Aug 16 2019 Alexander Bokovoy <abokovoy@redhat.com> - 11.1-14
|
||||
- Fix attribute templating in case of a missing default value
|
||||
- Resolves: rhbz#1741896
|
||||
|
||||
* Mon Oct 15 2018 Petr Menšík <pemensik@redhat.com> - 11.1-13
|
||||
- Move setting of named selinux boolean to bind (#1639410)
|
||||
|
||||
* Wed Aug 08 2018 Alexander Bokovoy <abokovoy@redhat.com> - 11.1-12
|
||||
- Make sure we explicitly require openssl-devel for a build
|
||||
- Resolves: rhbz#1613942
|
||||
|
||||
* Mon Jul 23 2018 Petr Menšík <pemensik@redhat.com> - 11.1-11
|
||||
- Rebuild against BIND 9.11.4
|
||||
|
||||
* Thu Mar 01 2018 Petr Menšík <pemensik@redhat.com> - 11.1-10
|
||||
- Rebuild for bind 9.11.3. Minor tweaks to compile.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 11.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Jan 19 2018 Petr Menšík <pemensik@redhat.com> - 11.1-8
|
||||
- Rebuild again against bind-9.11.2-P1
|
||||
|
||||
* Tue Jan 09 2018 Petr Menšík <pemensik@redhat.com> - 11.1-7
|
||||
- Rebuild for bind 9.11.2
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 11.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 11.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jun 27 2017 Tomas Krizek <tkrizek@redhat.com> - 11.1-4
|
||||
- Bump BIND version and fix library dependecies
|
||||
- Coverity fixes
|
||||
|
||||
* Mon Jun 26 2017 Petr Menšík <pemensik@redhat.com> - 11.1-3
|
||||
- Build with updated libraries
|
||||
|
||||
* Mon Mar 13 2017 Tomas Krizek <tkrizek@redhat.com> - 11.1-2
|
||||
- Fix error poinstall sed script
|
||||
|
||||
* Fri Mar 10 2017 Tomas Krizek <tkrizek@redhat.com> - 11.1-1
|
||||
- Update to 11.1
|
||||
- Bumped required version of BIND to 9.11.0-6.P2
|
||||
(required since bind-dyndb-ldap 11.0-1 release)
|
||||
- Updated source URL links to pagure
|
||||
|
||||
* Fri Feb 10 2017 Tomas Krizek <tkrizek@redhat.com> - 11.0-2
|
||||
- Patch to fix build warnings (removed duplicate const)
|
||||
|
||||
* Thu Feb 09 2017 Tomas Krizek <tkrizek@redhat.com> - 11.0-2
|
||||
- Added named.conf transformation script as post action
|
||||
|
||||
* Thu Dec 15 2016 Tomas Krizek <tkrizek@redhat.com> - 11.0-1
|
||||
- Update to 11.0
|
||||
|
||||
* Mon Nov 21 2016 Petr Menšík <pemensik@redhat.com> - 10.1-2
|
||||
- Patched to alfa 11.0 with support for BIND 9.11
|
||||
- Configuration format in named.conf is different
|
||||
and incompatible with all previous versions. Please see README.md.
|
||||
- Minimal BIND version is now 9.11.0rc1. Please see NEWS.
|
||||
|
||||
* Wed Aug 17 2016 Petr Spacek <pspacek@redhat.com> - 10.1-1
|
||||
- Update to 10.1.
|
||||
- Fix deletion of DNS root zone not to break global forwarding.
|
||||
https://fedorahosted.org/bind-dyndb-ldap/ticket/167
|
||||
|
||||
* Wed Jul 27 2016 Petr Spacek <pspacek@redhat.com> - 10.0-2
|
||||
- Backport fix for crash https://fedorahosted.org/bind-dyndb-ldap/ticket/166
|
||||
|
||||
* Tue Jun 21 2016 Petr Spacek <pspacek@redhat.com> - 10.0-1
|
||||
- Update to 10.0
|
||||
|
||||
* Fri May 27 2016 Tomas Hozza <thozza@redhat.com> - 9.0-3
|
||||
- Resolved build issue due to changes in libdns API
|
||||
|
||||
* Thu May 26 2016 Tomas Hozza <thozza@redhat.com> - 9.0-2
|
||||
- Rebuild against bind-9.10.4-P1
|
||||
|
||||
* Thu May 12 2016 Petr Spacek <pspacek@redhat.com> - 9.0-1
|
||||
- Update to 9.0
|
||||
- Fix for GCC 4.9+ was merged upstream
|
||||
|
||||
* Fri Mar 04 2016 Petr Spacek <pspacek@redhat.com> - 8.0-6
|
||||
- Fix builds with GCC 4.9+
|
||||
|
||||
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Dec 17 2015 Petr Spacek <pspacek@redhat.com> - 8.0-4
|
||||
- Rebuild against bind 9.10.3-P2
|
||||
|
||||
* Fri Sep 04 2015 Tomas Hozza <thozza@redhat.com> - 8.0-3
|
||||
- Rebuild against bind 9.10.3rc1
|
||||
|
||||
* Wed Jun 24 2015 Tomas Hozza <thozza@redhat.com> - 8.0-2
|
||||
- rebuild against bind-9.10.2-P1
|
||||
|
||||
* Tue Jun 23 2015 Petr Spacek <pspacek@redhat.com> - 8.0-1
|
||||
- update to 8.0
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Mar 13 2015 Tomas Hozza <thozza@redhat.com> - 7.0-4
|
||||
- rebuild against bind-9.10.2
|
||||
|
||||
* Wed Feb 25 2015 Tomas Hozza <thozza@redhat.com> - 7.0-3
|
||||
- Rebuild against bind-9.10.2rc2
|
||||
|
||||
* Mon Feb 02 2015 Tomas Hozza <thozza@redhat.com> - 7.0-2
|
||||
- rebuild against bind-9.10.2rc1
|
||||
|
||||
* Mon Jan 12 2015 Petr Spacek <pspacek@redhat.com> - 7.0-1
|
||||
- update to 7.0 to add support for BIND 9.10
|
||||
|
||||
* Tue Dec 02 2014 Petr Spacek <pspacek@redhat.com> - 6.1-1
|
||||
- update to 6.1
|
||||
- drop patches which were merged upstream
|
||||
|
||||
* Tue Oct 21 2014 Petr Viktorin <pviktori@redhat.com> - 6.0-5
|
||||
- use lower version of bind-pkcs11-utils for f20 and el7
|
||||
|
||||
* Mon Oct 20 2014 Petr Spacek <pspacek@redhat.com> - 6.0-4
|
||||
- add dependency on bind-pkcs11-utils >= 32:9.9.6-2
|
||||
to help with freeipa-server upgrade
|
||||
|
||||
* Mon Oct 20 2014 Petr Spacek <pspacek@redhat.com> - 6.0-3
|
||||
- replace dependency on bind with dependency on bind-pkcs11 >= 32:9.9.6-2
|
||||
to help with freeipa-server upgrade
|
||||
|
||||
* Fri Oct 03 2014 Tomas Hozza <thozza@redhat.com> - 6.0-2
|
||||
- rebuild against bind-9.9.6
|
||||
|
||||
* Tue Sep 23 2014 Petr Spacek <pspacek redhat com> - 6.0-1
|
||||
- update to 6.0
|
||||
|
||||
* Fri Sep 12 2014 Petr Spacek <pspacek redhat com> - 5.3-1
|
||||
- update to 5.3
|
||||
|
||||
* Mon Sep 08 2014 Petr Spacek <pspacek redhat com> 5.2-1
|
||||
- update to 5.2
|
||||
|
||||
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Thu Jul 24 2014 Petr Spacek <pspacek redhat com> 5.1-1
|
||||
- update to 5.1
|
||||
- fixes bug 1122393
|
||||
|
||||
* Tue Jun 24 2014 Petr Spacek <pspacek redhat com> 5.0-1
|
||||
- update to 5.0
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Apr 09 2014 Petr Spacek <pspacek redhat com> 4.3-1
|
||||
- update to 4.3
|
||||
|
||||
* Mon Feb 24 2014 Petr Spacek <pspacek redhat com> 4.1-2
|
||||
- remove deprecated define _BSD_SOURCE
|
||||
|
||||
* Mon Feb 24 2014 Petr Spacek <pspacek redhat com> 4.1-1
|
||||
- update to 4.1
|
||||
|
||||
* Thu Jul 18 2013 Petr Spacek <pspacek redhat com> 3.5-1
|
||||
- update to 3.5
|
||||
|
||||
* Mon Jul 15 2013 Tomas Hozza <thozza@redhat.com> 3.4-2
|
||||
- rebuild against new bind
|
||||
|
||||
* Tue Jun 25 2013 Petr Spacek <pspacek redhat com> 3.4-1
|
||||
- update to 3.4
|
||||
|
||||
* Tue Jun 04 2013 Petr Spacek <pspacek redhat com> 3.3-1
|
||||
- update to 3.3
|
||||
- patch bind-dyndb-ldap-tbabej-0001-Build-fixes-for-Fedora-19.patch merged
|
||||
|
||||
* Tue May 14 2013 Petr Spacek <pspacek redhat com> 3.2-1
|
||||
- update to 3.2
|
||||
|
||||
* Tue Apr 16 2013 Adam Tkac <atkac redhat com> 3.1-2
|
||||
- rebuild against new bind
|
||||
- build with --disable-werror
|
||||
|
||||
* Fri Apr 12 2013 Petr Spacek <pspacek redhat com> 3.1-1
|
||||
- update to 3.1
|
||||
|
||||
* Tue Apr 02 2013 Petr Spacek <pspacek redhat com> 3.0-1
|
||||
- update to 3.0
|
||||
|
||||
* Tue Mar 26 2013 Petr Spacek <pspacek redhat com> 2.6-1
|
||||
- update to 2.6
|
||||
|
||||
* Mon Feb 04 2013 Petr Spacek <pspacek redhat com> 2.5-1
|
||||
- update to 2.5
|
||||
|
||||
* Tue Jan 15 2013 Petr Spacek <pspacek redhat com> 2.4-1
|
||||
- update to 2.4
|
||||
|
||||
* Thu Nov 8 2012 Petr Spacek <pspacek redhat com> 2.3-2
|
||||
- rebuild with proper changelog
|
||||
|
||||
* Thu Nov 8 2012 Petr Spacek <pspacek redhat com> 2.3-1
|
||||
- update to 2.3
|
||||
|
||||
* Mon Oct 29 2012 Adam Tkac <atkac redhat com> 2.1-1
|
||||
- update to 2.1
|
||||
|
||||
* Thu Oct 11 2012 Adam Tkac <atkac redhat com> 2.0-0.3.20121009git6a86b1
|
||||
- rebuild against new bind-libs
|
||||
|
||||
* Tue Oct 9 2012 Petr Spacek <pspacek redhat com> 2.0-0.2.20121009git6a86b1
|
||||
- update to the latest master
|
||||
|
||||
* Fri Sep 21 2012 Adam Tkac <atkac redhat com> 2.0-0.1.20120921git7710d89
|
||||
- update to the latest master
|
||||
- bind-dyndb-ldap110-master.patch was merged
|
||||
|
||||
* Thu Aug 16 2012 Adam Tkac <atkac redhat com> 1.1.0-0.16.rc1
|
||||
- update to the latest git
|
||||
|
||||
* Thu Aug 02 2012 Adam Tkac <atkac redhat com> 1.1.0-0.15.rc1
|
||||
- update to the latest git
|
||||
- fix for CVE-2012-3429 has been merged
|
||||
|
||||
* Thu Aug 02 2012 Adam Tkac <atkac redhat com> 1.1.0-0.14.rc1
|
||||
- fix CVE-2012-3429
|
||||
|
||||
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.13.rc1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jun 07 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.12.rc1
|
||||
- update to the latest master (#827401)
|
||||
|
||||
* Thu Apr 26 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.11.rc1
|
||||
- update to 1.1.0rc1 (CVE-2012-2134)
|
||||
|
||||
* Tue Mar 27 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.10.b2
|
||||
- update to 1.1.0b2
|
||||
|
||||
* Tue Mar 06 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.9.b1
|
||||
- update to 1.1.0b1
|
||||
|
||||
* Mon Feb 13 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.8.a2
|
||||
- update to 1.1.0a2
|
||||
|
||||
* Thu Feb 02 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.7.a1
|
||||
- rebuild against new bind
|
||||
|
||||
* Wed Jan 18 2012 Adam Tkac <atkac redhat com> - 1.1.0-0.6.a1
|
||||
- update to 1.1.0a1
|
||||
|
||||
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-0.5.rc1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Nov 14 2011 Adam Tkac <atkac redhat com> - 1.0.0-0.4.rc1
|
||||
- update to 1.0.0rc1
|
||||
|
||||
* Mon Nov 14 2011 Adam Tkac <atkac redhat com> - 1.0.0-0.3.b1
|
||||
- rebuild against new bind
|
||||
|
||||
* Fri Sep 09 2011 Adam Tkac <atkac redhat com> - 1.0.0-0.2.b1
|
||||
- rebuild against new bind
|
||||
|
||||
* Wed Aug 31 2011 Adam Tkac <atkac redhat com> - 1.0.0-0.1.b1
|
||||
- update to 1.0.0b1 (psearch + bugfixes)
|
||||
- bind-dyndb-ldap-rh727856.patch merged
|
||||
|
||||
* Wed Aug 03 2011 Adam Tkac <atkac redhat com> - 0.2.0-4
|
||||
- fix race condition in semaphore_wait (#727856)
|
||||
|
||||
* Mon Feb 21 2011 Adam Tkac <atkac redhat com> - 0.2.0-3
|
||||
- rebuild against new bind
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 12 2011 Adam Tkac <atkac redhat com> - 0.2.0-1
|
||||
- update to 0.2.0
|
||||
- patches merged
|
||||
- 0001-Bugfix-Improve-LDAP-schema-to-be-loadable-by-OpenLDA.patch
|
||||
- 0004-Bugfix-Fix-loading-of-child-zones-from-LDAP.patch
|
||||
|
||||
* Wed Dec 15 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.17.b
|
||||
- fix LDAP schema (#622604)
|
||||
- load child zones from LDAP correctly (#622617)
|
||||
|
||||
* Fri Oct 22 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.16.b
|
||||
- build with correct RPM_OPT_FLAGS (#645529)
|
||||
|
||||
* Wed Oct 20 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.15.b
|
||||
- use "isc-config.sh" utility to get correct BIND9 CFLAGS
|
||||
|
||||
* Thu Sep 30 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.14.b
|
||||
- rebuild against new bind
|
||||
|
||||
* Fri Aug 27 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.13.b
|
||||
- rebuild against new bind
|
||||
|
||||
* Tue Aug 17 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.12.b
|
||||
- rebuild against new bind
|
||||
|
||||
* Tue Aug 03 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.11.b
|
||||
- rebuild against new bind
|
||||
|
||||
* Mon May 31 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.10.b
|
||||
- rebuild against new bind
|
||||
|
||||
* Wed Mar 24 2010 Martin Nagy <mnagy@redhat.com> - 0.1.0-0.9.b
|
||||
- update to the latest upstream release
|
||||
|
||||
* Thu Jan 28 2010 Adam Tkac <atkac redhat com> - 0.1.0-0.8.a1.20091210git
|
||||
- rebuild against new bind
|
||||
|
||||
* Tue Dec 15 2009 Adam Tkac <atkac redhat com> - 0.1.0-0.7.a1.20091210git
|
||||
- rebuild against new bind
|
||||
|
||||
* Thu Dec 10 2009 Martin Nagy <mnagy@redhat.com> - 0.1.0-0.6.a1.20091210git
|
||||
- update to the latest git snapshot
|
||||
- change upstream URL, project moved to fedorahosted
|
||||
- change license to GPL version 2 or later
|
||||
- add epoch to versioned requires
|
||||
- add krb5-devel to the list of build requires
|
||||
|
||||
* Tue Dec 01 2009 Adam Tkac <atkac redhat com> - 0.1.0-0.5.a1
|
||||
- rebuild against new bind
|
||||
|
||||
* Thu Nov 26 2009 Adam Tkac <atkac redhat com> - 0.1.0-0.4.a1
|
||||
- rebuild against new bind
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-0.3.a1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2009 Caolán McNamara <caolanm@redhat.com> - 0.1.0-0.2.a1
|
||||
- rebuild for dependencies
|
||||
|
||||
* Sun May 03 2009 Martin Nagy <mnagy@redhat.com> - 0.1.0-0.1.a1
|
||||
- initial packaging
|
7
gating.yaml
Normal file
7
gating.yaml
Normal file
@ -0,0 +1,7 @@
|
||||
# recipients: abokovoy, frenaud, kaleem, ftrivino
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: idm-ci.brew-build.tier1.functional}
|
25
remove_duplicate_const.patch
Normal file
25
remove_duplicate_const.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 3a4ad363879da129669dbb5ed10f6b0a1b7778af Mon Sep 17 00:00:00 2001
|
||||
From: Tomas Krizek <tkrizek@redhat.com>
|
||||
Date: Thu, 9 Feb 2017 17:52:59 +0100
|
||||
Subject: [PATCH] Remove duplicate const declaration specifier
|
||||
|
||||
---
|
||||
src/ldap_helper.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/ldap_helper.c b/src/ldap_helper.c
|
||||
index 5de9f69f6957fd838f7f7a73dd755db98b0ee8d5..1fa0ec9adfa2b9ca589587244da03cc6f0584919 100644
|
||||
--- a/src/ldap_helper.c
|
||||
+++ b/src/ldap_helper.c
|
||||
@@ -2349,7 +2349,7 @@ free_rdatalist(isc_mem_t *mctx, dns_rdatalist_t *rdlist)
|
||||
* @retval others Unexpected errors.
|
||||
*/
|
||||
static isc_result_t ATTR_NONNULLS ATTR_CHECKRESULT
|
||||
-ldap_substitute_rr_template(isc_mem_t *mctx, const settings_set_t const * set,
|
||||
+ldap_substitute_rr_template(isc_mem_t *mctx, const settings_set_t * set,
|
||||
ld_string_t *orig_val, ld_string_t **output) {
|
||||
isc_result_t result;
|
||||
regex_t regex;
|
||||
--
|
||||
2.9.3
|
||||
|
Loading…
Reference in New Issue
Block a user