import beignet-1.3.2-4.el8
This commit is contained in:
commit
59316676fa
1
.beignet.metadata
Normal file
1
.beignet.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
ac7225429f4adab3bbac6d6c4a39be7629717867 SOURCES/beignet-1.3.2-source.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/beignet-1.3.2-source.tar.gz
|
108
SOURCES/0001-Add-AppStream-metadata.patch
Normal file
108
SOURCES/0001-Add-AppStream-metadata.patch
Normal file
@ -0,0 +1,108 @@
|
|||||||
|
From 90a6c3c999f2ee5fd20f9f5866a6164866ac7dfa Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Rebecca N. Palmer" <rebecca_palmer@zoho.com>
|
||||||
|
Date: Sun, 15 Jan 2017 23:17:49 +0000
|
||||||
|
Subject: [PATCH] Add AppStream metadata
|
||||||
|
|
||||||
|
AppStream is a standard for software metadata,
|
||||||
|
including what hardware a driver supports:
|
||||||
|
https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
|
||||||
|
|
||||||
|
Signed-off-by: Rebecca N. Palmer <rebecca_palmer@zoho.com>
|
||||||
|
Reviewed-by: Yang Rong <rong.r.yang@intel.com>
|
||||||
|
(cherry picked from commit 033464f4b8045a49dbcc1a84cde5c05986ca11c2)
|
||||||
|
---
|
||||||
|
CMakeLists.txt | 5 +++++
|
||||||
|
com.intel.beignet.metainfo.xml.in | 18 ++++++++++++++++++
|
||||||
|
update_metainfo_xml.py | 32 ++++++++++++++++++++++++++++++++
|
||||||
|
3 files changed, 55 insertions(+)
|
||||||
|
create mode 100644 com.intel.beignet.metainfo.xml.in
|
||||||
|
create mode 100755 update_metainfo_xml.py
|
||||||
|
|
||||||
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
|
index face3ce7..2e520213 100644
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -37,6 +37,7 @@ INCLUDE (GNUInstallDirs OPTIONAL)
|
||||||
|
# support old CMake without GNUInstallDirs
|
||||||
|
if (NOT CMAKE_INSTALL_FULL_LIBDIR)
|
||||||
|
set (CMAKE_INSTALL_FULL_LIBDIR "${CMAKE_INSTALL_PREFIX}/lib")
|
||||||
|
+ set (CMAKE_INSTALL_FULL_DATADIR "${CMAKE_INSTALL_PREFIX}/share")
|
||||||
|
set (BEIGNET_LIBRARY_ARCHITECTURE "")
|
||||||
|
else (NOT CMAKE_INSTALL_FULL_LIBDIR)
|
||||||
|
set (BEIGNET_LIBRARY_ARCHITECTURE "${CMAKE_LIBRARY_ARCHITECTURE}")
|
||||||
|
@@ -340,6 +341,10 @@ IF(BUILD_EXAMPLES)
|
||||||
|
ADD_SUBDIRECTORY(examples)
|
||||||
|
ENDIF(BUILD_EXAMPLES)
|
||||||
|
|
||||||
|
+add_custom_target(metainfo ALL
|
||||||
|
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/update_metainfo_xml.py "${LIBCL_DRIVER_VERSION_MAJOR}.${LIBCL_DRIVER_VERSION_MINOR}.${LIBCL_DRIVER_VERSION_PATCH}" ${CMAKE_CURRENT_BINARY_DIR})
|
||||||
|
+install (FILES ${CMAKE_CURRENT_BINARY_DIR}/com.intel.beignet.metainfo.xml DESTINATION ${CMAKE_INSTALL_FULL_DATADIR}/metainfo)
|
||||||
|
+
|
||||||
|
SET(CPACK_SET_DESTDIR ON)
|
||||||
|
SET(CPACK_PACKAGE_VERSION_MAJOR "${LIBCL_DRIVER_VERSION_MAJOR}")
|
||||||
|
SET(CPACK_PACKAGE_VERSION_MINOR "${LIBCL_DRIVER_VERSION_MINOR}")
|
||||||
|
diff --git a/com.intel.beignet.metainfo.xml.in b/com.intel.beignet.metainfo.xml.in
|
||||||
|
new file mode 100644
|
||||||
|
index 00000000..65a2fad9
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/com.intel.beignet.metainfo.xml.in
|
||||||
|
@@ -0,0 +1,18 @@
|
||||||
|
+<?xml version="1.0" encoding="UTF-8"?>
|
||||||
|
+<component type="driver">
|
||||||
|
+<id>com.intel.beignet</id>
|
||||||
|
+<name>Beignet</name>
|
||||||
|
+<summary>OpenCL (GPU compute) driver for Intel GPUs</summary>
|
||||||
|
+<description>This allows using Intel integrated GPUs for general computation, speeding up some applications.</description>
|
||||||
|
+<provides>
|
||||||
|
+@modalias_list@
|
||||||
|
+</provides>
|
||||||
|
+<metadata_license>MIT</metadata_license>
|
||||||
|
+<project_license>LGPL-2.1+</project_license>
|
||||||
|
+<url type="homepage">https://www.freedesktop.org/wiki/Software/Beignet/</url>
|
||||||
|
+<url type="bugtracker">https://bugs.freedesktop.org/buglist.cgi?product=Beignet&component=Beignet&resolution=---</url>
|
||||||
|
+<developer_name>Intel</developer_name>
|
||||||
|
+<releases>
|
||||||
|
+<release version="@version@"></release>
|
||||||
|
+</releases>
|
||||||
|
+</component>
|
||||||
|
diff --git a/update_metainfo_xml.py b/update_metainfo_xml.py
|
||||||
|
new file mode 100755
|
||||||
|
index 00000000..487bd757
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/update_metainfo_xml.py
|
||||||
|
@@ -0,0 +1,32 @@
|
||||||
|
+#!/usr/bin/python
|
||||||
|
+
|
||||||
|
+import re
|
||||||
|
+import sys
|
||||||
|
+import os.path
|
||||||
|
+from io import open
|
||||||
|
+
|
||||||
|
+if len(sys.argv) != 3:
|
||||||
|
+ raise TypeError("requires version_string and output_directory")
|
||||||
|
+version_string = sys.argv[1]
|
||||||
|
+output_directory = sys.argv[2]
|
||||||
|
+source_directory = os.path.dirname(sys.argv[0])
|
||||||
|
+source_file = open(os.path.join(source_directory,"src/cl_device_data.h"),"r",encoding = 'utf-8')
|
||||||
|
+device_ids = []
|
||||||
|
+supported = False # first few devices in the file aren't supported
|
||||||
|
+for line in source_file:
|
||||||
|
+ device_id = re.match(r"#define\s+PCI_CHIP_([A-Za-z0-9_]+)\s+0x([0-9A-Fa-f]+)",line)
|
||||||
|
+ if device_id is None:
|
||||||
|
+ continue
|
||||||
|
+ if "IVYBRIDGE" in device_id.group(1):
|
||||||
|
+ supported = True # start of supported devices
|
||||||
|
+ if supported:
|
||||||
|
+ device_ids.append(device_id.group(2).upper())
|
||||||
|
+source_file.close()
|
||||||
|
+modalias_list_string = "\n".join("<modalias>pci:v00008086d0000{}*</modalias>".format(device_id) for device_id in sorted(device_ids))
|
||||||
|
+metadata_file_in = open(os.path.join(source_directory,"com.intel.beignet.metainfo.xml.in"),"r",encoding = 'utf-8')
|
||||||
|
+metadata_string = metadata_file_in.read()
|
||||||
|
+metadata_file_in.close()
|
||||||
|
+metadata_string = metadata_string.replace("@modalias_list@",modalias_list_string).replace("@version@",version_string)
|
||||||
|
+metadata_file_out = open(os.path.join(output_directory,"com.intel.beignet.metainfo.xml"),"w",encoding = 'utf-8')
|
||||||
|
+metadata_file_out.write(metadata_string)
|
||||||
|
+metadata_file_out.close()
|
||||||
|
--
|
||||||
|
2.14.2
|
||||||
|
|
37
SOURCES/beignet-llvm6.patch
Normal file
37
SOURCES/beignet-llvm6.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
Description: Support LLVM 6
|
||||||
|
|
||||||
|
LLVMContext::setDiagnosticHandler and LoopInfo::markAsRemoved are renamed
|
||||||
|
|
||||||
|
Author: Rebecca N. Palmer <rebecca_palmer@zoho.com>
|
||||||
|
Forwarded: <no|not-needed|url proving that it has been forwarded>
|
||||||
|
|
||||||
|
diff -uNr Beignet-1.3.2-Source.orig/backend/src/llvm/llvm_to_gen.cpp Beignet-1.3.2-Source/backend/src/llvm/llvm_to_gen.cpp
|
||||||
|
--- Beignet-1.3.2-Source.orig/backend/src/llvm/llvm_to_gen.cpp 2017-10-24 08:04:48.000000000 +0200
|
||||||
|
+++ Beignet-1.3.2-Source/backend/src/llvm/llvm_to_gen.cpp 2018-07-21 09:02:25.891056989 +0200
|
||||||
|
@@ -322,7 +322,11 @@
|
||||||
|
DataLayout DL(&mod);
|
||||||
|
|
||||||
|
gbeDiagnosticContext dc;
|
||||||
|
- mod.getContext().setDiagnosticHandler(&gbeDiagnosticHandler,&dc);
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 6
|
||||||
|
+ mod.getContext().setDiagnosticHandlerCallBack(&gbeDiagnosticHandler, &dc);
|
||||||
|
+#else
|
||||||
|
+ mod.getContext().setDiagnosticHandler(&gbeDiagnosticHandler, &dc);
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
#if LLVM_VERSION_MAJOR * 10 + LLVM_VERSION_MINOR >= 37
|
||||||
|
mod.setDataLayout(DL);
|
||||||
|
diff -uNr Beignet-1.3.2-Source.orig/backend/src/llvm/llvm_unroll.cpp Beignet-1.3.2-Source/backend/src/llvm/llvm_unroll.cpp
|
||||||
|
--- Beignet-1.3.2-Source.orig/backend/src/llvm/llvm_unroll.cpp 2017-10-24 08:04:48.000000000 +0200
|
||||||
|
+++ Beignet-1.3.2-Source/backend/src/llvm/llvm_unroll.cpp 2018-07-21 09:03:15.524362357 +0200
|
||||||
|
@@ -205,7 +205,9 @@
|
||||||
|
if (parentTripCount != 0 && currTripCount * parentTripCount > 32) {
|
||||||
|
//Don't change the unrollID if doesn't force unroll.
|
||||||
|
//setUnrollID(parentL, false);
|
||||||
|
-#if LLVM_VERSION_MAJOR * 10 + LLVM_VERSION_MINOR >= 38
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 6
|
||||||
|
+ loopInfo.erase(parentL);
|
||||||
|
+#elif LLVM_VERSION_MAJOR * 10 + LLVM_VERSION_MINOR >= 38
|
||||||
|
loopInfo.markAsRemoved(parentL);
|
||||||
|
#else
|
||||||
|
LPM.deleteLoopFromQueue(parentL);
|
135
SOURCES/beignet-llvm7.patch
Normal file
135
SOURCES/beignet-llvm7.patch
Normal file
@ -0,0 +1,135 @@
|
|||||||
|
From e1b2419a0008e38ef2d9d255d9e9c74e9fba084b Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Rebecca N. Palmer" <rebecca_palmer@zoho.com>
|
||||||
|
Date: Sat, 21 Jul 2018 20:05:54 +0100
|
||||||
|
Subject: Add preliminary LLVM 7 support
|
||||||
|
|
||||||
|
This is preliminary because LLVM 7 has not been released yet:
|
||||||
|
it was tested with the snapshot from Debian experimental (svn336894).
|
||||||
|
|
||||||
|
1.Change linking order, as clangCodeGen now links to clangFrontend
|
||||||
|
2.Pass references not pointers to WriteBitcodeToFile and CloneModule
|
||||||
|
3.Add the headers that LoopSimplifyID, LCSSAID and
|
||||||
|
some create*Pass have moved to
|
||||||
|
4.Define our DEBUG whether or not we just undefined LLVM's
|
||||||
|
(theirs is now LLVM_DEBUG, but we never actually use it)
|
||||||
|
|
||||||
|
Signed-off-by: Rebecca N. Palmer <rebecca_palmer@zoho.com>
|
||||||
|
Reviewed-by: Yang Rong <rong.r.yang@intel.com>
|
||||||
|
---
|
||||||
|
CMake/FindLLVM.cmake | 2 +-
|
||||||
|
backend/src/backend/gen_program.cpp | 8 ++++++++
|
||||||
|
backend/src/backend/program.cpp | 4 ++++
|
||||||
|
backend/src/llvm/ExpandLargeIntegers.cpp | 2 +-
|
||||||
|
backend/src/llvm/llvm_bitcode_link.cpp | 4 ++++
|
||||||
|
backend/src/llvm/llvm_includes.hpp | 4 ++++
|
||||||
|
6 files changed, 22 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/CMake/FindLLVM.cmake b/CMake/FindLLVM.cmake
|
||||||
|
index 5457f24..f882589 100644
|
||||||
|
--- a/CMake/FindLLVM.cmake
|
||||||
|
+++ b/CMake/FindLLVM.cmake
|
||||||
|
@@ -113,10 +113,10 @@ macro(add_one_lib name)
|
||||||
|
endmacro()
|
||||||
|
|
||||||
|
#Assume clang lib path same as llvm lib path
|
||||||
|
+add_one_lib("clangCodeGen")
|
||||||
|
add_one_lib("clangFrontend")
|
||||||
|
add_one_lib("clangSerialization")
|
||||||
|
add_one_lib("clangDriver")
|
||||||
|
-add_one_lib("clangCodeGen")
|
||||||
|
add_one_lib("clangSema")
|
||||||
|
add_one_lib("clangStaticAnalyzerFrontend")
|
||||||
|
add_one_lib("clangStaticAnalyzerCheckers")
|
||||||
|
diff --git a/backend/src/backend/gen_program.cpp b/backend/src/backend/gen_program.cpp
|
||||||
|
index 274c99c..4159234 100644
|
||||||
|
--- a/backend/src/backend/gen_program.cpp
|
||||||
|
+++ b/backend/src/backend/gen_program.cpp
|
||||||
|
@@ -454,7 +454,11 @@ namespace gbe {
|
||||||
|
#ifdef GBE_COMPILER_AVAILABLE
|
||||||
|
std::string str;
|
||||||
|
llvm::raw_string_ostream OS(str);
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 7
|
||||||
|
+ llvm::WriteBitcodeToFile(*((llvm::Module*)prog->module), OS);
|
||||||
|
+#else
|
||||||
|
llvm::WriteBitcodeToFile((llvm::Module*)prog->module, OS);
|
||||||
|
+#endif
|
||||||
|
std::string& bin_str = OS.str();
|
||||||
|
int llsz = bin_str.size();
|
||||||
|
*binary = (char *)malloc(sizeof(char) * (llsz+1) );
|
||||||
|
@@ -545,7 +549,11 @@ namespace gbe {
|
||||||
|
&modRef);
|
||||||
|
src = llvm::unwrap(modRef);
|
||||||
|
}
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 7
|
||||||
|
+ llvm::Module* clone = llvm::CloneModule(*src).release();
|
||||||
|
+#else
|
||||||
|
llvm::Module* clone = llvm::CloneModule(src).release();
|
||||||
|
+#endif
|
||||||
|
if (LLVMLinkModules2(wrap(dst), wrap(clone))) {
|
||||||
|
#elif LLVM_VERSION_MAJOR * 10 + LLVM_VERSION_MINOR >= 37
|
||||||
|
if (LLVMLinkModules(wrap(dst), wrap(src), LLVMLinkerPreserveSource_Removed, &errMsg)) {
|
||||||
|
diff --git a/backend/src/backend/program.cpp b/backend/src/backend/program.cpp
|
||||||
|
index c37c595..b36f7b4 100644
|
||||||
|
--- a/backend/src/backend/program.cpp
|
||||||
|
+++ b/backend/src/backend/program.cpp
|
||||||
|
@@ -794,7 +794,11 @@ namespace gbe {
|
||||||
|
llvm::raw_fd_ostream ostream (dumpSPIRBinaryName.c_str(),
|
||||||
|
err, llvm::sys::fs::F_None);
|
||||||
|
if (!err)
|
||||||
|
+#if LLVM_VERSION_MAJOR<7
|
||||||
|
llvm::WriteBitcodeToFile(*out_module, ostream);
|
||||||
|
+#else
|
||||||
|
+ llvm::WriteBitcodeToFile(**out_module, ostream);
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
return true;
|
||||||
|
diff --git a/backend/src/llvm/ExpandLargeIntegers.cpp b/backend/src/llvm/ExpandLargeIntegers.cpp
|
||||||
|
index 8515dc1..4aec44e 100644
|
||||||
|
--- a/backend/src/llvm/ExpandLargeIntegers.cpp
|
||||||
|
+++ b/backend/src/llvm/ExpandLargeIntegers.cpp
|
||||||
|
@@ -99,8 +99,8 @@ using namespace llvm;
|
||||||
|
|
||||||
|
#ifdef DEBUG
|
||||||
|
#undef DEBUG
|
||||||
|
- #define DEBUG(...)
|
||||||
|
#endif
|
||||||
|
+#define DEBUG(...)
|
||||||
|
// Break instructions up into no larger than 64-bit chunks.
|
||||||
|
static const unsigned kChunkBits = 64;
|
||||||
|
static const unsigned kChunkBytes = kChunkBits / CHAR_BIT;
|
||||||
|
diff --git a/backend/src/llvm/llvm_bitcode_link.cpp b/backend/src/llvm/llvm_bitcode_link.cpp
|
||||||
|
index ef56e4c..4c3e20e 100644
|
||||||
|
--- a/backend/src/llvm/llvm_bitcode_link.cpp
|
||||||
|
+++ b/backend/src/llvm/llvm_bitcode_link.cpp
|
||||||
|
@@ -340,7 +340,11 @@ namespace gbe
|
||||||
|
/* We use beignet's bitcode as dst because it will have a lot of
|
||||||
|
lazy functions which will not be loaded. */
|
||||||
|
#if LLVM_VERSION_MAJOR * 10 + LLVM_VERSION_MINOR >= 39
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 7
|
||||||
|
+ llvm::Module * linked_module = llvm::CloneModule(*(llvm::Module*)mod).release();
|
||||||
|
+#else
|
||||||
|
llvm::Module * linked_module = llvm::CloneModule((llvm::Module*)mod).release();
|
||||||
|
+#endif
|
||||||
|
if(LLVMLinkModules2(wrap(clonedLib), wrap(linked_module))) {
|
||||||
|
#else
|
||||||
|
char* errorMsg;
|
||||||
|
diff --git a/backend/src/llvm/llvm_includes.hpp b/backend/src/llvm/llvm_includes.hpp
|
||||||
|
index 184553a..ffccf02 100644
|
||||||
|
--- a/backend/src/llvm/llvm_includes.hpp
|
||||||
|
+++ b/backend/src/llvm/llvm_includes.hpp
|
||||||
|
@@ -89,6 +89,10 @@
|
||||||
|
#include "llvm/CodeGen/IntrinsicLowering.h"
|
||||||
|
|
||||||
|
#include "llvm/Transforms/Scalar.h"
|
||||||
|
+#if LLVM_VERSION_MAJOR >= 7
|
||||||
|
+#include "llvm/Transforms/Utils.h"
|
||||||
|
+#include "llvm/Transforms/InstCombine/InstCombine.h"
|
||||||
|
+#endif
|
||||||
|
#include "llvm/MC/MCAsmInfo.h"
|
||||||
|
#include "llvm/MC/MCContext.h"
|
||||||
|
#include "llvm/MC/MCInstrInfo.h"
|
||||||
|
--
|
||||||
|
cgit v1.1
|
||||||
|
|
||||||
|
|
235
SPECS/beignet.spec
Normal file
235
SPECS/beignet.spec
Normal file
@ -0,0 +1,235 @@
|
|||||||
|
Name: beignet
|
||||||
|
Version: 1.3.2
|
||||||
|
Release: 4%{?dist}
|
||||||
|
Summary: Open source implementation of the OpenCL for Intel GPUs
|
||||||
|
|
||||||
|
License: LGPLv2+
|
||||||
|
URL: https://01.org/beignet/
|
||||||
|
Source0: https://01.org/sites/default/files/%{name}-%{version}-source.tar.gz
|
||||||
|
# https://cgit.freedesktop.org/beignet/commit/?id=033464f4b8045a49dbcc1a84cde5c05986ca11c2
|
||||||
|
Patch1: 0001-Add-AppStream-metadata.patch
|
||||||
|
Patch2: beignet-llvm6.patch
|
||||||
|
Patch3: beignet-llvm7.patch
|
||||||
|
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: gcc
|
||||||
|
BuildRequires: gcc-c++
|
||||||
|
BuildRequires: llvm-devel
|
||||||
|
BuildRequires: clang-devel
|
||||||
|
BuildRequires: ncurses-devel
|
||||||
|
BuildRequires: zlib-devel
|
||||||
|
BuildRequires: pkgconfig(x11)
|
||||||
|
BuildRequires: pkgconfig(libdrm)
|
||||||
|
BuildRequires: pkgconfig(libdrm_intel) >= 2.4.52
|
||||||
|
BuildRequires: pkgconfig(xext)
|
||||||
|
BuildRequires: pkgconfig(xfixes)
|
||||||
|
BuildRequires: pkgconfig(gl)
|
||||||
|
BuildRequires: pkgconfig(egl) >= 11.0.0
|
||||||
|
BuildRequires: ocl-icd-devel
|
||||||
|
BuildRequires: pkgconfig(libva)
|
||||||
|
BuildRequires: pkgconfig(libva-x11)
|
||||||
|
BuildRequires: %{_bindir}/appstream-util
|
||||||
|
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
|
||||||
|
Requires: opencl-filesystem
|
||||||
|
|
||||||
|
ExclusiveArch: x86_64 %{ix86}
|
||||||
|
|
||||||
|
%description
|
||||||
|
Beignet is an open source implementation of the OpenCL specification - a generic
|
||||||
|
compute oriented API. This code base contains the code to run OpenCL programs
|
||||||
|
on Intel GPUs which basically defines and implements the OpenCL host functions
|
||||||
|
required to initialize the device, create the command queues, the kernels and
|
||||||
|
the programs and run them on the GPU.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: opencl-headers
|
||||||
|
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p1 -n Beignet-%{version}-Source
|
||||||
|
mkdir %{_target_platform}
|
||||||
|
|
||||||
|
%build
|
||||||
|
pushd %{_target_platform}
|
||||||
|
%cmake .. \
|
||||||
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||||
|
-DLLVM_INSTALL_DIR=%{_bindir}/ \
|
||||||
|
-DENABLE_GL_SHARING=ON \
|
||||||
|
-DEXPERIMENTAL_DOUBLE=ON \
|
||||||
|
%{nil}
|
||||||
|
popd
|
||||||
|
%make_build -C %{_target_platform}
|
||||||
|
|
||||||
|
%install
|
||||||
|
%make_install -C %{_target_platform}
|
||||||
|
find %{buildroot}%{_includedir}/CL/ -not -name "cl_intel.h" -type f -print -delete
|
||||||
|
mv %{buildroot}%{_sysconfdir}/OpenCL/vendors/intel-beignet.icd %{buildroot}%{_sysconfdir}/OpenCL/vendors/intel-beignet-$RPM_ARCH.icd
|
||||||
|
|
||||||
|
%check
|
||||||
|
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/com.intel.beignet.metainfo.xml || :
|
||||||
|
|
||||||
|
%files
|
||||||
|
%license COPYING
|
||||||
|
%doc README.md
|
||||||
|
%{_libdir}/beignet/
|
||||||
|
%{_sysconfdir}/OpenCL/vendors/*
|
||||||
|
%{_datadir}/metainfo/com.intel.beignet.metainfo.xml
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc docs/*
|
||||||
|
%{_includedir}/CL/cl_intel.h
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Jan 24 2019 Josef Ridky <jridky@redhat.com> - 1.3.2-4
|
||||||
|
- fix file conflict for multilib package
|
||||||
|
|
||||||
|
* Mon Jan 21 2019 Josef Ridky <jridky@redhat.com> - 1.3.2-3
|
||||||
|
- Initial package version for RHEL-8
|
||||||
|
- allow use LLVM version 7+
|
||||||
|
|
||||||
|
* Fri Nov 10 2017 Josef Ridky <jridky@redhat.com> - 1.3.2-2
|
||||||
|
- Initial package version for RHEL-7.5
|
||||||
|
|
||||||
|
* Wed Nov 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.2-1
|
||||||
|
- Update to 1.3.2
|
||||||
|
|
||||||
|
* Tue Oct 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.1-7
|
||||||
|
- Rebuild for LLVM 5.0
|
||||||
|
|
||||||
|
* Wed Oct 04 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.1-6
|
||||||
|
- Sync with 1.3 branch
|
||||||
|
|
||||||
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-5.git20170622.36f6a8b
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-4.git20170622.36f6a8b
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.1-3.git20170622.36f6a8b
|
||||||
|
- rebase to latest git, otherwise it is completely broken
|
||||||
|
|
||||||
|
* Tue Mar 21 2017 Tom Stellard <tstellar@redhat.com> - 1.3.1-2
|
||||||
|
- Fix build with LLVM 4.0
|
||||||
|
|
||||||
|
* Mon Mar 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.3.1-1
|
||||||
|
- Update to 1.3.1
|
||||||
|
|
||||||
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 22 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.3.0-3
|
||||||
|
- Update patch for OCL 2.0
|
||||||
|
|
||||||
|
* Sat Jan 21 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.3.0-2
|
||||||
|
- Enable OpenCL 2.0
|
||||||
|
|
||||||
|
* Fri Jan 20 2017 Igor Gnatenko <ignatenko@redhat.com> - 1.3.0-1
|
||||||
|
- Update to 1.3.0 (RHBZ #1415148)
|
||||||
|
|
||||||
|
* Tue Nov 08 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.2.1-1
|
||||||
|
- Update to 1.2.1 (RHBZ #1392639)
|
||||||
|
|
||||||
|
* Thu Oct 27 2016 Dave Airlie <airlied@redhat.com> - 1.2.0-2
|
||||||
|
- rebase to llvm 3.9
|
||||||
|
|
||||||
|
* Tue Aug 30 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.2.0-1
|
||||||
|
- Update to 1.2.0 (RHBZ #1328527)
|
||||||
|
- Drop virtual Provides for ocl-icd
|
||||||
|
|
||||||
|
* Tue Jun 28 2016 Igor Gnatenko <ignatenko@redhat.com> - 1.1.2-1
|
||||||
|
- Update to 1.1.2 (RHBZ #1328527)
|
||||||
|
|
||||||
|
* Fri Apr 08 2016 Björn Esser <fedora@besser82.io> - 1.1.1-5
|
||||||
|
- add virtual Provides for ocl-icd (RHBZ #1317603)
|
||||||
|
|
||||||
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.1-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||||
|
|
||||||
|
* Thu Nov 05 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.1.1-2
|
||||||
|
- Backport patch from upstream against "failed to release userptr" (RHBZ #1277925)
|
||||||
|
|
||||||
|
* Fri Oct 09 2015 Fedora Release Monitoring <release-monitoring@fedoraproject.org> - 1.1.1-1
|
||||||
|
- Update to 1.1.1 (#1249611)
|
||||||
|
|
||||||
|
* Tue Oct 06 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.0-2
|
||||||
|
- Make beignet compiling and working with LLVM 3.7
|
||||||
|
|
||||||
|
* Mon Aug 03 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.1.0-1
|
||||||
|
- Update to 1.1.0 (RHBZ #1249611)
|
||||||
|
|
||||||
|
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 19 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.0.3-2
|
||||||
|
- Fix licensing issues with not compatipble LGPL code
|
||||||
|
- use python3-devel for fedora23+
|
||||||
|
- use license macro
|
||||||
|
- use make_build macro
|
||||||
|
|
||||||
|
* Fri May 08 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.0.3-1
|
||||||
|
- Update to 1.0.3 (RHBZ #1202329)
|
||||||
|
|
||||||
|
* Mon Jan 19 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.0.1-1
|
||||||
|
- 1.0.1 (RHBZ #1183497)
|
||||||
|
|
||||||
|
* Mon Nov 17 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 1.0.0-1
|
||||||
|
- 1.0.0 (RHBZ #1142892)
|
||||||
|
|
||||||
|
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 28 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.9.2-1
|
||||||
|
- 0.9.2 upstream release (RHBZ #1123941)
|
||||||
|
|
||||||
|
* Sun Jul 06 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.9.1-1
|
||||||
|
- 0.9.1 upstream release (RHBZ #1116622)
|
||||||
|
|
||||||
|
* Fri Jul 04 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.9.0-1
|
||||||
|
- Update ot 0.9.0
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 13 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.8-2
|
||||||
|
- Update LLVM/Terminfo patch from upstream maillist
|
||||||
|
|
||||||
|
* Wed Feb 12 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.8-1
|
||||||
|
- 0.8 upstream release
|
||||||
|
|
||||||
|
* Mon Jan 20 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-9.48f8e5b
|
||||||
|
- We need opencl-filesystem as requires
|
||||||
|
|
||||||
|
* Thu Jan 16 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-8.48f8e5b
|
||||||
|
- Latest master branch
|
||||||
|
|
||||||
|
* Wed Jan 15 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-7.984d680
|
||||||
|
- Fix libdir
|
||||||
|
|
||||||
|
* Wed Jan 15 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-6.984d680
|
||||||
|
- Update to latest master + apply patches from upstream list
|
||||||
|
|
||||||
|
* Tue Jan 14 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-5.e427b3e
|
||||||
|
- spec: trivial fix
|
||||||
|
|
||||||
|
* Mon Jan 13 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-4.e427b3e
|
||||||
|
- Build only on x86 arches, because only Intel GPUs supported here
|
||||||
|
- Fix license
|
||||||
|
- Update description
|
||||||
|
|
||||||
|
* Mon Jan 13 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-3.e427b3e
|
||||||
|
- Update to latest master
|
||||||
|
|
||||||
|
* Fri Jan 10 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-2.991e0d7
|
||||||
|
- Git from OpenCL-1.2 branch
|
||||||
|
|
||||||
|
* Fri Jan 10 2014 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3-1
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user