Rebase to latest upstream
- Resolves #1871417 Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
b3f9cd66d8
commit
cd0f90c0a5
@ -1,36 +0,0 @@
|
|||||||
From a8e0830aa51a33181bc4de484bfc076d02c7e8a5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rafael Fonseca <r4f4rfs@gmail.com>
|
|
||||||
Date: Wed, 2 Sep 2020 09:59:11 +0200
|
|
||||||
Subject: [PATCH] tests: only run arg parser test on supported arches
|
|
||||||
|
|
||||||
Fixes #3077
|
|
||||||
|
|
||||||
Signed-off-by: Rafael Fonseca <r4f4rfs@gmail.com>
|
|
||||||
---
|
|
||||||
tests/cc/test_usdt_args.cc | 6 ++++++
|
|
||||||
1 file changed, 6 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/cc/test_usdt_args.cc b/tests/cc/test_usdt_args.cc
|
|
||||||
index c2c5fff3..b8db58d2 100644
|
|
||||||
--- a/tests/cc/test_usdt_args.cc
|
|
||||||
+++ b/tests/cc/test_usdt_args.cc
|
|
||||||
@@ -52,6 +52,10 @@ static void verify_register(USDT::ArgumentParser &parser, int arg_size,
|
|
||||||
REQUIRE(arg.scale() == scale);
|
|
||||||
}
|
|
||||||
|
|
||||||
+/* supported arches only */
|
|
||||||
+#if defined(__aarch64__) || defined(__powerpc64__) || \
|
|
||||||
+ defined(__s390x__) || defined(__x86_64__)
|
|
||||||
+
|
|
||||||
TEST_CASE("test usdt argument parsing", "[usdt]") {
|
|
||||||
SECTION("parse failure") {
|
|
||||||
#ifdef __aarch64__
|
|
||||||
@@ -205,3 +209,5 @@ TEST_CASE("test usdt argument parsing", "[usdt]") {
|
|
||||||
REQUIRE(parser.done());
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+
|
|
||||||
+#endif /* supported arches only */
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
8
bcc.spec
8
bcc.spec
@ -15,8 +15,8 @@
|
|||||||
%undefine __cmake_in_source_build
|
%undefine __cmake_in_source_build
|
||||||
|
|
||||||
Name: bcc
|
Name: bcc
|
||||||
Version: 0.16.0
|
Version: 0.17.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: BPF Compiler Collection (BCC)
|
Summary: BPF Compiler Collection (BCC)
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/iovisor/bcc
|
URL: https://github.com/iovisor/bcc
|
||||||
@ -25,7 +25,6 @@ Source0: %{url}/releases/download/v%{version}/%{name}-src-with-submodule.
|
|||||||
#Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
#Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
Patch0: %{name}-0.15.0-Reinstate-bpf_detach_kfunc.patch
|
Patch0: %{name}-0.15.0-Reinstate-bpf_detach_kfunc.patch
|
||||||
Patch1: 0001-tests-only-run-arg-parser-test-on-supported-arches.patch
|
|
||||||
|
|
||||||
# Arches will be included as upstream support is added and dependencies are
|
# Arches will be included as upstream support is added and dependencies are
|
||||||
# satisfied in the respective arches
|
# satisfied in the respective arches
|
||||||
@ -189,6 +188,9 @@ rm -rf %{buildroot}%{_datadir}/%{name}/tools/old/
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 30 11:25:46 CET 2020 Rafael dos Santos <rdossant@redhat.com> - 0.17.0-1
|
||||||
|
- Rebase to latest upstream (#1871417)
|
||||||
|
|
||||||
* Mon Oct 12 2020 Jerome Marchand <jmarchan@redhat.com> - 0.16.0.3
|
* Mon Oct 12 2020 Jerome Marchand <jmarchan@redhat.com> - 0.16.0.3
|
||||||
- Rebuild for LLVM 11.0.0-rc6
|
- Rebuild for LLVM 11.0.0-rc6
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (bcc-src-with-submodule.tar.gz) = ec2eec46ef45e96a269fe252de85734e12182bac839c7ee958852c6e7f4935b86f83536d6fd127933549f521d9b7af440544207818d5bd72a94567d41c6f3b75
|
SHA512 (bcc-src-with-submodule.tar.gz) = 5e10e8404f4d0615cd0d57077a2c095ff6837b157edf627e738f0229e2b59a1c3e0c8ea0226b4560929b2fed6532f3ff4037a805fd13c36394ac3166b7423ca0
|
||||||
|
Loading…
Reference in New Issue
Block a user