Rebase to latest upstream version
- Resolves #1957727 Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
79e2eb3237
commit
7b7ddeba41
@ -1,46 +0,0 @@
|
||||
From 0b9a7f0de847d945bc5dd83961136e04d6c890ec Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Wed, 1 Jul 2020 17:52:51 +0200
|
||||
Subject: [PATCH] Reinstate bpf_detach_kfunc
|
||||
|
||||
It doesn't do anything, but bpftrace still calls it.
|
||||
|
||||
---
|
||||
src/cc/libbpf.c | 7 +++++++
|
||||
src/cc/libbpf.h | 2 ++
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/src/cc/libbpf.c b/src/cc/libbpf.c
|
||||
index 010d1222..4c43218f 100644
|
||||
--- a/src/cc/libbpf.c
|
||||
+++ b/src/cc/libbpf.c
|
||||
@@ -1186,6 +1186,13 @@ bool bpf_has_kernel_btf(void)
|
||||
return libbpf_find_vmlinux_btf_id("bpf_prog_put", 0) > 0;
|
||||
}
|
||||
|
||||
+int bpf_detach_kfunc(int prog_fd, char *func)
|
||||
+{
|
||||
+ UNUSED(prog_fd);
|
||||
+ UNUSED(func);
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
int bpf_attach_kfunc(int prog_fd)
|
||||
{
|
||||
int ret;
|
||||
diff --git a/src/cc/libbpf.h b/src/cc/libbpf.h
|
||||
index 61471b5b..bcae5c99 100644
|
||||
--- a/src/cc/libbpf.h
|
||||
+++ b/src/cc/libbpf.h
|
||||
@@ -94,6 +94,8 @@ int bpf_detach_tracepoint(const char *tp_category, const char *tp_name);
|
||||
|
||||
int bpf_attach_raw_tracepoint(int progfd, const char *tp_name);
|
||||
|
||||
+ int bpf_detach_kfunc(int prog_fd, char *func);
|
||||
+
|
||||
int bpf_attach_kfunc(int prog_fd);
|
||||
|
||||
int bpf_attach_lsm(int prog_fd);
|
||||
--
|
||||
2.25.4
|
||||
|
9
bcc.spec
9
bcc.spec
@ -26,8 +26,8 @@
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
Name: bcc
|
||||
Version: 0.19.0
|
||||
Release: 6%{?dist}
|
||||
Version: 0.20.0
|
||||
Release: 1%{?dist}
|
||||
Summary: BPF Compiler Collection (BCC)
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/iovisor/bcc
|
||||
@ -35,8 +35,6 @@ URL: https://github.com/iovisor/bcc
|
||||
Source0: %{url}/releases/download/v%{version}/%{name}-src-with-submodule.tar.gz
|
||||
#Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch0: %{name}-0.15.0-Reinstate-bpf_detach_kfunc.patch
|
||||
|
||||
# Arches will be included as upstream support is added and dependencies are
|
||||
# satisfied in the respective arches
|
||||
ExclusiveArch: x86_64 %{power64} aarch64 s390x armv7hl
|
||||
@ -228,6 +226,9 @@ install libbpf-tools/tmp-install/bin/* %{buildroot}/%{_sbindir}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 17 2021 Rafael dos Santos <rdossant@redhat.com> - 0.20.0-1
|
||||
- Rebase to latest upstream (#1957727)
|
||||
|
||||
* Tue May 11 2021 Jeff Law <jlaw@tachyum.com> - 0.19.0-6
|
||||
- Re-enable LTO
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bcc-src-with-submodule.tar.gz) = 66a1ac0199e3e0405a795d0e4f0d7895a9df38260ac0d77e857a69c81457ff9976e1eb285fe49818a8e21461abd748c66837ce49cc9d3e0952278db92c611fb5
|
||||
SHA512 (bcc-src-with-submodule.tar.gz) = 60ab3e7e11015878895d009afb2290d1e677e3c7bc04f493eb586136af190d7c0930757b34e721822eaf6700ecc17edeb30a4b04ea29c4a26cb885164060030a
|
||||
|
Loading…
Reference in New Issue
Block a user