Resolves #1634684 - usdt probes failing
Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
ef7955a9b3
commit
5db0dffb68
24
bcc-0.7.0-usdt-addr-calc.patch
Normal file
24
bcc-0.7.0-usdt-addr-calc.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From b998421b18a34d0b47a6bda996c91bad12fa5da0 Mon Sep 17 00:00:00 2001
|
||||
From: Ildar Musin <zildermann@gmail.com>
|
||||
Date: Thu, 1 Nov 2018 01:19:41 +0100
|
||||
Subject: [PATCH] Fix USDT semaphore address calculation for position
|
||||
independent executables (resolves #1998) (#2023)
|
||||
|
||||
Fix USDT semaphore address calculation for position independent executables
|
||||
---
|
||||
src/cc/bcc_syms.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/cc/bcc_syms.cc b/src/cc/bcc_syms.cc
|
||||
index a52e3f432..be9781afc 100644
|
||||
--- a/src/cc/bcc_syms.cc
|
||||
+++ b/src/cc/bcc_syms.cc
|
||||
@@ -444,7 +444,7 @@ int bcc_resolve_global_addr(int pid, const char *module, const uint64_t address,
|
||||
mod.start == 0x0)
|
||||
return -1;
|
||||
|
||||
- *global = mod.start + mod.file_offset + address;
|
||||
+ *global = mod.start - mod.file_offset + address;
|
||||
return 0;
|
||||
}
|
||||
|
7
bcc.spec
7
bcc.spec
@ -9,7 +9,7 @@
|
||||
|
||||
Name: bcc
|
||||
Version: 0.7.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: BPF Compiler Collection (BCC)
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/iovisor/bcc
|
||||
@ -21,6 +21,8 @@ Patch0: %{name}-%{version}-uflow-str-bytes.patch
|
||||
Patch1: %{name}-%{version}-utf8-encoding.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1637515
|
||||
Patch2: %{name}-%{version}-killsnoop-str-bytes.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1634684
|
||||
Patch3: %{name}-%{version}-usdt-addr-calc.patch
|
||||
|
||||
# Arches will be included as upstream support is added and dependencies are
|
||||
# satisfied in the respective arches
|
||||
@ -172,6 +174,9 @@ mv %{buildroot}%{_datadir}/%{name}/examples %{buildroot}%{_docdir}/%{name}/
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Nov 01 2018 Rafael dos Santos <rdossant@redhat.com> - 0.7.0-4
|
||||
- Fix attaching to usdt probes (#1634684)
|
||||
|
||||
* Mon Oct 22 2018 Rafael dos Santos <rdossant@redhat.com> - 0.7.0-3
|
||||
- Fix encoding of non-utf8 characters (#1516678)
|
||||
- Fix str-bytes conversion in killsnoop (#1637515)
|
||||
|
Loading…
Reference in New Issue
Block a user