Rebase to latest upstream version
- Resolves #1805072 Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
9999aacebb
commit
4c8c8b7885
@ -1,45 +0,0 @@
|
|||||||
From fb3d17cec9ee8be9b7ac2582b39aad5db474f0da Mon Sep 17 00:00:00 2001
|
|
||||||
From: Yonghong Song <yhs@fb.com>
|
|
||||||
Date: Thu, 2 Jan 2020 09:20:07 -0800
|
|
||||||
Subject: [PATCH] fix test_map_in_map.cc compilation error
|
|
||||||
|
|
||||||
fix issue #2679 where test_map_in_map.cc has a
|
|
||||||
compilation error on ppc64le due to conflicting
|
|
||||||
type __u64. Let us just remove the typedef.
|
|
||||||
|
|
||||||
Signed-off-by: Yonghong Song <yhs@fb.com>
|
|
||||||
---
|
|
||||||
tests/cc/test_map_in_map.cc | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/cc/test_map_in_map.cc b/tests/cc/test_map_in_map.cc
|
|
||||||
index 76c07f77f..f8c1a0b66 100644
|
|
||||||
--- a/tests/cc/test_map_in_map.cc
|
|
||||||
+++ b/tests/cc/test_map_in_map.cc
|
|
||||||
@@ -22,7 +22,6 @@
|
|
||||||
#include "catch.hpp"
|
|
||||||
|
|
||||||
#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
|
|
||||||
-typedef unsigned long long __u64;
|
|
||||||
|
|
||||||
TEST_CASE("test hash of maps", "[hash_of_maps]") {
|
|
||||||
{
|
|
||||||
@@ -67,7 +66,7 @@ TEST_CASE("test hash of maps", "[hash_of_maps]") {
|
|
||||||
auto t = bpf.get_map_in_map_table("maps_hash");
|
|
||||||
auto ex1_table = bpf.get_array_table<int>("ex1");
|
|
||||||
auto ex2_table = bpf.get_array_table<int>("ex2");
|
|
||||||
- auto ex3_table = bpf.get_array_table<__u64>("ex3");
|
|
||||||
+ auto ex3_table = bpf.get_array_table<unsigned long long>("ex3");
|
|
||||||
int ex1_fd = ex1_table.get_fd();
|
|
||||||
int ex2_fd = ex2_table.get_fd();
|
|
||||||
int ex3_fd = ex3_table.get_fd();
|
|
||||||
@@ -162,7 +161,8 @@ TEST_CASE("test array of maps", "[array_of_maps]") {
|
|
||||||
auto t = bpf.get_map_in_map_table("maps_array");
|
|
||||||
auto ex1_table = bpf.get_hash_table<int, int>("ex1");
|
|
||||||
auto ex2_table = bpf.get_hash_table<int, int>("ex2");
|
|
||||||
- auto ex3_table = bpf.get_hash_table<__u64, __u64>("ex3");
|
|
||||||
+ auto ex3_table =
|
|
||||||
+ bpf.get_hash_table<unsigned long long, unsigned long long>("ex3");
|
|
||||||
int ex1_fd = ex1_table.get_fd();
|
|
||||||
int ex2_fd = ex2_table.get_fd();
|
|
||||||
int ex3_fd = ex3_table.get_fd();
|
|
13
bcc.spec
13
bcc.spec
@ -8,8 +8,8 @@
|
|||||||
%bcond_without llvm_static
|
%bcond_without llvm_static
|
||||||
|
|
||||||
Name: bcc
|
Name: bcc
|
||||||
Version: 0.12.0
|
Version: 0.13.0
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: BPF Compiler Collection (BCC)
|
Summary: BPF Compiler Collection (BCC)
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/iovisor/bcc
|
URL: https://github.com/iovisor/bcc
|
||||||
@ -17,9 +17,7 @@ URL: https://github.com/iovisor/bcc
|
|||||||
Source0: %{url}/releases/download/v%{version}/%{name}-src-with-submodule.tar.gz
|
Source0: %{url}/releases/download/v%{version}/%{name}-src-with-submodule.tar.gz
|
||||||
#Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
#Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# https://github.com/iovisor/bcc/issues/2679
|
Patch0: 0001-Link-against-libclang-cpp.so.patch
|
||||||
Patch0: 0001-Fix-compilation-error-ppc64le.patch
|
|
||||||
Patch1: 0001-Link-against-libclang-cpp.so.patch
|
|
||||||
|
|
||||||
# Arches will be included as upstream support is added and dependencies are
|
# Arches will be included as upstream support is added and dependencies are
|
||||||
# satisfied in the respective arches
|
# satisfied in the respective arches
|
||||||
@ -155,6 +153,8 @@ rm -rf %{buildroot}%{_datadir}/%{name}/tools/old/
|
|||||||
%{_libdir}/libbcc-no-libbpf.so.*
|
%{_libdir}/libbcc-no-libbpf.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
|
%exclude %{_libdir}/lib%{name}*.a
|
||||||
|
%exclude %{_libdir}/lib%{name}*.la
|
||||||
%{_libdir}/lib%{name}.so
|
%{_libdir}/lib%{name}.so
|
||||||
%{_libdir}/libbcc_bpf.so
|
%{_libdir}/libbcc_bpf.so
|
||||||
%{_libdir}/libbcc-no-libbpf.so
|
%{_libdir}/libbcc-no-libbpf.so
|
||||||
@ -181,6 +181,9 @@ rm -rf %{buildroot}%{_datadir}/%{name}/tools/old/
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 26 2020 Rafael dos Santos <rdossant@redhat.com> - 0.13.0-1
|
||||||
|
- Rebase to latest upstream version (#1805072)
|
||||||
|
|
||||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-3
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (bcc-src-with-submodule.tar.gz) = ba59189258387511f4bdc450e619802adf61afb96163e7d3c53cba689a18cafe598a7ea077eba612d113e2795b46e54db9bdef5593c5d5ccb4012391b2830e0d
|
SHA512 (bcc-src-with-submodule.tar.gz) = 9f95f70bbebb3b5e175b2c513a51c024fdbe67283c02b81b56cdef74b1720b82df40a4555c1e1fdcfa56c64cd418abfa11b371e4111ffb3997c848f014690471
|
||||||
|
Loading…
Reference in New Issue
Block a user