import bcc-0.20.0-6.el9
This commit is contained in:
commit
15400ae480
1
.bcc.metadata
Normal file
1
.bcc.metadata
Normal file
@ -0,0 +1 @@
|
||||
87f0836bc2a1d7a795a44622d14930e6d4f6d627 SOURCES/bcc-0.20.0.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/bcc-0.20.0.tar.gz
|
54
SOURCES/bcc-0.20.0-Define-KERNEL_VERSION.patch
Normal file
54
SOURCES/bcc-0.20.0-Define-KERNEL_VERSION.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From 6516fb0d00208f05b29f320176204957b02b23e3 Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Mon, 26 Jul 2021 12:05:57 +0200
|
||||
Subject: [PATCH] Define KERNEL_VERSION
|
||||
|
||||
The libbpf version on RHEL9 doesn't define it.
|
||||
---
|
||||
libbpf-tools/biolatency.bpf.c | 2 ++
|
||||
libbpf-tools/biosnoop.bpf.c | 2 ++
|
||||
libbpf-tools/bitesize.bpf.c | 2 ++
|
||||
3 files changed, 6 insertions(+)
|
||||
|
||||
diff --git a/libbpf-tools/biolatency.bpf.c b/libbpf-tools/biolatency.bpf.c
|
||||
index 8d8fe584..8e6e81e2 100644
|
||||
--- a/libbpf-tools/biolatency.bpf.c
|
||||
+++ b/libbpf-tools/biolatency.bpf.c
|
||||
@@ -9,6 +9,8 @@
|
||||
|
||||
#define MAX_ENTRIES 10240
|
||||
|
||||
+#define KERNEL_VERSION(a, b, c) (((a) << 16) + ((b) << 8) + (c))
|
||||
+
|
||||
extern int LINUX_KERNEL_VERSION __kconfig;
|
||||
|
||||
const volatile bool targ_per_disk = false;
|
||||
diff --git a/libbpf-tools/biosnoop.bpf.c b/libbpf-tools/biosnoop.bpf.c
|
||||
index 76697967..7b7cb1a4 100644
|
||||
--- a/libbpf-tools/biosnoop.bpf.c
|
||||
+++ b/libbpf-tools/biosnoop.bpf.c
|
||||
@@ -11,6 +11,8 @@
|
||||
const volatile bool targ_queued = false;
|
||||
const volatile dev_t targ_dev = -1;
|
||||
|
||||
+#define KERNEL_VERSION(a, b, c) (((a) << 16) + ((b) << 8) + (c))
|
||||
+
|
||||
extern __u32 LINUX_KERNEL_VERSION __kconfig;
|
||||
|
||||
struct piddata {
|
||||
diff --git a/libbpf-tools/bitesize.bpf.c b/libbpf-tools/bitesize.bpf.c
|
||||
index 7b4d3f9d..5e7d9d97 100644
|
||||
--- a/libbpf-tools/bitesize.bpf.c
|
||||
+++ b/libbpf-tools/bitesize.bpf.c
|
||||
@@ -10,6 +10,8 @@
|
||||
const volatile char targ_comm[TASK_COMM_LEN] = {};
|
||||
const volatile dev_t targ_dev = -1;
|
||||
|
||||
+#define KERNEL_VERSION(a, b, c) (((a) << 16) + ((b) << 8) + (c))
|
||||
+
|
||||
extern __u32 LINUX_KERNEL_VERSION __kconfig;
|
||||
|
||||
struct {
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,41 @@
|
||||
From aaa39601b756074e9ba8b9a607102a1ae0cb4c94 Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Mon, 26 Jul 2021 14:45:37 +0200
|
||||
Subject: [PATCH] Revert "libbpf-tools: remove unecessary custom NULL
|
||||
definitions"
|
||||
|
||||
Libbpf on RHEL does not define NULL
|
||||
This reverts commit a9f461d74a84be2f96fd35c02cf98c7251bd4166.
|
||||
---
|
||||
libbpf-tools/biostacks.bpf.c | 1 +
|
||||
libbpf-tools/xfsslower.bpf.c | 2 ++
|
||||
2 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/libbpf-tools/biostacks.bpf.c b/libbpf-tools/biostacks.bpf.c
|
||||
index f02a1ac5..6ed0bda6 100644
|
||||
--- a/libbpf-tools/biostacks.bpf.c
|
||||
+++ b/libbpf-tools/biostacks.bpf.c
|
||||
@@ -9,6 +9,7 @@
|
||||
#include "maps.bpf.h"
|
||||
|
||||
#define MAX_ENTRIES 10240
|
||||
+#define NULL 0
|
||||
|
||||
const volatile bool targ_ms = false;
|
||||
const volatile dev_t targ_dev = -1;
|
||||
diff --git a/libbpf-tools/xfsslower.bpf.c b/libbpf-tools/xfsslower.bpf.c
|
||||
index 05962f46..2b1c6e4b 100644
|
||||
--- a/libbpf-tools/xfsslower.bpf.c
|
||||
+++ b/libbpf-tools/xfsslower.bpf.c
|
||||
@@ -6,6 +6,8 @@
|
||||
#include <bpf/bpf_tracing.h>
|
||||
#include "xfsslower.h"
|
||||
|
||||
+#define NULL 0
|
||||
+
|
||||
const volatile pid_t targ_tgid = 0;
|
||||
const volatile __u64 min_lat = 0;
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
25
SOURCES/bcc-0.20.0-libbpf-tool-don-t-ignore-LDFLAGS.patch
Normal file
25
SOURCES/bcc-0.20.0-libbpf-tool-don-t-ignore-LDFLAGS.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 657f1b2049f2c7751a9d2a13abb42c409da1bb6f Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Wed, 2 Jun 2021 14:23:20 +0200
|
||||
Subject: [PATCH] libbpf-tool: don't ignore LDFLAGS
|
||||
|
||||
---
|
||||
libbpf-tools/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libbpf-tools/Makefile b/libbpf-tools/Makefile
|
||||
index 92dcf5a5..54288380 100644
|
||||
--- a/libbpf-tools/Makefile
|
||||
+++ b/libbpf-tools/Makefile
|
||||
@@ -77,7 +77,7 @@ endif
|
||||
|
||||
$(APPS): %: $(OUTPUT)/%.o $(LIBBPF_OBJ) $(COMMON_OBJ) | $(OUTPUT)
|
||||
$(call msg,BINARY,$@)
|
||||
- $(Q)$(CC) $(CFLAGS) $^ -lelf -lz -o $@
|
||||
+ $(Q)$(CC) $(CFLAGS) $^ $(LDFLAGS) -lelf -lz -o $@
|
||||
|
||||
$(patsubst %,$(OUTPUT)/%.o,$(APPS)): %.o: %.skel.h
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,35 @@
|
||||
From 4e2851687904cff7ab4f8faa862b9046e5aaab09 Mon Sep 17 00:00:00 2001
|
||||
From: Jerome Marchand <jmarchan@redhat.com>
|
||||
Date: Fri, 30 Jul 2021 18:15:05 +0200
|
||||
Subject: [PATCH] libbpf-tools: readahead: don't mark struct hist as static
|
||||
|
||||
Libbpf readahead tool does not compile with bpftool v5.14. Since
|
||||
commit 31332ccb756 ("bpftool: Stop emitting static variables in BPF
|
||||
skeleton"), bpftool gen skeleton does not include static variable into
|
||||
the skeleton file anymore.
|
||||
|
||||
Fixes the following compilation error:
|
||||
readahead.c: In function 'main':
|
||||
readahead.c:153:26: error: 'struct readahead_bpf__bss' has no member named 'hist'
|
||||
153 | histp = &obj->bss->hist;
|
||||
| ^~
|
||||
---
|
||||
libbpf-tools/readahead.bpf.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libbpf-tools/readahead.bpf.c b/libbpf-tools/readahead.bpf.c
|
||||
index ba22e534..cfead704 100644
|
||||
--- a/libbpf-tools/readahead.bpf.c
|
||||
+++ b/libbpf-tools/readahead.bpf.c
|
||||
@@ -24,7 +24,7 @@ struct {
|
||||
__uint(map_flags, BPF_F_NO_PREALLOC);
|
||||
} birth SEC(".maps");
|
||||
|
||||
-static struct hist hist;
|
||||
+struct hist hist = {};
|
||||
|
||||
SEC("fentry/do_page_cache_ra")
|
||||
int BPF_PROG(do_page_cache_ra)
|
||||
--
|
||||
2.31.1
|
||||
|
438
SPECS/bcc.spec
Normal file
438
SPECS/bcc.spec
Normal file
@ -0,0 +1,438 @@
|
||||
# We don't want to bring luajit in RHEL
|
||||
%if 0%{?rhel} > 0
|
||||
%bcond_with lua
|
||||
%else
|
||||
# luajit is not available for some architectures
|
||||
%ifarch ppc64 ppc64le s390x
|
||||
%bcond_with lua
|
||||
%else
|
||||
%bcond_without lua
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%ifarch x86_64 ppc64 ppc64le aarch64
|
||||
%bcond_without libbpf_tools
|
||||
%else
|
||||
%bcond_with libbpf_tools
|
||||
%endif
|
||||
|
||||
%bcond_with llvm_static
|
||||
|
||||
%if %{without llvm_static}
|
||||
%global with_llvm_shared 1
|
||||
%endif
|
||||
|
||||
# Force out of source build
|
||||
%undefine __cmake_in_source_build
|
||||
|
||||
Name: bcc
|
||||
Version: 0.20.0
|
||||
Release: 6%{?dist}
|
||||
Summary: BPF Compiler Collection (BCC)
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/iovisor/bcc
|
||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: %{name}-%{version}-libbpf-tool-don-t-ignore-LDFLAGS.patch
|
||||
Patch1: %{name}-%{version}-libbpf-tools-readahead-don-t-mark-struct-hist-as-sta.patch
|
||||
Patch2: %{name}-%{version}-Define-KERNEL_VERSION.patch
|
||||
Patch3: %{name}-%{version}-Revert-libbpf-tools-remove-unecessary-custom-NULL-de.patch
|
||||
|
||||
# Arches will be included as upstream support is added and dependencies are
|
||||
# satisfied in the respective arches
|
||||
ExclusiveArch: x86_64 %{power64} aarch64 s390x armv7hl
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: cmake >= 2.8.7
|
||||
BuildRequires: flex
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
BuildRequires: llvm-devel
|
||||
BuildRequires: clang-devel
|
||||
%if %{with llvm_static}
|
||||
BuildRequires: llvm-static
|
||||
%endif
|
||||
BuildRequires: ncurses-devel
|
||||
%if %{with lua}
|
||||
BuildRequires: pkgconfig(luajit)
|
||||
%endif
|
||||
BuildRequires: libbpf-devel >= 0.0.5-3, libbpf-static >= 0.0.5-3
|
||||
|
||||
Requires: libbpf >= 0.0.5-3
|
||||
Requires: tar
|
||||
Recommends: kernel-devel
|
||||
|
||||
Recommends: %{name}-tools = %{version}-%{release}
|
||||
|
||||
%description
|
||||
BCC is a toolkit for creating efficient kernel tracing and manipulation
|
||||
programs, and includes several useful tools and examples. It makes use of
|
||||
extended BPF (Berkeley Packet Filters), formally known as eBPF, a new feature
|
||||
that was first added to Linux 3.15. BCC makes BPF programs easier to write,
|
||||
with kernel instrumentation in C (and includes a C wrapper around LLVM), and
|
||||
front-ends in Python and lua. It is suited for many tasks, including
|
||||
performance analysis and network traffic control.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Shared library for BPF Compiler Collection (BCC)
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for developing
|
||||
application that use BPF Compiler Collection (BCC).
|
||||
|
||||
|
||||
%package doc
|
||||
Summary: Examples for BPF Compiler Collection (BCC)
|
||||
Recommends: python3-%{name} = %{version}-%{release}
|
||||
Recommends: %{name}-lua = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Examples for BPF Compiler Collection (BCC)
|
||||
|
||||
|
||||
%package -n python3-%{name}
|
||||
Summary: Python3 bindings for BPF Compiler Collection (BCC)
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
%{?python_provide:%python_provide python3-%{srcname}}
|
||||
|
||||
%description -n python3-%{name}
|
||||
Python3 bindings for BPF Compiler Collection (BCC)
|
||||
|
||||
|
||||
%if %{with lua}
|
||||
%package lua
|
||||
Summary: Standalone tool to run BCC tracers written in Lua
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description lua
|
||||
Standalone tool to run BCC tracers written in Lua
|
||||
%endif
|
||||
|
||||
|
||||
%package tools
|
||||
Summary: Command line tools for BPF Compiler Collection (BCC)
|
||||
Requires: bcc = %{version}-%{release}
|
||||
Requires: python3-%{name} = %{version}-%{release}
|
||||
Requires: python3-netaddr
|
||||
|
||||
%description tools
|
||||
Command line tools for BPF Compiler Collection (BCC)
|
||||
|
||||
%if %{with libbpf_tools}
|
||||
%package -n libbpf-tools
|
||||
Summary: Command line libbpf tools for BPF Compiler Collection (BCC)
|
||||
BuildRequires: libbpf-devel >= 0.0.5-3, libbpf-static >= 0.0.5-3
|
||||
BuildRequires: bpftool
|
||||
|
||||
%description -n libbpf-tools
|
||||
Command line libbpf tools for BPF Compiler Collection (BCC)
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
|
||||
%build
|
||||
%cmake . \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DREVISION_LAST=%{version} -DREVISION=%{version} -DPYTHON_CMD=python3 \
|
||||
-DCMAKE_USE_LIBBPF_PACKAGE:BOOL=TRUE \
|
||||
%{?with_llvm_shared:-DENABLE_LLVM_SHARED=1}
|
||||
%cmake_build
|
||||
|
||||
# It was discussed and agreed to package libbpf-tools with
|
||||
# 'bpf-' prefix (https://github.com/iovisor/bcc/pull/3263)
|
||||
# Installing libbpf-tools binaries in temp directory and
|
||||
# renaming them in there and the install code will just
|
||||
# take them.
|
||||
%if %{with libbpf_tools}
|
||||
pushd libbpf-tools;
|
||||
make BPFTOOL=bpftool LIBBPF_OBJ=%{_libdir}/libbpf.a CFLAGS="%{optflags}" LDFLAGS="%{build_ldflags}"
|
||||
make DESTDIR=./tmp-install prefix= install
|
||||
(cd tmp-install/bin; for file in *; do mv $file bpf-$file; done;)
|
||||
popd
|
||||
%endif
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
# Fix python shebangs
|
||||
find %{buildroot}%{_datadir}/%{name}/{tools,examples} -type f -exec \
|
||||
sed -i -e '1s=^#!/usr/bin/python\([0-9.]\+\)\?$=#!%{__python3}=' \
|
||||
-e '1s=^#!/usr/bin/env python\([0-9.]\+\)\?$=#!%{__python3}=' \
|
||||
-e '1s=^#!/usr/bin/env bcc-lua$=#!/usr/bin/bcc-lua=' {} \;
|
||||
|
||||
# Move man pages to the right location
|
||||
mkdir -p %{buildroot}%{_mandir}
|
||||
mv %{buildroot}%{_datadir}/%{name}/man/* %{buildroot}%{_mandir}/
|
||||
# Avoid conflict with other manpages
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1517408
|
||||
for i in `find %{buildroot}%{_mandir} -name "*.gz"`; do
|
||||
tname=$(basename $i)
|
||||
rename $tname %{name}-$tname $i
|
||||
done
|
||||
mkdir -p %{buildroot}%{_docdir}/%{name}
|
||||
mv %{buildroot}%{_datadir}/%{name}/examples %{buildroot}%{_docdir}/%{name}/
|
||||
|
||||
# Delete old tools we don't want to ship
|
||||
rm -rf %{buildroot}%{_datadir}/%{name}/tools/old/
|
||||
|
||||
# We cannot run the test suit since it requires root and it makes changes to
|
||||
# the machine (e.g, IP address)
|
||||
#%check
|
||||
|
||||
%if %{with libbpf_tools}
|
||||
mkdir -p %{buildroot}/%{_sbindir}
|
||||
install libbpf-tools/tmp-install/bin/* %{buildroot}/%{_sbindir}
|
||||
%endif
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc README.md
|
||||
%license LICENSE.txt
|
||||
%{_libdir}/lib%{name}.so.*
|
||||
%{_libdir}/libbcc_bpf.so.*
|
||||
|
||||
%files devel
|
||||
%exclude %{_libdir}/lib%{name}*.a
|
||||
%exclude %{_libdir}/lib%{name}*.la
|
||||
%{_libdir}/lib%{name}.so
|
||||
%{_libdir}/libbcc_bpf.so
|
||||
%{_libdir}/pkgconfig/lib%{name}.pc
|
||||
%{_includedir}/%{name}/
|
||||
|
||||
%files -n python3-%{name}
|
||||
%{python3_sitelib}/%{name}*
|
||||
|
||||
%files doc
|
||||
%dir %{_docdir}/%{name}
|
||||
%doc %{_docdir}/%{name}/examples/
|
||||
|
||||
%files tools
|
||||
%dir %{_datadir}/%{name}
|
||||
%{_datadir}/%{name}/tools/
|
||||
%{_datadir}/%{name}/introspection/
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%if %{with lua}
|
||||
%files lua
|
||||
%{_bindir}/bcc-lua
|
||||
%endif
|
||||
|
||||
%if %{with libbpf_tools}
|
||||
%files -n libbpf-tools
|
||||
%{_sbindir}/bpf-*
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.20.0-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Tue Aug 03 2021 Jerome Marchand <jmarchan@redhat.com> - 0.20.0-5
|
||||
- Add gating
|
||||
|
||||
* Mon Jul 26 2021 Jerome Marchand <jmarchan@redhat.com> - 0.20.0-4
|
||||
- Don't require bcc-tools by default (#1967550)
|
||||
- Add explicit bcc requirement to bcc-tools
|
||||
- Build bcc from standard sources
|
||||
|
||||
* Wed Jun 02 2021 Jerome Marchand <jmarchan@redhat.com> - 0.20.0-3
|
||||
- Don't ignore LDFLAGS for libbpf-tools
|
||||
|
||||
* Wed Jun 02 2021 Jerome Marchand <jmarchan@redhat.com> - 0.20.0-2
|
||||
- Don't override cflags for libbpf-tools
|
||||
|
||||
* Thu May 27 2021 Jerome Marchand <jmarchan@redhat.com> - 0.20.0-1
|
||||
- Rebase to bcc 0.20.0
|
||||
|
||||
* Thu May 13 2021 Tom Stellard <tstellar@redhat.com> - 0.18.0-6
|
||||
- Rebuild for LLVM 12
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.18.0-5
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Thu Feb 18 2021 Jerome Marchand <jmarchan@redhat.com> - 0.18.0-4
|
||||
- Disable lua for RHEL
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Jan 22 2021 Tom Stellard <tstellar@redhat.com> - 0.18.0-2
|
||||
- Rebuild for clang-11.1.0
|
||||
|
||||
* Tue Jan 5 15:08:26 CET 2021 Rafael dos Santos <rdossant@redhat.com> - 0.18.0-1
|
||||
- Rebase to latest upstream (#1912875)
|
||||
|
||||
* Fri Oct 30 11:25:46 CET 2020 Rafael dos Santos <rdossant@redhat.com> - 0.17.0-1
|
||||
- Rebase to latest upstream (#1871417)
|
||||
|
||||
* Mon Oct 12 2020 Jerome Marchand <jmarchan@redhat.com> - 0.16.0.3
|
||||
- Rebuild for LLVM 11.0.0-rc6
|
||||
|
||||
* Fri Aug 28 2020 Rafael dos Santos <rdossant@redhat.com> - 0.16.0-2
|
||||
- Enable build for armv7hl
|
||||
|
||||
* Sun Aug 23 2020 Rafael dos Santos <rdossant@redhat.com> - 0.16.0-1
|
||||
- Rebase to latest upstream (#1871417)
|
||||
|
||||
* Tue Aug 04 2020 Rafael dos Santos <rdossant@redhat.com> - 0.15.0-6
|
||||
- Fix build with cmake (#1863243)
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-5
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jul 09 2020 Tom Stellard <tstellar@redhat.com> - 0.15.0-3
|
||||
- Drop llvm-static dependency
|
||||
- https://docs.fedoraproject.org/en-US/packaging-guidelines/#_statically_linking_executables
|
||||
|
||||
* Thu Jul 02 2020 Rafael dos Santos <rdossant@redhat.com> - 0.15.0-2
|
||||
- Reinstate a function needed by bpftrace
|
||||
|
||||
* Tue Jun 23 2020 Rafael dos Santos <rdossant@redhat.com> - 0.15.0-1
|
||||
- Rebase to latest upstream version (#1849239)
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.14.0-2
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Tue Apr 21 2020 Rafael dos Santos <rdossant@redhat.com> - 0.14.0-1
|
||||
- Rebase to latest upstream version (#1826281)
|
||||
|
||||
* Wed Feb 26 2020 Rafael dos Santos <rdossant@redhat.com> - 0.13.0-1
|
||||
- Rebase to latest upstream version (#1805072)
|
||||
|
||||
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.12.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Jan 06 2020 Tom Stellard <tstellar@redhat.com> - 0.12.0-2
|
||||
- Link against libclang-cpp.so
|
||||
- https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
|
||||
|
||||
* Tue Dec 17 2019 Rafael dos Santos <rdossant@redhat.com> - 0.12.0-1
|
||||
- Rebase to latest upstream version (#1758417)
|
||||
|
||||
* Thu Dec 05 2019 Jiri Olsa <jolsa@redhat.com> - 0.11.0-2
|
||||
- Add libbpf support
|
||||
|
||||
* Fri Oct 04 2019 Rafael dos Santos <rdossant@redhat.com> - 0.11.0-1
|
||||
- Rebase to latest upstream version (#1758417)
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.10.0-4
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.10.0-3
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed May 29 2019 Rafael dos Santos <rdossant@redhat.com> - 0.10.0-1
|
||||
- Rebase to latest upstream version (#1714902)
|
||||
|
||||
* Thu Apr 25 2019 Rafael dos Santos <rdossant@redhat.com> - 0.9.0-1
|
||||
- Rebase to latest upstream version (#1686626)
|
||||
- Rename libbpf header to libbcc_bpf
|
||||
|
||||
* Mon Apr 22 2019 Neal Gompa <ngompa@datto.com> - 0.8.0-5
|
||||
- Make the Python 3 bindings package noarch
|
||||
- Small cleanups to the spec
|
||||
|
||||
* Tue Mar 19 2019 Rafael dos Santos <rdossant@redhat.com> - 0.8.0-4
|
||||
- Add s390x support (#1679310)
|
||||
|
||||
* Wed Feb 20 2019 Rafael dos Santos <rdossant@redhat.com> - 0.8.0-3
|
||||
- Add aarch64 support (#1679310)
|
||||
|
||||
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Jan 17 2019 Rafael dos Santos <rdossant@redhat.com> - 0.8.0-1
|
||||
- Rebase to new released version
|
||||
|
||||
* Thu Nov 01 2018 Rafael dos Santos <rdossant@redhat.com> - 0.7.0-4
|
||||
- Fix attaching to usdt probes (#1634684)
|
||||
|
||||
* Mon Oct 22 2018 Rafael dos Santos <rdossant@redhat.com> - 0.7.0-3
|
||||
- Fix encoding of non-utf8 characters (#1516678)
|
||||
- Fix str-bytes conversion in killsnoop (#1637515)
|
||||
|
||||
* Sat Oct 06 2018 Rafael dos Santos <rdossant@redhat.com> - 0.7.0-2
|
||||
- Fix str/bytes conversion in uflow (#1636293)
|
||||
|
||||
* Tue Sep 25 2018 Rafael Fonseca <r4f4rfs@gmail.com> - 0.7.0-1
|
||||
- Rebase to new released version
|
||||
|
||||
* Wed Aug 22 2018 Rafael Fonseca <r4f4rfs@gmail.com> - 0.6.1-2
|
||||
- Fix typo when mangling shebangs.
|
||||
|
||||
* Thu Aug 16 2018 Rafael Fonseca <r4f4rfs@gmail.com> - 0.6.1-1
|
||||
- Rebase to new released version (#1609485)
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.6.0-2
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Mon Jun 18 2018 Rafael dos Santos <rdossant@redhat.com> - 0.6.0-1
|
||||
- Rebase to new released version (#1591989)
|
||||
|
||||
* Thu Apr 05 2018 Rafael Santos <rdossant@redhat.com> - 0.5.0-4
|
||||
- Resolves #1555627 - fix compilation error with latest llvm/clang
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Feb 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Wed Jan 03 2018 Rafael Santos <rdossant@redhat.com> - 0.5.0-1
|
||||
- Rebase to new released version
|
||||
|
||||
* Thu Nov 16 2017 Rafael Santos <rdossant@redhat.com> - 0.4.0-4
|
||||
- Resolves #1517408 - avoid conflict with other manpages
|
||||
|
||||
* Thu Nov 02 2017 Rafael Santos <rdossant@redhat.com> - 0.4.0-3
|
||||
- Use weak deps to not require lua subpkg on ppc64(le)
|
||||
|
||||
* Wed Nov 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-2
|
||||
- Rebuild for LLVM5
|
||||
|
||||
* Wed Nov 01 2017 Rafael Fonseca <rdossant@redhat.com> - 0.4.0-1
|
||||
- Resolves #1460482 - rebase to new release
|
||||
- Resolves #1505506 - add support for LLVM 5.0
|
||||
- Resolves #1460482 - BPF module compilation issue
|
||||
- Partially address #1479990 - location of man pages
|
||||
- Enable ppc64(le) support without lua
|
||||
- Soname versioning for libbpf by ignatenkobrain
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu Mar 30 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.3.0-2
|
||||
- Rebuild for LLVM4
|
||||
- Trivial fixes in spec
|
||||
|
||||
* Fri Mar 10 2017 Rafael Fonseca <rdossant@redhat.com> - 0.3.0-1
|
||||
- Rebase to new release.
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jan 10 2017 Rafael Fonseca <rdossant@redhat.com> - 0.2.0-2
|
||||
- Fix typo
|
||||
|
||||
* Tue Nov 29 2016 Rafael Fonseca <rdossant@redhat.com> - 0.2.0-1
|
||||
- Initial import
|
Loading…
Reference in New Issue
Block a user