Rebase to latest upstream release
- Resolves #2004815 Signed-off-by: Rafael dos Santos <rdossant@redhat.com>
This commit is contained in:
parent
cbb25c63d3
commit
122cc03a55
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@
|
|||||||
/bcc-src-with-submodule.tar.gz
|
/bcc-src-with-submodule.tar.gz
|
||||||
/bcc-0.20.0.tar.gz
|
/bcc-0.20.0.tar.gz
|
||||||
/bcc-0.21.0.tar.gz
|
/bcc-0.21.0.tar.gz
|
||||||
|
/bcc-0.22.0.tar.gz
|
||||||
|
8
bcc.spec
8
bcc.spec
@ -26,16 +26,13 @@
|
|||||||
%undefine __cmake_in_source_build
|
%undefine __cmake_in_source_build
|
||||||
|
|
||||||
Name: bcc
|
Name: bcc
|
||||||
Version: 0.21.0
|
Version: 0.22.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: BPF Compiler Collection (BCC)
|
Summary: BPF Compiler Collection (BCC)
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/iovisor/bcc
|
URL: https://github.com/iovisor/bcc
|
||||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1987381
|
|
||||||
Patch0: libbpftools-readahead-fix.patch
|
|
||||||
|
|
||||||
# Arches will be included as upstream support is added and dependencies are
|
# Arches will be included as upstream support is added and dependencies are
|
||||||
# satisfied in the respective arches
|
# satisfied in the respective arches
|
||||||
ExclusiveArch: x86_64 %{power64} aarch64 s390x armv7hl
|
ExclusiveArch: x86_64 %{power64} aarch64 s390x armv7hl
|
||||||
@ -243,6 +240,9 @@ cp -a libbpf-tools/tmp-install/bin/* %{buildroot}/%{_sbindir}/
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 16 2021 Rafael dos Santos <rdossant@redhat.com> - 0.22.0-1
|
||||||
|
- Rebase to latest release version
|
||||||
|
|
||||||
* Mon Aug 02 2021 Rafael dos Santos <rdossant@redhat.com> - 0.21.0-1
|
* Mon Aug 02 2021 Rafael dos Santos <rdossant@redhat.com> - 0.21.0-1
|
||||||
- Rebase to latest release version
|
- Rebase to latest release version
|
||||||
- Add support to libdebuginfod
|
- Add support to libdebuginfod
|
||||||
|
@ -1,32 +0,0 @@
|
|||||||
From a3c61b4b296da193fd77b06a6a9a4eb655a6cf76 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jerome Marchand <jmarchan@redhat.com>
|
|
||||||
Date: Fri, 30 Jul 2021 18:15:05 +0200
|
|
||||||
Subject: [PATCH] libbpf-tools: readahead: don't mark struct hist as static
|
|
||||||
|
|
||||||
Libbpf readahead tool does not compile with bpftool v5.14. Since
|
|
||||||
commit 31332ccb756 ("bpftool: Stop emitting static variables in BPF
|
|
||||||
skeleton"), bpftool gen skeleton does not include static variables
|
|
||||||
into the skeleton file anymore.
|
|
||||||
|
|
||||||
Fixes the following compilation error:
|
|
||||||
readahead.c: In function 'main':
|
|
||||||
readahead.c:153:26: error: 'struct readahead_bpf__bss' has no member named 'hist'
|
|
||||||
153 | histp = &obj->bss->hist;
|
|
||||||
| ^~
|
|
||||||
---
|
|
||||||
libbpf-tools/readahead.bpf.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/libbpf-tools/readahead.bpf.c b/libbpf-tools/readahead.bpf.c
|
|
||||||
index ba22e534c4..b9423c3f9a 100644
|
|
||||||
--- a/libbpf-tools/readahead.bpf.c
|
|
||||||
+++ b/libbpf-tools/readahead.bpf.c
|
|
||||||
@@ -24,7 +24,7 @@ struct {
|
|
||||||
__uint(map_flags, BPF_F_NO_PREALLOC);
|
|
||||||
} birth SEC(".maps");
|
|
||||||
|
|
||||||
-static struct hist hist;
|
|
||||||
+struct hist hist = {};
|
|
||||||
|
|
||||||
SEC("fentry/do_page_cache_ra")
|
|
||||||
int BPF_PROG(do_page_cache_ra)
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (bcc-0.21.0.tar.gz) = cd60dcd60ac0fdfc4a89dd0791f358cef0dfae5c06ef88352a256bdb13760ea8ed2cb1834f0929e66d91b2da23cf7a62fbabb36757d041e092f301fd1b368536
|
SHA512 (bcc-0.22.0.tar.gz) = 946ec8ed96a83cb7a9d7e44436901445588dc5e37c5cbc8b720a7a0d226b2769ab780294fa7c52099f579f4f1b6935f662be19c739d13979044723dce8ed7792
|
||||||
|
Loading…
Reference in New Issue
Block a user