Bump version to incorporate upstream fixes.
- Add python3-netaddr as runtime dep for tools package
This commit is contained in:
parent
cf8b71fee5
commit
0734d68354
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/v0.2.0.tar.gz
|
||||
/v0.3.0.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- bcc-0.2.0/src/cc/CMakeLists.txt 2017-01-05 16:01:59.069871274 +0100
|
||||
+++ bcc-0.2.0/src/cc/CMakeLists.txt 2017-01-05 16:01:36.782847428 +0100
|
||||
@@ -39,7 +39,7 @@
|
||||
set_target_properties(bcc-shared PROPERTIES VERSION ${REVISION_LAST} SOVERSION 0)
|
||||
set_target_properties(bcc-shared PROPERTIES OUTPUT_NAME bcc)
|
||||
|
||||
-add_library(bcc-loader-static libbpf.c perf_reader.c bcc_elf.c bcc_perf_map.c bcc_proc.c)
|
||||
+add_library(bcc-loader-static STATIC libbpf.c perf_reader.c bcc_elf.c bcc_perf_map.c bcc_proc.c)
|
||||
add_library(bcc-static STATIC bpf_common.cc bpf_module.cc shared_table.cc exported_files.cc bcc_syms.cc usdt_args.cc usdt.cc)
|
||||
set_target_properties(bcc-static PROPERTIES OUTPUT_NAME bcc)
|
||||
|
||||
--- bcc-0.2.0/src/cc/frontends/b/CMakeLists.txt 2017-01-05 16:02:17.133890595 +0100
|
||||
+++ bcc-0.2.0/src/cc/frontends/b/CMakeLists.txt 2017-01-05 16:01:22.954832633 +0100
|
||||
@@ -11,5 +11,5 @@
|
||||
set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/lexer.ll.cc PROPERTIES COMPILE_FLAGS "-Wno-deprecated-register")
|
||||
endif()
|
||||
|
||||
-add_library(b_frontend loader.cc codegen_llvm.cc node.cc parser.cc printer.cc
|
||||
+add_library(b_frontend STATIC loader.cc codegen_llvm.cc node.cc parser.cc printer.cc
|
||||
type_check.cc ${BISON_Parser_OUTPUTS} ${FLEX_Lexer_OUTPUTS})
|
||||
--- bcc-0.2.0/src/cc/frontends/clang/CMakeLists.txt 2017-01-05 16:02:48.788924466 +0100
|
||||
+++ bcc-0.2.0/src/cc/frontends/clang/CMakeLists.txt 2017-01-05 16:02:36.038910825 +0100
|
||||
@@ -4,4 +4,4 @@
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DKERNEL_MODULES_DIR='\"${BCC_KERNEL_MODULES_DIR}\"'")
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DKERNEL_MODULES_SUFFIX='\"${BCC_KERNEL_MODULES_SUFFIX}\"'")
|
||||
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DKERNEL_HAS_SOURCE_DIR=${BCC_KERNEL_HAS_SOURCE_DIR}")
|
||||
-add_library(clang_frontend loader.cc b_frontend_action.cc tp_frontend_action.cc kbuild_helper.cc)
|
||||
+add_library(clang_frontend STATIC loader.cc b_frontend_action.cc tp_frontend_action.cc kbuild_helper.cc)
|
16
bcc.spec
16
bcc.spec
@ -1,14 +1,11 @@
|
||||
Name: bcc
|
||||
Version: 0.2.0
|
||||
Release: 3%{?dist}
|
||||
Version: 0.3.0
|
||||
Release: 1%{?dist}
|
||||
Summary: BPF Compiler Collection (BCC)
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/iovisor/bcc
|
||||
Source0: https://github.com/iovisor/%{name}/archive/v%{version}.tar.gz
|
||||
|
||||
# https://github.com/iovisor/bcc/issues/841
|
||||
Patch0: %{name}-0.2.0-explicit-static.patch
|
||||
|
||||
# Arches will be included as upstream support is added and dependencies are
|
||||
# satisfied in the respective arches
|
||||
ExclusiveArch: x86_64
|
||||
@ -68,14 +65,17 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%description lua
|
||||
Standalone tool to run BCC tracers written in Lua
|
||||
|
||||
|
||||
%package tools
|
||||
Summary: Command line tools for BPF Compiler Collection (BCC)
|
||||
Requires: python3-%{name} = %{version}-%{release}
|
||||
Requires: python3-netaddr
|
||||
BuildArch: noarch
|
||||
|
||||
%description tools
|
||||
Command line tools for BPF Compiler Collection (BCC)
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
@ -96,10 +96,13 @@ for i in `find %{buildroot}/usr/share/%{name}/tools/ -type f`; do
|
||||
sed -i 's/\/usr\/bin\/python\>/&3/' $i
|
||||
done
|
||||
|
||||
# Examples in /usr/share shouldn't contain binaries according to FHS
|
||||
rm -rf %{buildroot}/usr/share/%{name}/examples/cpp
|
||||
for i in `find %{buildroot}/usr/share/%{name}/examples/ -type f`; do
|
||||
sed -i 's/\/usr\/bin\/env python\>/\/usr\/bin\/python3/' $i
|
||||
sed -i 's/\/usr\/bin\/python\>/&3/' $i
|
||||
sed -i 's/\/usr\/bin\/env bcc-lua\>/\/usr\/bin\/bcc-lua/' $i
|
||||
chmod -x $i
|
||||
done
|
||||
|
||||
# Compress man pages
|
||||
@ -151,6 +154,9 @@ find %{buildroot}/usr/share/%{name}/man/man8/ -name "*.8" -exec gzip {} \;
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Mar 10 2017 Rafael Fonseca <rdossant@redhat.com> - 0.3.0-1
|
||||
- Rebase to new release.
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (v0.2.0.tar.gz) = edb696a5382e2f56d06e6b8b65c37b50e719da944fbce43cbad116c773e759fb51837d57ae3d159d83a489dfd0254b9f50b97dab7116465d57f787cf50d58808
|
||||
SHA512 (v0.3.0.tar.gz) = e5a0f9ad1b0ba865b5644a5a4a0ad130708aac882239ed545bcfd74a5d80328361bc92287bad5569710849682501841e89279089efc71a97da4e02bfc709b916
|
||||
|
Loading…
Reference in New Issue
Block a user