auto-import changelog data from bc-1.06-5.src.rpm
Sun Sep 09 2001 Phil Knirsch <phil@redhat.de> 1.06-5 - Fixed a variable initialization problem in load.c which broke badly on S390.
This commit is contained in:
parent
93eb2defda
commit
d215c37fe2
14
bc-1.06-s390.patch
Normal file
14
bc-1.06-s390.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- bc-1.06/bc/load.c.s390 Wed Sep 13 20:22:38 2000
|
||||||
|
+++ bc-1.06/bc/load.c Wed Sep 5 16:10:18 2001
|
||||||
|
@@ -156,7 +156,10 @@
|
||||||
|
long label_no;
|
||||||
|
long vaf_name; /* variable, array or function number. */
|
||||||
|
long func;
|
||||||
|
- program_counter save_adr;
|
||||||
|
+ /* Make save_adr static. Otherwise the whole address save stuff doesn't make
|
||||||
|
+ any sense at all and break e.g. on S390.
|
||||||
|
+ 09/05/01 Phil Knirsch <pknirsch@redhat.de> */
|
||||||
|
+ static program_counter save_adr;
|
||||||
|
|
||||||
|
/* Initialize. */
|
||||||
|
str = code;
|
11
bc.spec
11
bc.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: GNU's bc (a numeric processing language) and dc (a calculator).
|
Summary: GNU's bc (a numeric processing language) and dc (a calculator).
|
||||||
Name: bc
|
Name: bc
|
||||||
Version: 1.06
|
Version: 1.06
|
||||||
Release: 4
|
Release: 5
|
||||||
Copyright: GPL
|
Copyright: GPL
|
||||||
URL: http://www.gnu.org/software/bc/
|
URL: http://www.gnu.org/software/bc/
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
Source: ftp://ftp.gnu.org/gnu/bc/bc-%{version}.tar.bz2
|
Source: ftp://ftp.gnu.org/gnu/bc/bc-%{version}.tar.bz2
|
||||||
Patch: bc-1.06-readline42.patch
|
Patch1: bc-1.06-readline42.patch
|
||||||
|
Patch2: bc-1.06-s390.patch
|
||||||
Prereq: /sbin/install-info grep
|
Prereq: /sbin/install-info grep
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
@ -21,7 +22,8 @@ if you would like to use its text mode calculator.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch -p1 -b .rl22
|
%patch1 -p1 -b .rl22
|
||||||
|
%patch2 -p1 -b .s390
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoconf
|
autoconf
|
||||||
@ -64,6 +66,9 @@ fi
|
|||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 9 2001 Phil Knirsch <phil@redhat.de> 1.06-5
|
||||||
|
- Fixed a variable initialization problem in load.c which broke badly on S390.
|
||||||
|
|
||||||
* Fri May 11 2001 Preston Brown <pbrown@redhat.com> 1.06-4
|
* Fri May 11 2001 Preston Brown <pbrown@redhat.com> 1.06-4
|
||||||
- use mktemp, not the pid shell variable, in rpm scriptlets
|
- use mktemp, not the pid shell variable, in rpm scriptlets
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user