update to upstream alpha 1.06.95 (in use in Gentoo, Slackware for quite a

long time, marked stable there), removed already applied patches, fix
    small memory leak (gentoo patch)
This commit is contained in:
Ondrej Vasik 2009-09-24 07:42:06 +00:00
parent 13ae359249
commit 35984ba60f
8 changed files with 41 additions and 64 deletions

View File

@ -1 +1 @@
bc-1.06.tar.gz
bc-1.06.95.tar.bz2

View File

@ -1,15 +0,0 @@
--- bc-1.06/doc/bc.info.info_exp_bessel 2003-08-12 14:57:45.000000000 +0200
+++ bc-1.06/doc/bc.info 2003-08-12 14:57:51.000000000 +0200
@@ -664,10 +664,10 @@
`l (X)'
The natural logarithm of X.
-`E (X)'
+`e (X)'
The exponential function of raising E to the value X.
-`J (N,X)'
+`j (N,X)'
The bessel function of integer order N of X.


View File

@ -1,10 +0,0 @@
--- bc-1.06/bc/scan.l.sux Fri May 11 14:27:20 2001
+++ bc-1.06/bc/scan.l Fri May 11 14:27:32 2001
@@ -143,7 +143,6 @@
/* Definitions for readline access. */
extern FILE *rl_instream;
-_PROTOTYPE(char *readline, (char *));
/* rl_input puts upto MAX characters into BUF with the number put in
BUF placed in *RESULT. If the yy input file is the same as

View File

@ -1,14 +0,0 @@
--- bc-1.06/bc/load.c.s390 Wed Sep 13 20:22:38 2000
+++ bc-1.06/bc/load.c Wed Sep 5 16:10:18 2001
@@ -156,7 +156,10 @@
long label_no;
long vaf_name; /* variable, array or function number. */
long func;
- program_counter save_adr;
+ /* Make save_adr static. Otherwise the whole address save stuff doesn't make
+ any sense at all and break e.g. on S390.
+ 09/05/01 Phil Knirsch <pknirsch@redhat.de> */
+ static program_counter save_adr;
/* Initialize. */
str = code;

View File

@ -1,10 +0,0 @@
--- bc-1.06/lib/number.c.string 2007-07-26 15:01:34.000000000 +0200
+++ bc-1.06/lib/number.c 2007-07-26 15:01:41.000000000 +0200
@@ -34,6 +34,7 @@
#include <number.h>
#include <assert.h>
#include <stdlib.h>
+#include <string.h>
#include <ctype.h>/* Prototypes needed for external utility routines. */
#define bc_rt_warn rt_warn

26
bc-1.06.95-memleak.patch Normal file
View File

@ -0,0 +1,26 @@
diff --git a/bc/bc.y b/bc/bc.y
index 14dc4be..bd91c38 100644
--- a/bc/bc.y
+++ b/bc/bc.y
@@ -569,6 +569,7 @@ expression : named_expression ASSIGN_OP
generate (">");
break;
}
+ free($2);
}
| expression '+' expression
{
diff --git a/bc/util.c b/bc/util.c
index 30beaf9..26e2e85 100644
--- a/bc/util.c
+++ b/bc/util.c
@@ -602,8 +602,7 @@ lookup (name, namekind)
case FUNCTDEF:
if (id->f_name != 0)
{
- if (namekind != FUNCT)
- free(name);
+ free(name);
/* Check to see if we are redefining a math lib function. */
if (use_math && namekind == FUNCTDEF && id->f_name <= 6)
id->f_name = next_func++;

26
bc.spec
View File

@ -1,16 +1,13 @@
Summary: GNU's bc (a numeric processing language) and dc (a calculator)
Name: bc
Version: 1.06
Release: 36%{?dist}
Version: 1.06.95
Release: 1%{?dist}
License: GPLv2+
URL: http://www.gnu.org/software/bc/
Group: Applications/Engineering
Source: ftp://ftp.gnu.org/gnu/bc/bc-%{version}.tar.gz
Patch1: bc-1.06-readline42.patch
Patch2: bc-1.06-s390.patch
Patch3: bc-1.06-info_exp_bessel.patch
Patch5: bc-1.06-string.patch
Patch6: bc-1.06-dc_ibase.patch
Source: ftp://alpha.gnu.org/pub/gnu/bc/bc-%{version}.tar.bz2
Patch1: bc-1.06-dc_ibase.patch
Patch2: bc-1.06.95-memleak.patch
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -27,11 +24,8 @@ if you would like to use its text mode calculator.
%prep
%setup -q
%patch1 -p1 -b .rl22
%patch2 -p1 -b .s390
%patch3 -p1 -b .info_exp_bessel
%patch5 -p1 -b .string
%patch6 -p1 -b .dc_ibase
%patch1 -p1 -b .dc_ibase
%patch2 -p1 -b .memleak
%build
%configure --with-readline
@ -71,6 +65,12 @@ fi
%{_infodir}/*
%changelog
* Thu Sep 24 2009 Ondrej Vasik <ovasik@redhat.com> 1.06-95-1
- update to upstream alpha 1.06.95 (in use in Gentoo, Slackware
for quite a long time, marked stable there)
- removed already applied patches, fix small memory leak
(gentoo patch)
* Thu Aug 20 2009 Zdenek Prikryl <zprikryl@redhat.com> 1.06-36
- Don't complain if installing with --excludedocs (#515934)

View File

@ -1 +1 @@
d44b5dddebd8a7a7309aea6c36fda117 bc-1.06.tar.gz
5126a721b73f97d715bb72c13c889035 bc-1.06.95.tar.bz2