new upstream version 1.07, dropped patches already appllied in usptream version
This commit is contained in:
parent
2cdfa698bf
commit
29954f7629
@ -1,20 +0,0 @@
|
|||||||
diff -urNp bc-1.06.95-orig/bc/storage.c bc-1.06.95/bc/storage.c
|
|
||||||
--- bc-1.06.95-orig/bc/storage.c 2006-09-05 04:39:31.000000000 +0200
|
|
||||||
+++ bc-1.06.95/bc/storage.c 2010-12-22 10:26:43.805250912 +0100
|
|
||||||
@@ -99,6 +99,7 @@ more_functions (VOID)
|
|
||||||
{
|
|
||||||
f = &functions[indx];
|
|
||||||
f->f_defined = FALSE;
|
|
||||||
+ f->f_void = FALSE;
|
|
||||||
f->f_body = (char *) bc_malloc (BC_START_SIZE);
|
|
||||||
f->f_body_size = BC_START_SIZE;
|
|
||||||
f->f_code_size = 0;
|
|
||||||
@@ -179,7 +180,7 @@ more_arrays ()
|
|
||||||
|
|
||||||
|
|
||||||
/* Initialize the new elements. */
|
|
||||||
- for (; indx < v_count; indx++)
|
|
||||||
+ for (; indx < a_count; indx++)
|
|
||||||
arrays[indx] = NULL;
|
|
||||||
|
|
||||||
/* Free the old elements. */
|
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/bc/bc.y b/bc/bc.y
|
|
||||||
index 14dc4be..bd91c38 100644
|
|
||||||
--- a/bc/bc.y
|
|
||||||
+++ b/bc/bc.y
|
|
||||||
@@ -569,6 +569,7 @@ expression : named_expression ASSIGN_OP
|
|
||||||
generate (">");
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
+ free($2);
|
|
||||||
}
|
|
||||||
| expression '+' expression
|
|
||||||
{
|
|
||||||
diff --git a/bc/util.c b/bc/util.c
|
|
||||||
index 30beaf9..26e2e85 100644
|
|
||||||
--- a/bc/util.c
|
|
||||||
+++ b/bc/util.c
|
|
||||||
@@ -602,8 +602,7 @@ lookup (name, namekind)
|
|
||||||
case FUNCTDEF:
|
|
||||||
if (id->f_name != 0)
|
|
||||||
{
|
|
||||||
- if (namekind != FUNCT)
|
|
||||||
- free(name);
|
|
||||||
+ free(name);
|
|
||||||
/* Check to see if we are redefining a math lib function. */
|
|
||||||
if (use_math && namekind == FUNCTDEF && id->f_name <= 6)
|
|
||||||
id->f_name = next_func++;
|
|
@ -1,27 +0,0 @@
|
|||||||
Binary files bc-1.06.95-orig/dc/.dc.c.swp and bc-1.06.95/dc/.dc.c.swp differ
|
|
||||||
diff -urNp bc-1.06.95-orig/dc/eval.c bc-1.06.95/dc/eval.c
|
|
||||||
--- bc-1.06.95-orig/dc/eval.c 2006-06-04 13:04:40.000000000 +0200
|
|
||||||
+++ bc-1.06.95/dc/eval.c 2011-09-08 15:11:48.815060585 +0200
|
|
||||||
@@ -661,7 +661,9 @@ dc_evalfile DC_DECLARG((fp))
|
|
||||||
int next_negcmp = 0;
|
|
||||||
dc_data datum;
|
|
||||||
|
|
||||||
- signal(SIGINT, dc_trap_interrupt);
|
|
||||||
+ /* Do not mask SIGINT when running from stdin */
|
|
||||||
+ if (fp != stdin)
|
|
||||||
+ signal(SIGINT, dc_trap_interrupt);
|
|
||||||
stdin_lookahead = EOF;
|
|
||||||
for (c=getc(fp); c!=EOF; c=peekc){
|
|
||||||
peekc = getc(fp);
|
|
||||||
diff -urNp bc-1.06.95-orig/doc/dc.texi bc-1.06.95/doc/dc.texi
|
|
||||||
--- bc-1.06.95-orig/doc/dc.texi 2006-06-11 10:15:54.000000000 +0200
|
|
||||||
+++ bc-1.06.95/doc/dc.texi 2011-09-08 15:09:37.032059798 +0200
|
|
||||||
@@ -126,6 +126,8 @@ To exit, use @samp{q}.
|
|
||||||
(or whatever other keystroke your system uses to generate a @code{SIGINT})
|
|
||||||
does not exit;
|
|
||||||
it is used to abort macros that are looping, etc.
|
|
||||||
+This is not true if running on stdin to prevent accidental user confusion
|
|
||||||
+about @kbd{C-c} unfunctionality.
|
|
||||||
|
|
||||||
A reverse-polish calculator stores numbers on a stack.
|
|
||||||
Entering a number pushes it on the stack.
|
|
21
bc.spec
21
bc.spec
@ -1,19 +1,15 @@
|
|||||||
Summary: GNU's bc (a numeric processing language) and dc (a calculator)
|
Summary: GNU's bc (a numeric processing language) and dc (a calculator)
|
||||||
Name: bc
|
Name: bc
|
||||||
Version: 1.06.95
|
Version: 1.07
|
||||||
Release: 18%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.gnu.org/software/bc/
|
URL: http://www.gnu.org/software/bc/
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
Source: ftp://alpha.gnu.org/pub/gnu/bc/bc-%{version}.tar.bz2
|
Source: ftp://alpha.gnu.org/pub/gnu/bc/bc-%{version}.tar.gz
|
||||||
Patch1: bc-1.06-dc_ibase.patch
|
Patch1: bc-1.06-dc_ibase.patch
|
||||||
Patch2: bc-1.06.95-memleak.patch
|
Patch2: bc-1.06.95-doc.patch
|
||||||
Patch3: bc-1.06.95-matlib.patch
|
|
||||||
Patch4: bc-1.06.95-sigintmasking.patch
|
|
||||||
Patch5: bc-1.06.95-doc.patch
|
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
BuildRequires: readline-devel, flex, bison, texinfo
|
BuildRequires: readline-devel, flex, bison, texinfo
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -28,10 +24,7 @@ if you would like to use its text mode calculator.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .dc_ibase
|
%patch1 -p1 -b .dc_ibase
|
||||||
%patch2 -p1 -b .memleak
|
%patch2 -p1 -b .doc
|
||||||
%patch3 -p1 -b .matlib
|
|
||||||
%patch4 -p1 -b .sigintmask
|
|
||||||
%patch5 -p1 -b .doc
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-readline
|
%configure --with-readline
|
||||||
@ -67,6 +60,10 @@ fi
|
|||||||
%{_infodir}/*
|
%{_infodir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 10 2017 Ondrej Vasik <ovasik@redhat.com> - 1.07-1
|
||||||
|
- new upstream version 1.07, dropped patches already appllied
|
||||||
|
in usptream version
|
||||||
|
|
||||||
* Wed Feb 01 2017 Stephen Gallagher <sgallagh@redhat.com> - 1.06.95-18
|
* Wed Feb 01 2017 Stephen Gallagher <sgallagh@redhat.com> - 1.06.95-18
|
||||||
- Install COPYING[.*] using the %%license macro
|
- Install COPYING[.*] using the %%license macro
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user