bash/bash-4.0-no_debug_output.patch
2009-01-29 14:21:50 +00:00

40 lines
1.7 KiB
Diff

diff -up bash-4.0-rc1/error.h.no_debug_output bash-4.0-rc1/error.h
--- bash-4.0-rc1/error.h.no_debug_output 2009-01-08 14:32:45.000000000 +0100
+++ bash-4.0-rc1/error.h 2009-01-29 14:39:16.000000000 +0100
@@ -51,8 +51,10 @@ extern void internal_error __P((const ch
extern void internal_warning __P((const char *, ...)) __attribute__((__format__ (printf, 1, 2)));
/* Debugging functions, not enabled in released version. */
+#if defined (DEBUG)
extern void itrace __P((const char *, ...)) __attribute__ ((__format__ (printf, 1, 2)));
extern void trace __P((const char *, ...)) __attribute__ ((__format__ (printf, 1, 2)));
+#endif
/* Report an error having to do with command parsing or execution. */
extern void command_error __P((const char *, int, int, int));
diff -up bash-4.0-rc1/builtins/evalstring.c.no_debug_output bash-4.0-rc1/builtins/evalstring.c
--- bash-4.0-rc1/builtins/evalstring.c.no_debug_output 2009-01-04 20:32:22.000000000 +0100
+++ bash-4.0-rc1/builtins/evalstring.c 2009-01-29 14:39:16.000000000 +0100
@@ -268,7 +268,9 @@ parse_and_execute (string, from_file, fl
if ((subshell_environment & SUBSHELL_COMSUB) && comsub_ignore_return)
{
command->flags |= CMD_IGNORE_RETURN;
+#if defined (DEBUG)
itrace("parse_and_execute: turned on CMD_IGNORE_RETURN from comsub_ignore_return");
+#endif
}
#if defined (ONESHOT)
diff -up bash-4.0-rc1/Makefile.in.no_debug_output bash-4.0-rc1/Makefile.in
--- bash-4.0-rc1/Makefile.in.no_debug_output 2009-01-29 14:40:11.000000000 +0100
+++ bash-4.0-rc1/Makefile.in 2009-01-29 14:40:54.000000000 +0100
@@ -112,7 +112,7 @@ VENDOR = @host_vendor@
MACHTYPE = @host@
# comment out for release
-DEBUG = @DEBUG@
+#DEBUG = @DEBUG@
MALLOC_DEBUG = @MALLOC_DEBUG@
THIS_SH = $(BUILD_DIR)/$(Program)