bd5ac20b13
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
21 lines
667 B
Diff
21 lines
667 B
Diff
Another C compatibility issue: char ** and char * are distinct types,
|
|
and strtold expects the former for its second argument.
|
|
|
|
Submitted upstream:
|
|
|
|
<https://lists.gnu.org/archive/html/bug-bash/2023-11/msg00104.html>
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 6defea0835fe8877..955c1149a8141e19 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -885,7 +885,7 @@ AC_CHECK_DECLS([strtold], [
|
|
[AC_COMPILE_IFELSE(
|
|
[AC_LANG_PROGRAM(
|
|
[[#include <stdlib.h>]],
|
|
- [[long double r; char *foo, bar; r = strtold(foo, &bar);]]
|
|
+ [[long double r; char *foo, *bar; r = strtold(foo, &bar);]]
|
|
)],
|
|
[bash_cv_strtold_broken=no],[bash_cv_strtold_broken=yes])
|
|
]
|