Don't segfault when TERM=eterm* and EMACS is unset (#530911)
This commit is contained in:
parent
8b719048a5
commit
fa7b4e7294
11
bash-4.0-emacs.patch
Normal file
11
bash-4.0-emacs.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- bash-4.0/shell.c.orig 2009-10-15 15:57:56.000000000 -0400
|
||||||
|
+++ bash-4.0/shell.c 2009-10-15 15:58:28.000000000 -0400
|
||||||
|
@@ -572,7 +572,7 @@
|
||||||
|
|
||||||
|
/* running_under_emacs == 2 for `eterm' */
|
||||||
|
running_under_emacs = (emacs != 0) || (term && STREQN (term, "emacs", 5));
|
||||||
|
- running_under_emacs += term && STREQN (term, "eterm", 5) && strstr (emacs, "term");
|
||||||
|
+ running_under_emacs += term && STREQN (term, "eterm", 5) && (emacs != 0) && strstr (emacs, "term");
|
||||||
|
|
||||||
|
if (running_under_emacs)
|
||||||
|
gnu_error_format = 1;
|
17
bash.spec
17
bash.spec
@ -5,7 +5,7 @@
|
|||||||
Version: %{baseversion}%{patchlevel}
|
Version: %{baseversion}%{patchlevel}
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell
|
Summary: The GNU Bourne Again shell
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -61,7 +61,7 @@ Patch102: bash-2.03-paths.patch
|
|||||||
Patch103: bash-2.03-profile.patch
|
Patch103: bash-2.03-profile.patch
|
||||||
Patch104: bash-2.05a-interpreter.patch
|
Patch104: bash-2.05a-interpreter.patch
|
||||||
Patch105: bash-2.05b-debuginfo.patch
|
Patch105: bash-2.05b-debuginfo.patch
|
||||||
Patch106: bash-2.05b-manso.patch
|
#Patch106: bash-2.05b-manso.patch
|
||||||
Patch107: bash-2.05b-pgrp_sync.patch
|
Patch107: bash-2.05b-pgrp_sync.patch
|
||||||
Patch108: bash-2.05b-readline-oom.patch
|
Patch108: bash-2.05b-readline-oom.patch
|
||||||
Patch109: bash-2.05b-xcc.patch
|
Patch109: bash-2.05b-xcc.patch
|
||||||
@ -78,6 +78,9 @@ Patch118: bash-tty-tests.patch
|
|||||||
# 484809, check if interp section is NOBITS
|
# 484809, check if interp section is NOBITS
|
||||||
Patch123: bash-4.0-nobits.patch
|
Patch123: bash-4.0-nobits.patch
|
||||||
|
|
||||||
|
# 530911, bash was segfaulting when TERM=eterm* and EMACS was unset
|
||||||
|
Patch124: bash-4.0-emacs.patch
|
||||||
|
|
||||||
Requires(post): ncurses-libs
|
Requires(post): ncurses-libs
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
@ -139,8 +142,8 @@ This package contains documentation files for %{name}.
|
|||||||
%patch031 -p0 -b .031
|
%patch031 -p0 -b .031
|
||||||
%patch032 -p0 -b .032
|
%patch032 -p0 -b .032
|
||||||
%patch033 -p0 -b .033
|
%patch033 -p0 -b .033
|
||||||
%patch034 -p0 -b .034
|
#%patch034 -p0 -b .034
|
||||||
%patch035 -p0 -b .035
|
#%patch035 -p0 -b .035
|
||||||
|
|
||||||
# Other patches
|
# Other patches
|
||||||
%patch101 -p1 -b .security
|
%patch101 -p1 -b .security
|
||||||
@ -148,7 +151,7 @@ This package contains documentation files for %{name}.
|
|||||||
%patch103 -p1 -b .profile
|
%patch103 -p1 -b .profile
|
||||||
%patch104 -p1 -b .interpreter
|
%patch104 -p1 -b .interpreter
|
||||||
%patch105 -p1 -b .debuginfo
|
%patch105 -p1 -b .debuginfo
|
||||||
%patch106 -p1 -b .manso
|
#%patch106 -p1 -b .manso
|
||||||
%patch107 -p1 -b .pgrp_sync
|
%patch107 -p1 -b .pgrp_sync
|
||||||
%patch108 -p1 -b .readline_oom
|
%patch108 -p1 -b .readline_oom
|
||||||
%patch109 -p1 -b .xcc
|
%patch109 -p1 -b .xcc
|
||||||
@ -161,6 +164,7 @@ This package contains documentation files for %{name}.
|
|||||||
%patch117 -p1 -b .setlocale
|
%patch117 -p1 -b .setlocale
|
||||||
%patch118 -p1 -b .tty_tests
|
%patch118 -p1 -b .tty_tests
|
||||||
%patch123 -p1 -b .nobits
|
%patch123 -p1 -b .nobits
|
||||||
|
%patch124 -p1 -b .emacs
|
||||||
|
|
||||||
echo %{version} > _distribution
|
echo %{version} > _distribution
|
||||||
echo %{release} > _patchlevel
|
echo %{release} > _patchlevel
|
||||||
@ -328,6 +332,9 @@ fi
|
|||||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 11 2009 Roman Rakus <rrakus@redhat.com> - 4.0.35-2
|
||||||
|
- Don't segfault when TERM=eterm* and EMACS is unset (#530911)
|
||||||
|
|
||||||
* Thu Oct 29 2009 Roman Rakus <rrakus@redhat.com> - 4.0.35-1
|
* Thu Oct 29 2009 Roman Rakus <rrakus@redhat.com> - 4.0.35-1
|
||||||
- Patch level 35
|
- Patch level 35
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user