Changes in man page
This commit is contained in:
parent
2cb46035a4
commit
f9028232c0
18
bash-3.2-man-page-suspend.patch
Normal file
18
bash-3.2-man-page-suspend.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff -up bash-3.2/doc/bash.1.man-page-suspend bash-3.2/doc/bash.1
|
||||
--- bash-3.2/doc/bash.1.man-page-suspend 2008-07-11 16:35:20.000000000 +0200
|
||||
+++ bash-3.2/doc/bash.1 2008-07-11 16:38:26.000000000 +0200
|
||||
@@ -8222,10 +8222,11 @@ Suspend the execution of this shell unti
|
||||
.B SIGCONT
|
||||
signal. When the suspended shell is a background process, it can be restarted by the fg command. For more information, read the
|
||||
.B JOB CONTROL
|
||||
-section. The
|
||||
+section. The suspend command can not suspend the login shell.
|
||||
+However, when
|
||||
.B \-f
|
||||
-option says not to complain if this is
|
||||
-a login shell; just suspend anyway. The return status is 0 unless
|
||||
+option is specified, suspend command can suspend even login shell.
|
||||
+The return status is 0 unless
|
||||
the shell is a login shell and
|
||||
.B \-f
|
||||
is not supplied, or if job control is not enabled.
|
64
bash-3.2-manpage.patch
Normal file
64
bash-3.2-manpage.patch
Normal file
@ -0,0 +1,64 @@
|
||||
diff -up bash-3.2/doc/bash.1.manpage bash-3.2/doc/bash.1
|
||||
--- bash-3.2/doc/bash.1.manpage 2008-07-15 13:11:39.000000000 +0200
|
||||
+++ bash-3.2/doc/bash.1 2008-07-15 13:37:39.000000000 +0200
|
||||
@@ -4139,6 +4139,9 @@ The
|
||||
.I "previous job"
|
||||
may be referenced using
|
||||
.BR %\- .
|
||||
+When there is the current job only,
|
||||
+.BR %\-
|
||||
+refers to the shell's notion of the current job.
|
||||
In output pertaining to jobs (e.g., the output of the
|
||||
.B jobs
|
||||
command), the current job is always flagged with a
|
||||
@@ -6105,10 +6108,9 @@ loop. If \fIn\fP is specified, break \f
|
||||
must be \(>= 1. If
|
||||
.I n
|
||||
is greater than the number of enclosing loops, all enclosing loops
|
||||
-are exited. The return value is 0 unless the shell is not executing
|
||||
-a loop when
|
||||
-.B break
|
||||
-is executed.
|
||||
+are exited. The return value is non-zero when
|
||||
+.I n
|
||||
+is \(<= 0; Otherwise, break returns 0 value.
|
||||
.TP
|
||||
\fBbuiltin\fP \fIshell\-builtin\fP [\fIarguments\fP]
|
||||
Execute the specified shell builtin, passing it
|
||||
@@ -6448,10 +6450,11 @@ is specified, resume at the \fIn\fPth en
|
||||
must be \(>= 1. If
|
||||
.I n
|
||||
is greater than the number of enclosing loops, the last enclosing loop
|
||||
-(the ``top-level'' loop) is resumed. The return value is 0 unless the
|
||||
-shell is not executing a loop when
|
||||
-.B continue
|
||||
-is executed.
|
||||
+(the ``top-level'' loop) is resumed. When continue is executed inside
|
||||
+of loop, the return value is non-zero when
|
||||
+.I n
|
||||
+is \(<= 0; Otherwise, continue returns 0 value.
|
||||
+When continue is executed outside of loop, the return value is 0.
|
||||
.TP
|
||||
\fBdeclare\fP [\fB\-afFirtx\fP] [\fB\-p\fP] [\fIname\fP[=\fIvalue\fP] ...]
|
||||
.PD 0
|
||||
@@ -8217,7 +8220,9 @@ by default.
|
||||
Suspend the execution of this shell until it receives a
|
||||
.SM
|
||||
.B SIGCONT
|
||||
-signal. The
|
||||
+signal. When the suspended shell is a background process, it can be restarted by the fg command. For more information, read the
|
||||
+.B JOB CONTROL
|
||||
+section. The
|
||||
.B \-f
|
||||
option says not to complain if this is
|
||||
a login shell; just suspend anyway. The return status is 0 unless
|
||||
@@ -8901,5 +8907,9 @@ unmatched parentheses, even inside shell
|
||||
error messages while the construct is being read.
|
||||
.PP
|
||||
Array variables may not (yet) be exported.
|
||||
+.PP
|
||||
+When breaking out of multiple loops, if the outermost loop
|
||||
+consists of more than one command, the exit status of break and continue
|
||||
+is lost.
|
||||
.zZ
|
||||
.zY
|
11
bash.spec
11
bash.spec
@ -1,7 +1,7 @@
|
||||
Version: 3.2
|
||||
Name: bash
|
||||
Summary: The GNU Bourne Again shell (bash) version %{version}
|
||||
Release: 26%{?dist}
|
||||
Release: 27%{?dist}
|
||||
Group: System Environment/Shells
|
||||
License: GPLv2+
|
||||
Url: http://www.gnu.org/software/bash
|
||||
@ -71,6 +71,9 @@ Patch133: bash-3.2-rng.patch
|
||||
Patch136: bash-3.2-344411.patch
|
||||
Patch137: bash-3.2-190350.patch
|
||||
Patch138: bash-3.2-comp_wordbreaks.patch
|
||||
Patch139: bash-3.2-manpage.patch
|
||||
Patch140: bash-3.2-man-page-suspend.patch
|
||||
|
||||
Requires: mktemp
|
||||
Requires(post): ncurses
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -150,6 +153,9 @@ compliance over previous versions.
|
||||
%patch136 -p1 -b .344411
|
||||
%patch137 -p1 -b .190350
|
||||
%patch138 -p1 -b .comp_wordbreaks
|
||||
%patch139 -p1 -b .manpage
|
||||
%patch140 -p1 -b .man-page-suspend
|
||||
|
||||
|
||||
echo %{version} > _distribution
|
||||
echo %{release} > _patchlevel
|
||||
@ -291,6 +297,9 @@ fi
|
||||
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||
|
||||
%changelog
|
||||
* Thu Jul 17 2008 Roman Rakus <rrakus@redhat.com> - 3.2-27
|
||||
- Changes in man page - #442018, #445692, #446625, #453409
|
||||
|
||||
* Thu Jun 5 2008 Roman Rakus <rrakus@redhat.com> - 3.2-26
|
||||
- Patchlevel 39
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user