Removes requires to avoid dependency loops. Enable #define
SSH_SOURCE_BASHRC. Catch signals right after calling execve()
This commit is contained in:
parent
064f2912f8
commit
ef575b16c4
20
bash-3.2-execve_catch_signals.patch
Normal file
20
bash-3.2-execve_catch_signals.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up bash-3.2/execute_cmd.c.execve_catch_signals bash-3.2/execute_cmd.c
|
||||||
|
--- bash-3.2/execute_cmd.c.execve_catch_signals 2008-09-16 14:28:25.000000000 +0200
|
||||||
|
+++ bash-3.2/execute_cmd.c 2008-09-16 14:52:14.000000000 +0200
|
||||||
|
@@ -99,6 +99,8 @@ extern int errno;
|
||||||
|
# include "bashhist.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include "quit.h"
|
||||||
|
+
|
||||||
|
extern int posixly_correct;
|
||||||
|
extern int breaking, continuing, loop_level;
|
||||||
|
extern int expand_aliases;
|
||||||
|
@@ -3943,6 +3945,7 @@ shell_execve (command, args, env)
|
||||||
|
SETOSTYPE (0); /* Some systems use for USG/POSIX semantics */
|
||||||
|
execve (command, args, env);
|
||||||
|
i = errno; /* error from execve() */
|
||||||
|
+ CHECK_TERMSIG;
|
||||||
|
SETOSTYPE (1);
|
||||||
|
|
||||||
|
/* If we get to this point, then start checking out the file.
|
9
bash-3.2-ssh_source_bash.patch
Normal file
9
bash-3.2-ssh_source_bash.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
diff -up bash-3.2/config-top.h.ssh_source_bash bash-3.2/config-top.h
|
||||||
|
--- bash-3.2/config-top.h.ssh_source_bash 2008-10-23 15:08:04.000000000 +0200
|
||||||
|
+++ bash-3.2/config-top.h 2008-10-23 15:08:33.000000000 +0200
|
||||||
|
@@ -86,4 +86,4 @@
|
||||||
|
|
||||||
|
/* Define this if you want bash to try to check whether it's being run by
|
||||||
|
sshd and source the .bashrc if so (like the rshd behavior). */
|
||||||
|
-/* #define SSH_SOURCE_BASHRC */
|
||||||
|
+#define SSH_SOURCE_BASHRC
|
16
bash.spec
16
bash.spec
@ -1,7 +1,7 @@
|
|||||||
Version: 3.2
|
Version: 3.2
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell (bash) version %{version}
|
Summary: The GNU Bourne Again shell (bash) version %{version}
|
||||||
Release: 27%{?dist}
|
Release: 28%{?dist}
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -74,9 +74,9 @@ Patch138: bash-3.2-comp_wordbreaks.patch
|
|||||||
Patch139: bash-3.2-manpage.patch
|
Patch139: bash-3.2-manpage.patch
|
||||||
Patch140: bash-3.2-man-page-suspend.patch
|
Patch140: bash-3.2-man-page-suspend.patch
|
||||||
Patch141: bash-3.2-patch035.patch
|
Patch141: bash-3.2-patch035.patch
|
||||||
|
Patch142: bash-3.2-execve_catch_signals.patch
|
||||||
|
Patch143: bash-3.2-ssh_source_bash.patch
|
||||||
|
|
||||||
Requires: mktemp
|
|
||||||
Requires(post): ncurses
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: texinfo bison
|
BuildRequires: texinfo bison
|
||||||
@ -160,6 +160,8 @@ compliance over previous versions.
|
|||||||
%patch138 -p1 -b .comp_wordbreaks
|
%patch138 -p1 -b .comp_wordbreaks
|
||||||
%patch139 -p1 -b .manpage
|
%patch139 -p1 -b .manpage
|
||||||
%patch140 -p1 -b .man-page-suspend
|
%patch140 -p1 -b .man-page-suspend
|
||||||
|
%patch142 -p1 -b .execve_catch_signals
|
||||||
|
%patch143 -p1 -b .ssh_source_bash
|
||||||
|
|
||||||
echo %{version} > _distribution
|
echo %{version} > _distribution
|
||||||
echo %{release} > _patchlevel
|
echo %{release} > _patchlevel
|
||||||
@ -301,6 +303,14 @@ fi
|
|||||||
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 23 2008 Roman Rakus <rrakus@redhat.com> - 3.2-28
|
||||||
|
- Removing Requires for mktemp and ncurses, which cause
|
||||||
|
dependencing loop
|
||||||
|
- Enabling #define SSH_SOURCE_BASHRC, because ssh changed.
|
||||||
|
Resolves: #458839
|
||||||
|
- Catch signals right after calling execve()
|
||||||
|
Resolves: #455548
|
||||||
|
|
||||||
* Thu Jul 17 2008 Roman Rakus <rrakus@redhat.com> - 3.2-27
|
* Thu Jul 17 2008 Roman Rakus <rrakus@redhat.com> - 3.2-27
|
||||||
- Changes in man page - #442018, #445692, #446625, #453409
|
- Changes in man page - #442018, #445692, #446625, #453409
|
||||||
- Changed patches to satisfy fuzz=0
|
- Changed patches to satisfy fuzz=0
|
||||||
|
Loading…
Reference in New Issue
Block a user