- 3.1.
- No longer need ia64, utf8, multibyteifs, jobs, sigpipe, read-e-segfault, manpage, crash, pwd, afs, subshell patches. - Remove wrap patch for now. - Use upstream patch to fix arrays.
This commit is contained in:
parent
85fa809efe
commit
d98c1bccc5
@ -1,6 +1,6 @@
|
|||||||
--- bash-3.0/config.h.in.interpreter 2004-07-28 09:40:15.259722811 +0100
|
--- bash-3.1/config.h.in.interpreter 2005-12-23 15:53:21.000000000 +0000
|
||||||
+++ bash-3.0/config.h.in 2004-07-28 09:40:15.429690416 +0100
|
+++ bash-3.1/config.h.in 2005-12-23 15:53:21.000000000 +0000
|
||||||
@@ -601,6 +601,9 @@
|
@@ -622,6 +622,9 @@
|
||||||
/* Define if you have the pathconf function. */
|
/* Define if you have the pathconf function. */
|
||||||
#undef HAVE_PATHCONF
|
#undef HAVE_PATHCONF
|
||||||
|
|
||||||
@ -10,7 +10,7 @@
|
|||||||
/* Define if you have the putenv function. */
|
/* Define if you have the putenv function. */
|
||||||
#undef HAVE_PUTENV
|
#undef HAVE_PUTENV
|
||||||
|
|
||||||
@@ -756,6 +759,9 @@
|
@@ -783,6 +786,9 @@
|
||||||
/* Define if you have the <dlfcn.h> header file. */
|
/* Define if you have the <dlfcn.h> header file. */
|
||||||
#undef HAVE_DLFCN_H
|
#undef HAVE_DLFCN_H
|
||||||
|
|
||||||
@ -20,28 +20,28 @@
|
|||||||
/* Define if you have the <grp.h> header file. */
|
/* Define if you have the <grp.h> header file. */
|
||||||
#undef HAVE_GRP_H
|
#undef HAVE_GRP_H
|
||||||
|
|
||||||
--- bash-3.0/configure.in.interpreter 2004-07-21 21:06:54.000000000 +0100
|
--- bash-3.1/configure.in.interpreter 2005-12-01 14:36:03.000000000 +0000
|
||||||
+++ bash-3.0/configure.in 2004-07-28 09:43:21.657196239 +0100
|
+++ bash-3.1/configure.in 2005-12-23 15:55:10.000000000 +0000
|
||||||
@@ -573,7 +573,7 @@
|
@@ -632,7 +632,7 @@
|
||||||
|
|
||||||
AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
|
AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
|
||||||
memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
|
memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
|
||||||
- stddef.h stdint.h netdb.h grp.h strings.h regex.h)
|
- stddef.h stdint.h netdb.h pwd.h grp.h strings.h regex.h)
|
||||||
+ stddef.h stdint.h netdb.h grp.h strings.h regex.h elf.h)
|
+ stddef.h stdint.h netdb.h pwd.h grp.h strings.h regex.h elf.h)
|
||||||
AC_CHECK_HEADERS(sys/ptem.h sys/pte.h sys/stream.h sys/select.h sys/file.h \
|
AC_CHECK_HEADERS(sys/pte.h sys/stream.h sys/select.h sys/file.h \
|
||||||
sys/resource.h sys/param.h sys/socket.h sys/stat.h \
|
sys/resource.h sys/param.h sys/socket.h sys/stat.h \
|
||||||
sys/time.h sys/times.h sys/types.h sys/wait.h)
|
sys/time.h sys/times.h sys/types.h sys/wait.h)
|
||||||
@@ -628,7 +628,7 @@
|
@@ -695,7 +695,7 @@
|
||||||
AC_CHECK_FUNCS(dup2 select getdtablesize getgroups gethostname \
|
AC_CHECK_FUNCS(dup2 fcntl getdtablesize getgroups gethostname getpagesize \
|
||||||
setdtablesize getpagesize killpg lstat getpeername sbrk \
|
getpeername getrlimit getrusage gettimeofday kill killpg \
|
||||||
getrlimit getrusage gettimeofday waitpid tcgetpgrp \
|
lstat readlink sbrk select setdtablesize tcgetpgrp uname \
|
||||||
- readlink)
|
- ulimit waitpid)
|
||||||
+ readlink pread)
|
+ ulimit waitpid pread)
|
||||||
AC_REPLACE_FUNCS(rename)
|
AC_REPLACE_FUNCS(rename)
|
||||||
|
|
||||||
dnl checks for c library functions
|
dnl checks for c library functions
|
||||||
--- bash-3.0/execute_cmd.c.interpreter 2004-07-28 09:40:15.386698610 +0100
|
--- bash-3.1/execute_cmd.c.interpreter 2005-12-23 15:53:21.000000000 +0000
|
||||||
+++ bash-3.0/execute_cmd.c 2004-07-28 09:40:15.449686605 +0100
|
+++ bash-3.1/execute_cmd.c 2005-12-23 15:56:44.000000000 +0000
|
||||||
@@ -40,6 +40,10 @@
|
@@ -40,6 +40,10 @@
|
||||||
# include <unistd.h>
|
# include <unistd.h>
|
||||||
#endif
|
#endif
|
||||||
@ -53,7 +53,7 @@
|
|||||||
#include "posixtime.h"
|
#include "posixtime.h"
|
||||||
|
|
||||||
#if defined (HAVE_SYS_RESOURCE_H) && !defined (RLIMTYPE)
|
#if defined (HAVE_SYS_RESOURCE_H) && !defined (RLIMTYPE)
|
||||||
@@ -3842,12 +3846,20 @@
|
@@ -3872,13 +3876,21 @@
|
||||||
{
|
{
|
||||||
/* The file has the execute bits set, but the kernel refuses to
|
/* The file has the execute bits set, but the kernel refuses to
|
||||||
run it for some reason. See why. */
|
run it for some reason. See why. */
|
||||||
@ -70,12 +70,13 @@
|
|||||||
if (sample_len > 2 && sample[0] == '#' && sample[1] == '!')
|
if (sample_len > 2 && sample[0] == '#' && sample[1] == '!')
|
||||||
{
|
{
|
||||||
char *interp;
|
char *interp;
|
||||||
|
int ilen;
|
||||||
|
|
||||||
+ close (fd);
|
+ close (fd);
|
||||||
interp = getinterp (sample, sample_len, (int *)NULL);
|
interp = getinterp (sample, sample_len, (int *)NULL);
|
||||||
|
ilen = strlen (interp);
|
||||||
errno = i;
|
errno = i;
|
||||||
sys_error (_("%s: %s: bad interpreter"), command, interp ? interp : "");
|
@@ -3894,6 +3906,136 @@
|
||||||
@@ -3855,6 +3867,136 @@
|
|
||||||
return (EX_NOEXEC);
|
return (EX_NOEXEC);
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
@ -1,29 +1,19 @@
|
|||||||
--- bash-2.05b/Makefile.in.sopwith 2002-12-05 14:03:50.000000000 -0500
|
--- bash-3.1/Makefile.in.xcc 2005-10-25 19:37:52.000000000 +0100
|
||||||
+++ bash-2.05b/Makefile.in 2002-12-05 14:04:13.000000000 -0500
|
+++ bash-3.1/Makefile.in 2005-12-23 16:11:09.000000000 +0000
|
||||||
@@ -57,6 +57,7 @@
|
@@ -68,6 +68,7 @@
|
||||||
AR = @AR@
|
|
||||||
ARFLAGS = @ARFLAGS@
|
ARFLAGS = @ARFLAGS@
|
||||||
RANLIB = @RANLIB@
|
RANLIB = @RANLIB@
|
||||||
+STRIP=strip
|
SIZE = @SIZE@
|
||||||
|
+STRIP = strip
|
||||||
|
|
||||||
INSTALL = @INSTALL@
|
INSTALL = @INSTALL@
|
||||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||||
@@ -471,7 +472,6 @@
|
@@ -535,7 +536,7 @@
|
||||||
$(RM) $@
|
|
||||||
$(PURIFY) $(CC) $(BUILTINS_LDFLAGS) $(LIBRARY_LDFLAGS) $(LDFLAGS) -o $(Program) $(OBJECTS) $(LIBS)
|
|
||||||
ls -l $(Program)
|
|
||||||
- size $(Program)
|
|
||||||
|
|
||||||
.build: $(SOURCES) config.h Makefile version.h $(VERSPROG)
|
|
||||||
@echo
|
|
||||||
@@ -491,9 +491,8 @@
|
|
||||||
@chmod a+rx bashbug
|
@chmod a+rx bashbug
|
||||||
|
|
||||||
strip: $(Program) .made
|
strip: $(Program) .made
|
||||||
- strip $(Program)
|
- strip $(Program)
|
||||||
+ $(STRIP) $(Program)
|
+ $(STRIP) $(Program)
|
||||||
ls -l $(Program)
|
ls -l $(Program)
|
||||||
- size $(Program)
|
-$(SIZE) $(Program)
|
||||||
|
|
||||||
lint:
|
|
||||||
${MAKE} ${MFLAGS} CFLAGS='${GCC_LINT_FLAGS}' .made
|
|
||||||
|
69
bash.spec
69
bash.spec
@ -1,7 +1,7 @@
|
|||||||
Version: 3.0
|
Version: 3.1
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell (bash) version %{version}.
|
Summary: The GNU Bourne Again shell (bash) version %{version}.
|
||||||
Release: 41
|
Release: 1
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPL
|
License: GPL
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -11,52 +11,26 @@ Source3: dot-bashrc
|
|||||||
Source4: dot-bash_profile
|
Source4: dot-bash_profile
|
||||||
Source5: dot-bash_logout
|
Source5: dot-bash_logout
|
||||||
# Official upstream patches
|
# Official upstream patches
|
||||||
Patch1: bash30-001
|
Patch1: bash31-001
|
||||||
Patch2: bash30-002
|
Patch2: bash-arrays.patch
|
||||||
Patch3: bash30-003
|
|
||||||
Patch4: bash30-004
|
|
||||||
Patch5: bash30-005
|
|
||||||
Patch6: bash30-006
|
|
||||||
Patch7: bash30-007
|
|
||||||
Patch8: bash30-008
|
|
||||||
Patch9: bash30-009
|
|
||||||
Patch10: bash30-010
|
|
||||||
Patch11: bash30-011
|
|
||||||
Patch12: bash30-012
|
|
||||||
Patch13: bash30-013
|
|
||||||
Patch14: bash30-014
|
|
||||||
Patch15: bash30-015
|
|
||||||
Patch16: bash30-016
|
|
||||||
# Other patches
|
# Other patches
|
||||||
Patch100: bash-2.03-paths.patch
|
Patch100: bash-2.03-paths.patch
|
||||||
Patch101: bash-2.02-security.patch
|
Patch101: bash-2.02-security.patch
|
||||||
Patch102: bash-2.03-profile.patch
|
Patch102: bash-2.03-profile.patch
|
||||||
Patch103: bash-2.05a-requires.patch
|
Patch103: bash-2.05a-requires.patch
|
||||||
Patch104: bash-2.05a-shellfunc.patch
|
Patch104: bash-2.05a-shellfunc.patch
|
||||||
Patch105: bash-2.05-ia64.patch
|
|
||||||
Patch106: bash-2.05a-loadables.patch
|
Patch106: bash-2.05a-loadables.patch
|
||||||
Patch107: bash-2.05a-interpreter.patch
|
Patch107: bash-2.05a-interpreter.patch
|
||||||
Patch108: bash-2.05b-readline-oom.patch
|
Patch108: bash-2.05b-readline-oom.patch
|
||||||
Patch109: bash-2.05b-utf8.patch
|
|
||||||
Patch110: bash-2.05b-mbinc.patch
|
Patch110: bash-2.05b-mbinc.patch
|
||||||
Patch111: bash-multibyteifs.patch
|
|
||||||
Patch112: bash-ulimit.patch
|
Patch112: bash-ulimit.patch
|
||||||
Patch113: bash-jobs.patch
|
|
||||||
Patch114: bash-2.05b-xcc.patch
|
Patch114: bash-2.05b-xcc.patch
|
||||||
Patch115: bash-2.05b-pgrp_sync.patch
|
Patch115: bash-2.05b-pgrp_sync.patch
|
||||||
Patch116: bash-2.05b-manso.patch
|
Patch116: bash-2.05b-manso.patch
|
||||||
Patch117: bash-2.05b-debuginfo.patch
|
Patch117: bash-2.05b-debuginfo.patch
|
||||||
Patch118: bash-tty-tests.patch
|
Patch118: bash-tty-tests.patch
|
||||||
Patch119: bash-sigpipe.patch
|
|
||||||
Patch120: bash-read-e-segfault.patch
|
|
||||||
Patch121: bash-manpage.patch
|
|
||||||
Patch122: bash-wrap.patch
|
|
||||||
Patch123: bash-crash.patch
|
|
||||||
Patch124: bash-pwd.patch
|
|
||||||
Patch125: bash-afs.patch
|
|
||||||
Patch126: bash-setlocale.patch
|
Patch126: bash-setlocale.patch
|
||||||
Patch127: bash-sighandler.patch
|
Patch127: bash-sighandler.patch
|
||||||
Patch128: bash-subshell.patch
|
|
||||||
Patch129: bash-read-memleak.patch
|
Patch129: bash-read-memleak.patch
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
Requires: mktemp
|
Requires: mktemp
|
||||||
@ -82,21 +56,7 @@ popular and powerful, and you'll probably end up using it.
|
|||||||
%setup -q -a 2
|
%setup -q -a 2
|
||||||
# Official upstream patches
|
# Official upstream patches
|
||||||
%patch1 -p0 -b .001
|
%patch1 -p0 -b .001
|
||||||
%patch2 -p0 -b .002
|
%patch2 -p0 -b .arrays
|
||||||
%patch3 -p0 -b .003
|
|
||||||
%patch4 -p0 -b .004
|
|
||||||
%patch5 -p0 -b .005
|
|
||||||
%patch6 -p0 -b .006
|
|
||||||
%patch7 -p0 -b .007
|
|
||||||
%patch8 -p0 -b .008
|
|
||||||
%patch9 -p0 -b .009
|
|
||||||
%patch10 -p0 -b .010
|
|
||||||
%patch11 -p0 -b .011
|
|
||||||
%patch12 -p0 -b .012
|
|
||||||
%patch13 -p0 -b .013
|
|
||||||
%patch14 -p0 -b .014
|
|
||||||
%patch15 -p0 -b .015
|
|
||||||
%patch16 -p0 -b .016
|
|
||||||
|
|
||||||
# Other patches
|
# Other patches
|
||||||
%patch100 -p1 -b .paths
|
%patch100 -p1 -b .paths
|
||||||
@ -104,30 +64,18 @@ popular and powerful, and you'll probably end up using it.
|
|||||||
%patch102 -p1 -b .profile
|
%patch102 -p1 -b .profile
|
||||||
%patch103 -p1 -b .requires
|
%patch103 -p1 -b .requires
|
||||||
%patch104 -p1 -b .shellfunc
|
%patch104 -p1 -b .shellfunc
|
||||||
%patch105 -p1 -b .ia64
|
|
||||||
%patch106 -p1 -b .loadables
|
%patch106 -p1 -b .loadables
|
||||||
%patch107 -p1 -b .interpreter
|
%patch107 -p1 -b .interpreter
|
||||||
%patch108 -p1 -b .readline-oom
|
%patch108 -p1 -b .readline-oom
|
||||||
%patch109 -p1 -b .utf8
|
|
||||||
%patch110 -p1 -b .mbinc
|
%patch110 -p1 -b .mbinc
|
||||||
%patch111 -p1 -b .multibyteifs
|
|
||||||
%patch112 -p1 -b .ulimit
|
%patch112 -p1 -b .ulimit
|
||||||
%patch113 -p1 -b .jobs
|
|
||||||
%patch114 -p1 -b .xcc
|
%patch114 -p1 -b .xcc
|
||||||
%patch115 -p1 -b .pgrp_sync
|
%patch115 -p1 -b .pgrp_sync
|
||||||
%patch116 -p1 -b .manso
|
%patch116 -p1 -b .manso
|
||||||
%patch117 -p1 -b .debuginfo
|
%patch117 -p1 -b .debuginfo
|
||||||
%patch118 -p1 -b .tty-tests
|
%patch118 -p1 -b .tty-tests
|
||||||
%patch119 -p1 -b .sigpipe
|
|
||||||
%patch120 -p0 -b .read-e-segfault
|
|
||||||
%patch121 -p1 -b .manpage
|
|
||||||
%patch122 -p1 -b .wrap
|
|
||||||
%patch123 -p0 -b .crash
|
|
||||||
%patch124 -p1 -b .pwd
|
|
||||||
%patch125 -p1 -b .afs
|
|
||||||
%patch126 -p1 -b .setlocale
|
%patch126 -p1 -b .setlocale
|
||||||
%patch127 -p1 -b .sighandler
|
%patch127 -p1 -b .sighandler
|
||||||
%patch128 -p1 -b .subshell
|
|
||||||
%patch129 -p1 -b .read-memleak
|
%patch129 -p1 -b .read-memleak
|
||||||
|
|
||||||
echo %{version} > _distribution
|
echo %{version} > _distribution
|
||||||
@ -261,6 +209,13 @@ fi
|
|||||||
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 2 2006 Tim Waugh <twaugh@redhat.com> 3.1-1
|
||||||
|
- 3.1.
|
||||||
|
- No longer need ia64, utf8, multibyteifs, jobs, sigpipe,
|
||||||
|
read-e-segfault, manpage, crash, pwd, afs, subshell patches.
|
||||||
|
- Remove wrap patch for now.
|
||||||
|
- Use upstream patch to fix arrays.
|
||||||
|
|
||||||
* Thu Dec 15 2005 Tim Waugh <twaugh@redhat.com> 3.0-41
|
* Thu Dec 15 2005 Tim Waugh <twaugh@redhat.com> 3.0-41
|
||||||
- Missed another loop for improved sighandler patch (bug #169231).
|
- Missed another loop for improved sighandler patch (bug #169231).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user