Update to bash-4.2-rc2

Signed-off-by: Roman Rakus <rrakus@redhat.com>
This commit is contained in:
Roman Rakus 2011-02-09 12:49:55 +01:00
parent 5e32c353de
commit cd907279c8
6 changed files with 79 additions and 75 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
bash-4.1.tar.gz
/bash-4.2-rc2.tar.gz

View File

@ -1,7 +1,7 @@
diff -up bash-4.1-rc1/config.h.in.interpreter bash-4.1-rc1/config.h.in
--- bash-4.1-rc1/config.h.in.interpreter 2009-12-26 22:44:46.000000000 +0100
+++ bash-4.1-rc1/config.h.in 2009-12-26 22:44:46.000000000 +0100
@@ -695,6 +695,9 @@
diff -up bash-4.2-rc2/config.h.in.interpreter bash-4.2-rc2/config.h.in
--- bash-4.2-rc2/config.h.in.interpreter 2011-02-09 07:59:21.000000000 +0100
+++ bash-4.2-rc2/config.h.in 2011-02-09 07:59:21.000000000 +0100
@@ -706,6 +706,9 @@
/* Define if you have the pathconf function. */
#undef HAVE_PATHCONF
@ -11,7 +11,7 @@ diff -up bash-4.1-rc1/config.h.in.interpreter bash-4.1-rc1/config.h.in
/* Define if you have the putenv function. */
#undef HAVE_PUTENV
@@ -881,6 +884,9 @@
@@ -898,6 +901,9 @@
/* Define if you have the <dlfcn.h> header file. */
#undef HAVE_DLFCN_H
@ -21,15 +21,15 @@ diff -up bash-4.1-rc1/config.h.in.interpreter bash-4.1-rc1/config.h.in
/* Define if you have the <grp.h> header file. */
#undef HAVE_GRP_H
diff -up bash-4.1-rc1/configure.in.interpreter bash-4.1-rc1/configure.in
--- bash-4.1-rc1/configure.in.interpreter 2009-12-12 21:43:18.000000000 +0100
+++ bash-4.1-rc1/configure.in 2009-12-26 22:46:19.000000000 +0100
diff -up bash-4.2-rc2/configure.in.interpreter bash-4.2-rc2/configure.in
--- bash-4.2-rc2/configure.in.interpreter 2011-01-16 21:31:12.000000000 +0100
+++ bash-4.2-rc2/configure.in 2011-02-09 08:02:27.000000000 +0100
@@ -659,7 +659,7 @@ BASH_HEADER_INTTYPES
AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
stddef.h stdint.h netdb.h pwd.h grp.h strings.h regex.h \
- syslog.h)
+ syslog.h elf.h)
- syslog.h ulimit.h)
+ syslog.h ulimit.h elf.h)
AC_CHECK_HEADERS(sys/pte.h sys/stream.h sys/select.h sys/file.h \
sys/resource.h sys/param.h sys/socket.h sys/stat.h \
sys/time.h sys/times.h sys/types.h sys/wait.h)
@ -42,9 +42,9 @@ diff -up bash-4.1-rc1/configure.in.interpreter bash-4.1-rc1/configure.in
AC_REPLACE_FUNCS(rename)
dnl checks for c library functions
diff -up bash-4.1-rc1/execute_cmd.c.interpreter bash-4.1-rc1/execute_cmd.c
--- bash-4.1-rc1/execute_cmd.c.interpreter 2009-11-29 03:29:34.000000000 +0100
+++ bash-4.1-rc1/execute_cmd.c 2009-12-26 22:44:46.000000000 +0100
diff -up bash-4.2-rc2/execute_cmd.c.interpreter bash-4.2-rc2/execute_cmd.c
--- bash-4.2-rc2/execute_cmd.c.interpreter 2011-01-20 04:24:47.000000000 +0100
+++ bash-4.2-rc2/execute_cmd.c 2011-02-09 07:59:21.000000000 +0100
@@ -41,6 +41,10 @@
# include <unistd.h>
#endif
@ -56,7 +56,7 @@ diff -up bash-4.1-rc1/execute_cmd.c.interpreter bash-4.1-rc1/execute_cmd.c
#include "posixtime.h"
#if defined (HAVE_SYS_RESOURCE_H) && !defined (RLIMTYPE)
@@ -4805,13 +4809,21 @@ shell_execve (command, args, env)
@@ -4975,13 +4979,21 @@ shell_execve (command, args, env)
{
/* The file has the execute bits set, but the kernel refuses to
run it for some reason. See why. */
@ -79,7 +79,7 @@ diff -up bash-4.1-rc1/execute_cmd.c.interpreter bash-4.1-rc1/execute_cmd.c
interp = getinterp (sample, sample_len, (int *)NULL);
ilen = strlen (interp);
errno = i;
@@ -4827,6 +4839,136 @@ shell_execve (command, args, env)
@@ -4997,6 +5009,136 @@ shell_execve (command, args, env)
return (EX_NOEXEC);
}
#endif

View File

@ -1,7 +1,7 @@
diff -up bash-4.1-rc1/doc/bash.1.bashbug bash-4.1-rc1/doc/bash.1
--- bash-4.1-rc1/doc/bash.1.bashbug 2009-11-18 21:57:41.000000000 +0100
+++ bash-4.1-rc1/doc/bash.1 2009-12-27 12:42:31.000000000 +0100
@@ -9519,7 +9519,7 @@ The latest version is always available f
diff -up bash-4.2-rc2/doc/bash.1.bashbug bash-4.2-rc2/doc/bash.1
--- bash-4.2-rc2/doc/bash.1.bashbug 2011-01-16 21:31:39.000000000 +0100
+++ bash-4.2-rc2/doc/bash.1 2011-02-09 08:52:14.000000000 +0100
@@ -9857,7 +9857,7 @@ The latest version is always available f
.PP
Once you have determined that a bug actually exists, use the
.I bashbug
@ -10,7 +10,7 @@ diff -up bash-4.1-rc1/doc/bash.1.bashbug bash-4.1-rc1/doc/bash.1
If you have a fix, you are encouraged to mail that as well!
Suggestions and `philosophical' bug reports may be mailed
to \fIbug-bash@gnu.org\fP or posted to the Usenet
@@ -9541,10 +9541,6 @@ A description of the bug behaviour
@@ -9879,10 +9879,6 @@ A description of the bug behaviour
A short script or `recipe' which exercises the bug
.PD
.PP
@ -20,11 +20,11 @@ diff -up bash-4.1-rc1/doc/bash.1.bashbug bash-4.1-rc1/doc/bash.1
-.PP
Comments and bug reports concerning
this manual page should be directed to
.IR chet@po.cwru.edu .
diff -up bash-4.1-rc1/doc/bashref.texi.bashbug bash-4.1-rc1/doc/bashref.texi
--- bash-4.1-rc1/doc/bashref.texi.bashbug 2009-10-29 03:23:32.000000000 +0100
+++ bash-4.1-rc1/doc/bashref.texi 2009-12-27 12:45:32.000000000 +0100
@@ -7392,7 +7392,7 @@ The latest version of Bash is always ava
.IR chet.ramey@case.edu .
diff -up bash-4.2-rc2/doc/bashref.texi.bashbug bash-4.2-rc2/doc/bashref.texi
--- bash-4.2-rc2/doc/bashref.texi.bashbug 2011-01-16 21:31:57.000000000 +0100
+++ bash-4.2-rc2/doc/bashref.texi 2011-02-09 08:47:07.000000000 +0100
@@ -7635,7 +7635,7 @@ The latest version of Bash is always ava
@uref{ftp://ftp.gnu.org/pub/gnu/bash/}.
Once you have determined that a bug actually exists, use the
@ -33,7 +33,7 @@ diff -up bash-4.1-rc1/doc/bashref.texi.bashbug bash-4.1-rc1/doc/bashref.texi
If you have a fix, you are encouraged to mail that as well!
Suggestions and `philosophical' bug reports may be mailed
to @email{bug-bash@@gnu.org} or posted to the Usenet
@@ -7414,9 +7414,6 @@ to reproduce it.
@@ -7657,9 +7657,6 @@ to reproduce it.
@end itemize
@noindent
@ -43,10 +43,10 @@ diff -up bash-4.1-rc1/doc/bashref.texi.bashbug bash-4.1-rc1/doc/bashref.texi
Please send all reports concerning this manual to
@email{chet.ramey@@case.edu}.
diff -up bash-4.1-rc1/shell.c.bashbug bash-4.1-rc1/shell.c
--- bash-4.1-rc1/shell.c.bashbug 2009-11-19 16:05:54.000000000 +0100
+++ bash-4.1-rc1/shell.c 2009-12-27 12:42:31.000000000 +0100
@@ -1821,7 +1821,6 @@ show_shell_usage (fp, extra)
diff -up bash-4.2-rc2/shell.c.bashbug bash-4.2-rc2/shell.c
--- bash-4.2-rc2/shell.c.bashbug 2011-01-02 22:04:51.000000000 +0100
+++ bash-4.2-rc2/shell.c 2011-02-09 08:47:07.000000000 +0100
@@ -1823,7 +1823,6 @@ show_shell_usage (fp, extra)
{
fprintf (fp, _("Type `%s -c \"help set\"' for more information about shell options.\n"), shell_name);
fprintf (fp, _("Type `%s -c help' for more information about shell builtin commands.\n"), shell_name);

View File

@ -1,19 +1,29 @@
diff -up bash-4.0/tests/read.tests.tty_tests bash-4.0/tests/read.tests
--- bash-4.0/tests/read.tests.tty_tests 2008-09-06 19:09:11.000000000 +0200
+++ bash-4.0/tests/read.tests 2009-01-21 16:21:48.000000000 +0100
@@ -82,9 +82,6 @@ echo " foo" | { IFS=$':' ; read line; re
# test read -d delim behavior
${THIS_SH} ./read1.sub
diff -up bash-4.2-rc2/tests/exec.right.tty_tests bash-4.2-rc2/tests/exec.right
--- bash-4.2-rc2/tests/exec.right.tty_tests 2011-02-09 10:42:48.000000000 +0100
+++ bash-4.2-rc2/tests/exec.right 2011-02-09 10:42:59.000000000 +0100
@@ -50,7 +50,6 @@ this is ohio-state
0
1
testb
-expand_aliases on
1
1
1
diff -up bash-4.2-rc2/tests/execscript.tty_tests bash-4.2-rc2/tests/execscript
--- bash-4.2-rc2/tests/execscript.tty_tests 2010-12-27 22:01:02.000000000 +0100
+++ bash-4.2-rc2/tests/execscript 2011-02-09 10:42:34.000000000 +0100
@@ -107,8 +107,6 @@ ${THIS_SH} ./exec6.sub
# checks for properly deciding what constitutes an executable file
${THIS_SH} ./exec7.sub
-# test read -t timeout behavior
-${THIS_SH} ./read2.sub
-${THIS_SH} -i ./exec8.sub
-
# test read -n nchars behavior
${THIS_SH} ./read3.sub
${THIS_SH} ./exec9.sub
diff -up bash-4.0/tests/read.right.tty_tests bash-4.0/tests/read.right
--- bash-4.0/tests/read.right.tty_tests 2008-09-06 19:10:14.000000000 +0200
+++ bash-4.0/tests/read.right 2009-01-21 16:30:03.000000000 +0100
true | `echo true` &
diff -up bash-4.2-rc2/tests/read.right.tty_tests bash-4.2-rc2/tests/read.right
--- bash-4.2-rc2/tests/read.right.tty_tests 2010-12-21 16:49:00.000000000 +0100
+++ bash-4.2-rc2/tests/read.right 2011-02-09 10:42:34.000000000 +0100
@@ -33,14 +33,6 @@ a = abcdefg
a = xyz
a = -xyz 123-
@ -29,3 +39,16 @@ diff -up bash-4.0/tests/read.right.tty_tests bash-4.0/tests/read.right
./read3.sub: line 4: read: -1: invalid number
abc
ab
diff -up bash-4.2-rc2/tests/read.tests.tty_tests bash-4.2-rc2/tests/read.tests
--- bash-4.2-rc2/tests/read.tests.tty_tests 2008-09-06 19:09:11.000000000 +0200
+++ bash-4.2-rc2/tests/read.tests 2011-02-09 10:42:34.000000000 +0100
@@ -82,9 +82,6 @@ echo " foo" | { IFS=$':' ; read line; re
# test read -d delim behavior
${THIS_SH} ./read1.sub
-# test read -t timeout behavior
-${THIS_SH} ./read2.sub
-
# test read -n nchars behavior
${THIS_SH} ./read3.sub

View File

@ -1,16 +1,16 @@
#% define beta_tag rc1
%define patchleveltag .9
%define baseversion 4.1
%define beta_tag rc2
%define patchleveltag .0
%define baseversion 4.2
%bcond_without tests
Version: %{baseversion}%{patchleveltag}
Name: bash
Summary: The GNU Bourne Again shell
Release: 5%{?dist}
Release: 0.1.%{beta_tag}%{?dist}
Group: System Environment/Shells
License: GPLv3+
Url: http://www.gnu.org/software/bash
Source0: ftp://ftp.gnu.org/gnu/bash/bash-%{baseversion}.tar.gz
Source0: ftp://ftp.gnu.org/gnu/bash/bash-%{baseversion}-%{beta_tag}.tar.gz
# For now there isn't any doc
#Source2: ftp://ftp.gnu.org/gnu/bash/bash-doc-%{version}.tar.gz
@ -20,15 +20,7 @@ Source2: dot-bash_profile
Source3: dot-bash_logout
# Official upstream patches
Patch001: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-001
Patch002: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-002
Patch003: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-003
Patch004: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-004
Patch005: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-005
Patch006: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-006
Patch007: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-007
Patch008: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-008
Patch009: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-009
# none yet
# Other patches
Patch101: bash-2.02-security.patch
@ -55,10 +47,6 @@ Patch123: bash-4.0-nobits.patch
# Do the same CFLAGS in generated Makefile in examples
Patch124: bash-4.1-examples.patch
# 618289, don't segfault when trying to bind int variable to array
# with bad array subsrcipt
Patch125: bash-4.1-bind_int_variable.patch
# Builtins like echo and printf won't report errors
# when output does not succeed due to EPIPE
Patch126: bash-4.1-broken_pipe.patch
@ -87,19 +75,10 @@ This package contains documentation files for %{name}.
%prep
#%setup -q -a 2
%setup -q -n %{name}-%{baseversion}
%setup -q -n %{name}-%{baseversion}-%{beta_tag}
# Official upstream patches
%patch001 -p0 -b .001
%patch002 -p0 -b .002
%patch003 -p0 -b .003
%patch004 -p0 -b .004
%patch005 -p0 -b .005
%patch006 -p0 -b .006
%patch007 -p0 -b .007
%patch008 -p0 -b .008
%patch009 -p0 -b .009
# none yet
# Other patches
%patch101 -p1 -b .security
@ -120,9 +99,7 @@ This package contains documentation files for %{name}.
%patch118 -p1 -b .tty_tests
%patch123 -p1 -b .nobits
%patch124 -p1 -b .examples
%patch125 -p1 -b .bind_int_variable
%patch126 -p1 -b .broken_pipe
echo %{version} > _distribution
echo %{release} > _patchlevel
@ -300,6 +277,9 @@ fi
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
%changelog
* Wed Feb 09 2011 Roman Rakus <rrakus@redhat.com> - 4.2.0-0.1.rc2
- Update to bash-4.2-rc2
* Thu Jan 06 2011 Roman Rakus <rrakus@redhat.com> - 4.1.9-5
- Builtins like echo and printf won't report errors
when output does not succeed due to EPIPE

View File

@ -1 +1 @@
9800d8724815fd84994d9be65ab5e7b8 bash-4.1.tar.gz
844214d7928f5be3caa46fac177347ce bash-4.2-rc2.tar.gz