Patchlevel 4.2. Removed old patch. Returned back manso patch
This commit is contained in:
parent
b767106ff2
commit
b2750f7f08
@ -1,13 +0,0 @@
|
||||
diff -up bash-4.1-rc1/execute_cmd.c.cond_rmatch bash-4.1-rc1/execute_cmd.c
|
||||
--- bash-4.1-rc1/execute_cmd.c.cond_rmatch 2009-12-26 22:49:09.000000000 +0100
|
||||
+++ bash-4.1-rc1/execute_cmd.c 2009-12-26 22:54:11.000000000 +0100
|
||||
@@ -3278,8 +3278,7 @@ execute_cond_node (cond)
|
||||
arg1 = nullstr;
|
||||
if (ignore)
|
||||
comsub_ignore_return++;
|
||||
- arg2 = cond_expand_word (cond->right->op,
|
||||
- (rmatch && shell_compatibility_level > 31) ? 2 : (patmatch ? 1 : 0));
|
||||
+ arg2 = cond_expand_word (cond->right->op, patmatch ? 1 : 0);
|
||||
if (ignore)
|
||||
comsub_ignore_return--;
|
||||
if (arg2 == 0)
|
16
bash.spec
16
bash.spec
@ -2,10 +2,10 @@
|
||||
%define patchleveltag .0
|
||||
%define baseversion 4.1
|
||||
|
||||
Version: %{baseversion}%{?patchleveltag}
|
||||
Version: %{baseversion}%{patchleveltag}
|
||||
Name: bash
|
||||
Summary: The GNU Bourne Again shell
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Group: System Environment/Shells
|
||||
License: GPLv3+
|
||||
Url: http://www.gnu.org/software/bash
|
||||
@ -19,6 +19,9 @@ Source2: dot-bash_profile
|
||||
Source3: dot-bash_logout
|
||||
|
||||
# Official upstream patches
|
||||
Patch001: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-001
|
||||
Patch002: ftp://ftp.gnu.org/pub/gnu/bash/bash-4.1-patches/bash41-002
|
||||
|
||||
# Other patches
|
||||
Patch101: bash-2.02-security.patch
|
||||
Patch102: bash-2.03-paths.patch
|
||||
@ -69,6 +72,10 @@ This package contains documentation files for %{name}.
|
||||
%setup -q -n %{name}-%{baseversion}
|
||||
|
||||
# Official upstream patches
|
||||
%patch001 -p0 -b .001
|
||||
%patch002 -p0 -b .002
|
||||
|
||||
|
||||
# Other patches
|
||||
%patch101 -p1 -b .security
|
||||
%patch102 -p1 -b .paths
|
||||
@ -254,6 +261,11 @@ fi
|
||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||
|
||||
%changelog
|
||||
* Fri Jan 22 2010 Roman Rakus rrakus@redhat.com 4.1.2-1
|
||||
- Patchlevel 4.2
|
||||
- Removed old patch
|
||||
- Returned back manso patch
|
||||
|
||||
* Fri Jan 08 2010 Roman Rakus rrakus@redhat.com 4.1.0-2
|
||||
- Include COPYING in doc dir
|
||||
|
||||
|
48
bash41-001
Normal file
48
bash41-001
Normal file
@ -0,0 +1,48 @@
|
||||
BASH PATCH REPORT
|
||||
=================
|
||||
|
||||
Bash-Release: 4.1
|
||||
Patch-ID: bash41-001
|
||||
|
||||
Bug-Reported-by: Yann Rouillard <yann@pleiades.fr.eu.org>
|
||||
Bug-Reference-ID: <4B44A410.4070107@pleiades.fr.eu.org>
|
||||
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2010-01/msg00018.html
|
||||
|
||||
Bug-Description:
|
||||
|
||||
A prototype for vsnprintf was incorrect, and caused compilation failures
|
||||
on systems that did not have a suitable vsnprintf, but had a declaration in
|
||||
one of the system header files.
|
||||
|
||||
Patch (apply with `patch -p0'):
|
||||
|
||||
*** ../bash-4.1-patched/builtins/printf.def 2009-11-20 15:31:23.000000000 -0500
|
||||
--- builtins/printf.def 2010-01-07 08:50:06.000000000 -0500
|
||||
***************
|
||||
*** 173,177 ****
|
||||
|
||||
#if !HAVE_VSNPRINTF
|
||||
! extern int vsnprintf __P((char *, size_t, const char *, ...)) __attribute__((__format__ (printf, 3, 4)));
|
||||
#endif
|
||||
|
||||
--- 173,177 ----
|
||||
|
||||
#if !HAVE_VSNPRINTF
|
||||
! extern int vsnprintf __P((char *, size_t, const char *, va_list)) __attribute__((__format__ (printf, 3, 0)));
|
||||
#endif
|
||||
|
||||
*** ../bash-4.1-patched/patchlevel.h 2009-10-01 16:39:22.000000000 -0400
|
||||
--- patchlevel.h 2010-01-14 09:38:08.000000000 -0500
|
||||
***************
|
||||
*** 26,30 ****
|
||||
looks for to find the patch level (for the sccs version string). */
|
||||
|
||||
! #define PATCHLEVEL 0
|
||||
|
||||
#endif /* _PATCHLEVEL_H_ */
|
||||
--- 26,30 ----
|
||||
looks for to find the patch level (for the sccs version string). */
|
||||
|
||||
! #define PATCHLEVEL 1
|
||||
|
||||
#endif /* _PATCHLEVEL_H_ */
|
65
bash41-002
Normal file
65
bash41-002
Normal file
@ -0,0 +1,65 @@
|
||||
BASH PATCH REPORT
|
||||
=================
|
||||
|
||||
Bash-Release: 4.1
|
||||
Patch-ID: bash41-002
|
||||
|
||||
Bug-Reported-by: guillaume.outters@free.fr
|
||||
Bug-Reference-ID: <20100105230441.70D171AA7F52@asterix.local>
|
||||
Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2010-01/msg00017.html
|
||||
|
||||
Bug-Description:
|
||||
|
||||
Bash-4.1/Readline-6.1 introduced a hook function that allows applications
|
||||
to rewrite or modify filenames read from the file system before comparing
|
||||
them with a word to be completed. The converted filename, if it matches,
|
||||
needs to be inserted into the line buffer, replacing the original contents.
|
||||
|
||||
This fixes a completion bug on Mac OS X involving filenames containing
|
||||
UTF-8 characters.
|
||||
|
||||
Patch (apply with `patch -p0'):
|
||||
|
||||
*** ../bash-4.1-patched/lib/readline/complete.c 2009-11-29 18:39:30.000000000 -0500
|
||||
--- lib/readline/complete.c 2010-01-06 08:30:23.000000000 -0500
|
||||
***************
|
||||
*** 2139,2143 ****
|
||||
if (filename_len == 0)
|
||||
{
|
||||
! if (_rl_match_hidden_files == 0 && HIDDEN_FILE (entry->d_name))
|
||||
continue;
|
||||
|
||||
--- 2139,2143 ----
|
||||
if (filename_len == 0)
|
||||
{
|
||||
! if (_rl_match_hidden_files == 0 && HIDDEN_FILE (convfn))
|
||||
continue;
|
||||
|
||||
***************
|
||||
*** 2220,2224 ****
|
||||
}
|
||||
|
||||
! strcpy (temp + dirlen, entry->d_name);
|
||||
}
|
||||
else
|
||||
--- 2220,2224 ----
|
||||
}
|
||||
|
||||
! strcpy (temp + dirlen, convfn);
|
||||
}
|
||||
else
|
||||
*** ../bash-4.1-patched/patchlevel.h 2009-10-01 16:39:22.000000000 -0400
|
||||
--- patchlevel.h 2010-01-14 09:38:08.000000000 -0500
|
||||
***************
|
||||
*** 26,30 ****
|
||||
looks for to find the patch level (for the sccs version string). */
|
||||
|
||||
! #define PATCHLEVEL 1
|
||||
|
||||
#endif /* _PATCHLEVEL_H_ */
|
||||
--- 26,30 ----
|
||||
looks for to find the patch level (for the sccs version string). */
|
||||
|
||||
! #define PATCHLEVEL 2
|
||||
|
||||
#endif /* _PATCHLEVEL_H_ */
|
Loading…
Reference in New Issue
Block a user