Don't filter out environmental variables with a dot in the name
Resolves: #819995
This commit is contained in:
parent
3228855df9
commit
b11e4146c5
12
bash-4.2-dotted_variables.patch
Normal file
12
bash-4.2-dotted_variables.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up bash-4.2/general.h.patch bash-4.2/general.h
|
||||
--- bash-4.2/general.h.patch 2012-08-21 11:34:25.978724313 +0200
|
||||
+++ bash-4.2/general.h 2012-08-21 11:34:52.235947602 +0200
|
||||
@@ -104,7 +104,7 @@ extern char *strcpy __P((char *, const c
|
||||
|
||||
/* Define exactly what a legal shell identifier consists of. */
|
||||
#define legal_variable_starter(c) (ISALPHA(c) || (c == '_'))
|
||||
-#define legal_variable_char(c) (ISALNUM(c) || c == '_')
|
||||
+#define legal_variable_char(c) (ISALNUM(c) || c == '_'|| c == '.')
|
||||
|
||||
/* Definitions used in subst.c and by the `read' builtin for field
|
||||
splitting. */
|
12
bash.spec
12
bash.spec
@ -6,7 +6,7 @@
|
||||
Version: %{baseversion}%{patchleveltag}
|
||||
Name: bash
|
||||
Summary: The GNU Bourne Again shell
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Group: System Environment/Shells
|
||||
License: GPLv3+
|
||||
Url: http://www.gnu.org/software/bash
|
||||
@ -95,6 +95,10 @@ Patch121: bash-4.2-coverity.patch
|
||||
# Don't call malloc in signal handler
|
||||
Patch122: bash-4.1-defer-sigchld-trap.patch
|
||||
|
||||
# Bash filters out environmental variables containing a dot
|
||||
# in the name
|
||||
Patch123: bash-4.2-dotted_variables.patch
|
||||
|
||||
BuildRequires: texinfo bison
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: autoconf, gettext
|
||||
@ -184,6 +188,7 @@ This package contains documentation files for %{name}.
|
||||
%patch120 -p1 -b .logout
|
||||
%patch121 -p1 -b .coverity
|
||||
%patch122 -p1 -b .defer_sigchld_trap
|
||||
%patch123 -p1 -b .dotted_variables
|
||||
|
||||
echo %{version} > _distribution
|
||||
echo %{release} > _patchlevel
|
||||
@ -375,6 +380,11 @@ end
|
||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||
|
||||
%changelog
|
||||
* Tue Aug 21 2012 Ondrej Oprala <ooprala@redhat.com> - 4.2.37-5
|
||||
- Don't filter out environmental variables with
|
||||
a dot in the name
|
||||
Resolves: #819995
|
||||
|
||||
* Wed Aug 08 2012 Roman Rakus <rrakus@redhat.com> - 4.2.37-4
|
||||
- Added doc subdir to bash-doc ownership list
|
||||
Resolves: #846734
|
||||
|
Loading…
Reference in New Issue
Block a user