Fix usage of partial unitialized structure

Resolves: #857948

Signed-off-by: Roman Rakus <rrakus@redhat.com>
This commit is contained in:
Roman Rakus 2013-01-31 17:27:30 +01:00
parent ef50169abe
commit 932fd80d30
2 changed files with 19 additions and 14 deletions

View File

@ -1,7 +1,7 @@
diff -up bash-4.0/config.h.in.audit bash-4.0/config.h.in
--- bash-4.0/config.h.in.audit 2009-01-21 11:34:34.000000000 -0500
+++ bash-4.0/config.h.in 2009-01-21 11:34:35.000000000 -0500
@@ -1077,6 +1077,14 @@
diff -up bash-4.2/config.h.in.audit bash-4.2/config.h.in
--- bash-4.2/config.h.in.audit 2013-01-31 16:26:16.857698992 +0100
+++ bash-4.2/config.h.in 2013-01-31 16:26:16.876699255 +0100
@@ -1131,6 +1131,14 @@
/* End additions for lib/intl */
@ -16,10 +16,10 @@ diff -up bash-4.0/config.h.in.audit bash-4.0/config.h.in
#include "config-bot.h"
#endif /* _CONFIG_H_ */
diff -up bash-4.0/configure.in.audit bash-4.0/configure.in
--- bash-4.0/configure.in.audit 2009-01-21 11:34:34.000000000 -0500
+++ bash-4.0/configure.in 2009-01-21 11:34:35.000000000 -0500
@@ -875,6 +875,8 @@ BASH_FUNC_DUP2_CLOEXEC_CHECK
diff -up bash-4.2/configure.in.audit bash-4.2/configure.in
--- bash-4.2/configure.in.audit 2013-01-31 16:26:16.858699005 +0100
+++ bash-4.2/configure.in 2013-01-31 16:26:16.877699269 +0100
@@ -888,6 +888,8 @@ BASH_FUNC_DUP2_CLOEXEC_CHECK
BASH_SYS_PGRP_SYNC
BASH_SYS_SIGNAL_VINTAGE
@ -28,9 +28,9 @@ diff -up bash-4.0/configure.in.audit bash-4.0/configure.in
dnl checking for the presence of certain library symbols
BASH_SYS_ERRLIST
BASH_SYS_SIGLIST
diff -up bash-4.0/lib/readline/readline.c.audit bash-4.0/lib/readline/readline.c
--- bash-4.0/lib/readline/readline.c.audit 2009-01-21 11:34:34.000000000 -0500
+++ bash-4.0/lib/readline/readline.c 2009-01-21 11:40:12.000000000 -0500
diff -up bash-4.2/lib/readline/readline.c.audit bash-4.2/lib/readline/readline.c
--- bash-4.2/lib/readline/readline.c.audit 2013-01-31 16:26:16.871699185 +0100
+++ bash-4.2/lib/readline/readline.c 2013-01-31 17:24:23.902744860 +0100
@@ -55,6 +55,12 @@
extern int errno;
#endif /* !errno */
@ -44,7 +44,7 @@ diff -up bash-4.0/lib/readline/readline.c.audit bash-4.0/lib/readline/readline.c
/* System-specific feature definitions and include files. */
#include "rldefs.h"
#include "rlmbutil.h"
@@ -297,7 +303,47 @@ rl_set_prompt (prompt)
@@ -301,7 +307,48 @@ rl_set_prompt (prompt)
rl_visible_prompt_length = rl_expand_prompt (rl_prompt);
return 0;
}
@ -76,6 +76,7 @@ diff -up bash-4.0/lib/readline/readline.c.audit bash-4.0/lib/readline/readline.c
+ iov[1].iov_base = string;
+ iov[1].iov_len = size;
+ addr.nl_family = AF_NETLINK;
+ addr.nl_pad = 0;
+ addr.nl_pid = 0;
+ addr.nl_groups = 0;
+ msg.msg_name = &addr;
@ -93,7 +94,7 @@ diff -up bash-4.0/lib/readline/readline.c.audit bash-4.0/lib/readline/readline.c
/* Read a line of input. Prompt with PROMPT. An empty PROMPT means
none. A return value of NULL means that EOF was encountered. */
char *
@@ -348,6 +394,11 @@ readline (prompt)
@@ -352,6 +399,11 @@ readline (prompt)
RL_SETSTATE (RL_STATE_CALLBACK);
#endif

View File

@ -6,7 +6,7 @@
Version: %{baseversion}%{patchleveltag}
Name: bash
Summary: The GNU Bourne Again shell
Release: 2%{?dist}
Release: 3%{?dist}
Group: System Environment/Shells
License: GPLv3+
Url: http://www.gnu.org/software/bash
@ -402,6 +402,10 @@ end
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
%changelog
* Thu Jan 31 2013 Roman Rakus <rrakus@redhat.com> - 4.2.42-3
- Fix usage of partial unitialized structure
Resolves: #857948
* Thu Jan 31 2013 Roman Rakus <rrakus@redhat.com> - 4.2.42-2
- Fix fd leaks
Resolves: #903833