Builtins like echo and printf won't report errors
when output does not succeed due to EPIPE. Signed-off-by: Roman Rakus <rrakus@redhat.com>
This commit is contained in:
parent
f8831ae20e
commit
5e32c353de
12
bash-4.1-broken_pipe.patch
Normal file
12
bash-4.1-broken_pipe.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up bash-4.1/config-top.h.broken_pipe bash-4.1/config-top.h
|
||||||
|
--- bash-4.1/config-top.h.broken_pipe 2011-01-06 18:01:30.000000000 +0100
|
||||||
|
+++ bash-4.1/config-top.h 2011-01-06 18:02:14.000000000 +0100
|
||||||
|
@@ -51,7 +51,7 @@
|
||||||
|
/* Define DONT_REPORT_BROKEN_PIPE_WRITE_ERRORS if you don't want builtins
|
||||||
|
like `echo' and `printf' to report errors when output does not succeed
|
||||||
|
due to EPIPE. */
|
||||||
|
-/* #define DONT_REPORT_BROKEN_PIPE_WRITE_ERRORS */
|
||||||
|
+#define DONT_REPORT_BROKEN_PIPE_WRITE_ERRORS
|
||||||
|
|
||||||
|
/* The default value of the PATH variable. */
|
||||||
|
#ifndef DEFAULT_PATH_VALUE
|
11
bash.spec
11
bash.spec
@ -6,7 +6,7 @@
|
|||||||
Version: %{baseversion}%{patchleveltag}
|
Version: %{baseversion}%{patchleveltag}
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell
|
Summary: The GNU Bourne Again shell
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -59,6 +59,10 @@ Patch124: bash-4.1-examples.patch
|
|||||||
# with bad array subsrcipt
|
# with bad array subsrcipt
|
||||||
Patch125: bash-4.1-bind_int_variable.patch
|
Patch125: bash-4.1-bind_int_variable.patch
|
||||||
|
|
||||||
|
# Builtins like echo and printf won't report errors
|
||||||
|
# when output does not succeed due to EPIPE
|
||||||
|
Patch126: bash-4.1-broken_pipe.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: texinfo bison
|
BuildRequires: texinfo bison
|
||||||
@ -117,6 +121,7 @@ This package contains documentation files for %{name}.
|
|||||||
%patch123 -p1 -b .nobits
|
%patch123 -p1 -b .nobits
|
||||||
%patch124 -p1 -b .examples
|
%patch124 -p1 -b .examples
|
||||||
%patch125 -p1 -b .bind_int_variable
|
%patch125 -p1 -b .bind_int_variable
|
||||||
|
%patch126 -p1 -b .broken_pipe
|
||||||
|
|
||||||
echo %{version} > _distribution
|
echo %{version} > _distribution
|
||||||
echo %{release} > _patchlevel
|
echo %{release} > _patchlevel
|
||||||
@ -295,6 +300,10 @@ fi
|
|||||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 06 2011 Roman Rakus <rrakus@redhat.com> - 4.1.9-5
|
||||||
|
- Builtins like echo and printf won't report errors
|
||||||
|
when output does not succeed due to EPIPE
|
||||||
|
|
||||||
* Thu Dec 16 2010 Roman Rakus <rrakus@redhat.com> - 4.1.9-4
|
* Thu Dec 16 2010 Roman Rakus <rrakus@redhat.com> - 4.1.9-4
|
||||||
- Drop doc/examples/loadables
|
- Drop doc/examples/loadables
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user