auto-import changelog data from bash-2.05b-2.src.rpm
Tue Jul 23 2002 Phil Knirsch <pknirsch@redhat.com> 2.05b-2 - Added symlink for sh.1 in man1 section so that man sh works (#44039). Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 2.05b-1 - Update to 2.05b Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com> 2.05a-16 - Fixed readline utf8 problem (#68313). Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.05a-15 - automated rebuild Thu May 23 2002 Tim Powers <timp@redhat.com> 2.05a-14 - automated rebuild
This commit is contained in:
parent
b765d3ad63
commit
57ff95e718
@ -1,3 +1,3 @@
|
|||||||
bash-2.05a.tar.bz2
|
bash-2.05b.tar.bz2
|
||||||
bash-completion-20020220.tar.gz
|
bash-completion-20020220.tar.gz
|
||||||
bash-doc-2.05a.tar.bz2
|
bash-doc-2.05b.tar.bz2
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- bash-2.05a/config.h.in Mon Oct 22 06:58:13 2001
|
--- bash-2.05b/config.h.in.interpreter 2002-07-22 12:30:53.000000000 +0200
|
||||||
+++ bash-2.05a-ud/config.h.in Thu Mar 7 17:33:03 2002
|
+++ bash-2.05b/config.h.in 2002-07-22 12:30:54.000000000 +0200
|
||||||
@@ -541,6 +541,9 @@
|
@@ -579,6 +579,9 @@
|
||||||
/* Define if you have the pathconf function. */
|
/* Define if you have the pathconf function. */
|
||||||
#undef HAVE_PATHCONF
|
#undef HAVE_PATHCONF
|
||||||
|
|
||||||
@ -10,7 +10,7 @@
|
|||||||
/* Define if you have the putenv function. */
|
/* Define if you have the putenv function. */
|
||||||
#undef HAVE_PUTENV
|
#undef HAVE_PUTENV
|
||||||
|
|
||||||
@@ -675,6 +678,9 @@
|
@@ -722,6 +725,9 @@
|
||||||
/* Define if you have the <dlfcn.h> header file. */
|
/* Define if you have the <dlfcn.h> header file. */
|
||||||
#undef HAVE_DLFCN_H
|
#undef HAVE_DLFCN_H
|
||||||
|
|
||||||
@ -20,9 +20,9 @@
|
|||||||
/* Define if you have the <grp.h> header file. */
|
/* Define if you have the <grp.h> header file. */
|
||||||
#undef HAVE_GRP_H
|
#undef HAVE_GRP_H
|
||||||
|
|
||||||
--- bash-2.05a/configure.in Mon Nov 5 12:45:35 2001
|
--- bash-2.05b/configure.in.interpreter 2002-07-16 15:31:25.000000000 +0200
|
||||||
+++ bash-2.05a-ud/configure.in Thu Mar 7 17:28:32 2002
|
+++ bash-2.05b/configure.in 2002-07-22 12:30:54.000000000 +0200
|
||||||
@@ -484,7 +484,7 @@ BASH_HEADER_INTTYPES
|
@@ -525,7 +525,7 @@
|
||||||
|
|
||||||
AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
|
AC_CHECK_HEADERS(unistd.h stdlib.h stdarg.h varargs.h limits.h string.h \
|
||||||
memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
|
memory.h locale.h termcap.h termio.h termios.h dlfcn.h \
|
||||||
@ -31,25 +31,17 @@
|
|||||||
AC_CHECK_HEADERS(sys/ptem.h sys/pte.h sys/stream.h sys/select.h sys/file.h \
|
AC_CHECK_HEADERS(sys/ptem.h sys/pte.h sys/stream.h sys/select.h sys/file.h \
|
||||||
sys/resource.h sys/param.h sys/socket.h \
|
sys/resource.h sys/param.h sys/socket.h \
|
||||||
sys/time.h sys/times.h sys/wait.h)
|
sys/time.h sys/times.h sys/wait.h)
|
||||||
@@ -546,7 +546,7 @@ AC_CHECK_FUNCS(bcopy bzero confstr sysco
|
@@ -588,7 +588,7 @@
|
||||||
setlinebuf setvbuf setlocale strchr tcgetattr uname \
|
setlinebuf setvbuf setlocale strchr tcgetattr uname \
|
||||||
ulimit tzset siginterrupt memmove ttyname times \
|
ulimit tzset siginterrupt memmove ttyname times \
|
||||||
getaddrinfo gethostbyname getservbyname inet_aton \
|
getaddrinfo gethostbyname getservbyname getservent inet_aton \
|
||||||
- vsnprintf snprintf vasprintf asprintf fnmatch)
|
- vsnprintf snprintf vasprintf asprintf fnmatch)
|
||||||
+ vsnprintf snprintf vasprintf asprintf fnmatch pread)
|
+ vsnprintf snprintf vasprintf asprintf fnmatch pread)
|
||||||
AC_CHECK_FUNCS(isascii isblank isgraph isprint isspace isxdigit)
|
AC_CHECK_FUNCS(isascii isblank isgraph isprint isspace isxdigit)
|
||||||
AC_REPLACE_FUNCS(getcwd strcasecmp strerror strpbrk strtod)
|
AC_REPLACE_FUNCS(getcwd strcasecmp strerror strftime strpbrk memset)
|
||||||
AC_REPLACE_FUNCS(strtol strtoul strtoll strtoull strtoimax strtoumax)
|
AC_REPLACE_FUNCS(strtod strtol strtoul strtoll strtoull strtoimax strtoumax)
|
||||||
--- bash-2.05a/execute_cmd.c Mon Oct 29 11:03:18 2001
|
--- bash-2.05b/execute_cmd.c.interpreter 2002-07-22 12:30:54.000000000 +0200
|
||||||
+++ bash-2.05a-ud/execute_cmd.c Fri Mar 8 00:50:53 2002
|
+++ bash-2.05b/execute_cmd.c 2002-07-22 12:40:08.000000000 +0200
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
/* execute_command.c -- Execute a COMMAND structure. */
|
|
||||||
|
|
||||||
-/* Copyright (C) 1987,1991 Free Software Foundation, Inc.
|
|
||||||
+/* Copyright (C) 1987,1991, 2002 Free Software Foundation, Inc.
|
|
||||||
|
|
||||||
This file is part of GNU Bash, the Bourne Again SHell.
|
|
||||||
|
|
||||||
@@ -40,6 +40,10 @@
|
@@ -40,6 +40,10 @@
|
||||||
# include <unistd.h>
|
# include <unistd.h>
|
||||||
#endif
|
#endif
|
||||||
@ -61,19 +53,18 @@
|
|||||||
#include "posixtime.h"
|
#include "posixtime.h"
|
||||||
|
|
||||||
#if defined (HAVE_SYS_RESOURCE_H) && !defined (RLIMTYPE)
|
#if defined (HAVE_SYS_RESOURCE_H) && !defined (RLIMTYPE)
|
||||||
@@ -3499,12 +3503,21 @@ shell_execve (command, args, env)
|
@@ -3496,12 +3500,20 @@
|
||||||
internal_error ("%s: is a directory", command);
|
|
||||||
else
|
|
||||||
{
|
{
|
||||||
|
/* The file has the execute bits set, but the kernel refuses to
|
||||||
|
run it for some reason. See why. */
|
||||||
+#if defined (HAVE_HASH_BANG_EXEC) || defined (HAVE_ELF_H)
|
+#if defined (HAVE_HASH_BANG_EXEC) || defined (HAVE_ELF_H)
|
||||||
+ int fd = open (command, O_RDONLY);
|
+ int fd = open (command, O_RDONLY);
|
||||||
+
|
+
|
||||||
+ if (fd >= 0)
|
+ if (fd >= 0)
|
||||||
+ sample_len = read (fd, sample, sizeof (sample));
|
+ sample_len = read (fd, sample, sizeof (sample));
|
||||||
+ else
|
+ else
|
||||||
+ sample_len = -1;
|
+ sample_len = -1;
|
||||||
+#endif
|
+#endif
|
||||||
+
|
|
||||||
#if defined (HAVE_HASH_BANG_EXEC)
|
#if defined (HAVE_HASH_BANG_EXEC)
|
||||||
- READ_SAMPLE_BUF (command, sample, sample_len);
|
- READ_SAMPLE_BUF (command, sample, sample_len);
|
||||||
if (sample_len > 2 && sample[0] == '#' && sample[1] == '!')
|
if (sample_len > 2 && sample[0] == '#' && sample[1] == '!')
|
||||||
@ -84,7 +75,7 @@
|
|||||||
interp = getinterp (sample, sample_len, (int *)NULL);
|
interp = getinterp (sample, sample_len, (int *)NULL);
|
||||||
errno = i;
|
errno = i;
|
||||||
sys_error ("%s: %s: bad interpreter", command, interp ? interp : "");
|
sys_error ("%s: %s: bad interpreter", command, interp ? interp : "");
|
||||||
@@ -3512,6 +3525,136 @@ shell_execve (command, args, env)
|
@@ -3509,6 +3521,136 @@
|
||||||
return (EX_NOEXEC);
|
return (EX_NOEXEC);
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
|
35
bash.spec
35
bash.spec
@ -1,7 +1,7 @@
|
|||||||
Version: 2.05a
|
Version: 2.05b
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell (bash) version %{version}.
|
Summary: The GNU Bourne Again shell (bash) version %{version}.
|
||||||
Release: 13
|
Release: 2
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPL
|
License: GPL
|
||||||
Source0: ftp://ftp.gnu.org/gnu/bash/bash-%{version}.tar.bz2
|
Source0: ftp://ftp.gnu.org/gnu/bash/bash-%{version}.tar.bz2
|
||||||
@ -24,6 +24,7 @@ Patch10: bash-2.05a-service_completion.patch
|
|||||||
Patch11: bash-2.05a-loadables.patch
|
Patch11: bash-2.05a-loadables.patch
|
||||||
Patch12: bash-2.05a-interpreter.patch
|
Patch12: bash-2.05a-interpreter.patch
|
||||||
Patch13: bash-2.05a-killbuiltin.patch
|
Patch13: bash-2.05a-killbuiltin.patch
|
||||||
|
Patch14: bash-2.05a-readline-utf8.patch
|
||||||
Prefix: %{_prefix}
|
Prefix: %{_prefix}
|
||||||
Requires: mktemp
|
Requires: mktemp
|
||||||
Provides: bash2
|
Provides: bash2
|
||||||
@ -57,18 +58,19 @@ Again shell version %{version}.
|
|||||||
%setup -q -a 2 -a 6
|
%setup -q -a 2 -a 6
|
||||||
%patch0 -p1 -b .paths
|
%patch0 -p1 -b .paths
|
||||||
%patch1 -p1 -b .security
|
%patch1 -p1 -b .security
|
||||||
%patch2 -p1 -b .arm
|
#%patch2 -p1 -b .arm
|
||||||
%patch3 -p1 -b .profile
|
%patch3 -p1 -b .profile
|
||||||
%patch4 -p1 -b .readline
|
#%patch4 -p1 -b .readline
|
||||||
%patch5 -p1 -b .requires
|
%patch5 -p1 -b .requires
|
||||||
%patch6 -p1 -b .compat
|
%patch6 -p1 -b .compat
|
||||||
%patch7 -p1 -b .shellfunc
|
%patch7 -p1 -b .shellfunc
|
||||||
%patch8 -p1 -b .ia64
|
%patch8 -p1 -b .ia64
|
||||||
%patch9 -p1 -b .mailcheck
|
#%patch9 -p1 -b .mailcheck
|
||||||
%patch10 -p1 -b .servicecomp
|
#%patch10 -p1 -b .servicecomp
|
||||||
%patch11 -p1 -b .loadables
|
%patch11 -p1 -b .loadables
|
||||||
%patch12 -p1 -b .interpreter
|
%patch12 -p1 -b .interpreter
|
||||||
%patch13 -p1 -b .killbuiltin
|
#%patch13 -p1 -b .killbuiltin
|
||||||
|
#%patch14 -p1 -b .readline-utf8
|
||||||
echo %{version} > _distribution
|
echo %{version} > _distribution
|
||||||
echo %{release} > _patchlevel
|
echo %{release} > _patchlevel
|
||||||
|
|
||||||
@ -122,6 +124,10 @@ for i in `cat man.pages` ; do
|
|||||||
echo .so man1/builtins.1 > ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
|
echo .so man1/builtins.1 > ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
|
||||||
chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
|
chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# Link bash man page to sh so that man sh works.
|
||||||
|
ln -s bash.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/sh.1
|
||||||
|
|
||||||
# Not for printf (conflict with coreutils)
|
# Not for printf (conflict with coreutils)
|
||||||
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/printf.1
|
rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/printf.1
|
||||||
|
|
||||||
@ -217,6 +223,21 @@ fi
|
|||||||
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 23 2002 Phil Knirsch <pknirsch@redhat.com> 2.05b-2
|
||||||
|
- Added symlink for sh.1 in man1 section so that man sh works (#44039).
|
||||||
|
|
||||||
|
* Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 2.05b-1
|
||||||
|
- Update to 2.05b
|
||||||
|
|
||||||
|
* Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com> 2.05a-16
|
||||||
|
- Fixed readline utf8 problem (#68313).
|
||||||
|
|
||||||
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.05a-15
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
|
* Thu May 23 2002 Tim Powers <timp@redhat.com> 2.05a-14
|
||||||
|
- automated rebuild
|
||||||
|
|
||||||
* Fri Apr 12 2002 Tim Powers <timp@redhat.com> 2.05a-13
|
* Fri Apr 12 2002 Tim Powers <timp@redhat.com> 2.05a-13
|
||||||
- don't build the stuff in examples/loadables. It breaks FHS
|
- don't build the stuff in examples/loadables. It breaks FHS
|
||||||
compliance
|
compliance
|
||||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
|||||||
c29b50db808003e39558a0f6354f4cad bash-2.05a.tar.bz2
|
f3e5428ed52a4f536f571a945d5de95d bash-2.05b.tar.bz2
|
||||||
1fb7158868b3d0486fc4611a838c2662 bash-completion-20020220.tar.gz
|
1fb7158868b3d0486fc4611a838c2662 bash-completion-20020220.tar.gz
|
||||||
33d9704a812dd43c2e9fad44d74dc569 bash-doc-2.05a.tar.bz2
|
a402e8df0aab99137adb8d3659feb86c bash-doc-2.05b.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user