Save parser state in pcomplete. Resolves: #487257
This commit is contained in:
parent
12b3d6eae3
commit
22fd91b850
10
bash.spec
10
bash.spec
@ -3,7 +3,7 @@
|
|||||||
Version: 4.0
|
Version: 4.0
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell version %{version}
|
Summary: The GNU Bourne Again shell version %{version}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -38,6 +38,7 @@ Patch115: bash-infotags.patch
|
|||||||
Patch116: bash-requires.patch
|
Patch116: bash-requires.patch
|
||||||
Patch117: bash-setlocale.patch
|
Patch117: bash-setlocale.patch
|
||||||
Patch118: bash-tty-tests.patch
|
Patch118: bash-tty-tests.patch
|
||||||
|
Patch119: pcomplete-save-parser-state.patch
|
||||||
#Patch119: bash-ulimit-m.patch
|
#Patch119: bash-ulimit-m.patch
|
||||||
#Patch120: bash-4.0-no_debug_output.patch
|
#Patch120: bash-4.0-no_debug_output.patch
|
||||||
#Patch121: bash-4.0-shell_pipelines_handling.patch
|
#Patch121: bash-4.0-shell_pipelines_handling.patch
|
||||||
@ -82,6 +83,7 @@ compliance over previous versions.
|
|||||||
%patch116 -p1 -b .requires
|
%patch116 -p1 -b .requires
|
||||||
%patch117 -p1 -b .setlocale
|
%patch117 -p1 -b .setlocale
|
||||||
%patch118 -p1 -b .tty_tests
|
%patch118 -p1 -b .tty_tests
|
||||||
|
%patch119 -p1 -b .parser-state
|
||||||
#%patch119 -p1 -b .ulimit-m
|
#%patch119 -p1 -b .ulimit-m
|
||||||
#%patch120 -p1 -b .no_debug_output
|
#%patch120 -p1 -b .no_debug_output
|
||||||
#%patch121 -p1 -b .pipelines_handling
|
#%patch121 -p1 -b .pipelines_handling
|
||||||
@ -243,7 +245,11 @@ fi
|
|||||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Feb 24 2009 Roman Rakus <rrakus@rehat.com> - 4.0-1
|
* Wed Feb 25 2009 Roman Rakus <rrakus@redhat.com> - 4.0-2
|
||||||
|
- Save parser state in pcomplete.
|
||||||
|
Resolves: #487257
|
||||||
|
|
||||||
|
* Tue Feb 24 2009 Roman Rakus <rrakus@redhat.com> - 4.0-1
|
||||||
- Release of bash-4.0
|
- Release of bash-4.0
|
||||||
|
|
||||||
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-0.5.rc1
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0-0.5.rc1
|
||||||
|
11
pcomplete-save-parser-state.patch
Normal file
11
pcomplete-save-parser-state.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up bash-4.0/pcomplete.c.parser_state bash-4.0/pcomplete.c
|
||||||
|
--- bash-4.0/pcomplete.c.parser_state 2009-02-25 15:33:16.000000000 +0100
|
||||||
|
+++ bash-4.0/pcomplete.c 2009-02-25 15:34:06.000000000 +0100
|
||||||
|
@@ -1032,6 +1032,7 @@ gen_shell_function_matches (cs, text, li
|
||||||
|
cmdlist = build_arg_list (funcname, text, lwords, cw);
|
||||||
|
|
||||||
|
pps = &ps;
|
||||||
|
+ save_parser_state (pps);
|
||||||
|
begin_unwind_frame ("gen-shell-function-matches");
|
||||||
|
add_unwind_protect (restore_parser_state, (char *)pps);
|
||||||
|
add_unwind_protect (dispose_words, (char *)cmdlist);
|
Loading…
Reference in New Issue
Block a user