Resolves: #483002. No more debug output
This commit is contained in:
parent
b4cdcd3a4c
commit
0e588980b4
@ -1,12 +1,39 @@
|
|||||||
diff -up bash-4.0/builtins/evalstring.c.rr bash-4.0/builtins/evalstring.c
|
diff -up bash-4.0-rc1/error.h.no_debug_output bash-4.0-rc1/error.h
|
||||||
--- bash-4.0/builtins/evalstring.c.rr 2009-01-26 04:40:10.000000000 -0500
|
--- bash-4.0-rc1/error.h.no_debug_output 2009-01-08 14:32:45.000000000 +0100
|
||||||
+++ bash-4.0/builtins/evalstring.c 2009-01-26 04:40:52.000000000 -0500
|
+++ bash-4.0-rc1/error.h 2009-01-29 14:39:16.000000000 +0100
|
||||||
@@ -268,7 +268,7 @@ parse_and_execute (string, from_file, fl
|
@@ -51,8 +51,10 @@ extern void internal_error __P((const ch
|
||||||
|
extern void internal_warning __P((const char *, ...)) __attribute__((__format__ (printf, 1, 2)));
|
||||||
|
|
||||||
|
/* Debugging functions, not enabled in released version. */
|
||||||
|
+#if defined (DEBUG)
|
||||||
|
extern void itrace __P((const char *, ...)) __attribute__ ((__format__ (printf, 1, 2)));
|
||||||
|
extern void trace __P((const char *, ...)) __attribute__ ((__format__ (printf, 1, 2)));
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* Report an error having to do with command parsing or execution. */
|
||||||
|
extern void command_error __P((const char *, int, int, int));
|
||||||
|
diff -up bash-4.0-rc1/builtins/evalstring.c.no_debug_output bash-4.0-rc1/builtins/evalstring.c
|
||||||
|
--- bash-4.0-rc1/builtins/evalstring.c.no_debug_output 2009-01-04 20:32:22.000000000 +0100
|
||||||
|
+++ bash-4.0-rc1/builtins/evalstring.c 2009-01-29 14:39:16.000000000 +0100
|
||||||
|
@@ -268,7 +268,9 @@ parse_and_execute (string, from_file, fl
|
||||||
if ((subshell_environment & SUBSHELL_COMSUB) && comsub_ignore_return)
|
if ((subshell_environment & SUBSHELL_COMSUB) && comsub_ignore_return)
|
||||||
{
|
{
|
||||||
command->flags |= CMD_IGNORE_RETURN;
|
command->flags |= CMD_IGNORE_RETURN;
|
||||||
-itrace("parse_and_execute: turned on CMD_IGNORE_RETURN from comsub_ignore_return");
|
+#if defined (DEBUG)
|
||||||
+/* itrace("parse_and_execute: turned on CMD_IGNORE_RETURN from comsub_ignore_return"); */
|
itrace("parse_and_execute: turned on CMD_IGNORE_RETURN from comsub_ignore_return");
|
||||||
|
+#endif
|
||||||
}
|
}
|
||||||
|
|
||||||
#if defined (ONESHOT)
|
#if defined (ONESHOT)
|
||||||
|
diff -up bash-4.0-rc1/Makefile.in.no_debug_output bash-4.0-rc1/Makefile.in
|
||||||
|
--- bash-4.0-rc1/Makefile.in.no_debug_output 2009-01-29 14:40:11.000000000 +0100
|
||||||
|
+++ bash-4.0-rc1/Makefile.in 2009-01-29 14:40:54.000000000 +0100
|
||||||
|
@@ -112,7 +112,7 @@ VENDOR = @host_vendor@
|
||||||
|
MACHTYPE = @host@
|
||||||
|
|
||||||
|
# comment out for release
|
||||||
|
-DEBUG = @DEBUG@
|
||||||
|
+#DEBUG = @DEBUG@
|
||||||
|
MALLOC_DEBUG = @MALLOC_DEBUG@
|
||||||
|
|
||||||
|
THIS_SH = $(BUILD_DIR)/$(Program)
|
||||||
|
@ -3,7 +3,7 @@
|
|||||||
Version: 4.0
|
Version: 4.0
|
||||||
Name: bash
|
Name: bash
|
||||||
Summary: The GNU Bourne Again shell version %{version}
|
Summary: The GNU Bourne Again shell version %{version}
|
||||||
Release: 0.2.%{?beta_tag}%{?dist}
|
Release: 0.3.%{?beta_tag}%{?dist}
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Url: http://www.gnu.org/software/bash
|
Url: http://www.gnu.org/software/bash
|
||||||
@ -242,6 +242,10 @@ fi
|
|||||||
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
#%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 29 2009 Roman Rakus <rrakus@redhat.com> - 4.0-0.3.rc1
|
||||||
|
- No more debug output
|
||||||
|
Resolves: #483002
|
||||||
|
|
||||||
* Wed Jan 28 2009 Jesse Keating <jkeating@redhat.com> - 4.0-0.2.rc1
|
* Wed Jan 28 2009 Jesse Keating <jkeating@redhat.com> - 4.0-0.2.rc1
|
||||||
- Replace post code with lua to be able to not have external deps
|
- Replace post code with lua to be able to not have external deps
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user