parent
33325c0b7f
commit
f449c9931d
@ -1,14 +0,0 @@
|
||||
diff --git a/completions/man b/completions/man
|
||||
--- a/completions/man
|
||||
+++ b/completions/man
|
||||
@@ -53,9 +53,7 @@ _man()
|
||||
return
|
||||
fi
|
||||
|
||||
- local manpath="$MANPATH"
|
||||
- [[ -z $manpath ]] && \
|
||||
- manpath=$( manpath 2>/dev/null || command man -w 2>/dev/null )
|
||||
+ local manpath=$( manpath 2>/dev/null || command man -w 2>/dev/null )
|
||||
[[ -z $manpath ]] && manpath="/usr/share/man:/usr/local/share/man"
|
||||
|
||||
# determine manual section to search
|
@ -1,27 +0,0 @@
|
||||
diff --git a/completions/Makefile.am b/completions/Makefile.am
|
||||
--- a/completions/Makefile.am
|
||||
+++ b/completions/Makefile.am
|
||||
@@ -315,7 +315,7 @@ bashcomp_DATA = 2to3 \
|
||||
reportbug \
|
||||
_reptyr \
|
||||
resolvconf \
|
||||
- rfkill \
|
||||
+ _rfkill \
|
||||
ri \
|
||||
rmlist \
|
||||
rmmod \
|
||||
diff --git a/completions/rfkill b/completions/_rfkill
|
||||
similarity index 86%
|
||||
rename from completions/rfkill
|
||||
rename to completions/_rfkill
|
||||
--- a/completions/rfkill
|
||||
+++ b/completions/_rfkill
|
||||
@@ -1,5 +1,8 @@
|
||||
# bash completion for rfkill -*- shell-script -*-
|
||||
|
||||
+# Use of this file is deprecated on systems with util-linux >= 2.31, which
|
||||
+# ships completion for the rfkill included with it.
|
||||
+
|
||||
_rfkill()
|
||||
{
|
||||
local cur prev words cword
|
@ -4,8 +4,8 @@
|
||||
%global _python_bytecompile_errors_terminate_build 0
|
||||
|
||||
Name: bash-completion
|
||||
Version: 2.7
|
||||
Release: 4%{?dist}
|
||||
Version: 2.8
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
Summary: Programmable completion for Bash
|
||||
|
||||
@ -14,10 +14,7 @@ URL: https://github.com/scop/bash-completion
|
||||
Source0: https://github.com/scop/bash-completion/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||
# https://bugzilla.redhat.com/677446, see also redefine_filedir comments
|
||||
Patch0: %{name}-1.99-noblacklist.patch
|
||||
# It should be removed while rebasing to bash-completion-2.8
|
||||
Patch1: %{name}-rfkill.patch
|
||||
# It should be removed while rebasing to bash-completion-2.8
|
||||
Patch2: %{name}-manpath.patch
|
||||
|
||||
BuildArch: noarch
|
||||
%if %{with tests}
|
||||
BuildRequires: dejagnu
|
||||
@ -93,6 +90,10 @@ make -C completions check
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 12 2018 Siteshwar Vashisht <svashisht@redhat.com> - 1:2.8-1
|
||||
- Update to 2.8
|
||||
Resolves: #1561241
|
||||
|
||||
* Wed Mar 14 2018 Siteshwar Vashisht <svashisht@redhat.com> - 1:2.7-4
|
||||
- Do not use $MANPATH directly
|
||||
Resolves: #1495055
|
||||
|
Loading…
Reference in New Issue
Block a user