- 20080705; new upstream at http://bash-completion.alioth.debian.org/
- Perl, Debian, and scp patches applied upstream. - Patch to improve man completion: more sections, better filename handling. - Patch to speed up yum install/deplist completion (#478784). - Patch to fix and speed up rpm installed packages completion. - Update mock completion.
This commit is contained in:
parent
b05ebccd76
commit
ea0d49473c
@ -1 +1 @@
|
||||
bash-completion-20060301.tar.bz2
|
||||
bash-completion_20080705.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- bash_completion~ 2007-02-28 01:11:44.000000000 +0200
|
||||
+++ bash_completion 2007-02-28 01:11:44.000000000 +0200
|
||||
@@ -806,7 +806,7 @@
|
||||
[ $UNAME = GNU -o $UNAME = Linux -o $UNAME = Darwin \
|
||||
-o $UNAME = FreeBSD -o $UNAME = SunOS -o $UNAME = Cygwin \
|
||||
-o $UNAME = OpenBSD ] && \
|
||||
-complete -F _man $filenames man
|
||||
+complete -F _man $filenames man apropos whatis
|
||||
|
||||
# renice(8) completion
|
||||
#
|
@ -1,21 +0,0 @@
|
||||
diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
--- bash_completion/bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion/bash_completion 2008-09-11 01:29:49.000000000 +0300
|
||||
@@ -3281,7 +3281,7 @@ complete -F _mysqladmin mysqladmin
|
||||
have gzip &&
|
||||
_gzip()
|
||||
{
|
||||
- local cur prev xspec IFS=$'\t\n'
|
||||
+ local cur prev xspec
|
||||
|
||||
COMPREPLY=()
|
||||
cur=${COMP_WORDS[COMP_CWORD]}
|
||||
@@ -3290,7 +3290,7 @@ _gzip()
|
||||
--stdout --decompress --force --help --list \
|
||||
--license --no-name --name --quiet --recursive \
|
||||
--suffix --test --verbose --version --fast \
|
||||
- --best' -- $cur ) )
|
||||
+ --best --rsyncable' -- $cur ) )
|
||||
return 0
|
||||
fi
|
||||
|
@ -1,5 +0,0 @@
|
||||
--- bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion 2007-11-16 23:23:20.000000000 +0200
|
||||
@@ -86 +86 @@
|
||||
-complete -f -X '!*.@(gif|jp?(e)g|miff|tif?(f)|pn[gm]|p[bgp]m|bmp|xpm|ico|xwd|tga|pcx|GIF|JP?(E)G|MIFF|TIF?(F)|PN[GM]|P[BGP]M|BMP|XPM|ICO|XWD|TGA|PCX)' ee display
|
||||
+complete -f -X '!*.@(gif|jp?(e)g|jp[2cfx]|j2k|miff|tif?(f)|pn[gm]|p[bgp]m|bmp|xpm|ico|xwd|tga|pcx|GIF|JP?(E)G|JP[2CFX]|J2K|MIFF|TIF?(F)|PN[GM]|P[BGP]M|BMP|XPM|ICO|XWD|TGA|PCX)' ee display
|
39
bash-completion-20060301-man.patch
Normal file
39
bash-completion-20060301-man.patch
Normal file
@ -0,0 +1,39 @@
|
||||
--- bash_completion~ 2008-09-11 21:22:40.000000000 +0300
|
||||
+++ bash_completion 2009-01-05 23:31:44.000000000 +0200
|
||||
@@ -761,9 +761,9 @@
|
||||
|
||||
_expand || return 0
|
||||
|
||||
- # default completion if parameter contains /
|
||||
+ # file based completion if parameter contains /
|
||||
if [[ "$cur" == */* ]]; then
|
||||
- _filedir
|
||||
+ _filedir '@([0-9]?([px])|[ln]|man)?(.@(gz|bz2|lzma))'
|
||||
return 0
|
||||
fi
|
||||
|
||||
@@ -783,7 +783,7 @@
|
||||
fi
|
||||
|
||||
# determine manual section to search
|
||||
- [[ "$prev" == [0-9ln] ]] && sect=$prev || sect='*'
|
||||
+ [[ "$prev" == @([0-9]?([px])|[ln]) ]] && sect=$prev || sect='*'
|
||||
|
||||
manpath=$manpath:
|
||||
if [ -n "$cur" ]; then
|
||||
@@ -800,7 +800,14 @@
|
||||
COMPREPLY=( ${COMPREPLY[@]%.@(gz|bz2|lzma)} )
|
||||
COMPREPLY=( $( compgen -W '${COMPREPLY[@]%.*}' -- "${cur//\\\\/}" ) )
|
||||
|
||||
- [[ "$prev" != [0-9ln] ]] && _filedir '[0-9ln]'
|
||||
+ if [[ "$prev" != @([0-9]?([px])|[lnop]) ]]; then
|
||||
+ # file based completion for the rest, prepending ./ if needed
|
||||
+ local start=${#COMPREPLY[@]}
|
||||
+ _filedir '@([0-9]?([px])|[ln]|man)?(.@(gz|bz2|lzma))'
|
||||
+ for (( i=$start; i < ${#COMPREPLY[@]}; i++ )); do
|
||||
+ [[ ${COMPREPLY[i]} == */* ]] || COMPREPLY[i]=./${COMPREPLY[i]}
|
||||
+ done
|
||||
+ fi
|
||||
|
||||
return 0
|
||||
}
|
@ -1,20 +0,0 @@
|
||||
--- bash_completion.orig 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion 2008-04-28 20:52:32.000000000 +0300
|
||||
@@ -94,7 +94,7 @@ complete -f -X '!*.@(?(e)ps|?(E)PS)' ps2
|
||||
complete -f -X '!*.texi*' makeinfo texi2html
|
||||
complete -f -X '!*.@(?(la)tex|?(LA)TEX|texi|TEXI|dtx|DTX|ins|INS)' tex latex slitex jadetex pdfjadetex pdftex pdflatex texi2dvi
|
||||
complete -f -X '!*.@(mp3|MP3)' mpg123 mpg321 madplay
|
||||
-complete -f -X '!*.@(mp?(e)g|MP?(E)G|wma|avi|AVI|asf|vob|VOB|bin|dat|vcd|ps|pes|fli|viv|rm|ram|yuv|mov|MOV|qt|QT|wmv|mp3|MP3|ogg|OGG|ogm|OGM|mp4|MP4|wav|WAV|asx|ASX|mng|MNG)' xine aaxine fbxine kaffeine
|
||||
+complete -f -X '!*@(.@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|as[fx]|AS[FX]|vob|VOB|bin|BIN|dat|DAT|vcd|VCD|p?(e)s|fl[iv]|FL[IV]|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[234]|MP[234]|og[gm]|OG[GM]|wav|WAV|mng|MNG|mkv|MKV)|[0-9]*.@(vdr|VDR))' xine aaxine fbxine kaffeine
|
||||
complete -f -X '!*.@(avi|asf|wmv)' aviplay
|
||||
complete -f -X '!*.@(rm?(j)|ra?(m)|smi?(l))' realplay
|
||||
complete -f -X '!*.@(mpg|mpeg|avi|mov|qt)' xanim
|
||||
@@ -5888,7 +5888,7 @@ _mplayer()
|
||||
-xvidencopts -of --verbose' -- $cur) )
|
||||
;;
|
||||
*)
|
||||
- _filedir '@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|asf|ASF|vob|VOB|bin|BIN|dat|DAT|vcd|VCD|ps|PS|pes|PES|fli|FLI|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[34]|MP[34]|og[gm]|OG[GM]|wav|WAV|dump|DUMP|mkv|MKV|m4a|M4A|aac|AAC|m2v|M2V|dv|DV|rmvb|RMVB|mid|MID|ts|TS|3gp|mpc|MPC|flac|FLAC)'
|
||||
+ _filedir '@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|asf|ASF|vob|VOB|bin|BIN|dat|DAT|vcd|VCD|p?(e)s|P?(E)S|fl[iv]|FL[IV]|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[234]|MP[234]|og[gm]|OG[GM]|wav|WAV|dump|DUMP|mk[av]|MK[AV]|m4a|M4A|aac|AAC|m2v|M2V|dv|DV|rmvb|RMVB|mid|MID|ts|TS|3gp|mpc|MPC|flac|FLAC|vdr|VDR)'
|
||||
;;
|
||||
esac
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- bash_completion~ 2007-09-22 10:35:56.000000000 +0300
|
||||
+++ bash_completion 2007-09-22 10:37:56.000000000 +0300
|
||||
@@ -5196,8 +5196,8 @@
|
||||
;;
|
||||
esac
|
||||
|
||||
- # handle case where first parameter is not a dash option
|
||||
- if [ $COMP_CWORD -eq 1 ] && [[ "$cur" != -* ]]; then
|
||||
+ # handle non-dash options
|
||||
+ if [[ "$cur" != -* ]]; then
|
||||
_filedir
|
||||
return 0
|
||||
fi
|
@ -1,18 +0,0 @@
|
||||
--- bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion 2006-12-26 14:01:59.000000000 +0200
|
||||
@@ -2589,6 +2589,7 @@
|
||||
COMPREPLY=( $( ssh -o 'Batchmode yes' $userhost \
|
||||
command ls -aF1d "$path*" 2>/dev/null | \
|
||||
sed -e 's/[][(){}<>",:;^&!$&=?`|\ ]/\\\\\\&/g' \
|
||||
+ -e "s/'/\\\\\\\\\\\\&/g" \
|
||||
-e 's/[*@|=]$//g' -e 's/[^\/]$/& /g' ) )
|
||||
return 0
|
||||
fi
|
||||
@@ -2597,6 +2598,7 @@
|
||||
COMPREPLY=( ${COMPREPLY[@]} $( command ls -aF1d $cur* \
|
||||
2>/dev/null | sed \
|
||||
-e 's/[][(){}<>",:;^&!$&=?`|\ ]/\\&/g' \
|
||||
+ -e "s/'/\\\\&/g" \
|
||||
-e 's/[*@|=]$//g' -e 's/[^\/]$/& /g' ) )
|
||||
return 0
|
||||
}
|
@ -1,12 +0,0 @@
|
||||
diff -up bash_completion~ bash_completion
|
||||
--- bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion 2008-01-24 20:21:12.000000000 +0200
|
||||
@@ -9083,7 +9083,7 @@ _svn()
|
||||
|
||||
return 0
|
||||
}
|
||||
-complete -F _svn $default svn
|
||||
+complete -F _svn $filenames svn
|
||||
|
||||
_svnadmin()
|
||||
{
|
11
bash-completion-20060301-yum-available-speedup-478784.patch
Normal file
11
bash-completion-20060301-yum-available-speedup-478784.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bash_completion~ 2008-09-11 21:22:40.000000000 +0300
|
||||
+++ bash_completion 2009-01-05 18:47:08.000000000 +0200
|
||||
@@ -6352,7 +6352,7 @@
|
||||
if [ -n "$special" ]; then
|
||||
case $special in
|
||||
install|deplist)
|
||||
- COMPREPLY=( $( compgen -W '$( yum -C list | cut -d" " -f1 )' -- $cur ) )
|
||||
+ COMPREPLY=( $( compgen -W "$( yum -d 0 -C list available "$cur*" | cut -d' ' -f1 )" -- $cur ) )
|
||||
return 0
|
||||
;;
|
||||
*)
|
@ -1,7 +1,6 @@
|
||||
diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
--- bash_completion/bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion/bash_completion 2008-09-07 12:25:42.000000000 +0300
|
||||
@@ -8379,19 +8379,19 @@ _getent()
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 19:00:26.000000000 +0200
|
||||
@@ -8742,19 +8742,19 @@
|
||||
COMPREPLY=( $( compgen -A hostname $cur ) )
|
||||
return 0
|
||||
;;
|
20
bash-completion-20080705-gzip.patch
Normal file
20
bash-completion-20080705-gzip.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 19:02:34.000000000 +0200
|
||||
@@ -3377,7 +3377,7 @@
|
||||
have gzip &&
|
||||
_gzip()
|
||||
{
|
||||
- local cur prev xspec IFS=$'\t\n'
|
||||
+ local cur prev xspec
|
||||
|
||||
COMPREPLY=()
|
||||
cur=`_get_cword`
|
||||
@@ -3390,7 +3390,7 @@
|
||||
--stdout --decompress --force --help --list \
|
||||
--license --no-name --name --quiet --recursive \
|
||||
--suffix --test --verbose --version --fast \
|
||||
- --best' -- $cur ) )
|
||||
+ --best --rsyncable' -- $cur ) )
|
||||
return 0
|
||||
fi
|
||||
|
5
bash-completion-20080705-jpeg2000-304771.patch
Normal file
5
bash-completion-20080705-jpeg2000-304771.patch
Normal file
@ -0,0 +1,5 @@
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 18:39:48.000000000 +0200
|
||||
@@ -99 +99 @@
|
||||
-complete -f -X '!*.@(gif|jp?(e)g|miff|tif?(f)|pn[gm]|p[bgp]m|bmp|xpm|ico|xwd|tga|pcx|svg|GIF|JP?(E)G|MIFF|TIF?(F)|PN[GM]|P[BGP]M|BMP|XPM|ICO|XWD|TGA|PCX|SVG)' display
|
||||
+complete -f -X '!*.@(gif|jp?(e)g|jp[2cfx]|j2k|miff|tif?(f)|pn[gm]|p[bgp]m|bmp|xpm|ico|xwd|tga|pcx|svg|GIF|JP?(E)G|JP[2CFX]|J2K|MIFF|TIF?(F)|PN[GM]|P[BGP]M|BMP|XPM|ICO|XWD|TGA|PCX|SVG)' display
|
@ -1,7 +1,6 @@
|
||||
diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
--- bash_completion/bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion/bash_completion 2008-09-10 19:02:25.000000000 +0300
|
||||
@@ -796,7 +796,7 @@ _man()
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 19:12:03.000000000 +0200
|
||||
@@ -873,7 +873,7 @@
|
||||
# weed out directory path names and paths to man pages
|
||||
COMPREPLY=( ${COMPREPLY[@]##*/?(:)} )
|
||||
# strip suffix from man pages
|
||||
@ -10,7 +9,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
COMPREPLY=( $( compgen -W '${COMPREPLY[@]%.*}' -- "${cur//\\\\/}" ) )
|
||||
|
||||
[[ "$prev" != [0-9ln] ]] && _filedir '[0-9ln]'
|
||||
@@ -1971,7 +1971,7 @@ _rpm()
|
||||
@@ -2050,7 +2050,7 @@
|
||||
elif [[ ${COMP_WORDS[1]} == -b* ]]; then
|
||||
_filedir 'spec'
|
||||
else
|
||||
@ -19,7 +18,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
fi
|
||||
;;
|
||||
--re@(build|compile))
|
||||
@@ -1983,7 +1983,7 @@ _rpm()
|
||||
@@ -2062,7 +2062,7 @@
|
||||
fi
|
||||
;;
|
||||
--tarbuild)
|
||||
@ -28,7 +27,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
;;
|
||||
--@(re|add)sign)
|
||||
_filedir 'rpm'
|
||||
@@ -3356,6 +3356,44 @@ _bzip2()
|
||||
@@ -3454,6 +3454,44 @@
|
||||
} &&
|
||||
complete -F _bzip2 $filenames bzip2
|
||||
|
||||
@ -40,7 +39,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
+ local cur prev xspec
|
||||
+
|
||||
+ COMPREPLY=()
|
||||
+ cur=${COMP_WORDS[COMP_CWORD]}
|
||||
+ cur=`_get_cword`
|
||||
+ prev=${COMP_WORDS[COMP_CWORD-1]}
|
||||
+
|
||||
+ if [[ "$cur" == -* ]]; then
|
||||
@ -73,7 +72,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
# openssl(1) completion
|
||||
#
|
||||
have openssl && {
|
||||
@@ -6968,7 +7006,7 @@ _info()
|
||||
@@ -7331,7 +7369,7 @@
|
||||
fi;
|
||||
done
|
||||
# strip suffix from info pages
|
8
bash-completion-20080705-mediafiles-444467.patch
Normal file
8
bash-completion-20080705-mediafiles-444467.patch
Normal file
@ -0,0 +1,8 @@
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 18:55:49.000000000 +0200
|
||||
@@ -112 +112 @@
|
||||
-complete -f -X '!*.@(mp?(e)g|MP?(E)G|wma|avi|AVI|asf|vob|VOB|bin|dat|divx|DIVX|vcd|ps|pes|fli|flv|FLV|viv|rm|ram|yuv|mov|MOV|qt|QT|wmv|mp3|MP3|m4[pv]|M4[PV]|ogg|OGG|ogm|OGM|mp4|MP4|wav|WAV|asx|ASX|mng|MNG|srt)' xine aaxine fbxine kaffeine
|
||||
+complete -f -X '!*@(.@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|as[fx]|AS[FX]|vob|VOB|bin|BIN|dat|DAT|divx|DIVX|vcd|VCD|p?(e)s|P?(E)S|fl[iv]|FL[IV]|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[234]|MP[234]|m4[pv]|M4[PV]|og[gm]|OG[GM]|wav|WAV|mng|MNG|srt|SRT|mkv|MKV|[0-9]*.@(vdr|VDR))' xine aaxine fbxine kaffeine
|
||||
@@ -6090 +6090 @@
|
||||
- _filedir '@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|asf|ASF|vob|VOB|bin|BIN|dat|DAT|vcd|VCD|ps|PS|pes|PES|fl[iv]|FL[IV]|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[34]|MP[34]|m4[av]|M4[AV]|og[gm]|OG[GM]|w?(a)v|W?(A)V|dump|DUMP|mk[av]|MK[AV]|m4a|M4A|aac|AAC|m2v|M2V|dv|DV|rmvb|RMVB|mid|MID|ts|TS|3g[p2]|mpc|MPC|flac|FLAC|vro|VRO|divx|DIVX|aif?(f)|AIF?(F)|m2ts|M2TS)'
|
||||
+ _filedir '@(mp?(e)g|MP?(E)G|wm[av]|WM[AV]|avi|AVI|asf|ASF|vob|VOB|bin|BIN|dat|DAT|vcd|VCD|p?(e)s|P?(E)S|fl[iv]|FL[IV]|viv|VIV|rm?(j)|RM?(J)|ra?(m)|RA?(M)|yuv|YUV|mov|MOV|qt|QT|mp[234]|MP[234]|m4[av]|M4[AV]|og[gm]|OG[GM]|w?(a)v|W?(A)V|dump|DUMP|mk[av]|MK[AV]|m4a|M4A|aac|AAC|m2v|M2V|dv|DV|rmvb|RMVB|mid|MID|ts|TS|3g[p2]|3G[P2]|mpc|MPC|flac|FLAC|vro|VRO|divx|DIVX|aif?(f)|AIF?(F)|m2ts|M2TS|vdr|VDR)'
|
@ -1,7 +1,6 @@
|
||||
diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
--- bash_completion/bash_completion~ 2006-03-01 18:20:18.000000000 +0200
|
||||
+++ bash_completion/bash_completion 2008-09-07 12:12:11.000000000 +0300
|
||||
@@ -348,10 +348,10 @@ _services()
|
||||
--- bash_completion~ 2009-01-06 19:12:03.000000000 +0200
|
||||
+++ bash_completion 2009-01-06 19:23:35.000000000 +0200
|
||||
@@ -424,10 +424,10 @@
|
||||
local sysvdir famdir
|
||||
[ -d /etc/rc.d/init.d ] && sysvdir=/etc/rc.d/init.d || sysvdir=/etc/init.d
|
||||
famdir=/etc/xinetd.d
|
||||
@ -9,12 +8,12 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
+ COMPREPLY=( $( builtin echo $sysvdir/!(*.rpmsave|*.rpmorig|*.rpmnew|*~|functions)) )
|
||||
|
||||
if [ -d $famdir ]; then
|
||||
- COMPREPLY=( ${COMPREPLY[@]} $( builtin echo $famdir/!(*.rpmsave|*.rpmorig|*~)) )
|
||||
+ COMPREPLY=( ${COMPREPLY[@]} $( builtin echo $famdir/!(*.rpmsave|*.rpmorig|*.rpmnew|*~)) )
|
||||
- COMPREPLY=( "${COMPREPLY[@]}" $( builtin echo $famdir/!(*.rpmsave|*.rpmorig|*~)) )
|
||||
+ COMPREPLY=( "${COMPREPLY[@]}" $( builtin echo $famdir/!(*.rpmsave|*.rpmorig|*.rpmnew|*~)) )
|
||||
fi
|
||||
|
||||
COMPREPLY=( $( compgen -W '${COMPREPLY[@]#@($sysvdir|$famdir)/}' -- $cur ) )
|
||||
@@ -8679,7 +8679,7 @@ _update_rc_d()
|
||||
@@ -9080,7 +9080,7 @@
|
||||
[ -d /etc/rc.d/init.d ] && sysvdir=/etc/rc.d/init.d \
|
||||
|| sysvdir=/etc/init.d
|
||||
|
||||
@ -23,7 +22,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
services=( ${services[@]#$sysvdir/} )
|
||||
options=( -f -n )
|
||||
|
||||
@@ -8745,7 +8745,7 @@ _invoke_rc_d()
|
||||
@@ -9146,7 +9146,7 @@
|
||||
[ -d /etc/rc.d/init.d ] && sysvdir=/etc/rc.d/init.d \
|
||||
|| sysvdir=/etc/init.d
|
||||
|
||||
@ -32,7 +31,7 @@ diff -up bash_completion/bash_completion~ bash_completion/bash_completion
|
||||
services=( ${services[@]#$sysvdir/} )
|
||||
options=( --help --quiet --force --try-anyway --disclose-deny --query --no-fallback )
|
||||
|
||||
@@ -9281,7 +9281,7 @@ unset list
|
||||
@@ -9700,7 +9700,7 @@
|
||||
if [ -d $BASH_COMPLETION_DIR -a -r $BASH_COMPLETION_DIR -a \
|
||||
-x $BASH_COMPLETION_DIR ]; then
|
||||
for i in $BASH_COMPLETION_DIR/*; do
|
80
bash-completion-20080705-rpm-installed.patch
Normal file
80
bash-completion-20080705-rpm-installed.patch
Normal file
@ -0,0 +1,80 @@
|
||||
--- bash_completion~ 2009-01-06 19:12:03.000000000 +0200
|
||||
+++ bash_completion 2009-01-06 19:31:06.000000000 +0200
|
||||
@@ -1811,29 +1811,28 @@
|
||||
#
|
||||
_rpm_installed_packages()
|
||||
{
|
||||
- local ver nodig nosig
|
||||
+ local ver nodig="$1" nosig="$2"
|
||||
|
||||
if [ -r /var/log/rpmpkgs -a \
|
||||
/var/log/rpmpkgs -nt /var/lib/rpm/Packages ]; then
|
||||
# using RHL 7.2 or later - this is quicker than querying the DB
|
||||
COMPREPLY=( $( sed -ne \
|
||||
- 's|^\('$cur'.*\)-[0-9a-zA-Z._]\+-[0-9a-z.@]\+.*\.rpm$|\1|p' \
|
||||
+ 's|^\('$cur'[^[:space:]]*\)-[^[:space:]-]\+-[^[:space:]-]\+\.rpm$|\1|p' \
|
||||
/var/log/rpmpkgs ) )
|
||||
else
|
||||
- nodig=""
|
||||
- nosig=""
|
||||
- ver=$(rpm --version)
|
||||
- ver=${ver##* }
|
||||
+ if [ -z "$nodig" -a -z "$nosig" ]; then
|
||||
+ ver=$(rpm --version)
|
||||
+ ver=${ver##* }
|
||||
|
||||
- if [[ "$ver" > "4.0.4" ]]; then
|
||||
- nodig="--nodigest"
|
||||
- fi
|
||||
- if [[ "$ver" > "4.0.99" ]]; then
|
||||
- nosig="--nosignature"
|
||||
+ if [[ "$ver" > "4.0.4" ]]; then
|
||||
+ nodig="--nodigest"
|
||||
+ fi
|
||||
+ if [[ "$ver" > "4.0.99" ]]; then
|
||||
+ nosig="--nosignature"
|
||||
+ fi
|
||||
fi
|
||||
|
||||
- COMPREPLY=( $( rpm -qa $nodig $nosig | sed -ne \
|
||||
- 's|^\('$cur'.*\)-[0-9a-zA-Z._]\+-[0-9a-z.@]\+$|\1|p' ) )
|
||||
+ COMPREPLY=( $( rpm -qa $nodig $nosig --qf='%{NAME} ' "$cur*" ) )
|
||||
fi
|
||||
}
|
||||
|
||||
@@ -1959,7 +1958,7 @@
|
||||
COMPREPLY=( $( compgen -W '--allmatches --noscripts \
|
||||
--notriggers --nodeps --test --repackage' -- $cur ) )
|
||||
else
|
||||
- _rpm_installed_packages
|
||||
+ _rpm_installed_packages "$nodig" "$nosig"
|
||||
fi
|
||||
;;
|
||||
-@(q*|-query))
|
||||
@@ -2011,7 +2010,7 @@
|
||||
--fileid --tid --nodigest --nosignature \
|
||||
--triggerscripts' -- $cur ) )
|
||||
elif [ "${COMP_LINE#* -*([^ -])a}" == "$COMP_LINE" ]; then
|
||||
- _rpm_installed_packages
|
||||
+ _rpm_installed_packages "$nodig" "$nosig"
|
||||
fi
|
||||
fi
|
||||
;;
|
||||
@@ -2038,7 +2037,7 @@
|
||||
elif [ "${COMP_LINE#* -*([^ -])p}" != "$COMP_LINE" ]; then
|
||||
_filedir 'rpm'
|
||||
else
|
||||
- _rpm_installed_packages
|
||||
+ _rpm_installed_packages "$nodig" "$nosig"
|
||||
fi
|
||||
;;
|
||||
-[bt]*)
|
||||
@@ -2068,7 +2067,7 @@
|
||||
_filedir 'rpm'
|
||||
;;
|
||||
--set@(perms|gids))
|
||||
- _rpm_installed_packages
|
||||
+ _rpm_installed_packages "$nodig" "$nosig"
|
||||
;;
|
||||
--@(clean|rms@(ource|pec)))
|
||||
if [[ "$cur" == -* ]]; then
|
11
bash-completion-20080705-svn-filenames-430059.patch
Normal file
11
bash-completion-20080705-svn-filenames-430059.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- bash_completion~ 2008-07-05 16:55:03.000000000 +0300
|
||||
+++ bash_completion 2009-01-06 18:58:11.000000000 +0200
|
||||
@@ -9446,7 +9446,7 @@
|
||||
|
||||
return 0
|
||||
}
|
||||
-complete -F _svn $default svn
|
||||
+complete -F _svn $filenames svn
|
||||
|
||||
_svnadmin()
|
||||
{
|
@ -6,7 +6,7 @@ _lzop()
|
||||
local cur prev xspec IFS=$' \t\n'
|
||||
|
||||
COMPREPLY=()
|
||||
cur=${COMP_WORDS[COMP_CWORD]}
|
||||
cur=`_get_cword`
|
||||
prev=${COMP_WORDS[COMP_CWORD-1]}
|
||||
|
||||
if [[ "$cur" == -* ]]; then
|
||||
|
@ -7,13 +7,13 @@ _mock()
|
||||
local cur prev plugins cfgdir
|
||||
|
||||
COMPREPLY=()
|
||||
cur=${COMP_WORDS[COMP_CWORD]}
|
||||
cur=`_get_cword`
|
||||
prev=${COMP_WORDS[COMP_CWORD-1]}
|
||||
plugins='ccache yum_cache root_cache bind_mount'
|
||||
cfgdir=/etc/mock
|
||||
|
||||
count=0
|
||||
for i in ${COMP_WORDS[@]} ; do
|
||||
for i in "${COMP_WORDS[@]}" ; do
|
||||
[ $count -eq $COMP_CWORD ] && break
|
||||
if [[ "$i" == --configdir ]] ; then
|
||||
cfgdir="${COMP_WORDS[((count+1))]}"
|
||||
@ -24,7 +24,7 @@ _mock()
|
||||
done
|
||||
|
||||
case $prev in
|
||||
-r)
|
||||
-@(-root|r))
|
||||
COMPREPLY=( $( command ls $cfgdir | \
|
||||
sed -ne 's/^\('$cur'.*\)\.cfg$/\1/p') )
|
||||
return 0
|
||||
@ -47,19 +47,20 @@ _mock()
|
||||
COMPREPLY=( $( compgen -W "$plugins" -- $cur ) )
|
||||
return 0
|
||||
;;
|
||||
--@(arch|define|with|without|uniqueext|rpmbuild_timeout))
|
||||
--@(arch|target|define|with|without|uniqueext|rpmbuild_timeout|cwd))
|
||||
return 0
|
||||
;;
|
||||
esac
|
||||
fi
|
||||
|
||||
if [[ "$cur" == -* ]] ; then
|
||||
COMPREPLY=( $( compgen -W '--version -h --help --rebuild --chroot \
|
||||
--shell --clean --init --installdeps --install --update \
|
||||
--orphanskill -r --offline --no-clean --cleanup-after \
|
||||
--no-cleanup-after --arch= --define= --with= --without= \
|
||||
--resultdir= --uniqueext= --configdir= --rpmbuild_timeout -v \
|
||||
--verbose -q --quiet --trace --enable-plugin= --disable-plugin=' \
|
||||
COMPREPLY=( $( compgen -W '--version -h --help --rebuild --shell \
|
||||
--chroot --clean --init --installdeps --install --update \
|
||||
--orphanskill -r --root= --offline --no-clean --cleanup-after \
|
||||
--no-cleanup-after --arch= --target= -D --define= --with= \
|
||||
--without= --resultdir= --uniqueext= --configdir= \
|
||||
--rpmbuild_timeout --unpriv --cwd= -v --verbose -q --quiet \
|
||||
--trace --enable-plugin= --disable-plugin= --print-root-path' \
|
||||
-- $cur ) )
|
||||
else
|
||||
_filedir '?(no)src.rpm'
|
||||
|
@ -5,7 +5,7 @@ _plague_client()
|
||||
local cur
|
||||
|
||||
COMPREPLY=()
|
||||
cur=${COMP_WORDS[COMP_CWORD]}
|
||||
cur=`_get_cword`
|
||||
|
||||
[ $COMP_CWORD = 1 ] && \
|
||||
COMPREPLY=( $( compgen -W 'build detail finish help is_paused kill list \
|
||||
|
@ -5,7 +5,7 @@ _repomanage()
|
||||
local cur prev
|
||||
|
||||
COMPREPLY=()
|
||||
cur=${COMP_WORDS[COMP_CWORD]}
|
||||
cur=`_get_cword`
|
||||
prev=${COMP_WORDS[COMP_CWORD-1]}
|
||||
|
||||
case $prev in
|
||||
|
@ -1,27 +1,27 @@
|
||||
Name: bash-completion
|
||||
Version: 20060301
|
||||
Release: 13
|
||||
Version: 20080705
|
||||
Release: 1
|
||||
Summary: Programmable completion for Bash
|
||||
|
||||
Group: System Environment/Shells
|
||||
License: GPLv2+
|
||||
URL: http://www.caliban.org/bash/
|
||||
Source0: http://www.caliban.org/files/bash/%{name}-%{version}.tar.bz2
|
||||
URL: http://bash-completion.alioth.debian.org/
|
||||
Source0: http://ftp.debian.org/debian/pool/main/b/bash-completion/%{name}_%{version}.tar.gz
|
||||
Source1: %{name}-lzop
|
||||
Source2: %{name}-mock
|
||||
Source3: %{name}-repomanage
|
||||
Source4: %{name}-plague-client
|
||||
Patch0: %{name}-20060301-scp-apos-217178.patch
|
||||
Patch1: %{name}-20060301-debian.patch
|
||||
Patch2: %{name}-20060301-perl-299571.patch
|
||||
Patch3: %{name}-20060301-jpeg2000-304771.patch
|
||||
Patch4: %{name}-20060301-mediafiles-444467.patch
|
||||
Patch5: %{name}-20060301-svn-filenames-430059.patch
|
||||
Patch6: %{name}-20060301-gzip.patch
|
||||
Patch7: %{name}-20060301-lzma.patch
|
||||
Patch8: %{name}-20060301-rpm-backups.patch
|
||||
Patch0: %{name}-20080705-rpm-installed.patch
|
||||
Patch1: %{name}-20060301-yum-available-speedup-478784.patch
|
||||
Patch2: %{name}-20060301-man.patch
|
||||
Patch3: %{name}-20080705-jpeg2000-304771.patch
|
||||
Patch4: %{name}-20080705-mediafiles-444467.patch
|
||||
Patch5: %{name}-20080705-svn-filenames-430059.patch
|
||||
Patch6: %{name}-20080705-gzip.patch
|
||||
Patch7: %{name}-20080705-lzma.patch
|
||||
Patch8: %{name}-20080705-rpm-backups.patch
|
||||
Patch9: %{name}-20060301-rpm-eval.patch
|
||||
Patch10: %{name}-20060301-getent.patch
|
||||
Patch10: %{name}-20080705-getent.patch
|
||||
Patch11: %{name}-20060301-sqlite.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -34,20 +34,19 @@ of the programmable completion feature of bash 2.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n bash_completion
|
||||
%setup -q -n %{name}
|
||||
%patch0
|
||||
%patch1
|
||||
%patch2
|
||||
%patch3
|
||||
%patch4
|
||||
%patch5
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch6
|
||||
%patch7
|
||||
%patch8
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch10
|
||||
%patch11 -p1
|
||||
f=Changelog ; iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
|
||||
install -pm 644 %{SOURCE1} contrib/lzop
|
||||
install -pm 644 %{SOURCE2} contrib/mock
|
||||
install -pm 644 %{SOURCE3} contrib/repomanage
|
||||
@ -211,7 +210,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files -f %{name}-ghosts.list
|
||||
%defattr(-,root,root,-)
|
||||
%doc BUGS Changelog COPYING README
|
||||
%doc README TODO debian/changelog debian/copyright
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/bash_completion.sh
|
||||
%{_sysconfdir}/bash_completion
|
||||
%dir %{_sysconfdir}/bash_completion.d/
|
||||
@ -219,6 +218,14 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jan 6 2009 Ville Skyttä <ville.skytta at iki.fi> - 20080705-1
|
||||
- 20080705; new upstream at http://bash-completion.alioth.debian.org/
|
||||
- Perl, Debian, and scp patches applied upstream.
|
||||
- Patch to improve man completion: more sections, better filename handling.
|
||||
- Patch to speed up yum install/deplist completion (#478784).
|
||||
- Patch to fix and speed up rpm installed packages completion.
|
||||
- Update mock completion.
|
||||
|
||||
* Thu Sep 25 2008 Ville Skyttä <ville.skytta at iki.fi>
|
||||
- More Matroska associations (#463829, based on patch from Yanko Kaneti).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user