#1132959, #1135489) - Clean up no longer needed specfile conditionals - Mark COPYING as %license where applicable
This commit is contained in:
parent
3c8d903f72
commit
c30b02ab60
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/*.tar.*
|
||||
/CHANGES.package.old
|
||||
/bash-completion-2.1+git52d8316.patch.xz
|
||||
|
@ -1,264 +0,0 @@
|
||||
diff -up bash-completion-2.1/bash_completion~ bash-completion-2.1/bash_completion
|
||||
--- bash-completion-2.1/bash_completion~ 2013-04-05 13:55:51.000000000 +0300
|
||||
+++ bash-completion-2.1/bash_completion 2013-04-06 11:43:56.292170674 +0300
|
||||
@@ -59,7 +59,7 @@ complete -d pushd
|
||||
# start of section containing compspecs that can be handled within bash
|
||||
|
||||
# user commands see only users
|
||||
-complete -u write chfn groups slay w sux runuser
|
||||
+complete -u groups slay w sux
|
||||
|
||||
# bg completes with stopped jobs
|
||||
complete -A stopped -P '"%' -S '"' bg
|
||||
diff -up bash-completion-2.1/completions/Makefile.am~ bash-completion-2.1/completions/Makefile.am
|
||||
--- bash-completion-2.1/completions/Makefile.am~ 2013-04-05 13:55:51.000000000 +0300
|
||||
+++ bash-completion-2.1/completions/Makefile.am 2013-04-06 11:49:59.955323723 +0300
|
||||
@@ -27,7 +27,6 @@ bashcomp_DATA = a2x \
|
||||
brctl \
|
||||
btdownloadheadless.py \
|
||||
bzip2 \
|
||||
- cal \
|
||||
cancel \
|
||||
cardctl \
|
||||
ccache \
|
||||
@@ -43,7 +42,6 @@ bashcomp_DATA = a2x \
|
||||
chpasswd \
|
||||
chronyc \
|
||||
chrpath \
|
||||
- chsh \
|
||||
cksfv \
|
||||
cleanarch \
|
||||
clisp \
|
||||
@@ -65,7 +63,6 @@ bashcomp_DATA = a2x \
|
||||
desktop-file-validate \
|
||||
dhclient \
|
||||
dict \
|
||||
- dmesg \
|
||||
dnsspoof \
|
||||
dot \
|
||||
dpkg \
|
||||
@@ -76,7 +73,6 @@ bashcomp_DATA = a2x \
|
||||
dumpe2fs \
|
||||
e2freefrag \
|
||||
e2label \
|
||||
- eject \
|
||||
eog \
|
||||
ether-wake \
|
||||
evince \
|
||||
@@ -120,12 +116,10 @@ bashcomp_DATA = a2x \
|
||||
gzip \
|
||||
hcitool \
|
||||
hddtemp \
|
||||
- hexdump \
|
||||
hid2hci \
|
||||
hping2 \
|
||||
htop \
|
||||
htpasswd \
|
||||
- hwclock \
|
||||
iconv \
|
||||
id \
|
||||
idn \
|
||||
@@ -137,7 +131,6 @@ bashcomp_DATA = a2x \
|
||||
installpkg \
|
||||
interdiff \
|
||||
invoke-rc.d \
|
||||
- ionice \
|
||||
ip \
|
||||
iperf \
|
||||
ipmitool \
|
||||
@@ -177,7 +170,6 @@ bashcomp_DATA = a2x \
|
||||
list_lists \
|
||||
list_members \
|
||||
list_owners \
|
||||
- look \
|
||||
lpq \
|
||||
lpr \
|
||||
lrzip \
|
||||
@@ -225,7 +217,6 @@ bashcomp_DATA = a2x \
|
||||
nc \
|
||||
ncftp \
|
||||
nethogs \
|
||||
- newgrp \
|
||||
newlist \
|
||||
newusers \
|
||||
ngrep \
|
||||
@@ -283,7 +274,6 @@ bashcomp_DATA = a2x \
|
||||
rdesktop \
|
||||
remove_members \
|
||||
removepkg \
|
||||
- renice \
|
||||
reportbug \
|
||||
reptyr \
|
||||
resolvconf \
|
||||
@@ -298,7 +288,6 @@ bashcomp_DATA = a2x \
|
||||
rpmcheck \
|
||||
rrdtool \
|
||||
rsync \
|
||||
- rtcwake \
|
||||
sbcl \
|
||||
sbopkg \
|
||||
screen \
|
||||
@@ -320,7 +309,6 @@ bashcomp_DATA = a2x \
|
||||
sshow \
|
||||
strace \
|
||||
strings \
|
||||
- su \
|
||||
sudo \
|
||||
svcadm \
|
||||
svk \
|
||||
@@ -478,7 +466,6 @@ CLEANFILES = \
|
||||
mplayer2 \
|
||||
msgsnarf \
|
||||
muttng \
|
||||
- ncal \
|
||||
pbzip2 \
|
||||
pccardctl \
|
||||
pdlzip \
|
||||
@@ -603,10 +590,6 @@ symlinks: $(targetdir) $(DATA)
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) bzip2 $(targetdir)/$$file ; \
|
||||
done
|
||||
- for file in ncal ; do \
|
||||
- rm -f $(targetdir)/$$file && \
|
||||
- $(LN_S) cal $(targetdir)/$$file ; \
|
||||
- done
|
||||
for file in pccardctl ; do \
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) cardctl $(targetdir)/$$file ; \
|
||||
@@ -669,10 +652,6 @@ symlinks: $(targetdir) $(DATA)
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) hcitool $(targetdir)/$$file ; \
|
||||
done
|
||||
- for file in hd ; do \
|
||||
- rm -f $(targetdir)/$$file && \
|
||||
- $(LN_S) hexdump $(targetdir)/$$file ; \
|
||||
- done
|
||||
for file in hping hping3 ; do \
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) hping2 $(targetdir)/$$file ; \
|
||||
diff -up bash-completion-2.1/completions/Makefile.in~ bash-completion-2.1/completions/Makefile.in
|
||||
--- bash-completion-2.1/completions/Makefile.in~ 2013-04-05 13:56:55.000000000 +0300
|
||||
+++ bash-completion-2.1/completions/Makefile.in 2013-04-06 11:51:40.564047943 +0300
|
||||
@@ -198,7 +198,6 @@ bashcomp_DATA = a2x \
|
||||
brctl \
|
||||
btdownloadheadless.py \
|
||||
bzip2 \
|
||||
- cal \
|
||||
cancel \
|
||||
cardctl \
|
||||
ccache \
|
||||
@@ -214,7 +213,6 @@ bashcomp_DATA = a2x \
|
||||
chpasswd \
|
||||
chronyc \
|
||||
chrpath \
|
||||
- chsh \
|
||||
cksfv \
|
||||
cleanarch \
|
||||
clisp \
|
||||
@@ -236,7 +234,6 @@ bashcomp_DATA = a2x \
|
||||
desktop-file-validate \
|
||||
dhclient \
|
||||
dict \
|
||||
- dmesg \
|
||||
dnsspoof \
|
||||
dot \
|
||||
dpkg \
|
||||
@@ -247,7 +244,6 @@ bashcomp_DATA = a2x \
|
||||
dumpe2fs \
|
||||
e2freefrag \
|
||||
e2label \
|
||||
- eject \
|
||||
eog \
|
||||
ether-wake \
|
||||
evince \
|
||||
@@ -291,12 +287,10 @@ bashcomp_DATA = a2x \
|
||||
gzip \
|
||||
hcitool \
|
||||
hddtemp \
|
||||
- hexdump \
|
||||
hid2hci \
|
||||
hping2 \
|
||||
htop \
|
||||
htpasswd \
|
||||
- hwclock \
|
||||
iconv \
|
||||
id \
|
||||
idn \
|
||||
@@ -308,7 +302,6 @@ bashcomp_DATA = a2x \
|
||||
installpkg \
|
||||
interdiff \
|
||||
invoke-rc.d \
|
||||
- ionice \
|
||||
ip \
|
||||
iperf \
|
||||
ipmitool \
|
||||
@@ -348,7 +341,6 @@ bashcomp_DATA = a2x \
|
||||
list_lists \
|
||||
list_members \
|
||||
list_owners \
|
||||
- look \
|
||||
lpq \
|
||||
lpr \
|
||||
lrzip \
|
||||
@@ -396,7 +388,6 @@ bashcomp_DATA = a2x \
|
||||
nc \
|
||||
ncftp \
|
||||
nethogs \
|
||||
- newgrp \
|
||||
newlist \
|
||||
newusers \
|
||||
ngrep \
|
||||
@@ -454,7 +445,6 @@ bashcomp_DATA = a2x \
|
||||
rdesktop \
|
||||
remove_members \
|
||||
removepkg \
|
||||
- renice \
|
||||
reportbug \
|
||||
reptyr \
|
||||
resolvconf \
|
||||
@@ -469,7 +459,6 @@ bashcomp_DATA = a2x \
|
||||
rpmcheck \
|
||||
rrdtool \
|
||||
rsync \
|
||||
- rtcwake \
|
||||
sbcl \
|
||||
sbopkg \
|
||||
screen \
|
||||
@@ -491,7 +480,6 @@ bashcomp_DATA = a2x \
|
||||
sshow \
|
||||
strace \
|
||||
strings \
|
||||
- su \
|
||||
sudo \
|
||||
svcadm \
|
||||
svk \
|
||||
@@ -649,7 +637,6 @@ CLEANFILES = \
|
||||
mplayer2 \
|
||||
msgsnarf \
|
||||
muttng \
|
||||
- ncal \
|
||||
pbzip2 \
|
||||
pccardctl \
|
||||
pdlzip \
|
||||
@@ -984,10 +971,6 @@ symlinks: $(targetdir) $(DATA)
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) bzip2 $(targetdir)/$$file ; \
|
||||
done
|
||||
- for file in ncal ; do \
|
||||
- rm -f $(targetdir)/$$file && \
|
||||
- $(LN_S) cal $(targetdir)/$$file ; \
|
||||
- done
|
||||
for file in pccardctl ; do \
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) cardctl $(targetdir)/$$file ; \
|
||||
@@ -1050,10 +1033,6 @@ symlinks: $(targetdir) $(DATA)
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) hcitool $(targetdir)/$$file ; \
|
||||
done
|
||||
- for file in hd ; do \
|
||||
- rm -f $(targetdir)/$$file && \
|
||||
- $(LN_S) hexdump $(targetdir)/$$file ; \
|
||||
- done
|
||||
for file in hping hping3 ; do \
|
||||
rm -f $(targetdir)/$$file && \
|
||||
$(LN_S) hping2 $(targetdir)/$$file ; \
|
@ -5,7 +5,7 @@
|
||||
|
||||
Name: bash-completion
|
||||
Version: 2.1
|
||||
Release: 5%{?dist}
|
||||
Release: 6.20141110git52d8316%{?dist}
|
||||
Epoch: 1
|
||||
Summary: Programmable completion for Bash
|
||||
|
||||
@ -17,8 +17,8 @@ Source2: CHANGES.package.old
|
||||
Source3: %{name}-2.0-redefine_filedir.bash
|
||||
# https://bugzilla.redhat.com/677446, see also redefine_filedir source
|
||||
Patch0: %{name}-1.99-noblacklist.patch
|
||||
# Commands included in util-linux >= 2.23-rc2
|
||||
Patch1: %{name}-2.1-util-linux-223.patch
|
||||
# git diff 2.1..52d8316, removed .gitignore and runLint changes
|
||||
Patch1: bash-completion-2.1+git52d8316.patch.xz
|
||||
|
||||
BuildArch: noarch
|
||||
%if %{with tests}
|
||||
@ -26,6 +26,8 @@ BuildRequires: dejagnu
|
||||
BuildRequires: screen
|
||||
BuildRequires: tcllib
|
||||
%endif
|
||||
# For Patch1
|
||||
BuildRequires: automake
|
||||
Requires: bash >= 4.1
|
||||
|
||||
%description
|
||||
@ -36,10 +38,9 @@ of the programmable completion feature of bash.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%if 0%{?fedora} >= 19
|
||||
%patch1 -p1
|
||||
%endif
|
||||
install -pm 644 %{SOURCE2} .
|
||||
autoreconf # for patch1
|
||||
|
||||
|
||||
%build
|
||||
@ -49,18 +50,12 @@ make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
# http://anonscm.debian.org/cgit/bash-completion/bash-completion.git/commit/?id=ed07b18
|
||||
install -pm 644 completions/lz4 \
|
||||
$RPM_BUILD_ROOT%{_datadir}/bash-completion/completions
|
||||
|
||||
# Updated completion shipped in cowsay package:
|
||||
rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/{cowsay,cowthink}
|
||||
%if 0%{?fedora} < 19
|
||||
# systemd >= 198 ships this one:
|
||||
install -pm 644 completions/_udevadm \
|
||||
$RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/udevadm
|
||||
%endif
|
||||
%if 0%{?fedora} > 17
|
||||
# NetworkManager >= 0.9.8.0 ships this one:
|
||||
rm $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/nmcli
|
||||
%endif
|
||||
|
||||
install -Dpm 644 %{SOURCE3} \
|
||||
$RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/redefine_filedir
|
||||
@ -81,14 +76,23 @@ exit $result
|
||||
|
||||
|
||||
%files
|
||||
%doc AUTHORS CHANGES CHANGES.package.old COPYING README doc/bash_completion.txt
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc AUTHORS CHANGES CHANGES.package.old README doc/bash_completion.txt
|
||||
%config(noreplace) %{_sysconfdir}/profile.d/bash_completion.sh
|
||||
%{_sysconfdir}/bash_completion.d/
|
||||
%{_datadir}/bash-completion/
|
||||
%{_datadir}/cmake/
|
||||
%{_datadir}/pkgconfig/bash-completion.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 10 2014 Ville Skyttä <ville.skytta@iki.fi> - 1:2.1-6.20141110git52d8316
|
||||
- Update to current upstream git (fixes #744406, #949479, #1090481, #1015935,
|
||||
#1132959, #1135489)
|
||||
- Clean up no longer needed specfile conditionals
|
||||
- Mark COPYING as %%license where applicable
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user