Rename rfkill function to avoid conflict with util-linux >= 2.31
Resolves: #1494855
This commit is contained in:
parent
cdc5fc634b
commit
01b9c3d676
27
bash-completion-rfkill.patch
Normal file
27
bash-completion-rfkill.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
diff --git a/completions/Makefile.am b/completions/Makefile.am
|
||||||
|
--- a/completions/Makefile.am
|
||||||
|
+++ b/completions/Makefile.am
|
||||||
|
@@ -315,7 +315,7 @@ bashcomp_DATA = 2to3 \
|
||||||
|
reportbug \
|
||||||
|
_reptyr \
|
||||||
|
resolvconf \
|
||||||
|
- rfkill \
|
||||||
|
+ _rfkill \
|
||||||
|
ri \
|
||||||
|
rmlist \
|
||||||
|
rmmod \
|
||||||
|
diff --git a/completions/rfkill b/completions/_rfkill
|
||||||
|
similarity index 86%
|
||||||
|
rename from completions/rfkill
|
||||||
|
rename to completions/_rfkill
|
||||||
|
--- a/completions/rfkill
|
||||||
|
+++ b/completions/_rfkill
|
||||||
|
@@ -1,5 +1,8 @@
|
||||||
|
# bash completion for rfkill -*- shell-script -*-
|
||||||
|
|
||||||
|
+# Use of this file is deprecated on systems with util-linux >= 2.31, which
|
||||||
|
+# ships completion for the rfkill included with it.
|
||||||
|
+
|
||||||
|
_rfkill()
|
||||||
|
{
|
||||||
|
local cur prev words cword
|
@ -5,7 +5,7 @@
|
|||||||
|
|
||||||
Name: bash-completion
|
Name: bash-completion
|
||||||
Version: 2.7
|
Version: 2.7
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Summary: Programmable completion for Bash
|
Summary: Programmable completion for Bash
|
||||||
|
|
||||||
@ -14,6 +14,7 @@ URL: https://github.com/scop/bash-completion
|
|||||||
Source0: https://github.com/scop/bash-completion/releases/download/%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/scop/bash-completion/releases/download/%{version}/%{name}-%{version}.tar.xz
|
||||||
# https://bugzilla.redhat.com/677446, see also redefine_filedir comments
|
# https://bugzilla.redhat.com/677446, see also redefine_filedir comments
|
||||||
Patch0: %{name}-1.99-noblacklist.patch
|
Patch0: %{name}-1.99-noblacklist.patch
|
||||||
|
Patch1: %{name}-rfkill.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
%if %{with tests}
|
%if %{with tests}
|
||||||
@ -84,6 +85,10 @@ make -C completions check
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 09 2017 Siteshwar Vashisht <svashisht@redhat.com> - 1:2.7-2
|
||||||
|
- Rename rfkill function to avoid conflict with util-linux >= 2.31
|
||||||
|
Resolves: #1494855
|
||||||
|
|
||||||
* Thu Oct 05 2017 Siteshwar Vashisht <svashisht@redhat.com> - 1:2.7-1
|
* Thu Oct 05 2017 Siteshwar Vashisht <svashisht@redhat.com> - 1:2.7-1
|
||||||
- Update to 2.7
|
- Update to 2.7
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user