bacula/bacula-9.4.1-s3-configure.patch
2019-01-13 12:40:35 +01:00

33 lines
1.1 KiB
Diff

diff -Naur bacula-9.4.1.old/autoconf/configure.in bacula-9.4.1/autoconf/configure.in
--- bacula-9.4.1.old/autoconf/configure.in 2019-01-13 11:45:34.176106888 +0100
+++ bacula-9.4.1/autoconf/configure.in 2019-01-13 11:46:13.992832830 +0100
@@ -1887,6 +1887,20 @@
AC_CHECK_FUNC(accept4, [AC_DEFINE(HAVE_ACCEPT4, 1, [Define to 1 if you have the 'accept4' function.])])
+dnl ---------------------------------------------------
+dnl Check for S3 support/directory (default on)
+dnl ---------------------------------------------------
+dnl this allows you to turn it completely off
+
+AC_ARG_ENABLE(s3,
+ AC_HELP_STRING([--disable-s3], [disable S3 support @<:@default=yes@:>@]),
+ [
+ if test x$enableval = xno; then
+ support_s3=no
+ fi
+ ]
+)
+
S3_INC=
S3_LIBS=
S3_LDFLAGS=
@@ -3624,6 +3638,7 @@
Encryption support: ${support_crypto}
ZLIB support: ${have_zlib}
LZO support: ${have_lzo}
+ S3 support: ${have_libs3}
enable-smartalloc: ${support_smartalloc}
enable-lockmgr: ${support_lockmgr}
bat support: ${support_bat}