bacula/bacula-s3-configure.patch
2019-05-18 08:28:11 +02:00

33 lines
1.1 KiB
Diff

diff -Naur bacula-9.4.2.old/autoconf/configure.in bacula-9.4.2/autoconf/configure.in
--- bacula-9.4.2.old/autoconf/configure.in 2019-04-18 11:50:32.221553081 +0200
+++ bacula-9.4.2/autoconf/configure.in 2019-04-18 11:51:49.346938638 +0200
@@ -1894,6 +1894,20 @@
AC_CHECK_FUNC(accept4, [AC_DEFINE(HAVE_ACCEPT4, 1, [Define to 1 if you have the 'accept4' function.])])
+dnl ---------------------------------------------------
+dnl Check for S3 support/directory (default on)
+dnl ---------------------------------------------------
+dnl this allows you to turn it completely off
+
+AC_ARG_ENABLE(s3,
+ AC_HELP_STRING([--disable-s3], [disable S3 support @<:@default=yes@:>@]),
+ [
+ if test x$enableval = xno; then
+ support_s3=no
+ fi
+ ]
+)
+
S3_INC=
S3_LIBS=
S3_LDFLAGS=
@@ -3631,6 +3645,7 @@
Encryption support: ${support_crypto}
ZLIB support: ${have_zlib}
LZO support: ${have_lzo}
+ S3 support: ${have_libs3}
enable-smartalloc: ${support_smartalloc}
enable-lockmgr: ${support_lockmgr}
bat support: ${support_bat}