Fix ppc64le and tray monitor builds
This commit is contained in:
parent
f89001faae
commit
f9a2c10c29
3617
0001-Add-new-tray-monitor-files-that-were-omitted-in-the-.patch
Normal file
3617
0001-Add-new-tray-monitor-files-that-were-omitted-in-the-.patch
Normal file
File diff suppressed because it is too large
Load Diff
26
0002-Fix-bug-2293-bad-big-endian-detection-in-lz4.c.patch
Normal file
26
0002-Fix-bug-2293-bad-big-endian-detection-in-lz4.c.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 2e3e5dd3d1e7408b7e58f67a618e6579e5b7d302 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kern Sibbald <kern@sibbald.com>
|
||||||
|
Date: Mon, 10 Jul 2017 19:10:34 +0200
|
||||||
|
Subject: [PATCH 2/4] Fix bug #2293 bad big endian detection in lz4.c
|
||||||
|
|
||||||
|
---
|
||||||
|
bacula/src/lib/lz4.c | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/bacula/src/lib/lz4.c b/bacula/src/lib/lz4.c
|
||||||
|
index e04c1345c..2ffb24452 100644
|
||||||
|
--- a/bacula/src/lib/lz4.c
|
||||||
|
+++ b/bacula/src/lib/lz4.c
|
||||||
|
@@ -67,7 +67,8 @@ Note : this source file requires "lz4_encoder.h"
|
||||||
|
|| defined(__powerpc__) || defined(__ppc__) || defined(__PPC__) \
|
||||||
|
|| defined(__hpux) || defined(__hppa) \
|
||||||
|
|| defined(_MIPSEB) || defined(__s390__)
|
||||||
|
-#error "BIG Endian detected but not set"
|
||||||
|
+// KES -- the following is not a correct assumption
|
||||||
|
+//#error "BIG Endian detected but not set"
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--
|
||||||
|
2.13.0
|
||||||
|
|
34
0004-Remove-two-incorrect-trailing-commas-in-bsock.h.patch
Normal file
34
0004-Remove-two-incorrect-trailing-commas-in-bsock.h.patch
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
From 54f7bf4f627bb73bf8fdd672d6e723dfdf60d7b4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kern Sibbald <kern@sibbald.com>
|
||||||
|
Date: Mon, 10 Jul 2017 20:24:10 +0200
|
||||||
|
Subject: [PATCH 4/4] Remove two incorrect trailing commas in bsock.h
|
||||||
|
|
||||||
|
---
|
||||||
|
bacula/src/lib/bsock.h | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/bacula/src/lib/bsock.h b/bacula/src/lib/bsock.h
|
||||||
|
index e2de186b5..b18b9bcee 100644
|
||||||
|
--- a/bacula/src/lib/bsock.h
|
||||||
|
+++ b/bacula/src/lib/bsock.h
|
||||||
|
@@ -289,7 +289,7 @@ enum {
|
||||||
|
BNET_SIGNAL = -1,
|
||||||
|
BNET_HARDEOF = -2,
|
||||||
|
BNET_ERROR = -3,
|
||||||
|
- BNET_COMMAND = -4,
|
||||||
|
+ BNET_COMMAND = -4
|
||||||
|
};
|
||||||
|
|
||||||
|
/*
|
||||||
|
@@ -307,7 +307,7 @@ enum {
|
||||||
|
BNET_CMD_STO_BLOCK = 4, /* backup FD->SD FD send requested block */
|
||||||
|
BNET_CMD_REC_ACK = 5, /* restore FD->SD FD has consumed records from the buffer */
|
||||||
|
BNET_CMD_STP_THREAD = 6, /* restore FD->SD SD must stop thread */
|
||||||
|
- BNET_CMD_STP_FLOWCTRL = 7, /* backup FD->SD SD must stop sending flowcontrol information */
|
||||||
|
+ BNET_CMD_STP_FLOWCTRL = 7 /* backup FD->SD SD must stop sending flowcontrol information */
|
||||||
|
};
|
||||||
|
|
||||||
|
const char *bnet_cmd_to_name(int val);
|
||||||
|
--
|
||||||
|
2.13.0
|
||||||
|
|
26
bacula.spec
26
bacula.spec
@ -1,12 +1,9 @@
|
|||||||
%global uid 133
|
%global uid 133
|
||||||
%global username bacula
|
%global username bacula
|
||||||
|
|
||||||
# Temporarily disable tray-monitor due to missing files in the source
|
|
||||||
#global _with_tray_monitor 1
|
|
||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 9.0.0
|
Version: 9.0.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -47,6 +44,11 @@ Patch7: %{name}-9.0.0-non-free-code.patch
|
|||||||
# http://bugs.bacula.org/view.php?id=2084
|
# http://bugs.bacula.org/view.php?id=2084
|
||||||
Patch10: %{name}-7.0.4-autoconf.patch
|
Patch10: %{name}-7.0.4-autoconf.patch
|
||||||
|
|
||||||
|
# Temporary patches from upstream git
|
||||||
|
Patch11: 0001-Add-new-tray-monitor-files-that-were-omitted-in-the-.patch
|
||||||
|
Patch12: 0002-Fix-bug-2293-bad-big-endian-detection-in-lz4.c.patch
|
||||||
|
Patch13: 0004-Remove-two-incorrect-trailing-commas-in-bsock.h.patch
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -272,7 +274,6 @@ based on a client/server architecture.
|
|||||||
|
|
||||||
This package contains the bat version of the bacula management console.
|
This package contains the bat version of the bacula management console.
|
||||||
|
|
||||||
%{?_with_tray_monitor:
|
|
||||||
%package traymonitor
|
%package traymonitor
|
||||||
Summary: Bacula system tray monitor
|
Summary: Bacula system tray monitor
|
||||||
Requires: bacula-libs%{?_isa} = %{version}-%{release}
|
Requires: bacula-libs%{?_isa} = %{version}-%{release}
|
||||||
@ -285,7 +286,6 @@ based on a client/server architecture.
|
|||||||
|
|
||||||
This package contains the Gnome and KDE compatible tray monitor to monitor your
|
This package contains the Gnome and KDE compatible tray monitor to monitor your
|
||||||
bacula server.
|
bacula server.
|
||||||
}
|
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: Bacula development files
|
Summary: Bacula development files
|
||||||
@ -317,6 +317,10 @@ Provides check_bacula support for Nagios.
|
|||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
|
|
||||||
|
%patch11 -p2
|
||||||
|
%patch12 -p2
|
||||||
|
%patch13 -p2
|
||||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
# Remove execution permissions from files we're packaging as docs later on
|
# Remove execution permissions from files we're packaging as docs later on
|
||||||
@ -369,7 +373,6 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
|||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
make -C examples/nagios/check_bacula
|
make -C examples/nagios/check_bacula
|
||||||
|
|
||||||
%{?_with_tray_monitor:
|
|
||||||
pushd src/qt-console/tray-monitor
|
pushd src/qt-console/tray-monitor
|
||||||
%{?qmake_qt4}%{!?qmake_qt4:qmake-qt4} tray-monitor.pro
|
%{?qmake_qt4}%{!?qmake_qt4:qmake-qt4} tray-monitor.pro
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -378,7 +381,6 @@ popd
|
|||||||
|
|
||||||
# Convert image to png for tray monitor icon
|
# Convert image to png for tray monitor icon
|
||||||
convert %{SOURCE19} bacula-tray-monitor.png
|
convert %{SOURCE19} bacula-tray-monitor.png
|
||||||
}
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%make_install
|
%make_install
|
||||||
@ -398,14 +400,12 @@ desktop-file-install \
|
|||||||
--set-key=Categories --set-value="Utility" \
|
--set-key=Categories --set-value="Utility" \
|
||||||
scripts/bat.desktop
|
scripts/bat.desktop
|
||||||
|
|
||||||
%{?_with_tray_monitor:
|
|
||||||
# QT Tray monitor
|
# QT Tray monitor
|
||||||
install -p -m 755 -D src/qt-console/tray-monitor/bacula-tray-monitor %{buildroot}%{_sbindir}/bacula-tray-monitor
|
install -p -m 755 -D src/qt-console/tray-monitor/bacula-tray-monitor %{buildroot}%{_sbindir}/bacula-tray-monitor
|
||||||
install -p -m 644 -D src/qt-console/tray-monitor/tray-monitor.conf %{buildroot}%{_sysconfdir}/bacula/tray-monitor.conf
|
install -p -m 644 -D src/qt-console/tray-monitor/tray-monitor.conf %{buildroot}%{_sysconfdir}/bacula/tray-monitor.conf
|
||||||
install -p -m 644 -D manpages/bacula-tray-monitor.1 %{buildroot}%{_mandir}/man1/bacula-tray-monitor.1
|
install -p -m 644 -D manpages/bacula-tray-monitor.1 %{buildroot}%{_mandir}/man1/bacula-tray-monitor.1
|
||||||
install -p -m 644 -D bacula-tray-monitor.png %{buildroot}%{_datadir}/pixmaps/bacula-tray-monitor.png
|
install -p -m 644 -D bacula-tray-monitor.png %{buildroot}%{_datadir}/pixmaps/bacula-tray-monitor.png
|
||||||
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE14}
|
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE14}
|
||||||
}
|
|
||||||
|
|
||||||
# Logrotate
|
# Logrotate
|
||||||
mkdir -p %{buildroot}%{_localstatedir}/log/bacula
|
mkdir -p %{buildroot}%{_localstatedir}/log/bacula
|
||||||
@ -709,14 +709,12 @@ fi
|
|||||||
%{_mandir}/man1/bat.1*
|
%{_mandir}/man1/bat.1*
|
||||||
%{_sbindir}/bat
|
%{_sbindir}/bat
|
||||||
|
|
||||||
%{?_with_tray_monitor:
|
|
||||||
%files traymonitor
|
%files traymonitor
|
||||||
%config(noreplace) %{_sysconfdir}/bacula/tray-monitor.conf %attr(640,root,root)
|
%config(noreplace) %{_sysconfdir}/bacula/tray-monitor.conf %attr(640,root,root)
|
||||||
%{_datadir}/applications/bacula-traymonitor.desktop
|
%{_datadir}/applications/bacula-traymonitor.desktop
|
||||||
%{_datadir}/pixmaps/bacula-tray-monitor.png
|
%{_datadir}/pixmaps/bacula-tray-monitor.png
|
||||||
%{_mandir}/man1/bacula-tray-monitor.1*
|
%{_mandir}/man1/bacula-tray-monitor.1*
|
||||||
%{_sbindir}/bacula-tray-monitor
|
%{_sbindir}/bacula-tray-monitor
|
||||||
}
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/bacula
|
%{_includedir}/bacula
|
||||||
@ -730,6 +728,10 @@ fi
|
|||||||
%{_libdir}/nagios/plugins/check_bacula
|
%{_libdir}/nagios/plugins/check_bacula
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 11 2017 Simone Caronni <negativo17@gmail.com> - 9.0.0-2
|
||||||
|
- Fix ppc64le build.
|
||||||
|
- Fix tray-monitor build.
|
||||||
|
|
||||||
* Mon Jul 10 2017 Simone Caronni <negativo17@gmail.com> - 9.0.0-1
|
* Mon Jul 10 2017 Simone Caronni <negativo17@gmail.com> - 9.0.0-1
|
||||||
- Update to 9.0.0, update all patches.
|
- Update to 9.0.0, update all patches.
|
||||||
- Add new utitilies.
|
- Add new utitilies.
|
||||||
|
Loading…
Reference in New Issue
Block a user