Update to 7.0.2.

This commit is contained in:
Simone Caronni 2014-04-03 09:17:28 +02:00
parent 457a0b7583
commit e47e3f5024
3 changed files with 11 additions and 77 deletions

View File

@ -1,68 +0,0 @@
diff -Naur bacula-7.0.1/examples/nagios/check_bacula/authenticate.c bacula-7.0.1.new/examples/nagios/check_bacula/authenticate.c
--- bacula-7.0.1/examples/nagios/check_bacula/authenticate.c 2014-03-31 20:51:34.000000000 +0200
+++ bacula-7.0.1.new/examples/nagios/check_bacula/authenticate.c 2014-04-01 16:45:15.315588066 +0200
@@ -50,12 +50,14 @@
/* Response from Director */
static char DIROKhello[] = "1000 OK:";
-/* Commands sent to Storage daemon and File daemon and received
- * from the User Agent */
-static char SDFDhello[] = "Hello Director %s calling\n";
+/* Commands sent to Storage daemon */
+static char SDhello[] = "Hello SD: Bacula Director %s calling\n";
+
+/* Commands sent to File daemon */
+static char FDhello[] = "Hello Director %s calling\n";
/* Response from SD */
-static char SDOKhello[] = "3000 OK Hello\n";
+static char SDOKhello[] = "3000 OK Hello";
/* Response from FD */
static char FDOKhello[] = "2000 OK Hello";
@@ -114,7 +116,7 @@
bash_spaces(dirname);
/* Timeout Hello after 5 mins */
btimer_t *tid = start_bsock_timer(sd, 60 * 5);
- if (!sd->fsend(SDFDhello, dirname)) {
+ if (!sd->fsend(SDhello, dirname)) {
stop_bsock_timer(tid);
return 0;
}
@@ -130,7 +132,7 @@
}
Dmsg1(110, "<stored: %s", sd->msg);
stop_bsock_timer(tid);
- if (strncmp(sd->msg, SDOKhello, sizeof(SDOKhello)) != 0) {
+ if (strncmp(sd->msg, SDOKhello, strlen(SDOKhello)) != 0) {
return 0;
}
return 1;
@@ -153,7 +155,7 @@
bash_spaces(dirname);
/* Timeout Hello after 5 mins */
btimer_t *tid = start_bsock_timer(fd, 60 * 5);
- if (!fd->fsend(SDFDhello, dirname)) {
+ if (!fd->fsend(FDhello, dirname)) {
stop_bsock_timer(tid);
return 0;
}
diff -Naur bacula-7.0.1/examples/nagios/check_bacula/Makefile.in bacula-7.0.1.new/examples/nagios/check_bacula/Makefile.in
--- bacula-7.0.1/examples/nagios/check_bacula/Makefile.in 2014-03-31 20:51:34.000000000 +0200
+++ bacula-7.0.1.new/examples/nagios/check_bacula/Makefile.in 2014-04-01 16:46:12.364115625 +0200
@@ -70,7 +70,7 @@
(cd $(srcdir); $(RMF) Makefile)
install: all
- $(INSTALL_PROGRAM) check_bacula $(DESTDIR)$(sbindir)/check_bacula
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) check_bacula $(DESTDIR)$(sbindir)/check_bacula
uninstall:
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
diff -Naur bacula-7.0.1/examples/nagios/check_bacula/makeit bacula-7.0.1.new/examples/nagios/check_bacula/makeit
--- bacula-7.0.1/examples/nagios/check_bacula/makeit 2014-03-31 20:51:34.000000000 +0200
+++ bacula-7.0.1.new/examples/nagios/check_bacula/makeit 1970-01-01 01:00:00.000000000 +0100
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-make LIBS="-lpthread -ldl -lssl -lcrypto -lz"

View File

@ -1,6 +1,7 @@
--- bacula-7.0.0.old/configure 2014-03-29 10:00:03.000000000 +0100 diff -Naur bacula-7.0.2.old/configure bacula-7.0.2/configure
+++ bacula-7.0.0/configure 2014-03-30 12:10:44.275522112 +0200 --- bacula-7.0.2.old/configure 2014-04-03 09:14:50.713286953 +0200
@@ -30888,7 +30888,7 @@ +++ bacula-7.0.2/configure 2014-04-03 09:14:59.093210079 +0200
@@ -30680,7 +30680,7 @@
exit 1 exit 1
fi fi
@ -9,7 +10,7 @@
ac_config_commands="$ac_config_commands default" ac_config_commands="$ac_config_commands default"
@@ -32021,6 +32021,8 @@ @@ -31813,6 +31813,8 @@
"src/qt-console/bat.pro") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro" ;; "src/qt-console/bat.pro") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro" ;;
"src/qt-console/bat.pro.mingw32") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro.mingw32" ;; "src/qt-console/bat.pro.mingw32") CONFIG_FILES="$CONFIG_FILES src/qt-console/bat.pro.mingw32" ;;
"src/qt-console/install_conf_file") CONFIG_FILES="$CONFIG_FILES src/qt-console/install_conf_file" ;; "src/qt-console/install_conf_file") CONFIG_FILES="$CONFIG_FILES src/qt-console/install_conf_file" ;;

View File

@ -2,8 +2,8 @@
%global username bacula %global username bacula
Name: bacula Name: bacula
Version: 7.0.1 Version: 7.0.2
Release: 2%{?dist} Release: 1%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details # See LICENSE for details
License: AGPLv3 with exceptions License: AGPLv3 with exceptions
@ -38,8 +38,7 @@ Patch4: %{name}-5.2.13-bat-build.patch
Patch5: %{name}-5.2.12-seg-fault.patch Patch5: %{name}-5.2.12-seg-fault.patch
Patch6: %{name}-5.2.13-logwatch.patch Patch6: %{name}-5.2.13-logwatch.patch
Patch7: %{name}-non-free-code.patch Patch7: %{name}-non-free-code.patch
Patch8: %{name}-7.0.0-configure.patch Patch8: %{name}-7.0.2-configure.patch
Patch9: %{name}-7.0.1-fix-nagios.patch
BuildRequires: desktop-file-utils BuildRequires: desktop-file-utils
BuildRequires: perl BuildRequires: perl
@ -303,7 +302,6 @@ Provides check_bacula support for Nagios.
%patch6 -p1 %patch6 -p1
%patch7 -p1 %patch7 -p1
%patch8 -p1 %patch8 -p1
%patch9 -p1
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} . cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
# Remove execution permissions from files we're packaging as docs later on # Remove execution permissions from files we're packaging as docs later on
@ -737,6 +735,9 @@ fi
%{_libdir}/nagios/plugins/check_bacula %{_libdir}/nagios/plugins/check_bacula
%changelog %changelog
* Thu Apr 03 2014 Simone Caronni <negativo17@gmail.com> - 7.0.2-1
- Update to 7.0.2, drop upstreamed patches.
* Tue Apr 01 2014 Simone Caronni <negativo17@gmail.com> - 7.0.1-2 * Tue Apr 01 2014 Simone Caronni <negativo17@gmail.com> - 7.0.1-2
- Add patch for Nagios plugin. - Add patch for Nagios plugin.
- Add missing requirement for Nagios plugin folder. - Add missing requirement for Nagios plugin folder.