Update to 9.0.1
This commit is contained in:
parent
0c89566871
commit
e39a29ebc6
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-7.4.6.tar.gz
|
||||
/bacula-7.4.7.tar.gz
|
||||
/bacula-9.0.0.tar.gz
|
||||
/bacula-9.0.1.tar.gz
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,26 +0,0 @@
|
||||
From 2e3e5dd3d1e7408b7e58f67a618e6579e5b7d302 Mon Sep 17 00:00:00 2001
|
||||
From: Kern Sibbald <kern@sibbald.com>
|
||||
Date: Mon, 10 Jul 2017 19:10:34 +0200
|
||||
Subject: [PATCH 2/4] Fix bug #2293 bad big endian detection in lz4.c
|
||||
|
||||
---
|
||||
bacula/src/lib/lz4.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/bacula/src/lib/lz4.c b/bacula/src/lib/lz4.c
|
||||
index e04c1345c..2ffb24452 100644
|
||||
--- a/bacula/src/lib/lz4.c
|
||||
+++ b/bacula/src/lib/lz4.c
|
||||
@@ -67,7 +67,8 @@ Note : this source file requires "lz4_encoder.h"
|
||||
|| defined(__powerpc__) || defined(__ppc__) || defined(__PPC__) \
|
||||
|| defined(__hpux) || defined(__hppa) \
|
||||
|| defined(_MIPSEB) || defined(__s390__)
|
||||
-#error "BIG Endian detected but not set"
|
||||
+// KES -- the following is not a correct assumption
|
||||
+//#error "BIG Endian detected but not set"
|
||||
#endif
|
||||
#endif
|
||||
|
||||
--
|
||||
2.13.0
|
||||
|
@ -1,34 +0,0 @@
|
||||
From 54f7bf4f627bb73bf8fdd672d6e723dfdf60d7b4 Mon Sep 17 00:00:00 2001
|
||||
From: Kern Sibbald <kern@sibbald.com>
|
||||
Date: Mon, 10 Jul 2017 20:24:10 +0200
|
||||
Subject: [PATCH 4/4] Remove two incorrect trailing commas in bsock.h
|
||||
|
||||
---
|
||||
bacula/src/lib/bsock.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/bacula/src/lib/bsock.h b/bacula/src/lib/bsock.h
|
||||
index e2de186b5..b18b9bcee 100644
|
||||
--- a/bacula/src/lib/bsock.h
|
||||
+++ b/bacula/src/lib/bsock.h
|
||||
@@ -289,7 +289,7 @@ enum {
|
||||
BNET_SIGNAL = -1,
|
||||
BNET_HARDEOF = -2,
|
||||
BNET_ERROR = -3,
|
||||
- BNET_COMMAND = -4,
|
||||
+ BNET_COMMAND = -4
|
||||
};
|
||||
|
||||
/*
|
||||
@@ -307,7 +307,7 @@ enum {
|
||||
BNET_CMD_STO_BLOCK = 4, /* backup FD->SD FD send requested block */
|
||||
BNET_CMD_REC_ACK = 5, /* restore FD->SD FD has consumed records from the buffer */
|
||||
BNET_CMD_STP_THREAD = 6, /* restore FD->SD SD must stop thread */
|
||||
- BNET_CMD_STP_FLOWCTRL = 7, /* backup FD->SD SD must stop sending flowcontrol information */
|
||||
+ BNET_CMD_STP_FLOWCTRL = 7 /* backup FD->SD SD must stop sending flowcontrol information */
|
||||
};
|
||||
|
||||
const char *bnet_cmd_to_name(int val);
|
||||
--
|
||||
2.13.0
|
||||
|
15
bacula.spec
15
bacula.spec
@ -2,8 +2,8 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 9.0.0
|
||||
Release: 2%{?dist}
|
||||
Version: 9.0.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -44,11 +44,6 @@ Patch8: %{name}-9.0.0-tray-monitor-desktop.patch
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch10: %{name}-7.0.4-autoconf.patch
|
||||
|
||||
# Temporary patches from upstream git
|
||||
Patch11: 0001-Add-new-tray-monitor-files-that-were-omitted-in-the-.patch
|
||||
Patch12: 0002-Fix-bug-2293-bad-big-endian-detection-in-lz4.c.patch
|
||||
Patch13: 0004-Remove-two-incorrect-trailing-commas-in-bsock.h.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl-generators
|
||||
@ -320,9 +315,6 @@ Provides check_bacula support for Nagios.
|
||||
|
||||
%patch10 -p1
|
||||
|
||||
%patch11 -p2
|
||||
%patch12 -p2
|
||||
%patch13 -p2
|
||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||
|
||||
# Remove execution permissions from files we're packaging as docs later on
|
||||
@ -735,6 +727,9 @@ fi
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Tue Jul 18 2017 Simone Caronni <negativo17@gmail.com> - 9.0.1-1
|
||||
- Update to 9.0.1.
|
||||
|
||||
* Tue Jul 11 2017 Simone Caronni <negativo17@gmail.com> - 9.0.0-2
|
||||
- Fix ppc64le build.
|
||||
- Fix tray-monitor build. Use source file for tray monitor desktop entry.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-9.0.0.tar.gz) = 2ca4bd763dcb9cf7b6411302b55757c52820b8598683ef664f4eee2d1acfd55718906b17be8f8f093f33f173469a6221635b244248c8eedd5bd0dc477b21d5af
|
||||
SHA512 (bacula-9.0.1.tar.gz) = c189a2f7d6318c1e9b1fee6e15d7fb1dfa09782a8f56201660c3baec74f1ba29d8048752fc81bde5039e0139440e611503ceaead6359eb4b36ed06336db0939a
|
||||
|
Loading…
Reference in New Issue
Block a user