Update queryfile patch
This commit is contained in:
parent
2354547b11
commit
c68f414e66
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-7.0.0.old/src/dird/bacula-dir.conf.in bacula-7.0.0/src/dird/bacula-dir.conf.in
|
||||
--- bacula-7.0.0.old/src/dird/bacula-dir.conf.in 2014-03-29 10:00:03.000000000 +0100
|
||||
+++ bacula-7.0.0/src/dird/bacula-dir.conf.in 2014-03-30 11:21:16.293167507 +0200
|
||||
+++ bacula-7.0.0/src/dird/bacula-dir.conf.in 2014-03-31 09:59:31.629996491 +0200
|
||||
@@ -15,7 +15,7 @@
|
||||
Director { # define myself
|
||||
Name = @basename@-dir
|
||||
@ -10,3 +10,30 @@ diff -Naur bacula-7.0.0.old/src/dird/bacula-dir.conf.in bacula-7.0.0/src/dird/ba
|
||||
WorkingDirectory = "@working_dir@"
|
||||
PidDirectory = "@piddir@"
|
||||
Maximum Concurrent Jobs = 20
|
||||
diff -Naur bacula-7.0.0.old/src/dird/Makefile.in bacula-7.0.0/src/dird/Makefile.in
|
||||
--- bacula-7.0.0.old/src/dird/Makefile.in 2014-03-29 10:00:03.000000000 +0100
|
||||
+++ bacula-7.0.0/src/dird/Makefile.in 2014-03-31 10:00:34.017663662 +0200
|
||||
@@ -112,11 +112,11 @@
|
||||
@if test "x${dir_group}" != "x"; then \
|
||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||
fi
|
||||
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
||||
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
||||
echo " ==> Saving existing query.sql to query.sql.old"; \
|
||||
- $(MV) -f ${DESTDIR}${scriptdir}/query.sql ${DESTDIR}${scriptdir}/query.sql.old; \
|
||||
+ $(MV) -f ${DESTDIR}${sysconfdir}/query.sql ${DESTDIR}${sysconfdir}/query.sql.old; \
|
||||
fi
|
||||
- ${INSTALL_DATA} query.sql ${DESTDIR}${scriptdir}/query.sql
|
||||
+ ${INSTALL_DATA} query.sql ${DESTDIR}${sysconfdir}/query.sql
|
||||
@if test -f static-bacula-dir; then \
|
||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
||||
fi
|
||||
@@ -125,7 +125,7 @@
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir
|
||||
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
||||
- (cd $(DESTDIR)$(scriptdir); $(RMF) query.sql)
|
||||
+ (cd $(DESTDIR)$(sysconfdir); $(RMF) query.sql)
|
||||
|
||||
|
||||
|
||||
|
@ -386,9 +386,6 @@ install -p -m 755 -D examples/nagios/check_bacula/.libs/check_bacula %{buildroot
|
||||
rm -f %{buildroot}%{_libdir}/libbaccats.so
|
||||
rm -f %{buildroot}%{_libdir}/libbaccats-%{version}.so
|
||||
|
||||
# Sample query file
|
||||
mv %{buildroot}%{_libexecdir}/bacula/query.sql %{buildroot}%{_sysconfdir}/bacula/query.sql
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 6
|
||||
# Bat
|
||||
install -p -m 644 -D src/qt-console/images/bat_icon.png %{buildroot}%{_datadir}/pixmaps/bat.png
|
||||
|
Loading…
Reference in New Issue
Block a user