Update to 7.4.5
This commit is contained in:
parent
6e528fb3f1
commit
b829d29125
@ -1,13 +0,0 @@
|
|||||||
--- a/src/lib/edit.c
|
|
||||||
+++ b/src/lib/edit.c
|
|
||||||
@@ -350,8 +350,8 @@ static bool strunit_to_uint64(char *str, int str_len, uint64_t *value,
|
|
||||||
1000000, /* mb megabyte */
|
|
||||||
1073741824, /* gigabyte */
|
|
||||||
1000000000, /* gb gigabyte */
|
|
||||||
- 1099511627776, /* terabyte */
|
|
||||||
- 1000000000000}; /* tb terabyte */
|
|
||||||
+ 1099511627776LL, /* terabyte */
|
|
||||||
+ 1000000000000LL}; /* tb terabyte */
|
|
||||||
|
|
||||||
if (!get_modifier(str, num_str, sizeof(num_str), mod_str, sizeof(mod_str))) {
|
|
||||||
return 0;
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur bacula-7.2.0.old/src/lib/lib.h bacula-7.2.0.new/src/lib/lib.h
|
diff -Naur bacula-7.4.5.old/src/lib/lib.h bacula-7.4.5/src/lib/lib.h
|
||||||
--- bacula-7.2.0.old/src/lib/lib.h 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.5.old/src/lib/lib.h 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.2.0.new/src/lib/lib.h 2015-09-29 10:35:11.720417548 +0200
|
+++ bacula-7.4.5/src/lib/lib.h 2017-02-08 14:26:11.069966406 +0100
|
||||||
@@ -51,7 +51,6 @@
|
@@ -50,7 +50,6 @@
|
||||||
#include "fnmatch.h"
|
#include "fnmatch.h"
|
||||||
#endif
|
#endif
|
||||||
#include "md5.h"
|
#include "md5.h"
|
||||||
@ -9,9 +9,9 @@ diff -Naur bacula-7.2.0.old/src/lib/lib.h bacula-7.2.0.new/src/lib/lib.h
|
|||||||
#include "tree.h"
|
#include "tree.h"
|
||||||
#include "watchdog.h"
|
#include "watchdog.h"
|
||||||
#include "btimers.h"
|
#include "btimers.h"
|
||||||
diff -Naur bacula-7.2.0.old/src/lib/Makefile.in bacula-7.2.0.new/src/lib/Makefile.in
|
diff -Naur bacula-7.4.5.old/src/lib/Makefile.in bacula-7.4.5/src/lib/Makefile.in
|
||||||
--- bacula-7.2.0.old/src/lib/Makefile.in 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.5.old/src/lib/Makefile.in 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.2.0.new/src/lib/Makefile.in 2015-09-29 10:35:34.896034387 +0200
|
+++ bacula-7.4.5/src/lib/Makefile.in 2017-02-08 14:26:11.070966423 +0100
|
||||||
@@ -38,7 +38,7 @@
|
@@ -38,7 +38,7 @@
|
||||||
fnmatch.h guid_to_name.h htable.h lex.h \
|
fnmatch.h guid_to_name.h htable.h lex.h \
|
||||||
lib.h md5.h mem_pool.h message.h \
|
lib.h md5.h mem_pool.h message.h \
|
||||||
@ -53,9 +53,9 @@ diff -Naur bacula-7.2.0.old/src/lib/Makefile.in bacula-7.2.0.new/src/lib/Makefil
|
|||||||
|
|
||||||
realclean: clean
|
realclean: clean
|
||||||
@$(RMF) tags
|
@$(RMF) tags
|
||||||
diff -Naur bacula-7.2.0.old/src/lib/sha1.c bacula-7.2.0.new/src/lib/sha1.c
|
diff -Naur bacula-7.4.5.old/src/lib/sha1.c bacula-7.4.5/src/lib/sha1.c
|
||||||
--- bacula-7.2.0.old/src/lib/sha1.c 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.5.old/src/lib/sha1.c 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.2.0.new/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
+++ bacula-7.4.5/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
@@ -1,510 +0,0 @@
|
@@ -1,510 +0,0 @@
|
||||||
-/*
|
-/*
|
||||||
- * sha1.c
|
- * sha1.c
|
||||||
@ -567,9 +567,9 @@ diff -Naur bacula-7.2.0.old/src/lib/sha1.c bacula-7.2.0.new/src/lib/sha1.c
|
|||||||
- fclose(fd);
|
- fclose(fd);
|
||||||
-}
|
-}
|
||||||
-#endif
|
-#endif
|
||||||
diff -Naur bacula-7.2.0.old/src/lib/sha1.h bacula-7.2.0.new/src/lib/sha1.h
|
diff -Naur bacula-7.4.5.old/src/lib/sha1.h bacula-7.4.5/src/lib/sha1.h
|
||||||
--- bacula-7.2.0.old/src/lib/sha1.h 2015-08-13 15:52:24.000000000 +0200
|
--- bacula-7.4.5.old/src/lib/sha1.h 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.2.0.new/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
+++ bacula-7.4.5/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||||
@@ -1,107 +0,0 @@
|
@@ -1,107 +0,0 @@
|
||||||
-/*
|
-/*
|
||||||
- * sha1.h
|
- * sha1.h
|
@ -1,6 +1,6 @@
|
|||||||
diff -Naur bacula-7.4.0.old/src/dird/bacula-dir.conf.in bacula-7.4.0/src/dird/bacula-dir.conf.in
|
diff -Naur bacula-7.4.5.old/src/dird/bacula-dir.conf.in bacula-7.4.5/src/dird/bacula-dir.conf.in
|
||||||
--- bacula-7.4.0.old/src/dird/bacula-dir.conf.in 2016-01-25 21:00:14.020670323 +0100
|
--- bacula-7.4.5.old/src/dird/bacula-dir.conf.in 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.4.0/src/dird/bacula-dir.conf.in 2016-01-25 21:01:40.449132870 +0100
|
+++ bacula-7.4.5/src/dird/bacula-dir.conf.in 2017-02-08 14:23:08.468849148 +0100
|
||||||
@@ -18,7 +18,7 @@
|
@@ -18,7 +18,7 @@
|
||||||
Director { # define myself
|
Director { # define myself
|
||||||
Name = @basename@-dir
|
Name = @basename@-dir
|
||||||
@ -10,10 +10,10 @@ diff -Naur bacula-7.4.0.old/src/dird/bacula-dir.conf.in bacula-7.4.0/src/dird/ba
|
|||||||
WorkingDirectory = "@working_dir@"
|
WorkingDirectory = "@working_dir@"
|
||||||
PidDirectory = "@piddir@"
|
PidDirectory = "@piddir@"
|
||||||
Maximum Concurrent Jobs = 20
|
Maximum Concurrent Jobs = 20
|
||||||
diff -Naur bacula-7.4.0.old/src/dird/Makefile.in bacula-7.4.0/src/dird/Makefile.in
|
diff -Naur bacula-7.4.5.old/src/dird/Makefile.in bacula-7.4.5/src/dird/Makefile.in
|
||||||
--- bacula-7.4.0.old/src/dird/Makefile.in 2016-01-25 21:00:14.020670323 +0100
|
--- bacula-7.4.5.old/src/dird/Makefile.in 2017-02-07 15:07:45.000000000 +0100
|
||||||
+++ bacula-7.4.0/src/dird/Makefile.in 2016-01-25 21:01:40.449132870 +0100
|
+++ bacula-7.4.5/src/dird/Makefile.in 2017-02-08 14:23:08.469849165 +0100
|
||||||
@@ -113,11 +113,11 @@
|
@@ -114,11 +114,11 @@
|
||||||
@if test "x${dir_group}" != "x"; then \
|
@if test "x${dir_group}" != "x"; then \
|
||||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||||
fi
|
fi
|
||||||
@ -28,7 +28,7 @@ diff -Naur bacula-7.4.0.old/src/dird/Makefile.in bacula-7.4.0/src/dird/Makefile.
|
|||||||
@if test -f static-bacula-dir; then \
|
@if test -f static-bacula-dir; then \
|
||||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
||||||
fi
|
fi
|
||||||
@@ -125,7 +125,7 @@
|
@@ -126,7 +126,7 @@
|
||||||
|
|
||||||
uninstall:
|
uninstall:
|
||||||
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
@ -34,13 +34,12 @@ Source18: %{name}-sd.sysconfig.el5
|
|||||||
Source19: generic.xpm
|
Source19: generic.xpm
|
||||||
|
|
||||||
Patch1: %{name}-7.4.0-openssl.patch
|
Patch1: %{name}-7.4.0-openssl.patch
|
||||||
Patch2: %{name}-7.4.0-queryfile.patch
|
Patch2: %{name}-7.4.5-queryfile.patch
|
||||||
Patch3: %{name}-7.4.0-sqlite-priv.patch
|
Patch3: %{name}-7.4.0-sqlite-priv.patch
|
||||||
Patch4: %{name}-7.4.0-bat-build.patch
|
Patch4: %{name}-7.4.0-bat-build.patch
|
||||||
Patch5: %{name}-7.4.0-seg-fault.patch
|
Patch5: %{name}-7.4.0-seg-fault.patch
|
||||||
Patch6: %{name}-5.2.13-logwatch.patch
|
Patch6: %{name}-5.2.13-logwatch.patch
|
||||||
Patch7: %{name}-7.2.0-non-free-code.patch
|
Patch7: %{name}-7.4.5-non-free-code.patch
|
||||||
#Patch8: %{name}-7.4.3-fix-el5-build.patch
|
|
||||||
|
|
||||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||||
@ -332,7 +331,6 @@ Provides check_bacula support for Nagios.
|
|||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
%patch6 -p1
|
%patch6 -p1
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
#%patch8 -p1
|
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
@ -776,6 +774,7 @@ fi
|
|||||||
%changelog
|
%changelog
|
||||||
* Wed Feb 08 2017 Simone Caronni <negativo17@gmail.com> - 7.4.5-1
|
* Wed Feb 08 2017 Simone Caronni <negativo17@gmail.com> - 7.4.5-1
|
||||||
- Update to 7.4.5.
|
- Update to 7.4.5.
|
||||||
|
- Update patches.
|
||||||
|
|
||||||
* Fri Jan 13 2017 Jon Ciesla <limburgher@gmail.com> - 7.4.4-3
|
* Fri Jan 13 2017 Jon Ciesla <limburgher@gmail.com> - 7.4.4-3
|
||||||
- Move to compat-openssl10 to fix FTBFS, BZ 1412924.
|
- Move to compat-openssl10 to fix FTBFS, BZ 1412924.
|
||||||
|
Loading…
Reference in New Issue
Block a user