Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/bacula.git#611188996a7a4a233eaac53f6f2be1d13db9843b
This commit is contained in:
parent
0a840e1326
commit
a6a1b25fa9
1
.gitignore
vendored
1
.gitignore
vendored
@ -52,3 +52,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-9.6.5.tar.gz
|
||||
/bacula-9.6.6.tar.gz
|
||||
/bacula-9.6.7.tar.gz
|
||||
/bacula-11.0.0.tar.gz
|
||||
|
@ -1,19 +1,15 @@
|
||||
======== Features
|
||||
|
||||
- Standard components: director, storage, client, docs, bconsole.
|
||||
- Graphical components: bat, bacula-tray-monitor (where supported).
|
||||
- Graphical components: bat, bacula-tray-monitor.
|
||||
- Tab completion for bconsole.
|
||||
- Nagios plugin.
|
||||
- HTML/PDF docs.
|
||||
- Quick start guides.
|
||||
- File Daemon bpipe-fd plugin.
|
||||
- POSIX.1e capabilities for File Daemon.
|
||||
- Systemd for Fedora and RHEL 7+.
|
||||
- SysV init scripts for RHEL 5/6.
|
||||
- GZIP/LZO compression.
|
||||
- Static uid/gid of 133 (see "setup" package).
|
||||
- No usermode / fedora-usermgmt stuff in the console packages.
|
||||
- Docs no longer an arch specific subpackage.
|
||||
- SQL libraries needed only by Director and Storage daemons.
|
||||
- SQL backend management through the alternatives system.
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-9.0.6.old/src/qt-console/bat.pro.in bacula-9.0.6/src/qt-console/bat.pro.in
|
||||
--- bacula-9.0.6.old/src/qt-console/bat.pro.in 2017-12-07 15:44:44.737173178 +0100
|
||||
+++ bacula-9.0.6/src/qt-console/bat.pro.in 2017-12-07 15:44:55.118366334 +0100
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/bat.pro.in bacula-11.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-11.0.0.old/src/qt-console/bat.pro.in 2021-01-12 12:36:32.639470258 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/bat.pro.in 2021-01-12 12:39:13.647417778 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
#
|
||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
@ -8,8 +8,8 @@ diff -Naur bacula-9.0.6.old/src/qt-console/bat.pro.in bacula-9.0.6/src/qt-consol
|
||||
-CONFIG += qt debug @QWT@
|
||||
+CONFIG += qt release @QWT@
|
||||
|
||||
|
||||
greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
|
||||
|
||||
@@ -15,7 +15,7 @@
|
||||
bins.files = bat
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
@ -18,10 +18,10 @@ diff -Naur bacula-9.0.6.old/src/qt-console/bat.pro.in bacula-9.0.6/src/qt-consol
|
||||
+help.path = /$(DESTDIR)@htmldir@
|
||||
help.files = help/*.html images/status.png images/mail-message-new.png
|
||||
|
||||
datarootdir = @datarootdir@
|
||||
diff -Naur bacula-9.0.6.old/src/qt-console/main.cpp bacula-9.0.6/src/qt-console/main.cpp
|
||||
--- bacula-9.0.6.old/src/qt-console/main.cpp 2017-12-07 15:44:44.742173271 +0100
|
||||
+++ bacula-9.0.6/src/qt-console/main.cpp 2017-12-07 15:44:55.119366353 +0100
|
||||
TEMPLATE = app
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/main.cpp bacula-11.0.0/src/qt-console/main.cpp
|
||||
--- bacula-11.0.0.old/src/qt-console/main.cpp 2021-01-12 12:36:32.640470277 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/main.cpp 2021-01-12 12:39:13.647417778 +0100
|
||||
@@ -29,11 +29,11 @@
|
||||
#include <QTranslator>
|
||||
|
||||
|
29
bacula-docker-plugin.patch
Normal file
29
bacula-docker-plugin.patch
Normal file
@ -0,0 +1,29 @@
|
||||
diff -Naur bacula-11.0.0.old/autoconf/configure.in bacula-11.0.0/autoconf/configure.in
|
||||
--- bacula-11.0.0.old/autoconf/configure.in 2021-01-12 12:54:46.373504805 +0100
|
||||
+++ bacula-11.0.0/autoconf/configure.in 2021-01-12 12:57:21.990356810 +0100
|
||||
@@ -3237,20 +3237,11 @@
|
||||
]
|
||||
)
|
||||
if test x$support_docker = xyes -o x$support_docker = xauto; then
|
||||
- AC_CHECK_PROG(docker_bin, docker, yes, no, "/usr/bin/")
|
||||
- if test x$docker_bin = xyes; then
|
||||
- support_docker=yes
|
||||
- FD_PLUGIN_DIR="$FD_PLUGIN_DIR src/plugins/fd/docker"
|
||||
- PLUGCONFILES="${PLUGCONFILES} src/plugins/fd/docker/Makefile"
|
||||
- else
|
||||
- if test x$support_docker = xyes; then
|
||||
- echo " "
|
||||
- echo "You enabled a Docker Plugin build but 'docker' command not found."
|
||||
- echo " "
|
||||
- exit 1
|
||||
- fi
|
||||
- support_docker=no
|
||||
- fi
|
||||
+ support_docker=yes
|
||||
+ FD_PLUGIN_DIR="$FD_PLUGIN_DIR src/plugins/fd/docker"
|
||||
+ PLUGCONFILES="${PLUGCONFILES} src/plugins/fd/docker/Makefile"
|
||||
+else
|
||||
+ support_docker=no
|
||||
fi
|
||||
|
||||
AC_SUBST(FD_PLUGIN_DIR)
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-9.6.5.old/autoconf/configure.in bacula-9.6.5/autoconf/configure.in
|
||||
--- bacula-9.6.5.old/autoconf/configure.in 2020-07-24 09:11:40.890118308 +0200
|
||||
+++ bacula-9.6.5/autoconf/configure.in 2020-07-24 09:18:37.263451673 +0200
|
||||
@@ -3088,11 +3088,6 @@
|
||||
diff -Naur bacula-11.0.0.old/autoconf/configure.in bacula-11.0.0/autoconf/configure.in
|
||||
--- bacula-11.0.0.old/autoconf/configure.in 2021-01-12 12:36:32.689471174 +0100
|
||||
+++ bacula-11.0.0/autoconf/configure.in 2021-01-12 12:42:02.619511095 +0100
|
||||
@@ -3271,11 +3271,6 @@
|
||||
AC_DEFINE(FDLIBS)
|
||||
|
||||
CFLAGS=${CFLAGS--O}
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -Naur bacula-9.6.5.old/autoconf/configure.in bacula-9.6.5/autoconf/configure.in
|
||||
--- bacula-9.6.5.old/autoconf/configure.in 2020-07-24 09:19:47.073513530 +0200
|
||||
+++ bacula-9.6.5/autoconf/configure.in 2020-07-24 09:25:50.708044682 +0200
|
||||
@@ -3612,6 +3612,8 @@
|
||||
diff -Naur bacula-11.0.0.old/autoconf/configure.in bacula-11.0.0/autoconf/configure.in
|
||||
--- bacula-11.0.0.old/autoconf/configure.in 2021-01-12 12:42:18.332798754 +0100
|
||||
+++ bacula-11.0.0/autoconf/configure.in 2021-01-12 12:43:50.415484480 +0100
|
||||
@@ -3795,7 +3795,7 @@
|
||||
cd src/qt-console
|
||||
chmod 755 install_conf_file build-depkgs-qt-console
|
||||
cd tray-monitor
|
||||
chmod 755 install_conf_file build-depkgs-qt-console
|
||||
+cd tray-monitor
|
||||
-chmod 755 install_conf_file
|
||||
+chmod 755 install_conf_file build-depkgs-qt-console
|
||||
cd ${BUILD_DIR}
|
||||
|
||||
cd scripts
|
||||
diff -Naur bacula-9.6.5.old/examples/nagios/check_bacula/Makefile.in bacula-9.6.5/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-9.6.5.old/examples/nagios/check_bacula/Makefile.in 2020-07-24 09:11:40.888118277 +0200
|
||||
+++ bacula-9.6.5/examples/nagios/check_bacula/Makefile.in 2020-07-24 09:25:50.708044682 +0200
|
||||
diff -Naur bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.0/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in 2021-01-12 12:36:32.682471046 +0100
|
||||
+++ bacula-11.0.0/examples/nagios/check_bacula/Makefile.in 2021-01-12 12:42:38.919175622 +0100
|
||||
@@ -72,7 +72,7 @@
|
||||
(cd $(srcdir); $(RMF) Makefile)
|
||||
|
||||
@ -22,21 +22,21 @@ diff -Naur bacula-9.6.5.old/examples/nagios/check_bacula/Makefile.in bacula-9.6.
|
||||
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
||||
diff -Naur bacula-9.6.5.old/src/qt-console/bat.pro.in bacula-9.6.5/src/qt-console/bat.pro.in
|
||||
--- bacula-9.6.5.old/src/qt-console/bat.pro.in 2020-07-24 09:13:23.953685986 +0200
|
||||
+++ bacula-9.6.5/src/qt-console/bat.pro.in 2020-07-24 09:25:52.180067067 +0200
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/bat.pro.in bacula-11.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-11.0.0.old/src/qt-console/bat.pro.in 2021-01-12 12:39:35.876824725 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/bat.pro.in 2021-01-12 12:42:38.919175622 +0100
|
||||
@@ -12,7 +12,7 @@
|
||||
greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
|
||||
|
||||
datarootdir = @datarootdir@
|
||||
bins.path = /$(DESTDIR)@sbindir@
|
||||
-bins.files = bat
|
||||
+bins.files = .libs/bat
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
confs.commands = ./install_conf_file
|
||||
help.path = /$(DESTDIR)@htmldir@
|
||||
diff -Naur bacula-9.6.5.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-9.6.5/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-9.6.5.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2020-07-24 09:11:40.947119177 +0200
|
||||
+++ bacula-9.6.5/src/qt-console/tray-monitor/tray-monitor.pro.in 2020-07-24 09:25:52.212067555 +0200
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-11.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2021-01-12 12:36:32.636470203 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2021-01-12 12:42:38.920175640 +0100
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-9.6.2.old/src/lib/lib.h bacula-9.6.2/src/lib/lib.h
|
||||
--- bacula-9.6.2.old/src/lib/lib.h 2020-02-29 17:45:42.941374709 +0100
|
||||
+++ bacula-9.6.2/src/lib/lib.h 2020-02-29 17:45:49.721502334 +0100
|
||||
@@ -55,7 +55,6 @@
|
||||
diff -Naur bacula-11.0.0.old/src/lib/lib.h bacula-11.0.0/src/lib/lib.h
|
||||
--- bacula-11.0.0.old/src/lib/lib.h 2021-01-12 12:36:32.629470075 +0100
|
||||
+++ bacula-11.0.0/src/lib/lib.h 2021-01-12 12:40:33.030871025 +0100
|
||||
@@ -56,7 +56,6 @@
|
||||
#include "fnmatch.h"
|
||||
#endif
|
||||
#include "md5.h"
|
||||
@ -9,19 +9,19 @@ diff -Naur bacula-9.6.2.old/src/lib/lib.h bacula-9.6.2/src/lib/lib.h
|
||||
#include "tree.h"
|
||||
#include "watchdog.h"
|
||||
#include "btimers.h"
|
||||
diff -Naur bacula-9.6.2.old/src/lib/Makefile.in bacula-9.6.2/src/lib/Makefile.in
|
||||
--- bacula-9.6.2.old/src/lib/Makefile.in 2020-02-29 17:45:42.940374690 +0100
|
||||
+++ bacula-9.6.2/src/lib/Makefile.in 2020-02-29 17:45:49.722502353 +0100
|
||||
@@ -38,7 +38,7 @@
|
||||
diff -Naur bacula-11.0.0.old/src/lib/Makefile.in bacula-11.0.0/src/lib/Makefile.in
|
||||
--- bacula-11.0.0.old/src/lib/Makefile.in 2021-01-12 12:36:32.628470057 +0100
|
||||
+++ bacula-11.0.0/src/lib/Makefile.in 2021-01-12 12:40:54.400262228 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
flist.h fnmatch.h guid_to_name.h htable.h lex.h \
|
||||
lib.h lz4.h md5.h mem_pool.h message.h \
|
||||
openssl.h parse_conf.h plugins.h protos.h queue.h rblist.h \
|
||||
openssl.h plugins.h protos.h queue.h rblist.h \
|
||||
- runscript.h rwlock.h serial.h sellist.h sha1.h sha2.h \
|
||||
+ runscript.h rwlock.h serial.h sellist.h sha2.h \
|
||||
smartall.h status.h tls.h tree.h var.h \
|
||||
watchdog.h workq.h ini.h collect.h \
|
||||
lockmgr.h devlock.h output.h bwlimit.h
|
||||
@@ -52,7 +52,7 @@
|
||||
waitq.h watchdog.h workq.h \
|
||||
parse_conf.h ini.h \
|
||||
@@ -57,7 +57,7 @@
|
||||
guid_to_name.c hmac.c jcr.c lex.c lz4.c alist.c dlist.c \
|
||||
md5.c message.c mem_pool.c openssl.c \
|
||||
plugins.c priv.c queue.c bregex.c bsockcore.c \
|
||||
@ -30,7 +30,7 @@ diff -Naur bacula-9.6.2.old/src/lib/Makefile.in bacula-9.6.2/src/lib/Makefile.in
|
||||
signal.c smartall.c rblist.c tls.c tree.c \
|
||||
util.c var.c watchdog.c workq.c btimers.c \
|
||||
worker.c flist.c bcollector.c collect.c \
|
||||
@@ -246,22 +246,6 @@
|
||||
@@ -278,22 +278,6 @@
|
||||
$(RMF) md5.o
|
||||
$(CXX) $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) md5.c
|
||||
|
||||
@ -53,7 +53,7 @@ diff -Naur bacula-9.6.2.old/src/lib/Makefile.in bacula-9.6.2/src/lib/Makefile.in
|
||||
bsnprintf_test: Makefile libbac.la bsnprintf.c unittests.o
|
||||
$(RMF) bsnprintf.o
|
||||
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) bsnprintf.c
|
||||
@@ -343,7 +327,7 @@
|
||||
@@ -389,7 +373,7 @@
|
||||
|
||||
clean: libtool-clean
|
||||
@$(RMF) core a.out *.o *.bak *.tex *.pdf *~ *.intpro *.extpro 1 2 3
|
||||
@ -62,9 +62,9 @@ diff -Naur bacula-9.6.2.old/src/lib/Makefile.in bacula-9.6.2/src/lib/Makefile.in
|
||||
|
||||
realclean: clean
|
||||
@$(RMF) tags
|
||||
diff -Naur bacula-9.6.2.old/src/lib/sha1.c bacula-9.6.2/src/lib/sha1.c
|
||||
--- bacula-9.6.2.old/src/lib/sha1.c 2020-02-29 17:45:42.943374747 +0100
|
||||
+++ bacula-9.6.2/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-11.0.0.old/src/lib/sha1.c bacula-11.0.0/src/lib/sha1.c
|
||||
--- bacula-11.0.0.old/src/lib/sha1.c 2021-01-12 12:36:32.629470075 +0100
|
||||
+++ bacula-11.0.0/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,517 +0,0 @@
|
||||
-/*
|
||||
- * sha1.c
|
||||
@ -583,9 +583,9 @@ diff -Naur bacula-9.6.2.old/src/lib/sha1.c bacula-9.6.2/src/lib/sha1.c
|
||||
- fclose(fd);
|
||||
-}
|
||||
-#endif /* SHA1_SUM */
|
||||
diff -Naur bacula-9.6.2.old/src/lib/sha1.h bacula-9.6.2/src/lib/sha1.h
|
||||
--- bacula-9.6.2.old/src/lib/sha1.h 2020-02-29 17:45:42.940374690 +0100
|
||||
+++ bacula-9.6.2/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
diff -Naur bacula-11.0.0.old/src/lib/sha1.h bacula-11.0.0/src/lib/sha1.h
|
||||
--- bacula-11.0.0.old/src/lib/sha1.h 2021-01-12 12:36:32.630470094 +0100
|
||||
+++ bacula-11.0.0/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,107 +0,0 @@
|
||||
-/*
|
||||
- * sha1.h
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-9.0.0.old/src/dird/bacula-dir.conf.in bacula-9.0.0/src/dird/bacula-dir.conf.in
|
||||
--- bacula-9.0.0.old/src/dird/bacula-dir.conf.in 2017-07-10 08:52:38.930834509 +0200
|
||||
+++ bacula-9.0.0/src/dird/bacula-dir.conf.in 2017-07-10 08:53:11.189444548 +0200
|
||||
diff -Naur bacula-11.0.0.old/src/dird/bacula-dir.conf.in bacula-11.0.0/src/dird/bacula-dir.conf.in
|
||||
--- bacula-11.0.0.old/src/dird/bacula-dir.conf.in 2021-01-12 12:36:32.650470459 +0100
|
||||
+++ bacula-11.0.0/src/dird/bacula-dir.conf.in 2021-01-12 12:36:38.297573839 +0100
|
||||
@@ -18,7 +18,7 @@
|
||||
Director { # define myself
|
||||
Name = @basename@-dir
|
||||
@ -10,15 +10,15 @@ diff -Naur bacula-9.0.0.old/src/dird/bacula-dir.conf.in bacula-9.0.0/src/dird/ba
|
||||
WorkingDirectory = "@working_dir@"
|
||||
PidDirectory = "@piddir@"
|
||||
Maximum Concurrent Jobs = 20
|
||||
diff -Naur bacula-9.0.0.old/src/dird/Makefile.in bacula-9.0.0/src/dird/Makefile.in
|
||||
--- bacula-9.0.0.old/src/dird/Makefile.in 2017-07-10 08:52:38.930834509 +0200
|
||||
+++ bacula-9.0.0/src/dird/Makefile.in 2017-07-10 08:54:24.363828341 +0200
|
||||
@@ -124,11 +124,11 @@
|
||||
@if test "x${dir_group}" != "x" -a "x${DESTDIR}" = "x" ; then \
|
||||
diff -Naur bacula-11.0.0.old/src/dird/Makefile.in bacula-11.0.0/src/dird/Makefile.in
|
||||
--- bacula-11.0.0.old/src/dird/Makefile.in 2021-01-12 12:36:32.657470588 +0100
|
||||
+++ bacula-11.0.0/src/dird/Makefile.in 2021-01-12 12:37:37.827663637 +0100
|
||||
@@ -125,11 +125,11 @@
|
||||
@if test "x${dir_group}" != "x"; then \
|
||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||
fi
|
||||
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
||||
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
||||
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
||||
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
||||
echo " ==> Saving existing query.sql to query.sql.old"; \
|
||||
- $(MV) -f ${DESTDIR}${scriptdir}/query.sql ${DESTDIR}${scriptdir}/query.sql.old; \
|
||||
+ $(MV) -f ${DESTDIR}${sysconfdir}/query.sql ${DESTDIR}${sysconfdir}/query.sql.old; \
|
||||
@ -28,7 +28,7 @@ diff -Naur bacula-9.0.0.old/src/dird/Makefile.in bacula-9.0.0/src/dird/Makefile.
|
||||
@if test -f static-bacula-dir; then \
|
||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
||||
fi
|
||||
@@ -137,7 +137,7 @@
|
||||
@@ -138,7 +138,7 @@
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir bdirjson)
|
||||
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-9.6.5.old/src/lib/message.c bacula-9.6.5/src/lib/message.c
|
||||
--- bacula-9.6.5.old/src/lib/message.c 2020-07-24 09:11:40.900118460 +0200
|
||||
+++ bacula-9.6.5/src/lib/message.c 2020-07-24 09:12:48.705149825 +0200
|
||||
diff -Naur bacula-11.0.0.old/src/lib/message.c bacula-11.0.0/src/lib/message.c
|
||||
--- bacula-11.0.0.old/src/lib/message.c 2021-01-12 12:36:32.630470094 +0100
|
||||
+++ bacula-11.0.0/src/lib/message.c 2021-01-12 12:39:42.477945569 +0100
|
||||
@@ -28,6 +28,7 @@
|
||||
*
|
||||
*/
|
||||
@ -9,7 +9,7 @@ diff -Naur bacula-9.6.5.old/src/lib/message.c bacula-9.6.5/src/lib/message.c
|
||||
#include "bacula.h"
|
||||
#include "jcr.h"
|
||||
|
||||
@@ -1429,7 +1430,8 @@
|
||||
@@ -1476,7 +1477,8 @@
|
||||
|
||||
if (type == M_ABORT) {
|
||||
char *p = 0;
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -Naur bacula-9.0.4.old/src/cats/make_sqlite3_tables.in bacula-9.0.4/src/cats/make_sqlite3_tables.in
|
||||
--- bacula-9.0.4.old/src/cats/make_sqlite3_tables.in 2017-09-15 13:38:22.717599355 +0200
|
||||
+++ bacula-9.0.4/src/cats/make_sqlite3_tables.in 2017-09-15 13:38:36.414851879 +0200
|
||||
@@ -481,4 +481,5 @@
|
||||
diff -Naur bacula-11.0.0.old/src/cats/make_sqlite3_tables.in bacula-11.0.0/src/cats/make_sqlite3_tables.in
|
||||
--- bacula-11.0.0.old/src/cats/make_sqlite3_tables.in 2021-01-12 12:36:32.660470643 +0100
|
||||
+++ bacula-11.0.0/src/cats/make_sqlite3_tables.in 2021-01-12 12:38:45.241897767 +0100
|
||||
@@ -555,4 +555,5 @@
|
||||
echo ""
|
||||
|
||||
chmod 640 ${db_name}.db
|
||||
|
16
bacula.spec
16
bacula.spec
@ -2,7 +2,7 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 9.6.7
|
||||
Version: 11.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
@ -33,7 +33,8 @@ Patch6: %{name}-logwatch.patch
|
||||
Patch7: %{name}-non-free-code.patch
|
||||
Patch8: %{name}-desktop.patch
|
||||
Patch9: %{name}-g++-options.patch
|
||||
Patch12: %{name}-install.patch
|
||||
Patch10: %{name}-install.patch
|
||||
Patch11: %{name}-docker-plugin.patch
|
||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||
# Without this, there is no library providing the correct shared object name
|
||||
@ -322,7 +323,7 @@ export PATH="$PATH:%{_qt5_bindir}"
|
||||
--with-mysql \
|
||||
--with-openssl \
|
||||
--with-pid-dir=%{_localstatedir}/run \
|
||||
--with-plugindir=%{_libdir}/bacula \
|
||||
--with-plugindir=%{_libdir}/%{name} \
|
||||
--with-postgresql \
|
||||
--with-scriptdir=%{_libexecdir}/bacula \
|
||||
--with-sd-password=@@SD_PASSWORD@@ \
|
||||
@ -400,7 +401,7 @@ rm -f %{buildroot}%{_datadir}/bacula/{ChangeLog,INSTALL,LICENSE*,README,ReleaseN
|
||||
|
||||
# Fix up some perms so rpmlint does not complain too much
|
||||
chmod 755 %{buildroot}%{_sbindir}/*
|
||||
chmod 755 %{buildroot}%{_libdir}/bacula/*
|
||||
chmod 755 %{buildroot}%{_libdir}/%{name}/*
|
||||
chmod 755 %{buildroot}%{_libexecdir}/bacula/*
|
||||
chmod 644 %{buildroot}%{_libexecdir}/bacula/btraceback.*
|
||||
|
||||
@ -582,7 +583,8 @@ exit 0
|
||||
%config(noreplace) %{_sysconfdir}/bacula/bacula-fd.conf %attr(640,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/bacula-fd
|
||||
%{_mandir}/man8/bacula-fd.8*
|
||||
%{_libdir}/bacula/bpipe-fd.so
|
||||
%{_libdir}/%{name}/bpipe-fd.so
|
||||
%{_libdir}/%{name}/docker-fd.so
|
||||
%{_sbindir}/bacula-fd
|
||||
%{_sbindir}/bfdjson
|
||||
%{_unitdir}/bacula-fd.service
|
||||
@ -621,6 +623,10 @@ exit 0
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Tue Jan 12 2021 Simone Caronni <negativo17@gmail.com> - 11.0.0-1
|
||||
- Update to 11.0.0.
|
||||
- Enable Docker plugin.
|
||||
|
||||
* Tue Jan 12 2021 Simone Caronni <negativo17@gmail.com> - 9.6.7-1
|
||||
- Update to 9.6.7.
|
||||
- Drop support for building on CentOS/RHEL 6 and upgrades from version 2.4.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-9.6.7.tar.gz) = 27551faa2e4b13c6c2b9a2500f1253dfa5ee84929013491a7bf512d965d655c5af78b08201090474bc9b29827ca0a5c1c5a23a55712a1f739f37de75449cfd4d
|
||||
SHA512 (bacula-11.0.0.tar.gz) = 5c835dbaa65f89add5b38abf0105a20b4fd545d7a8ab9828cfc4f7e9f27862f9e18f7beab1c1ea8e3528504f265a46d50a1e73720737b981ba092bb72aa63501
|
||||
|
Loading…
Reference in New Issue
Block a user