Update to 9.0.6
This commit is contained in:
parent
5d4b2ec980
commit
9ad9175545
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@ bacula-docs-5.0.3.tar.bz2
|
||||
/bacula-9.0.3.tar.gz
|
||||
/bacula-9.0.4.tar.gz
|
||||
/bacula-9.0.5.tar.gz
|
||||
/bacula-9.0.6.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-9.0.0.old/src/qt-console/bat.pro.in bacula-9.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-9.0.0.old/src/qt-console/bat.pro.in 2017-07-10 08:52:38.933834565 +0200
|
||||
+++ bacula-9.0.0/src/qt-console/bat.pro.in 2017-07-10 08:59:45.545902183 +0200
|
||||
diff -Naur bacula-9.0.6.old/src/qt-console/bat.pro.in bacula-9.0.6/src/qt-console/bat.pro.in
|
||||
--- bacula-9.0.6.old/src/qt-console/bat.pro.in 2017-12-07 15:44:44.737173178 +0100
|
||||
+++ bacula-9.0.6/src/qt-console/bat.pro.in 2017-12-07 15:44:55.118366334 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
#
|
||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
@ -8,9 +8,9 @@ diff -Naur bacula-9.0.0.old/src/qt-console/bat.pro.in bacula-9.0.0/src/qt-consol
|
||||
-CONFIG += qt debug @QWT@
|
||||
+CONFIG += qt release @QWT@
|
||||
|
||||
datarootdir = @datarootdir@
|
||||
|
||||
@@ -14,7 +14,7 @@
|
||||
greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
|
||||
@@ -15,7 +15,7 @@
|
||||
bins.files = bat
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
confs.commands = ./install_conf_file
|
||||
@ -18,10 +18,10 @@ diff -Naur bacula-9.0.0.old/src/qt-console/bat.pro.in bacula-9.0.0/src/qt-consol
|
||||
+help.path = /$(DESTDIR)@htmldir@
|
||||
help.files = help/*.html images/status.png images/mail-message-new.png
|
||||
|
||||
TEMPLATE = app
|
||||
diff -Naur bacula-9.0.0.old/src/qt-console/main.cpp bacula-9.0.0/src/qt-console/main.cpp
|
||||
--- bacula-9.0.0.old/src/qt-console/main.cpp 2017-07-10 08:52:38.933834565 +0200
|
||||
+++ bacula-9.0.0/src/qt-console/main.cpp 2017-07-10 09:48:57.479241154 +0200
|
||||
datarootdir = @datarootdir@
|
||||
diff -Naur bacula-9.0.6.old/src/qt-console/main.cpp bacula-9.0.6/src/qt-console/main.cpp
|
||||
--- bacula-9.0.6.old/src/qt-console/main.cpp 2017-12-07 15:44:44.742173271 +0100
|
||||
+++ bacula-9.0.6/src/qt-console/main.cpp 2017-12-07 15:44:55.119366353 +0100
|
||||
@@ -29,11 +29,11 @@
|
||||
#include <QTranslator>
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-7.4.0.old/src/lib/crypto.c bacula-7.4.0/src/lib/crypto.c
|
||||
--- bacula-7.4.0.old/src/lib/crypto.c 2016-01-25 21:00:14.019670307 +0100
|
||||
+++ bacula-7.4.0/src/lib/crypto.c 2016-01-25 21:00:22.216798164 +0100
|
||||
diff -Naur bacula-9.0.6.old/src/lib/crypto.c bacula-9.0.6/src/lib/crypto.c
|
||||
--- bacula-9.0.6.old/src/lib/crypto.c 2017-12-07 15:42:03.771178189 +0100
|
||||
+++ bacula-9.0.6/src/lib/crypto.c 2017-12-07 15:42:25.300578772 +0100
|
||||
@@ -42,7 +42,7 @@
|
||||
* For OpenSSL version 1.x, EVP_PKEY_encrypt no longer
|
||||
* exists. It was not an official API.
|
||||
@ -10,24 +10,12 @@ diff -Naur bacula-7.4.0.old/src/lib/crypto.c bacula-7.4.0/src/lib/crypto.c
|
||||
#define EVP_PKEY_encrypt EVP_PKEY_encrypt_old
|
||||
#define EVP_PKEY_decrypt EVP_PKEY_decrypt_old
|
||||
#endif
|
||||
diff -Naur bacula-7.4.0.old/src/lib/tls.c bacula-7.4.0/src/lib/tls.c
|
||||
--- bacula-7.4.0.old/src/lib/tls.c 2016-01-25 21:00:14.019670307 +0100
|
||||
+++ bacula-7.4.0/src/lib/tls.c 2016-01-25 21:00:22.218798196 +0100
|
||||
@@ -329,7 +329,7 @@
|
||||
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
|
||||
diff -Naur bacula-9.0.6.old/src/lib/tls.c bacula-9.0.6/src/lib/tls.c
|
||||
--- bacula-9.0.6.old/src/lib/tls.c 2017-12-07 15:42:03.770178170 +0100
|
||||
+++ bacula-9.0.6/src/lib/tls.c 2017-12-07 15:42:26.891608376 +0100
|
||||
@@ -47,9 +47,6 @@
|
||||
|
||||
if (strcmp(extname, "subjectAltName") == 0) {
|
||||
-#ifdef HAVE_OPENSSLv1
|
||||
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
|
||||
const X509V3_EXT_METHOD *method;
|
||||
#else
|
||||
X509V3_EXT_METHOD *method;
|
||||
diff -Naur bacula-9.0.0.old/src/lib/tls.c bacula-9.0.0/src/lib/tls.c
|
||||
--- bacula-9.0.0.old/src/lib/tls.c 2017-07-10 08:52:38.929834490 +0200
|
||||
+++ bacula-9.0.0/src/lib/tls.c 2017-07-10 10:52:34.032273634 +0200
|
||||
@@ -45,9 +45,6 @@
|
||||
|
||||
#ifdef HAVE_OPENSSL /* How about OpenSSL? */
|
||||
#include "openssl-compat.h"
|
||||
|
||||
-/* No anonymous ciphers, no <128 bit ciphers, no export ciphers, no MD5 ciphers */
|
||||
-#define TLS_DEFAULT_CIPHERS "ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH"
|
||||
@ -35,7 +23,7 @@ diff -Naur bacula-9.0.0.old/src/lib/tls.c bacula-9.0.0/src/lib/tls.c
|
||||
/* TLS Context Structure */
|
||||
struct TLS_Context {
|
||||
SSL_CTX *openssl;
|
||||
@@ -207,7 +204,7 @@
|
||||
@@ -206,7 +203,7 @@
|
||||
SSL_CTX_set_options(ctx->openssl, SSL_OP_SINGLE_DH_USE);
|
||||
}
|
||||
|
||||
@ -44,3 +32,12 @@ diff -Naur bacula-9.0.0.old/src/lib/tls.c bacula-9.0.0/src/lib/tls.c
|
||||
Jmsg0(NULL, M_ERROR, 0,
|
||||
_("Error setting cipher list, no valid ciphers available\n"));
|
||||
goto err;
|
||||
@@ -328,7 +325,7 @@
|
||||
extname = OBJ_nid2sn(OBJ_obj2nid(X509_EXTENSION_get_object(ext)));
|
||||
|
||||
if (strcmp(extname, "subjectAltName") == 0) {
|
||||
-#ifdef HAVE_OPENSSLv1
|
||||
+#if (OPENSSL_VERSION_NUMBER >= 0x10000000L)
|
||||
const X509V3_EXT_METHOD *method;
|
||||
#else
|
||||
X509V3_EXT_METHOD *method;
|
15
bacula.spec
15
bacula.spec
@ -2,7 +2,7 @@
|
||||
%global username bacula
|
||||
|
||||
Name: bacula
|
||||
Version: 9.0.5
|
||||
Version: 9.0.6
|
||||
Release: 1%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
@ -28,10 +28,10 @@ Source17: %{name}-sd.sysconfig
|
||||
# Image taken from http://www.bacula.org/git/cgit.cgi/bacula/plain/bacula/src/tray-monitor/generic.xpm
|
||||
Source19: generic.xpm
|
||||
|
||||
Patch1: %{name}-9.0.0-openssl.patch
|
||||
Patch1: %{name}-9.0.6-openssl.patch
|
||||
Patch2: %{name}-9.0.0-queryfile.patch
|
||||
Patch3: %{name}-9.0.4-sqlite-priv.patch
|
||||
Patch4: %{name}-9.0.0-bat-build.patch
|
||||
Patch4: %{name}-9.0.6-bat-build.patch
|
||||
Patch5: %{name}-9.0.0-seg-fault.patch
|
||||
Patch6: %{name}-5.2.13-logwatch.patch
|
||||
Patch7: %{name}-9.0.0-non-free-code.patch
|
||||
@ -59,6 +59,7 @@ BuildRequires: libxml2-devel
|
||||
BuildRequires: libcap-devel
|
||||
BuildRequires: lzo-devel
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: postgresql-devel
|
||||
BuildRequires: qt4-devel >= 4.6.2
|
||||
BuildRequires: readline-devel
|
||||
@ -73,11 +74,6 @@ BuildRequires: perl-interpreter
|
||||
BuildRequires: perl
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
|
||||
BuildRequires: compat-openssl10-devel
|
||||
%else
|
||||
BuildRequires: openssl-devel
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 7
|
||||
BuildRequires: systemd
|
||||
@ -729,6 +725,9 @@ fi
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Thu Dec 07 2017 Simone Caronni <negativo17@gmail.com> - 9.0.6-1
|
||||
- Update to 9.0.6, supports OpenSSL 1.1.
|
||||
|
||||
* Mon Nov 06 2017 Simone Caronni <negativo17@gmail.com> - 9.0.5-1
|
||||
- Update to 9.0.5.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (bacula-9.0.5.tar.gz) = 97a23c701808666833e773106f5618bcce1af90fff299da88e58b23ed04fc7e6bfdf4c231f3724d2186fad7985f5f9d7f6b629d59cea489b2d4d4ce6f041ca63
|
||||
SHA512 (bacula-9.0.6.tar.gz) = a85b8e089951eb9949c9906af45f204a69cd4a7d2e0f29439b74a29ade20c05a49a8c38665189a46c0ad07af0c97380485e10da6aa53dfc47a22934f589f265e
|
||||
|
Loading…
Reference in New Issue
Block a user