Fix bat build on RHEL 6
This commit is contained in:
parent
8a7e202b6e
commit
80bfa76a6b
@ -1,12 +0,0 @@
|
||||
diff -up bacula-5.2.2/src/qt-console/bat.pro.in.optflags bacula-5.2.2/src/qt-console/bat.pro.in
|
||||
--- bacula-5.2.2/src/qt-console/bat.pro.in.optflags 2011-11-29 16:44:53.459899389 -0500
|
||||
+++ bacula-5.2.2/src/qt-console/bat.pro.in 2011-11-29 16:48:46.749029323 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
#
|
||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
#
|
||||
-CONFIG += qt debug @QWT@
|
||||
+CONFIG += qt release @QWT@
|
||||
|
||||
bins.path = /$(DESTDIR)@sbindir@
|
||||
bins.files = bat
|
27
bacula-5.2.7-bat-build.patch
Normal file
27
bacula-5.2.7-bat-build.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -Naur bacula-5.2.7.old/src/qt-console/bat.pro.in bacula-5.2.7/src/qt-console/bat.pro.in
|
||||
--- bacula-5.2.7.old/src/qt-console/bat.pro.in 2012-06-04 13:45:31.454418944 +0200
|
||||
+++ bacula-5.2.7/src/qt-console/bat.pro.in 2012-06-04 13:47:37.730768564 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
#
|
||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
#
|
||||
-CONFIG += qt debug @QWT@
|
||||
+CONFIG += qt release @QWT@
|
||||
|
||||
bins.path = /$(DESTDIR)@sbindir@
|
||||
bins.files = bat
|
||||
diff -Naur bacula-5.2.7.old/src/qt-console/main.cpp bacula-5.2.7/src/qt-console/main.cpp
|
||||
--- bacula-5.2.7.old/src/qt-console/main.cpp 2012-06-04 13:45:31.446418795 +0200
|
||||
+++ bacula-5.2.7/src/qt-console/main.cpp 2012-06-04 13:46:28.959489349 +0200
|
||||
@@ -40,9 +40,9 @@
|
||||
/*
|
||||
* We need Qt version 4.7.4 or later to be able to comple correctly
|
||||
*/
|
||||
-#if QT_VERSION < 0x040704
|
||||
+#if QT_VERSION < 0x040602
|
||||
#error "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
-#error "You need Qt version 4.7.4 or later to build Bat"
|
||||
+#error "You need Qt version 4.6.2 or later to build Bat"
|
||||
#error "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
#endif
|
||||
|
10
bacula.spec
10
bacula.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: bacula
|
||||
Version: 5.2.7
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -31,7 +31,7 @@ Patch1: bacula-5.0.2-openssl.patch
|
||||
Patch2: bacula-5.2.2-queryfile.patch
|
||||
Patch3: bacula-5.2.4-log-path.patch
|
||||
Patch4: bacula-5.0.3-sqlite-priv.patch
|
||||
Patch5: bacula-5.2.2-qt-console-optflags.patch
|
||||
Patch5: bacula-5.2.7-bat-build.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl
|
||||
@ -289,7 +289,7 @@ Provides check_bacula support for Nagios.
|
||||
%patch2 -p1 -b .queryfile
|
||||
%patch3 -p1 -b .log-path
|
||||
%patch4 -p0 -b .priv
|
||||
%patch5 -p1 -b .optflags
|
||||
%patch5 -p1 -b .bat-build
|
||||
|
||||
# Remove execution permissions from files we're packaging as docs later on
|
||||
find updatedb -type f | xargs chmod -x
|
||||
@ -829,6 +829,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 04 2012 Simone Caronni <negativo17@gmail.com> - 5.2.7-2
|
||||
- Remove python-devel test leftover.
|
||||
- Updated bat build patch to add support for RHEL 6.
|
||||
|
||||
* Mon Jun 04 2012 Simone Caronni <negativo17@gmail.com> - 5.2.7-1
|
||||
- Updated to 5.2.7, removed patches included upstream.
|
||||
- Removed python-devel patch, fix included in python package.
|
||||
|
Loading…
Reference in New Issue
Block a user