- Fixed previous fix of alternatives
- Changed initscript return value for non-configured service - Director address is required in tray-monitor config now (#626490)
This commit is contained in:
parent
38c1d437b6
commit
767f6bf514
13
bacula-5.0.3-tray-dir.patch
Normal file
13
bacula-5.0.3-tray-dir.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/bacula/src/tray-monitor/tray_conf.c b/bacula/src/tray-monitor/tray_conf.c
|
||||||
|
index 2c2f0ec..32d207c 100644
|
||||||
|
--- a/bacula/src/tray-monitor/tray_conf.c
|
||||||
|
+++ b/bacula/src/tray-monitor/tray_conf.c
|
||||||
|
@@ -95,7 +95,7 @@ static RES_ITEM dir_items[] = {
|
||||||
|
{"name", store_name, ITEM(res_dir.hdr.name), 0, ITEM_REQUIRED, 0},
|
||||||
|
{"description", store_str, ITEM(res_dir.hdr.desc), 0, 0, 0},
|
||||||
|
{"dirport", store_pint32, ITEM(res_dir.DIRport), 0, ITEM_DEFAULT, 9101},
|
||||||
|
- {"address", store_str, ITEM(res_dir.address), 0, 0, 0},
|
||||||
|
+ {"address", store_str, ITEM(res_dir.address), 0, ITEM_REQUIRED, 0},
|
||||||
|
{"enablessl", store_bool, ITEM(res_dir.enable_ssl), 1, ITEM_DEFAULT, 0},
|
||||||
|
{NULL, NULL, {0}, 0, 0, 0}
|
||||||
|
};
|
@ -91,8 +91,9 @@
|
|||||||
@@ -26 +26 @@
|
@@ -26 +26 @@
|
||||||
- Name = @basename@-dir
|
- Name = @basename@-dir
|
||||||
+ Name = bacula-dir
|
+ Name = bacula-dir
|
||||||
@@ -28 +27,0 @@
|
@@ -28 +28 @@
|
||||||
- address = @hostname@
|
- address = @hostname@
|
||||||
|
+ Address = director.example.com
|
||||||
--- bacula-2.4.3/src/qt-console/bat.conf.in.orig 2008-12-10 10:27:02.000000000 -0600
|
--- bacula-2.4.3/src/qt-console/bat.conf.in.orig 2008-12-10 10:27:02.000000000 -0600
|
||||||
+++ bacula-2.4.3/src/qt-console/bat.conf.in 2008-12-10 10:27:02.000000000 -0600
|
+++ bacula-2.4.3/src/qt-console/bat.conf.in 2008-12-10 10:27:02.000000000 -0600
|
||||||
@@ -6 +6 @@
|
@@ -6 +6 @@
|
||||||
|
@ -41,7 +41,7 @@ checkconf() {
|
|||||||
echo -n "Error: Default password in config"
|
echo -n "Error: Default password in config"
|
||||||
echo_failure
|
echo_failure
|
||||||
echo
|
echo
|
||||||
exit 1
|
exit 6
|
||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -41,7 +41,7 @@ checkconf() {
|
|||||||
echo -n "Error: Default password in config"
|
echo -n "Error: Default password in config"
|
||||||
echo_failure
|
echo_failure
|
||||||
echo
|
echo
|
||||||
exit 1
|
exit 6
|
||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -40,7 +40,7 @@ checkconf() {
|
|||||||
echo -n "Error: Default password in config"
|
echo -n "Error: Default password in config"
|
||||||
echo_failure
|
echo_failure
|
||||||
echo
|
echo
|
||||||
exit 1
|
exit 6
|
||||||
fi
|
fi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
15
bacula.spec
15
bacula.spec
@ -8,7 +8,7 @@
|
|||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 5.0.3
|
Version: 5.0.3
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: GPLv2 with exceptions
|
License: GPLv2 with exceptions
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -51,6 +51,7 @@ Patch17: bacula-5.0.2-python27.patch
|
|||||||
Patch18: bacula-5.0.3-dsolink.patch
|
Patch18: bacula-5.0.3-dsolink.patch
|
||||||
Patch19: bacula-5.0.3-log-path.patch
|
Patch19: bacula-5.0.3-log-path.patch
|
||||||
Patch20: bacula-5.0.3-sqlite-priv.patch
|
Patch20: bacula-5.0.3-sqlite-priv.patch
|
||||||
|
Patch21: bacula-5.0.3-tray-dir.patch
|
||||||
|
|
||||||
URL: http://www.bacula.org
|
URL: http://www.bacula.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -368,6 +369,7 @@ pushd bacula-%{version}
|
|||||||
%patch18 -p2
|
%patch18 -p2
|
||||||
%patch19 -p2 -b .log-path
|
%patch19 -p2 -b .log-path
|
||||||
%patch20 -p0 -b .priv
|
%patch20 -p0 -b .priv
|
||||||
|
%patch21 -p2 -b .tray-dir
|
||||||
|
|
||||||
# Remove execution permissions from files we're packaging as docs later on
|
# Remove execution permissions from files we're packaging as docs later on
|
||||||
find examples -type f | xargs chmod -x
|
find examples -type f | xargs chmod -x
|
||||||
@ -716,17 +718,17 @@ fi
|
|||||||
|
|
||||||
%post storage-mysql
|
%post storage-mysql
|
||||||
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.mysql 50 \
|
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.mysql 50 \
|
||||||
--slave /usr/sbin/dbcheck bacula-dbcheck /usr/sbin/dbcheck.mysql
|
--slave /usr/sbin/bscan bacula-bscan /usr/sbin/bscan.mysql
|
||||||
|
|
||||||
|
|
||||||
%post storage-sqlite
|
%post storage-sqlite
|
||||||
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.sqlite 40 \
|
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.sqlite 40 \
|
||||||
--slave /usr/sbin/dbcheck bacula-dbcheck /usr/sbin/dbcheck.sqlite
|
--slave /usr/sbin/bscan bacula-bscan /usr/sbin/bscan.sqlite
|
||||||
|
|
||||||
|
|
||||||
%post storage-postgresql
|
%post storage-postgresql
|
||||||
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.postgresql 60 \
|
/usr/sbin/alternatives --install /usr/sbin/bcopy bacula-sd /usr/sbin/bcopy.postgresql 60 \
|
||||||
--slave /usr/sbin/dbcheck bacula-dbcheck /usr/sbin/dbcheck.postgresql
|
--slave /usr/sbin/bscan bacula-bscan /usr/sbin/bscan.postgresql
|
||||||
|
|
||||||
|
|
||||||
%preun storage-mysql
|
%preun storage-mysql
|
||||||
@ -1022,6 +1024,11 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 26 2010 Jan Görig <jgorig@redhat.com> - 5.0.3-6
|
||||||
|
- Fixed previous fix of alternatives
|
||||||
|
- Changed initscript return value for non-configured service
|
||||||
|
- Director address is required in tray-monitor config now (#626490)
|
||||||
|
|
||||||
* Tue Nov 23 2010 Jan Görig <jgorig@redhat.com> - 5.0.3-5
|
* Tue Nov 23 2010 Jan Görig <jgorig@redhat.com> - 5.0.3-5
|
||||||
- Fixed alternatives for dbcheck (#650224)
|
- Fixed alternatives for dbcheck (#650224)
|
||||||
- Moved director log file to /var/log/bacula/
|
- Moved director log file to /var/log/bacula/
|
||||||
|
Loading…
Reference in New Issue
Block a user