Build bacula against Qt5
This commit is contained in:
parent
985991c127
commit
714ac00993
12
bacula-9.0.6-qt5-support.patch
Normal file
12
bacula-9.0.6-qt5-support.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -urNp old/src/qt-console/pages.h new/src/qt-console/pages.h
|
||||||
|
--- old/src/qt-console/pages.h 2017-11-21 18:37:16.000000000 +0100
|
||||||
|
+++ new/src/qt-console/pages.h 2018-02-06 12:37:04.490297821 +0100
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
/*
|
||||||
|
* Dirk Bartley, March 2007
|
||||||
|
*/
|
||||||
|
-
|
||||||
|
+#include <QtGlobal>
|
||||||
|
#if QT_VERSION >= 0x050000
|
||||||
|
#include <QtWidgets>
|
||||||
|
#else
|
20
bacula.spec
20
bacula.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 9.0.6
|
Version: 9.0.6
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -46,6 +46,7 @@ Patch9: %{name}-9.0.6-tray-monitor-task.patch
|
|||||||
# required by the daemons.
|
# required by the daemons.
|
||||||
# http://bugs.bacula.org/view.php?id=2084
|
# http://bugs.bacula.org/view.php?id=2084
|
||||||
Patch10: %{name}-7.0.4-autoconf.patch
|
Patch10: %{name}-7.0.4-autoconf.patch
|
||||||
|
Patch11: %{name}-9.0.6-qt5-support.patch
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -63,13 +64,13 @@ BuildRequires: lzo-devel
|
|||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: postgresql-devel
|
BuildRequires: postgresql-devel
|
||||||
BuildRequires: qt4-devel >= 4.6.2
|
BuildRequires: qt5-devel
|
||||||
BuildRequires: readline-devel
|
BuildRequires: readline-devel
|
||||||
BuildRequires: sqlite-devel
|
BuildRequires: sqlite-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
|
|
||||||
# https://fedoraproject.org/wiki/Changes/perl_Package_to_Install_Core_Modules
|
# https://fedoraproject.org/wiki/Changes/perl_Package_to_Install_Core_Modules
|
||||||
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
|
%if 0%{?fedora} >= 27 || 0%{?rhel} > 7
|
||||||
BuildRequires: perl-interpreter
|
BuildRequires: perl-interpreter
|
||||||
%else
|
%else
|
||||||
BuildRequires: perl
|
BuildRequires: perl
|
||||||
@ -80,7 +81,7 @@ BuildRequires: perl
|
|||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
|
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
|
||||||
BuildRequires: mariadb-connector-c-devel
|
BuildRequires: mariadb-connector-c-devel
|
||||||
%else
|
%else
|
||||||
BuildRequires: mysql-devel
|
BuildRequires: mysql-devel
|
||||||
@ -324,6 +325,7 @@ Provides check_bacula support for Nagios.
|
|||||||
%patch8 -p1
|
%patch8 -p1
|
||||||
%patch9 -p1
|
%patch9 -p1
|
||||||
%patch10 -p1
|
%patch10 -p1
|
||||||
|
%patch11 -p1
|
||||||
|
|
||||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||||
|
|
||||||
@ -333,7 +335,7 @@ find updatedb -type f | xargs chmod -x
|
|||||||
%build
|
%build
|
||||||
export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
|
export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
|
||||||
export CPPFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
|
export CPPFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/ncurses"
|
||||||
export PATH="$PATH:%{_qt4_bindir}"
|
export PATH="$PATH:%{_qt5_bindir}"
|
||||||
%configure \
|
%configure \
|
||||||
--disable-conio \
|
--disable-conio \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
@ -366,7 +368,7 @@ export PATH="$PATH:%{_qt4_bindir}"
|
|||||||
--with-smtp-host=localhost \
|
--with-smtp-host=localhost \
|
||||||
--with-sqlite3 \
|
--with-sqlite3 \
|
||||||
--with-subsys-dir=%{_localstatedir}/lock/subsys \
|
--with-subsys-dir=%{_localstatedir}/lock/subsys \
|
||||||
%if 0%{!?fedora} >= 28 || 0%{!?rhel} >= 8
|
%if 0%{!?fedora} >= 28 || 0%{!?rhel} > 7
|
||||||
--with-tcp-wrappers \
|
--with-tcp-wrappers \
|
||||||
%endif
|
%endif
|
||||||
--with-working-dir=%{_localstatedir}/spool/bacula \
|
--with-working-dir=%{_localstatedir}/spool/bacula \
|
||||||
@ -380,7 +382,7 @@ make %{?_smp_mflags}
|
|||||||
make -C examples/nagios/check_bacula
|
make -C examples/nagios/check_bacula
|
||||||
|
|
||||||
pushd src/qt-console/tray-monitor
|
pushd src/qt-console/tray-monitor
|
||||||
%{?qmake_qt4}%{!?qmake_qt4:qmake-qt4} tray-monitor.pro
|
%{?qmake_qt5}%{!?qmake_qt5:qmake-qt5} tray-monitor.pro
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
cp -f .libs/bacula-tray-monitor .
|
cp -f .libs/bacula-tray-monitor .
|
||||||
popd
|
popd
|
||||||
@ -578,6 +580,7 @@ fi
|
|||||||
%{_libdir}/libbaccfg-%{version}.so
|
%{_libdir}/libbaccfg-%{version}.so
|
||||||
%{_libdir}/libbacfind-%{version}.so
|
%{_libdir}/libbacfind-%{version}.so
|
||||||
%{_libdir}/libbacsd-%{version}.so
|
%{_libdir}/libbacsd-%{version}.so
|
||||||
|
%{_libdir}/libbaccats-%{version}.so
|
||||||
|
|
||||||
%files libs-sql
|
%files libs-sql
|
||||||
%{_libdir}/libbaccats-mysql-%{version}.so
|
%{_libdir}/libbaccats-mysql-%{version}.so
|
||||||
@ -730,6 +733,9 @@ fi
|
|||||||
%{_libdir}/nagios/plugins/check_bacula
|
%{_libdir}/nagios/plugins/check_bacula
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 06 2018 Josef Ridky <jridky@redhat.com> - 9.0.6-6
|
||||||
|
- Build bacula against Qt5.
|
||||||
|
|
||||||
* Mon Jan 29 2018 Simone Caronni <negativo17@gmail.com> - 9.0.6-5
|
* Mon Jan 29 2018 Simone Caronni <negativo17@gmail.com> - 9.0.6-5
|
||||||
- Fix tray monitor build on RHEL/CentOS 7.
|
- Fix tray monitor build on RHEL/CentOS 7.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user