Update patches
This commit is contained in:
parent
3dbd5f08d7
commit
6fda920c47
131
bacula-compile-options.patch
Normal file
131
bacula-compile-options.patch
Normal file
@ -0,0 +1,131 @@
|
|||||||
|
diff -Naur bacula-11.0.6.old/autoconf/bacula-macros/db.m4 bacula-11.0.6/autoconf/bacula-macros/db.m4
|
||||||
|
--- bacula-11.0.6.old/autoconf/bacula-macros/db.m4 2022-03-26 15:44:08.577953123 +0100
|
||||||
|
+++ bacula-11.0.6/autoconf/bacula-macros/db.m4 2022-03-26 15:49:32.246622405 +0100
|
||||||
|
@@ -102,7 +102,7 @@
|
||||||
|
fi
|
||||||
|
DBI_INCLUDE=-I$DBI_INCDIR
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- DBI_LIBS="-R $DBI_LIBDIR -L$DBI_LIBDIR -ldbi"
|
||||||
|
+ DBI_LIBS="-L$DBI_LIBDIR -ldbi"
|
||||||
|
else
|
||||||
|
DBI_LIBS="-L$DBI_LIBDIR -ldbi"
|
||||||
|
fi
|
||||||
|
@@ -494,7 +494,7 @@
|
||||||
|
elif test -f $MYSQL_LIBDIR/libmysqlclient_r.a \
|
||||||
|
-o -f $MYSQL_LIBDIR/libmysqlclient_r.so; then
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- MYSQL_LIBS="-R $MYSQL_LIBDIR -L$MYSQL_LIBDIR -lmysqlclient_r -lz"
|
||||||
|
+ MYSQL_LIBS="-L$MYSQL_LIBDIR -lmysqlclient_r -lz"
|
||||||
|
else
|
||||||
|
MYSQL_LIBS="-L$MYSQL_LIBDIR -lmysqlclient_r -lz"
|
||||||
|
fi
|
||||||
|
@@ -625,7 +625,7 @@
|
||||||
|
fi
|
||||||
|
MYSQL_INCLUDE=-I$MYSQL_INCDIR
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- MYSQL_LIBS="-R $MYSQL_LIBDIR -L$MYSQL_LIBDIR -lmysqld -lz -lm -lcrypt"
|
||||||
|
+ MYSQL_LIBS="-L$MYSQL_LIBDIR -lmysqld -lz -lm -lcrypt"
|
||||||
|
else
|
||||||
|
MYSQL_LIBS="-L$MYSQL_LIBDIR -lmysqld -lz -lm -lcrypt"
|
||||||
|
fi
|
||||||
|
@@ -715,7 +715,7 @@
|
||||||
|
fi
|
||||||
|
INGRES_INCLUDE=-I$INGRES_INCDIR
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- INGRES_LIBS="-R $INGRES_LIBDIR -L$INGRES_LIBDIR -lq.1 -lcompat.1 -lframe.1"
|
||||||
|
+ INGRES_LIBS="-L$INGRES_LIBDIR -lq.1 -lcompat.1 -lframe.1"
|
||||||
|
else
|
||||||
|
INGRES_LIBS="-L$INGRES_LIBDIR -lq.1 -lcompat.1 -lframe.1"
|
||||||
|
fi
|
||||||
|
@@ -803,7 +803,7 @@
|
||||||
|
fi
|
||||||
|
SQLITE_INCLUDE=-I$SQLITE_INCDIR
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- SQLITE_LIBS="-R $SQLITE_LIBDIR -L$SQLITE_LIBDIR -lsqlite3"
|
||||||
|
+ SQLITE_LIBS="-L$SQLITE_LIBDIR -lsqlite3"
|
||||||
|
else
|
||||||
|
SQLITE_LIBS="-L$SQLITE_LIBDIR -lsqlite3"
|
||||||
|
fi
|
||||||
|
@@ -936,7 +936,7 @@
|
||||||
|
|
||||||
|
POSTGRESQL_INCLUDE=-I$POSTGRESQL_INCDIR
|
||||||
|
if test x$use_libtool != xno; then
|
||||||
|
- POSTGRESQL_LIBS="-R $POSTGRESQL_LIBDIR -L$POSTGRESQL_LIBDIR -lpq"
|
||||||
|
+ POSTGRESQL_LIBS="-L$POSTGRESQL_LIBDIR -lpq"
|
||||||
|
else
|
||||||
|
POSTGRESQL_LIBS="-L$POSTGRESQL_LIBDIR -lpq"
|
||||||
|
fi
|
||||||
|
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||||
|
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:44:08.578953140 +0100
|
||||||
|
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:49:32.297623298 +0100
|
||||||
|
@@ -16,7 +16,7 @@
|
||||||
|
cd ${BUILD_DIR}
|
||||||
|
AC_SUBST(BUILD_DIR)
|
||||||
|
AC_SUBST(TOP_DIR)
|
||||||
|
-AC_CONFIG_AUX_DIR(${BUILD_DIR}/autoconf)
|
||||||
|
+AC_CONFIG_AUX_DIR(autoconf)
|
||||||
|
AC_CONFIG_HEADERS(src/config.h:autoconf/config.h.in)
|
||||||
|
|
||||||
|
dnl minimal Win32 stuff for "make clean"
|
||||||
|
@@ -3335,11 +3335,6 @@
|
||||||
|
AC_DEFINE(FDLIBS)
|
||||||
|
|
||||||
|
CFLAGS=${CFLAGS--O}
|
||||||
|
-
|
||||||
|
-if test x$have_gcc = xyes ; then
|
||||||
|
- CPPFLAGS="$CPPFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
|
||||||
|
- CFLAGS="$CFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
|
||||||
|
-fi
|
||||||
|
LDFLAGS=${LDFLAGS--O}
|
||||||
|
CPPFLAGS="$CPPFLAGS"
|
||||||
|
CFLAGS="$CFLAGS"
|
||||||
|
diff -Naur bacula-11.0.6.old/autoconf/Make.common.in bacula-11.0.6/autoconf/Make.common.in
|
||||||
|
--- bacula-11.0.6.old/autoconf/Make.common.in 2022-03-26 15:44:08.578953140 +0100
|
||||||
|
+++ bacula-11.0.6/autoconf/Make.common.in 2022-03-26 15:49:32.297623298 +0100
|
||||||
|
@@ -75,12 +75,12 @@
|
||||||
|
DEFAULT_ARCHIVE_TYPE = @DEFAULT_ARCHIVE_TYPE@
|
||||||
|
DEFAULT_SHARED_OBJECT_TYPE = @DEFAULT_SHARED_OBJECT_TYPE@
|
||||||
|
LIBTOOL = @BUILD_DIR@/libtool
|
||||||
|
-LIBTOOL_COMPILE = @LIBTOOL@ --silent --tag=CXX --mode=compile
|
||||||
|
-LIBTOOL_LINK = @LIBTOOL@ --silent --tag=CXX --mode=link
|
||||||
|
-LIBTOOL_INSTALL = @LIBTOOL@ --silent --tag=CXX --mode=install
|
||||||
|
-LIBTOOL_INSTALL_FINISH = @LIBTOOL@ --silent --tag=CXX --finish --mode=install
|
||||||
|
-LIBTOOL_UNINSTALL = @LIBTOOL@ --silent --tag=CXX --mode=uninstall
|
||||||
|
-LIBTOOL_CLEAN = @LIBTOOL@ --silent --tag=CXX --mode=clean
|
||||||
|
+LIBTOOL_COMPILE = @LIBTOOL@ --tag=CXX --mode=compile
|
||||||
|
+LIBTOOL_LINK = @LIBTOOL@ --tag=CXX --mode=link
|
||||||
|
+LIBTOOL_INSTALL = @LIBTOOL@ --tag=CXX --mode=install
|
||||||
|
+LIBTOOL_INSTALL_FINISH = @LIBTOOL@ --tag=CXX --finish --mode=install
|
||||||
|
+LIBTOOL_UNINSTALL = @LIBTOOL@ --tag=CXX --mode=uninstall
|
||||||
|
+LIBTOOL_CLEAN = @LIBTOOL@ --tag=CXX --mode=clean
|
||||||
|
|
||||||
|
# Flags & libs
|
||||||
|
CFLAGS = @CFLAGS@ @OPENSSL_INC@
|
||||||
|
diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-console/bat.pro.in
|
||||||
|
--- bacula-11.0.6.old/src/qt-console/bat.pro.in 2022-03-26 15:44:29.088312370 +0100
|
||||||
|
+++ bacula-11.0.6/src/qt-console/bat.pro.in 2022-03-26 15:49:32.297623298 +0100
|
||||||
|
@@ -23,8 +23,8 @@
|
||||||
|
DEPENDPATH += .
|
||||||
|
INCLUDEPATH += .. . ./console ./restore ./select
|
||||||
|
LIBS += -L../lib -lbaccfg -lbac -L../findlib -lbacfind @OPENSSL_LIBS@
|
||||||
|
-LIBTOOL_LINK = @QMAKE_LIBTOOL@ --silent --tag=CXX --mode=link
|
||||||
|
-LIBTOOL_INSTALL = @QMAKE_LIBTOOL@ --silent --mode=install
|
||||||
|
+LIBTOOL_LINK = @QMAKE_LIBTOOL@ --tag=CXX --mode=link
|
||||||
|
+LIBTOOL_INSTALL = @QMAKE_LIBTOOL@ --mode=install
|
||||||
|
QMAKE_LINK = $${LIBTOOL_LINK} $(CXX)
|
||||||
|
QMAKE_INSTALL_PROGRAM = $${LIBTOOL_INSTALL} install -m @SBINPERM@ -p
|
||||||
|
QMAKE_CLEAN += .libs/* bat
|
||||||
|
diff -Naur bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||||
|
--- bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:44:08.523952177 +0100
|
||||||
|
+++ bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:49:32.298623316 +0100
|
||||||
|
@@ -36,8 +36,8 @@
|
||||||
|
DEPENDPATH += .
|
||||||
|
INCLUDEPATH += ../.. .
|
||||||
|
QMAKE_CC = $(CXX)
|
||||||
|
-LIBTOOL_LINK = @QMAKE_LIBTOOL@ --silent --tag=CXX --mode=link
|
||||||
|
-LIBTOOL_INSTALL = @QMAKE_LIBTOOL@ --silent --mode=install
|
||||||
|
+LIBTOOL_LINK = @QMAKE_LIBTOOL@ --tag=CXX --mode=link
|
||||||
|
+LIBTOOL_INSTALL = @QMAKE_LIBTOOL@ --mode=install
|
||||||
|
QMAKE_LINK = $${LIBTOOL_LINK} $(CXX)
|
||||||
|
QMAKE_INSTALL_PROGRAM = $${LIBTOOL_INSTALL} install -m @SBINPERM@ -p
|
||||||
|
QMAKE_CLEAN += obj/* .libs/* bacula-tray-monitor release/bacula-tray-monitor
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur bacula-11.0.1.old/autoconf/configure.in bacula-11.0.1/autoconf/configure.in
|
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||||
--- bacula-11.0.1.old/autoconf/configure.in 2021-02-11 14:12:19.547538024 +0100
|
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:51:18.976491851 +0100
|
||||||
+++ bacula-11.0.1/autoconf/configure.in 2021-02-11 14:12:25.803641252 +0100
|
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:53:22.522655847 +0100
|
||||||
@@ -3240,20 +3240,11 @@
|
@@ -3301,20 +3301,11 @@
|
||||||
]
|
]
|
||||||
)
|
)
|
||||||
if test x$support_docker = xyes -o x$support_docker = xauto; then
|
if test x$support_docker = xyes -o x$support_docker = xauto; then
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -Naur bacula-11.0.1.old/autoconf/configure.in bacula-11.0.1/autoconf/configure.in
|
|
||||||
--- bacula-11.0.1.old/autoconf/configure.in 2021-02-11 14:09:48.635047858 +0100
|
|
||||||
+++ bacula-11.0.1/autoconf/configure.in 2021-02-11 14:10:48.026027852 +0100
|
|
||||||
@@ -3274,11 +3274,6 @@
|
|
||||||
AC_DEFINE(FDLIBS)
|
|
||||||
|
|
||||||
CFLAGS=${CFLAGS--O}
|
|
||||||
-
|
|
||||||
-if test x$have_gcc = xyes ; then
|
|
||||||
- CPPFLAGS="$CPPFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
|
|
||||||
- CFLAGS="$CFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
|
|
||||||
-fi
|
|
||||||
LDFLAGS=${LDFLAGS--O}
|
|
||||||
CPPFLAGS="$CPPFLAGS"
|
|
||||||
CFLAGS="$CFLAGS"
|
|
@ -1,7 +1,7 @@
|
|||||||
diff -Naur bacula-11.0.1.old/autoconf/configure.in bacula-11.0.1/autoconf/configure.in
|
diff -Naur bacula-11.0.6.old/autoconf/configure.in bacula-11.0.6/autoconf/configure.in
|
||||||
--- bacula-11.0.1.old/autoconf/configure.in 2021-02-11 14:11:00.673236537 +0100
|
--- bacula-11.0.6.old/autoconf/configure.in 2022-03-26 15:50:09.232270232 +0100
|
||||||
+++ bacula-11.0.1/autoconf/configure.in 2021-02-11 14:11:36.910834489 +0100
|
+++ bacula-11.0.6/autoconf/configure.in 2022-03-26 15:50:24.774542471 +0100
|
||||||
@@ -3798,7 +3798,7 @@
|
@@ -3859,7 +3859,7 @@
|
||||||
cd src/qt-console
|
cd src/qt-console
|
||||||
chmod 755 install_conf_file build-depkgs-qt-console
|
chmod 755 install_conf_file build-depkgs-qt-console
|
||||||
cd tray-monitor
|
cd tray-monitor
|
||||||
@ -10,21 +10,70 @@ diff -Naur bacula-11.0.1.old/autoconf/configure.in bacula-11.0.1/autoconf/config
|
|||||||
cd ${BUILD_DIR}
|
cd ${BUILD_DIR}
|
||||||
|
|
||||||
cd scripts
|
cd scripts
|
||||||
diff -Naur bacula-11.0.1.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.1/examples/nagios/check_bacula/Makefile.in
|
diff -Naur bacula-11.0.6.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.6/examples/nagios/check_bacula/Makefile.in
|
||||||
--- bacula-11.0.1.old/examples/nagios/check_bacula/Makefile.in 2021-02-11 14:09:48.630047776 +0100
|
--- bacula-11.0.6.old/examples/nagios/check_bacula/Makefile.in 2022-03-26 15:44:08.615953788 +0100
|
||||||
+++ bacula-11.0.1/examples/nagios/check_bacula/Makefile.in 2021-02-11 14:11:07.708352620 +0100
|
+++ bacula-11.0.6/examples/nagios/check_bacula/Makefile.in 2022-03-26 15:50:24.775542488 +0100
|
||||||
@@ -72,7 +72,7 @@
|
@@ -72,7 +72,8 @@
|
||||||
(cd $(srcdir); $(RMF) Makefile)
|
(cd $(srcdir); $(RMF) Makefile)
|
||||||
|
|
||||||
install: all
|
install: all
|
||||||
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
||||||
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
+ $(MKDIR) $(DESTDIR)$(libdir)/nagios/plugins
|
||||||
|
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(libdir)/nagios/plugins/check_bacula
|
||||||
|
|
||||||
uninstall:
|
uninstall:
|
||||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
||||||
diff -Naur bacula-11.0.1.old/src/qt-console/bat.pro.in bacula-11.0.1/src/qt-console/bat.pro.in
|
diff -Naur bacula-11.0.6.old/src/cats/make_sqlite3_tables.in bacula-11.0.6/src/cats/make_sqlite3_tables.in
|
||||||
--- bacula-11.0.1.old/src/qt-console/bat.pro.in 2021-02-11 14:09:48.599047264 +0100
|
--- bacula-11.0.6.old/src/cats/make_sqlite3_tables.in 2022-03-26 15:44:08.497951721 +0100
|
||||||
+++ bacula-11.0.1/src/qt-console/bat.pro.in 2021-02-11 14:11:07.742353181 +0100
|
+++ bacula-11.0.6/src/cats/make_sqlite3_tables.in 2022-03-26 15:50:30.181637182 +0100
|
||||||
|
@@ -555,4 +555,5 @@
|
||||||
|
echo ""
|
||||||
|
|
||||||
|
chmod 640 ${db_name}.db
|
||||||
|
+chown bacula:bacula ${db_name}.db
|
||||||
|
exit 0
|
||||||
|
diff -Naur bacula-11.0.6.old/src/dird/bacula-dir.conf.in bacula-11.0.6/src/dird/bacula-dir.conf.in
|
||||||
|
--- bacula-11.0.6.old/src/dird/bacula-dir.conf.in 2022-03-26 15:44:08.560952825 +0100
|
||||||
|
+++ bacula-11.0.6/src/dird/bacula-dir.conf.in 2022-03-26 15:50:27.421588838 +0100
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
Director { # define myself
|
||||||
|
Name = @basename@-dir
|
||||||
|
DIRport = @dir_port@ # where we listen for UA connections
|
||||||
|
- QueryFile = "@scriptdir@/query.sql"
|
||||||
|
+ QueryFile = "@sysconfdir@/query.sql"
|
||||||
|
WorkingDirectory = "@working_dir@"
|
||||||
|
PidDirectory = "@piddir@"
|
||||||
|
Maximum Concurrent Jobs = 20
|
||||||
|
diff -Naur bacula-11.0.6.old/src/dird/Makefile.in bacula-11.0.6/src/dird/Makefile.in
|
||||||
|
--- bacula-11.0.6.old/src/dird/Makefile.in 2022-03-26 15:44:08.560952825 +0100
|
||||||
|
+++ bacula-11.0.6/src/dird/Makefile.in 2022-03-26 15:50:27.452589381 +0100
|
||||||
|
@@ -125,11 +125,11 @@
|
||||||
|
@if test "x${dir_group}" != "x"; then \
|
||||||
|
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||||
|
fi
|
||||||
|
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
||||||
|
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
||||||
|
echo " ==> Saving existing query.sql to query.sql.old"; \
|
||||||
|
- $(MV) -f ${DESTDIR}${scriptdir}/query.sql ${DESTDIR}${scriptdir}/query.sql.old; \
|
||||||
|
+ $(MV) -f ${DESTDIR}${sysconfdir}/query.sql ${DESTDIR}${sysconfdir}/query.sql.old; \
|
||||||
|
fi
|
||||||
|
- ${INSTALL_DATA} query.sql ${DESTDIR}${scriptdir}/query.sql
|
||||||
|
+ ${INSTALL_DATA} query.sql ${DESTDIR}${sysconfdir}/query.sql
|
||||||
|
@if test -f static-bacula-dir; then \
|
||||||
|
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
||||||
|
fi
|
||||||
|
@@ -138,7 +138,7 @@
|
||||||
|
uninstall:
|
||||||
|
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir bdirjson)
|
||||||
|
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
||||||
|
- (cd $(DESTDIR)$(scriptdir); $(RMF) query.sql)
|
||||||
|
+ (cd $(DESTDIR)$(sysconfdir); $(RMF) query.sql)
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
diff -Naur bacula-11.0.6.old/src/qt-console/bat.pro.in bacula-11.0.6/src/qt-console/bat.pro.in
|
||||||
|
--- bacula-11.0.6.old/src/qt-console/bat.pro.in 2022-03-26 15:50:09.233270249 +0100
|
||||||
|
+++ bacula-11.0.6/src/qt-console/bat.pro.in 2022-03-26 15:50:24.807543049 +0100
|
||||||
@@ -12,7 +12,7 @@
|
@@ -12,7 +12,7 @@
|
||||||
|
|
||||||
datarootdir = @datarootdir@
|
datarootdir = @datarootdir@
|
||||||
@ -34,9 +83,9 @@ diff -Naur bacula-11.0.1.old/src/qt-console/bat.pro.in bacula-11.0.1/src/qt-cons
|
|||||||
confs.path = /$(DESTDIR)@sysconfdir@
|
confs.path = /$(DESTDIR)@sysconfdir@
|
||||||
confs.commands = ./install_conf_file
|
confs.commands = ./install_conf_file
|
||||||
help.path = /$(DESTDIR)@htmldir@
|
help.path = /$(DESTDIR)@htmldir@
|
||||||
diff -Naur bacula-11.0.1.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.1/src/qt-console/tray-monitor/tray-monitor.pro.in
|
diff -Naur bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||||
--- bacula-11.0.1.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2021-02-11 14:09:48.603047330 +0100
|
--- bacula-11.0.6.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:50:09.234270267 +0100
|
||||||
+++ bacula-11.0.1/src/qt-console/tray-monitor/tray-monitor.pro.in 2021-02-11 14:11:07.743353198 +0100
|
+++ bacula-11.0.6/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-03-26 15:50:24.807543049 +0100
|
||||||
@@ -26,7 +26,7 @@
|
@@ -26,7 +26,7 @@
|
||||||
|
|
||||||
|
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -Naur bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.0/examples/nagios/check_bacula/Makefile.in
|
|
||||||
--- bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in 2021-01-15 14:28:41.415719526 +0100
|
|
||||||
+++ bacula-11.0.0/examples/nagios/check_bacula/Makefile.in 2021-01-15 15:01:26.371678793 +0100
|
|
||||||
@@ -72,7 +72,8 @@
|
|
||||||
(cd $(srcdir); $(RMF) Makefile)
|
|
||||||
|
|
||||||
install: all
|
|
||||||
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
|
||||||
+ $(MKDIR) $(DESTDIR)$(libdir)/nagios/plugins
|
|
||||||
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(libdir)/nagios/plugins/check_bacula
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
|
@ -1,39 +0,0 @@
|
|||||||
diff -Naur bacula-11.0.0.old/src/dird/bacula-dir.conf.in bacula-11.0.0/src/dird/bacula-dir.conf.in
|
|
||||||
--- bacula-11.0.0.old/src/dird/bacula-dir.conf.in 2021-01-12 12:36:32.650470459 +0100
|
|
||||||
+++ bacula-11.0.0/src/dird/bacula-dir.conf.in 2021-01-12 12:36:38.297573839 +0100
|
|
||||||
@@ -18,7 +18,7 @@
|
|
||||||
Director { # define myself
|
|
||||||
Name = @basename@-dir
|
|
||||||
DIRport = @dir_port@ # where we listen for UA connections
|
|
||||||
- QueryFile = "@scriptdir@/query.sql"
|
|
||||||
+ QueryFile = "@sysconfdir@/query.sql"
|
|
||||||
WorkingDirectory = "@working_dir@"
|
|
||||||
PidDirectory = "@piddir@"
|
|
||||||
Maximum Concurrent Jobs = 20
|
|
||||||
diff -Naur bacula-11.0.0.old/src/dird/Makefile.in bacula-11.0.0/src/dird/Makefile.in
|
|
||||||
--- bacula-11.0.0.old/src/dird/Makefile.in 2021-01-12 12:36:32.657470588 +0100
|
|
||||||
+++ bacula-11.0.0/src/dird/Makefile.in 2021-01-12 12:37:37.827663637 +0100
|
|
||||||
@@ -125,11 +125,11 @@
|
|
||||||
@if test "x${dir_group}" != "x"; then \
|
|
||||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
|
||||||
fi
|
|
||||||
- @if test -f ${DESTDIR}${scriptdir}/query.sql; then \
|
|
||||||
+ @if test -f ${DESTDIR}${sysconfdir}/query.sql; then \
|
|
||||||
echo " ==> Saving existing query.sql to query.sql.old"; \
|
|
||||||
- $(MV) -f ${DESTDIR}${scriptdir}/query.sql ${DESTDIR}${scriptdir}/query.sql.old; \
|
|
||||||
+ $(MV) -f ${DESTDIR}${sysconfdir}/query.sql ${DESTDIR}${sysconfdir}/query.sql.old; \
|
|
||||||
fi
|
|
||||||
- ${INSTALL_DATA} query.sql ${DESTDIR}${scriptdir}/query.sql
|
|
||||||
+ ${INSTALL_DATA} query.sql ${DESTDIR}${sysconfdir}/query.sql
|
|
||||||
@if test -f static-bacula-dir; then \
|
|
||||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) static-bacula-dir $(DESTDIR)$(sbindir)/static-bacula-dir; \
|
|
||||||
fi
|
|
||||||
@@ -138,7 +138,7 @@
|
|
||||||
uninstall:
|
|
||||||
(cd $(DESTDIR)$(sbindir); $(RMF) bacula-dir bdirjson)
|
|
||||||
(cd $(DESTDIR)$(sysconfdir); $(RMF) bacula-dir.conf bacula-dir.conf.new)
|
|
||||||
- (cd $(DESTDIR)$(scriptdir); $(RMF) query.sql)
|
|
||||||
+ (cd $(DESTDIR)$(sysconfdir); $(RMF) query.sql)
|
|
||||||
|
|
||||||
|
|
||||||
|
|
@ -1,9 +0,0 @@
|
|||||||
diff -Naur bacula-11.0.0.old/src/cats/make_sqlite3_tables.in bacula-11.0.0/src/cats/make_sqlite3_tables.in
|
|
||||||
--- bacula-11.0.0.old/src/cats/make_sqlite3_tables.in 2021-01-12 12:36:32.660470643 +0100
|
|
||||||
+++ bacula-11.0.0/src/cats/make_sqlite3_tables.in 2021-01-12 12:38:45.241897767 +0100
|
|
||||||
@@ -555,4 +555,5 @@
|
|
||||||
echo ""
|
|
||||||
|
|
||||||
chmod 640 ${db_name}.db
|
|
||||||
+chown bacula:bacula ${db_name}.db
|
|
||||||
exit 0
|
|
23
bacula-traceback-man.patch
Normal file
23
bacula-traceback-man.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
Description: Fix libexec path in man-pages
|
||||||
|
Author: Sven Hartge <sven@svenhartge.de>
|
||||||
|
Forwarded: not-needed
|
||||||
|
|
||||||
|
--- a/manpages/btraceback.8
|
||||||
|
+++ b/manpages/btraceback.8
|
||||||
|
@@ -45,14 +45,14 @@
|
||||||
|
|
||||||
|
.SH FILES
|
||||||
|
.TP
|
||||||
|
-.I /usr/lib/bacula/btraceback
|
||||||
|
+.I /usr/libexec/bacula/btraceback
|
||||||
|
.RS
|
||||||
|
The script itself.
|
||||||
|
.RE
|
||||||
|
.TP
|
||||||
|
.I /usr/sbin/btraceback
|
||||||
|
.RS
|
||||||
|
-symbolic link to \fI/usr/lib/bacula/btraceback\fR
|
||||||
|
+symbolic link to \fI/usr/libexec/bacula/btraceback\fR
|
||||||
|
.RE
|
||||||
|
.TP
|
||||||
|
.I /etc/bacula/scripts/btraceback.gdb
|
27
bacula.spec
27
bacula.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 11.0.6
|
Version: 11.0.6
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -25,24 +25,22 @@ Source17: %{name}-sd.sysconfig
|
|||||||
Source19: https://salsa.debian.org/bacula-team/bacula/-/raw/master/debian/additions/bacula-tray-monitor.png#/bacula-tray-monitor.png
|
Source19: https://salsa.debian.org/bacula-team/bacula/-/raw/master/debian/additions/bacula-tray-monitor.png#/bacula-tray-monitor.png
|
||||||
|
|
||||||
Patch1: %{name}-openssl.patch
|
Patch1: %{name}-openssl.patch
|
||||||
Patch2: %{name}-queryfile.patch
|
Patch2: %{name}-bat-build.patch
|
||||||
Patch3: %{name}-sqlite-priv.patch
|
Patch3: %{name}-seg-fault.patch
|
||||||
Patch4: %{name}-bat-build.patch
|
Patch4: %{name}-logwatch.patch
|
||||||
Patch5: %{name}-seg-fault.patch
|
Patch5: %{name}-non-free-code.patch
|
||||||
Patch6: %{name}-logwatch.patch
|
Patch6: %{name}-desktop.patch
|
||||||
Patch7: %{name}-non-free-code.patch
|
Patch7: %{name}-compile-options.patch
|
||||||
Patch8: %{name}-desktop.patch
|
Patch8: %{name}-install.patch
|
||||||
Patch9: %{name}-g++-options.patch
|
Patch9: %{name}-docker-plugin.patch
|
||||||
Patch10: %{name}-install.patch
|
Patch10: %{name}-build-cdp-plugin.patch
|
||||||
Patch11: %{name}-docker-plugin.patch
|
Patch11: %{name}-traceback-man.patch
|
||||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||||
# Without this, there is no library providing the correct shared object name
|
# Without this, there is no library providing the correct shared object name
|
||||||
# required by the daemons.
|
# required by the daemons.
|
||||||
# http://bugs.bacula.org/view.php?id=2084
|
# http://bugs.bacula.org/view.php?id=2084
|
||||||
Patch12: %{name}-autoconf.patch
|
Patch12: %{name}-autoconf.patch
|
||||||
Patch13: %{name}-build-cdp-plugin.patch
|
|
||||||
Patch14: %{name}-nagios.patch
|
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -630,6 +628,9 @@ exit 0
|
|||||||
%{_libdir}/nagios/plugins/check_bacula
|
%{_libdir}/nagios/plugins/check_bacula
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Mar 26 2022 Simone Caronni <negativo17@gmail.com> - 11.0.6-2
|
||||||
|
- Update/reorganize patches.
|
||||||
|
|
||||||
* Fri Mar 25 2022 Simone Caronni <negativo17@gmail.com> - 11.0.6-1
|
* Fri Mar 25 2022 Simone Caronni <negativo17@gmail.com> - 11.0.6-1
|
||||||
- Update to 11.0.6.
|
- Update to 11.0.6.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user