Update to 11.0.2
This commit is contained in:
parent
a41734c023
commit
6e8326d9d5
1
.gitignore
vendored
1
.gitignore
vendored
@ -54,3 +54,4 @@ bacula-docs-5.0.3.tar.bz2
|
|||||||
/bacula-9.6.7.tar.gz
|
/bacula-9.6.7.tar.gz
|
||||||
/bacula-11.0.0.tar.gz
|
/bacula-11.0.0.tar.gz
|
||||||
/bacula-11.0.1.tar.gz
|
/bacula-11.0.1.tar.gz
|
||||||
|
/bacula-11.0.2.tar.gz
|
||||||
|
12
bacula-nagios-check-fix.patch
Normal file
12
bacula-nagios-check-fix.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Naur bacula-11.0.2.old/examples/nagios/check_bacula/check_bacula.c bacula-11.0.2/examples/nagios/check_bacula/check_bacula.c
|
||||||
|
--- bacula-11.0.2.old/examples/nagios/check_bacula/check_bacula.c 2021-04-16 13:14:48.443226030 +0200
|
||||||
|
+++ bacula-11.0.2/examples/nagios/check_bacula/check_bacula.c 2021-04-16 13:15:04.773497587 +0200
|
||||||
|
@@ -324,7 +324,7 @@
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (strncmp(item->D_sock, "Events:", strlen("Events:")) == 0) {
|
||||||
|
+ if (strncmp(item->D_sock->msg, "Events:", strlen("Events:")) == 0) {
|
||||||
|
/* Daemons can send events to the director, ignore them here */
|
||||||
|
continue;
|
||||||
|
}
|
@ -1,6 +1,6 @@
|
|||||||
diff -Naur bacula-11.0.1.old/src/lib/lib.h bacula-11.0.1/src/lib/lib.h
|
diff -Naur bacula-11.0.2.old/src/lib/lib.h bacula-11.0.2/src/lib/lib.h
|
||||||
--- bacula-11.0.1.old/src/lib/lib.h 2021-02-11 14:09:48.598047248 +0100
|
--- bacula-11.0.2.old/src/lib/lib.h 2021-04-16 13:03:57.372394803 +0200
|
||||||
+++ bacula-11.0.1/src/lib/lib.h 2021-02-11 14:10:04.432308524 +0100
|
+++ bacula-11.0.2/src/lib/lib.h 2021-04-16 13:04:05.322527064 +0200
|
||||||
@@ -57,7 +57,6 @@
|
@@ -57,7 +57,6 @@
|
||||||
#include "fnmatch.h"
|
#include "fnmatch.h"
|
||||||
#endif
|
#endif
|
||||||
@ -9,9 +9,9 @@ diff -Naur bacula-11.0.1.old/src/lib/lib.h bacula-11.0.1/src/lib/lib.h
|
|||||||
#include "tree.h"
|
#include "tree.h"
|
||||||
#include "watchdog.h"
|
#include "watchdog.h"
|
||||||
#include "btimers.h"
|
#include "btimers.h"
|
||||||
diff -Naur bacula-11.0.1.old/src/lib/Makefile.in bacula-11.0.1/src/lib/Makefile.in
|
diff -Naur bacula-11.0.2.old/src/lib/Makefile.in bacula-11.0.2/src/lib/Makefile.in
|
||||||
--- bacula-11.0.1.old/src/lib/Makefile.in 2021-02-11 14:09:48.598047248 +0100
|
--- bacula-11.0.2.old/src/lib/Makefile.in 2021-04-16 13:03:57.372394803 +0200
|
||||||
+++ bacula-11.0.1/src/lib/Makefile.in 2021-02-11 14:10:04.433308540 +0100
|
+++ bacula-11.0.2/src/lib/Makefile.in 2021-04-16 13:04:05.356527630 +0200
|
||||||
@@ -40,7 +40,7 @@
|
@@ -40,7 +40,7 @@
|
||||||
flist.h fnmatch.h guid_to_name.h htable.h lex.h \
|
flist.h fnmatch.h guid_to_name.h htable.h lex.h \
|
||||||
lib.h lz4.h md5.h mem_pool.h message.h \
|
lib.h lz4.h md5.h mem_pool.h message.h \
|
||||||
@ -52,7 +52,7 @@ diff -Naur bacula-11.0.1.old/src/lib/Makefile.in bacula-11.0.1/src/lib/Makefile.
|
|||||||
-
|
-
|
||||||
bsnprintf_test: Makefile libbac.la bsnprintf.c unittests.o
|
bsnprintf_test: Makefile libbac.la bsnprintf.c unittests.o
|
||||||
$(RMF) bsnprintf.o
|
$(RMF) bsnprintf.o
|
||||||
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) bsnprintf.c
|
$(CXX) -DTEST_PROGRAM $(DEFS) $(DEBUG) -c $(CPPFLAGS) -I$(srcdir) -I$(basedir) $(DINCLUDE) $(CFLAGS) -Wno-format-truncation bsnprintf.c
|
||||||
@@ -397,7 +381,7 @@
|
@@ -397,7 +381,7 @@
|
||||||
|
|
||||||
clean: libtool-clean
|
clean: libtool-clean
|
||||||
@ -62,9 +62,9 @@ diff -Naur bacula-11.0.1.old/src/lib/Makefile.in bacula-11.0.1/src/lib/Makefile.
|
|||||||
|
|
||||||
realclean: clean
|
realclean: clean
|
||||||
@$(RMF) tags
|
@$(RMF) tags
|
||||||
diff -Naur bacula-11.0.1.old/src/lib/sha1.c bacula-11.0.1/src/lib/sha1.c
|
diff -Naur bacula-11.0.2.old/src/lib/sha1.c bacula-11.0.2/src/lib/sha1.c
|
||||||
--- bacula-11.0.1.old/src/lib/sha1.c 2021-02-11 14:09:48.598047248 +0100
|
--- bacula-11.0.2.old/src/lib/sha1.c 2021-04-16 13:03:57.372394803 +0200
|
||||||
+++ bacula-11.0.1/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
+++ bacula-11.0.2/src/lib/sha1.c 1970-01-01 01:00:00.000000000 +0100
|
||||||
@@ -1,517 +0,0 @@
|
@@ -1,517 +0,0 @@
|
||||||
-/*
|
-/*
|
||||||
- * sha1.c
|
- * sha1.c
|
||||||
@ -583,9 +583,9 @@ diff -Naur bacula-11.0.1.old/src/lib/sha1.c bacula-11.0.1/src/lib/sha1.c
|
|||||||
- fclose(fd);
|
- fclose(fd);
|
||||||
-}
|
-}
|
||||||
-#endif /* SHA1_SUM */
|
-#endif /* SHA1_SUM */
|
||||||
diff -Naur bacula-11.0.1.old/src/lib/sha1.h bacula-11.0.1/src/lib/sha1.h
|
diff -Naur bacula-11.0.2.old/src/lib/sha1.h bacula-11.0.2/src/lib/sha1.h
|
||||||
--- bacula-11.0.1.old/src/lib/sha1.h 2021-02-11 14:09:48.599047264 +0100
|
--- bacula-11.0.2.old/src/lib/sha1.h 2021-04-16 13:03:57.373394819 +0200
|
||||||
+++ bacula-11.0.1/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
+++ bacula-11.0.2/src/lib/sha1.h 1970-01-01 01:00:00.000000000 +0100
|
||||||
@@ -1,107 +0,0 @@
|
@@ -1,107 +0,0 @@
|
||||||
-/*
|
-/*
|
||||||
- * sha1.h
|
- * sha1.h
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
%global username bacula
|
%global username bacula
|
||||||
|
|
||||||
Name: bacula
|
Name: bacula
|
||||||
Version: 11.0.1
|
Version: 11.0.2
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||||
# See LICENSE for details
|
# See LICENSE for details
|
||||||
License: AGPLv3 with exceptions
|
License: AGPLv3 with exceptions
|
||||||
@ -43,6 +43,8 @@ Patch11: %{name}-docker-plugin.patch
|
|||||||
Patch12: %{name}-autoconf.patch
|
Patch12: %{name}-autoconf.patch
|
||||||
Patch13: %{name}-build-cdp-plugin.patch
|
Patch13: %{name}-build-cdp-plugin.patch
|
||||||
Patch14: %{name}-nagios.patch
|
Patch14: %{name}-nagios.patch
|
||||||
|
# Included in 11.0.3 - https://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-11.0&id=ef3a7fe40a2aee5e7acb3bf3144bba713c9cf982:
|
||||||
|
Patch15: %{name}-nagios-check-fix.patch
|
||||||
|
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: perl-generators
|
BuildRequires: perl-generators
|
||||||
@ -626,6 +628,9 @@ exit 0
|
|||||||
%{_libdir}/nagios/plugins/check_bacula
|
%{_libdir}/nagios/plugins/check_bacula
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 16 2021 Simone Caronni <negativo17@gmail.com> - 11.0.2-1
|
||||||
|
- Update to 11.0.2.
|
||||||
|
|
||||||
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 11.0.1-2
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 11.0.1-2
|
||||||
- Rebuilt for updated systemd-rpm-macros
|
- Rebuilt for updated systemd-rpm-macros
|
||||||
See https://pagure.io/fesco/issue/2583.
|
See https://pagure.io/fesco/issue/2583.
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (bacula-11.0.1.tar.gz) = d2ac473f322ba5eec8737f02b12bcee6feafc0185cbc92feee4b9f5f33f1ce622a6de75fbec41b3f3709463c7aa661ada2daa9985cab1b71d271af7cb55cd4ca
|
SHA512 (bacula-11.0.2.tar.gz) = 7e90352036a544b6a508547ae38660ca5d59b0bfd17126f346652e5c9977367ad9fe972e3f2823c10e7f8ffdcd1623ef24e8a82de030041762f0c0e09783e65c
|
||||||
|
Loading…
Reference in New Issue
Block a user