Fix bat build and compiler settings

This commit is contained in:
Simone Caronni 2018-05-14 13:19:34 +02:00
parent 78e9afd3cd
commit 665925f521
2 changed files with 41 additions and 1 deletions

View File

@ -0,0 +1,30 @@
diff -Naur bacula-9.0.7.old/autoconf/configure.in bacula-9.0.7/autoconf/configure.in
--- bacula-9.0.7.old/autoconf/configure.in 2018-05-14 13:11:00.903170609 +0200
+++ bacula-9.0.7/autoconf/configure.in 2018-05-14 13:14:07.173620200 +0200
@@ -2947,11 +2947,6 @@
AC_DEFINE(FDLIBS)
CFLAGS=${CFLAGS--O}
-
-if test x$have_gcc = xyes ; then
- CPPFLAGS="$CPPFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
- CFLAGS="$CFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
-fi
LDFLAGS=${LDFLAGS--O}
CPPFLAGS="$CPPFLAGS"
CFLAGS="$CFLAGS"
diff -Naur bacula-9.0.7.old/configure bacula-9.0.7/configure
--- bacula-9.0.7.old/configure 2018-05-14 13:11:00.822169109 +0200
+++ bacula-9.0.7/configure 2018-05-14 13:13:59.495478007 +0200
@@ -30826,11 +30826,6 @@
CFLAGS=${CFLAGS--O}
-
-if test x$have_gcc = xyes ; then
- CPPFLAGS="$CPPFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
- CFLAGS="$CFLAGS -x c++ -fno-strict-aliasing -fno-exceptions -fno-rtti"
-fi
LDFLAGS=${LDFLAGS--O}
CPPFLAGS="$CPPFLAGS"
CFLAGS="$CFLAGS"

View File

@ -6,7 +6,7 @@
Name: bacula
Version: 9.0.7
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
# See LICENSE for details
License: AGPLv3 with exceptions
@ -42,6 +42,7 @@ Patch7: %{name}-9.0.0-non-free-code.patch
Patch8: %{name}-9.0.2-desktop.patch
# http://bugs.bacula.org/view.php?id=2354
Patch9: %{name}-9.0.6-tray-monitor-task.patch
Patch10: %{name}-9.0.7-g++-options.patch
BuildRequires: desktop-file-utils
BuildRequires: perl-generators
@ -319,6 +320,7 @@ Provides check_bacula support for Nagios.
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
@ -404,6 +406,10 @@ rm -f %{buildroot}%{_libdir}/libbaccats-%{version}.so
# Bat
install -p -m 644 -D src/qt-console/images/bat_icon.png %{buildroot}%{_datadir}/pixmaps/bat_icon.png
install -p -m 644 -D scripts/bat.desktop %{buildroot}%{_datadir}/applications/bat.desktop
%if 0%{?fedora} >= 28 || 0%{?rhel} > 7
# ?
install -p -m 755 -D src/qt-console/.libs/bat %{buildroot}%{_sbindir}/bat
%endif
# QT Tray monitor
install -p -m 755 -D src/qt-console/tray-monitor/bacula-tray-monitor %{buildroot}%{_sbindir}/bacula-tray-monitor
@ -733,6 +739,10 @@ fi
%{_libdir}/nagios/plugins/check_bacula
%changelog
* Mon May 14 2018 Simone Caronni <negativo17@gmail.com> - 9.0.7-2
- Fix bat build on Fedora 28.
- Remove hardcoded compiler settings (#1551679).
* Mon May 14 2018 Simone Caronni <negativo17@gmail.com> - 9.0.7-1
- Update to 9.0.7.
- Do not override libbaccats soname anymore. As of Fedora 28, the RPM assembly