Add back patch inadvertently removed during upstream 7.0 release
This commit is contained in:
parent
58263aca58
commit
5f381d68db
35
bacula-7.0.4-autoconf.patch
Normal file
35
bacula-7.0.4-autoconf.patch
Normal file
@ -0,0 +1,35 @@
|
||||
diff -Naur bacula-7.0.4.old/autoconf/ltmain.sh bacula-7.0.4/autoconf/ltmain.sh
|
||||
--- bacula-7.0.4.old/autoconf/ltmain.sh 2014-07-24 17:43:23.085243360 +0200
|
||||
+++ bacula-7.0.4/autoconf/ltmain.sh 2014-07-24 17:45:12.505330842 +0200
|
||||
@@ -2429,6 +2429,7 @@
|
||||
-R[ ]LIBDIR add LIBDIR to the runtime path of programs and libraries
|
||||
-shared only do dynamic linking of libtool libraries
|
||||
-shrext SUFFIX override the standard shared library file extension
|
||||
+ -soname SONAME override the standard shared object name
|
||||
-static do not do any dynamic linking of uninstalled libtool libraries
|
||||
-static-libtool-libs
|
||||
do not do any dynamic linking of libtool libraries
|
||||
@@ -5434,6 +5435,11 @@
|
||||
prev=
|
||||
continue
|
||||
;;
|
||||
+ soname)
|
||||
+ soname_spec="$arg"
|
||||
+ prev=
|
||||
+ continue
|
||||
+ ;;
|
||||
weak)
|
||||
func_append weak_libs " $arg"
|
||||
prev=
|
||||
@@ -5754,6 +5760,11 @@
|
||||
continue
|
||||
;;
|
||||
|
||||
+ -soname)
|
||||
+ prev=soname
|
||||
+ continue
|
||||
+ ;;
|
||||
+
|
||||
-static | -static-libtool-libs)
|
||||
# The effects of -static are defined in a previous loop.
|
||||
# We used to do the same as -all-static on platforms that
|
38
bacula.spec
38
bacula.spec
@ -1,25 +1,9 @@
|
||||
%global uid 133
|
||||
%global username bacula
|
||||
|
||||
# Prevent the non-existant libbacats-x.x.x.so library to be required. The library
|
||||
# is provided by the libbacats-database-x.x.x.so variants and selected with the
|
||||
# update-alternatives mechanism.
|
||||
# RPM complains, as the shared object name it is always libbacats-x.x.x.so in all
|
||||
# the database shared object variants.
|
||||
%if 0%{?rhel} == 5 || 0%{?rhel} == 6
|
||||
%{?filter_setup:
|
||||
%filter_from_provides /^libbaccats.*\.so.*/d;
|
||||
%filter_from_requires /^libbaccats.*\.so.*/d;
|
||||
%filter_setup
|
||||
}
|
||||
%else
|
||||
%global __provides_exclude ^libbaccats.*\\.so.*$
|
||||
%global __requires_exclude ^libbaccats.*\\.so.*$
|
||||
%endif
|
||||
|
||||
Name: bacula
|
||||
Version: 7.0.4
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -55,6 +39,7 @@ Patch5: %{name}-7.0.3-seg-fault.patch
|
||||
Patch6: %{name}-5.2.13-logwatch.patch
|
||||
Patch7: %{name}-7.0.3-non-free-code.patch
|
||||
Patch8: %{name}-7.0.3-tray-monitor-configure.patch
|
||||
Patch9: %{name}-7.0.4-autoconf.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl
|
||||
@ -318,6 +303,7 @@ Provides check_bacula support for Nagios.
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||
|
||||
# Remove execution permissions from files we're packaging as docs later on
|
||||
@ -475,17 +461,9 @@ rm -rf %{buildroot}
|
||||
exit 0
|
||||
|
||||
%post libs-sql
|
||||
# Add alternative on unversioned library, so it's not broken during upgrades,
|
||||
# and use the versioned library as a slave alternative.
|
||||
/usr/sbin/alternatives \
|
||||
--install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-mysql.so 50 \
|
||||
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-mysql-%{version}.so
|
||||
/usr/sbin/alternatives \
|
||||
--install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-sqlite3.so 40 \
|
||||
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-sqlite3-%{version}.so
|
||||
/usr/sbin/alternatives \
|
||||
--install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-postgresql.so 60 \
|
||||
--slave %{_libdir}/libbaccats-%{version}.so libbaccats-%{version}.so %{_libdir}/libbaccats-postgresql-%{version}.so
|
||||
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-mysql.so 50
|
||||
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-sqlite3.so 40
|
||||
/usr/sbin/alternatives --install %{_libdir}/libbaccats.so libbaccats.so %{_libdir}/libbaccats-postgresql.so 60
|
||||
|
||||
# Fix for automatic selection of backends during upgrades
|
||||
if readlink /etc/alternatives/libbaccats.so | grep --silent mysql || \
|
||||
@ -760,6 +738,10 @@ fi
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Thu Jul 24 2014 Simone Caronni <negativo17@gmail.com> - 7.0.4-3
|
||||
- Remove RPM filters, add back patch inadvertently removed during 7.0 upstream
|
||||
release.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user