Port configure script to C99
Related to: <https://fedoraproject.org/wiki/Changes/PortingToModernC> <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
This commit is contained in:
parent
be6619026a
commit
4b87613045
38
bacula-configure-c99.patch
Normal file
38
bacula-configure-c99.patch
Normal file
@ -0,0 +1,38 @@
|
||||
autoconf: Do not call exit in the getaddrinfo check
|
||||
|
||||
The exit function is not declared in this context, so the check
|
||||
will always fail with compilers which do not accept implicit function
|
||||
declarations. Change the return type of main to int and return
|
||||
directly from main instead.
|
||||
|
||||
Submitted upstream: <https://gitlab.bacula.org/bacula-community-edition/bacula-community/-/issues/2666>
|
||||
|
||||
diff --git a/autoconf/configure.in b/autoconf/configure.in
|
||||
index 56cb94e9a904b47d..937ad330fb68d77b 100644
|
||||
--- a/autoconf/configure.in
|
||||
+++ b/autoconf/configure.in
|
||||
@@ -2585,7 +2585,7 @@ AC_CACHE_CHECK(for working getaddrinfo, ac_cv_working_getaddrinfo,
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
|
||||
- void main(void) {
|
||||
+ int main(void) {
|
||||
struct addrinfo hints, *ai;
|
||||
int error;
|
||||
|
||||
@@ -2594,12 +2594,12 @@ AC_CACHE_CHECK(for working getaddrinfo, ac_cv_working_getaddrinfo,
|
||||
hints.ai_socktype = SOCK_STREAM;
|
||||
error = getaddrinfo("127.0.0.1", NULL, &hints, &ai);
|
||||
if (error) {
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
}
|
||||
if (ai->ai_addr->sa_family != AF_INET) {
|
||||
- exit(1);
|
||||
+ return 1;
|
||||
}
|
||||
- exit(0);
|
||||
+ return 0;
|
||||
}
|
||||
],[
|
||||
ac_cv_working_getaddrinfo="yes"
|
@ -3,7 +3,7 @@
|
||||
|
||||
Name: bacula
|
||||
Version: 13.0.1
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -42,6 +42,7 @@ Patch8: %{name}-docker-plugin.patch
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch9: %{name}-autoconf.patch
|
||||
Patch10: %{name}-scripts.patch
|
||||
Patch11: bacula-configure-c99.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-generators
|
||||
@ -642,6 +643,9 @@ exit 0
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Mon Dec 19 2022 Florian Weimer <fweimer@redhat.com> - 13.0.1-5
|
||||
- Port configure script to C99
|
||||
|
||||
* Tue Nov 29 2022 Simone Caronni <negativo17@gmail.com> - 13.0.1-4
|
||||
- Fix isworm script.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user