Rework patches
This commit is contained in:
parent
d5a5ca16e2
commit
499204a276
@ -1,39 +0,0 @@
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/bat.pro.in bacula-11.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-11.0.0.old/src/qt-console/bat.pro.in 2021-01-12 12:36:32.639470258 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/bat.pro.in 2021-01-12 12:39:13.647417778 +0100
|
||||
@@ -6,7 +6,7 @@
|
||||
#
|
||||
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
|
||||
#
|
||||
-CONFIG += qt debug @QWT@
|
||||
+CONFIG += qt release @QWT@
|
||||
|
||||
greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
|
||||
|
||||
@@ -15,7 +15,7 @@
|
||||
bins.files = bat
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
confs.commands = ./install_conf_file
|
||||
-help.path = /$(DESTDIR)@docdir@
|
||||
+help.path = /$(DESTDIR)@htmldir@
|
||||
help.files = help/*.html images/status.png images/mail-message-new.png
|
||||
|
||||
TEMPLATE = app
|
||||
diff -Naur bacula-11.0.0.old/src/qt-console/main.cpp bacula-11.0.0/src/qt-console/main.cpp
|
||||
--- bacula-11.0.0.old/src/qt-console/main.cpp 2021-01-12 12:36:32.640470277 +0100
|
||||
+++ bacula-11.0.0/src/qt-console/main.cpp 2021-01-12 12:39:13.647417778 +0100
|
||||
@@ -29,11 +29,11 @@
|
||||
#include <QTranslator>
|
||||
|
||||
/*
|
||||
- * We need Qt version 4.8.4 or later to be able to comple correctly
|
||||
+ * We need Qt version 4.6.2 or later to be able to comple correctly
|
||||
*/
|
||||
-#if QT_VERSION < 0x040804
|
||||
+#if QT_VERSION < 0x040602
|
||||
#error "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
-#error "You need Qt version 4.8.4 or later to build Bat"
|
||||
+#error "You need Qt version 4.6.2 or later to build Bat"
|
||||
#error "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
|
||||
#endif
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur bacula-13.0.0.old/autoconf/bacula-macros/db.m4 bacula-13.0.0/autoconf/bacula-macros/db.m4
|
||||
--- bacula-13.0.0.old/autoconf/bacula-macros/db.m4 2022-07-08 14:50:02.293058459 +0200
|
||||
+++ bacula-13.0.0/autoconf/bacula-macros/db.m4 2022-07-08 14:52:40.525902566 +0200
|
||||
--- bacula-13.0.0.old/autoconf/bacula-macros/db.m4 2022-07-13 15:03:38.205154215 +0200
|
||||
+++ bacula-13.0.0/autoconf/bacula-macros/db.m4 2022-07-13 15:03:43.486275326 +0200
|
||||
@@ -102,7 +102,7 @@
|
||||
fi
|
||||
DBI_INCLUDE=-I$DBI_INCDIR
|
||||
@ -56,8 +56,8 @@ diff -Naur bacula-13.0.0.old/autoconf/bacula-macros/db.m4 bacula-13.0.0/autoconf
|
||||
POSTGRESQL_LIBS="-L$POSTGRESQL_LIBDIR -lpq"
|
||||
fi
|
||||
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:50:02.292058441 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:52:40.528902620 +0200
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-13 15:03:38.204154192 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-13 15:03:43.489275395 +0200
|
||||
@@ -16,7 +16,7 @@
|
||||
cd ${BUILD_DIR}
|
||||
AC_SUBST(BUILD_DIR)
|
||||
@ -67,7 +67,15 @@ diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/config
|
||||
AC_CONFIG_HEADERS(src/config.h:autoconf/config.h.in)
|
||||
|
||||
dnl minimal Win32 stuff for "make clean"
|
||||
@@ -3508,11 +3508,6 @@
|
||||
@@ -217,7 +217,6 @@
|
||||
QMAKE_LIBTOOL="${BUILD_DIR}/libtool"
|
||||
FD_PLUGIN_DIR="src/plugins/fd"
|
||||
DIR_PLUGIN_DIR="src/plugins/dir"
|
||||
- DLIB="-rpath \$(libdir)"
|
||||
have_plugins=yes
|
||||
else
|
||||
DEFAULT_OBJECT_TYPE=".o"
|
||||
@@ -3508,11 +3507,6 @@
|
||||
AC_DEFINE(FDLIBS)
|
||||
|
||||
CFLAGS=${CFLAGS--O}
|
||||
@ -80,8 +88,17 @@ diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/config
|
||||
CPPFLAGS="$CPPFLAGS"
|
||||
CFLAGS="$CFLAGS"
|
||||
diff -Naur bacula-13.0.0.old/autoconf/Make.common.in bacula-13.0.0/autoconf/Make.common.in
|
||||
--- bacula-13.0.0.old/autoconf/Make.common.in 2022-07-08 14:50:02.290058405 +0200
|
||||
+++ bacula-13.0.0/autoconf/Make.common.in 2022-07-08 14:52:40.529902638 +0200
|
||||
--- bacula-13.0.0.old/autoconf/Make.common.in 2022-07-13 15:03:38.204154192 +0200
|
||||
+++ bacula-13.0.0/autoconf/Make.common.in 2022-07-13 15:03:43.490275418 +0200
|
||||
@@ -39,7 +39,7 @@
|
||||
mandir = @mandir@
|
||||
manext = 8
|
||||
|
||||
-NO_ECHO = @
|
||||
+NO_ECHO =
|
||||
|
||||
# Tools & program stuff
|
||||
CC = @CC@
|
||||
@@ -75,12 +75,12 @@
|
||||
DEFAULT_ARCHIVE_TYPE = @DEFAULT_ARCHIVE_TYPE@
|
||||
DEFAULT_SHARED_OBJECT_TYPE = @DEFAULT_SHARED_OBJECT_TYPE@
|
||||
@ -102,8 +119,8 @@ diff -Naur bacula-13.0.0.old/autoconf/Make.common.in bacula-13.0.0/autoconf/Make
|
||||
# Flags & libs
|
||||
CFLAGS = @CFLAGS@ @OPENSSL_INC@
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-08 14:50:57.498050723 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-08 14:52:40.529902638 +0200
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-13 15:03:38.149152930 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-13 15:03:43.490275418 +0200
|
||||
@@ -23,8 +23,8 @@
|
||||
DEPENDPATH += .
|
||||
INCLUDEPATH += .. . ./console ./restore ./select
|
||||
@ -115,9 +132,18 @@ diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-cons
|
||||
QMAKE_LINK = $${LIBTOOL_LINK} $(CXX)
|
||||
QMAKE_INSTALL_PROGRAM = $${LIBTOOL_INSTALL} install -m @SBINPERM@ -p
|
||||
QMAKE_CLEAN += .libs/* bat
|
||||
@@ -195,3 +195,8 @@
|
||||
QMAKE_EXTRA_TARGETS += depend
|
||||
|
||||
TRANSLATIONS += ts/bat_fr.ts ts/bat_de.ts
|
||||
+
|
||||
+QMAKE_CPPFLAGS += @CPPFLAGS@
|
||||
+QMAKE_CFLAGS += @CFLAGS@
|
||||
+QMAKE_CXXFLAGS += @CXXFLAGS@
|
||||
+QMAKE_LFLAGS += @LDFLAGS@
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:50:02.187056554 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:52:40.530902656 +0200
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-13 15:03:38.166153320 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-13 15:03:43.491275441 +0200
|
||||
@@ -36,8 +36,8 @@
|
||||
DEPENDPATH += .
|
||||
INCLUDEPATH += ../.. .
|
||||
@ -129,3 +155,12 @@ diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bac
|
||||
QMAKE_LINK = $${LIBTOOL_LINK} $(CXX)
|
||||
QMAKE_INSTALL_PROGRAM = $${LIBTOOL_INSTALL} install -m @SBINPERM@ -p
|
||||
QMAKE_CLEAN += obj/* .libs/* bacula-tray-monitor release/bacula-tray-monitor
|
||||
@@ -69,3 +69,8 @@
|
||||
INCLUDEPATH += $$JOURNAL_DIR
|
||||
|
||||
TRANSLATIONS += ts/tm_fr.ts ts/tm_de.ts ts/tm_ja.ts
|
||||
+
|
||||
+QMAKE_CPPFLAGS += @CPPFLAGS@
|
||||
+QMAKE_CFLAGS += @CFLAGS@
|
||||
+QMAKE_CXXFLAGS += @CXXFLAGS@
|
||||
+QMAKE_LFLAGS += @LDFLAGS@
|
||||
|
@ -21,14 +21,3 @@ diff -Naur bacula-9.6.5.old/scripts/bat.desktop.in bacula-9.6.5/scripts/bat.desk
|
||||
X-Desktop-File-Install-Version=0.3
|
||||
-Categories=System;Application;Utility;X-Red-Hat-Base;
|
||||
+Categories=System;Utility;
|
||||
diff -Naur bacula-9.6.5.old/scripts/Makefile.in bacula-9.6.5/scripts/Makefile.in
|
||||
--- bacula-9.6.5.old/scripts/Makefile.in 2020-07-24 09:11:40.976119619 +0200
|
||||
+++ bacula-9.6.5/scripts/Makefile.in 2020-07-24 09:17:57.725850277 +0200
|
||||
@@ -67,7 +67,6 @@
|
||||
$(MV) -f ${DESTDIR}${scriptdir}/baculabackupreport ${DESTDIR}${scriptdir}/baculabackupreport.old; \
|
||||
fi
|
||||
$(INSTALL_SCRIPT) baculabackupreport $(DESTDIR)$(scriptdir)/baculabackupreport
|
||||
- $(INSTALL_SCRIPT) bacula-tray-monitor.desktop $(DESTDIR)$(scriptdir)/bacula-tray-monitor.desktop
|
||||
chmod 0644 $(DESTDIR)$(scriptdir)/btraceback.gdb \
|
||||
$(DESTDIR)$(scriptdir)/btraceback.dbx \
|
||||
$(DESTDIR)$(scriptdir)/btraceback.mdb
|
||||
|
@ -1,18 +1,18 @@
|
||||
diff -Naur bacula-13.0.0.old/autoconf/configure.in bacula-13.0.0/autoconf/configure.in
|
||||
--- bacula-13.0.0.old/autoconf/configure.in 2022-07-08 14:52:53.890141040 +0200
|
||||
+++ bacula-13.0.0/autoconf/configure.in 2022-07-08 14:53:05.527348638 +0200
|
||||
@@ -4040,7 +4040,7 @@
|
||||
cd src/qt-console
|
||||
chmod 755 install_conf_file build-depkgs-qt-console
|
||||
cd tray-monitor
|
||||
-chmod 755 install_conf_file
|
||||
+chmod 755 install_conf_file build-depkgs-qt-console
|
||||
cd ${BUILD_DIR}
|
||||
diff -Naur bacula-13.0.0.old/autoconf/config.rpath bacula-13.0.0/autoconf/config.rpath
|
||||
--- bacula-13.0.0.old/autoconf/config.rpath 2022-07-13 15:03:38.204154192 +0200
|
||||
+++ bacula-13.0.0/autoconf/config.rpath 2022-07-13 15:43:05.223631146 +0200
|
||||
@@ -555,7 +555,7 @@
|
||||
|
||||
cd scripts
|
||||
# Flag to hardcode \$libdir into a binary during linking.
|
||||
# This must work even if \$libdir does not exist.
|
||||
-hardcode_libdir_flag_spec="$escaped_hardcode_libdir_flag_spec"
|
||||
+hardcode_libdir_flag_spec=""
|
||||
|
||||
# Whether we need a single -rpath flag with a separated argument.
|
||||
hardcode_libdir_separator="$hardcode_libdir_separator"
|
||||
diff -Naur bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-13.0.0/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:50:02.318058909 +0200
|
||||
+++ bacula-13.0.0/examples/nagios/check_bacula/Makefile.in 2022-07-08 14:53:05.527348638 +0200
|
||||
--- bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in 2022-07-13 15:03:38.216154467 +0200
|
||||
+++ bacula-13.0.0/examples/nagios/check_bacula/Makefile.in 2022-07-20 12:39:13.750123318 +0200
|
||||
@@ -72,7 +72,8 @@
|
||||
(cd $(srcdir); $(RMF) Makefile)
|
||||
|
||||
@ -23,9 +23,28 @@ diff -Naur bacula-13.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-13.
|
||||
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
||||
diff -Naur bacula-13.0.0.old/scripts/logwatch/logfile.bacula.conf.in bacula-13.0.0/scripts/logwatch/logfile.bacula.conf.in
|
||||
--- bacula-13.0.0.old/scripts/logwatch/logfile.bacula.conf.in 2022-07-13 15:03:38.130152495 +0200
|
||||
+++ bacula-13.0.0/scripts/logwatch/logfile.bacula.conf.in 2022-07-20 12:39:13.751123337 +0200
|
||||
@@ -1,3 +1,3 @@
|
||||
# What actual file? Defaults to LogPath if not absolute path....
|
||||
-LogFile = @logdir@/bacula.log
|
||||
+LogFile = @logdir@/*.log
|
||||
|
||||
diff -Naur bacula-13.0.0.old/scripts/Makefile.in bacula-13.0.0/scripts/Makefile.in
|
||||
--- bacula-13.0.0.old/scripts/Makefile.in 2022-07-13 15:03:38.127152426 +0200
|
||||
+++ bacula-13.0.0/scripts/Makefile.in 2022-07-20 12:39:13.752123356 +0200
|
||||
@@ -67,7 +67,6 @@
|
||||
$(MV) -f ${DESTDIR}${scriptdir}/baculabackupreport ${DESTDIR}${scriptdir}/baculabackupreport.old; \
|
||||
fi
|
||||
$(INSTALL_SCRIPT) baculabackupreport $(DESTDIR)$(scriptdir)/baculabackupreport
|
||||
- $(INSTALL_SCRIPT) bacula-tray-monitor.desktop $(DESTDIR)$(scriptdir)/bacula-tray-monitor.desktop
|
||||
chmod 0644 $(DESTDIR)$(scriptdir)/btraceback.gdb \
|
||||
$(DESTDIR)$(scriptdir)/btraceback.dbx \
|
||||
$(DESTDIR)$(scriptdir)/btraceback.mdb
|
||||
diff -Naur bacula-13.0.0.old/src/cats/make_sqlite3_tables.in bacula-13.0.0/src/cats/make_sqlite3_tables.in
|
||||
--- bacula-13.0.0.old/src/cats/make_sqlite3_tables.in 2022-07-08 14:50:02.173056303 +0200
|
||||
+++ bacula-13.0.0/src/cats/make_sqlite3_tables.in 2022-07-08 14:53:05.562349262 +0200
|
||||
--- bacula-13.0.0.old/src/cats/make_sqlite3_tables.in 2022-07-13 15:03:38.137152655 +0200
|
||||
+++ bacula-13.0.0/src/cats/make_sqlite3_tables.in 2022-07-20 12:39:13.753123374 +0200
|
||||
@@ -560,4 +560,5 @@
|
||||
echo ""
|
||||
|
||||
@ -33,8 +52,8 @@ diff -Naur bacula-13.0.0.old/src/cats/make_sqlite3_tables.in bacula-13.0.0/src/c
|
||||
+chown bacula:bacula ${db_name}.db
|
||||
exit 0
|
||||
diff -Naur bacula-13.0.0.old/src/dird/bacula-dir.conf.in bacula-13.0.0/src/dird/bacula-dir.conf.in
|
||||
--- bacula-13.0.0.old/src/dird/bacula-dir.conf.in 2022-07-08 14:50:02.205056878 +0200
|
||||
+++ bacula-13.0.0/src/dird/bacula-dir.conf.in 2022-07-08 14:53:05.563349280 +0200
|
||||
--- bacula-13.0.0.old/src/dird/bacula-dir.conf.in 2022-07-13 15:03:38.185153756 +0200
|
||||
+++ bacula-13.0.0/src/dird/bacula-dir.conf.in 2022-07-20 12:39:13.753123374 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
Director { # define myself
|
||||
Name = @basename@-dir
|
||||
@ -45,8 +64,8 @@ diff -Naur bacula-13.0.0.old/src/dird/bacula-dir.conf.in bacula-13.0.0/src/dird/
|
||||
PidDirectory = "@piddir@"
|
||||
Maximum Concurrent Jobs = 20
|
||||
diff -Naur bacula-13.0.0.old/src/dird/Makefile.in bacula-13.0.0/src/dird/Makefile.in
|
||||
--- bacula-13.0.0.old/src/dird/Makefile.in 2022-07-08 14:50:02.205056878 +0200
|
||||
+++ bacula-13.0.0/src/dird/Makefile.in 2022-07-08 14:53:05.564349298 +0200
|
||||
--- bacula-13.0.0.old/src/dird/Makefile.in 2022-07-13 15:03:38.185153756 +0200
|
||||
+++ bacula-13.0.0/src/dird/Makefile.in 2022-07-20 12:39:13.754123393 +0200
|
||||
@@ -126,11 +126,11 @@
|
||||
@if test "x${dir_group}" != "x"; then \
|
||||
chgrp -f ${dir_group} ${DESTDIR}${sysconfdir}/$$destconf ; \
|
||||
@ -71,10 +90,27 @@ diff -Naur bacula-13.0.0.old/src/dird/Makefile.in bacula-13.0.0/src/dird/Makefil
|
||||
|
||||
|
||||
|
||||
diff -Naur bacula-13.0.0.old/src/plugins/fd/docker/Makefile bacula-13.0.0/src/plugins/fd/docker/Makefile
|
||||
--- bacula-13.0.0.old/src/plugins/fd/docker/Makefile 2022-07-13 15:03:38.182153687 +0200
|
||||
+++ bacula-13.0.0/src/plugins/fd/docker/Makefile 2022-07-20 12:39:36.651554865 +0200
|
||||
@@ -25,11 +25,11 @@
|
||||
|
||||
.c.lo:
|
||||
@echo "Compiling $< ..."
|
||||
- $(NO_ECHO)$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -I${FDPLUGDIR} -I${LIBDIR} -DWORKDIR=\"$(DESTDIR)$(working_dir)\" -c $<
|
||||
+ $(NO_ECHO)$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -I${FDPLUGDIR} -I${LIBDIR} -DWORKDIR=\"$(working_dir)\" -c $<
|
||||
|
||||
%.lo: %.c %.h
|
||||
@echo "Pattern compiling $< ..."
|
||||
- $(NO_ECHO)$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -I${FDPLUGDIR} -I${LIBDIR} -DWORKDIR=\"$(DESTDIR)$(working_dir)\" -c $(@:.lo=.c)
|
||||
+ $(NO_ECHO)$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -I${FDPLUGDIR} -I${LIBDIR} -DWORKDIR=\"$(working_dir)\" -c $(@:.lo=.c)
|
||||
|
||||
docker-fd.la: Makefile $(DOCKEROBJ) $(PLUGINLIBDIR)/pluginlib.lo $(DOCKERSRCH)
|
||||
@echo "Linking $(@:.la=.so) ..."
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-console/bat.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-08 14:52:53.891141058 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-08 14:53:05.564349298 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
--- bacula-13.0.0.old/src/qt-console/bat.pro.in 2022-07-20 12:39:07.881012727 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/bat.pro.in 2022-07-20 12:39:13.755123412 +0200
|
||||
@@ -12,10 +12,10 @@
|
||||
|
||||
datarootdir = @datarootdir@
|
||||
bins.path = /$(DESTDIR)@sbindir@
|
||||
@ -82,10 +118,14 @@ diff -Naur bacula-13.0.0.old/src/qt-console/bat.pro.in bacula-13.0.0/src/qt-cons
|
||||
+bins.files = .libs/bat
|
||||
confs.path = /$(DESTDIR)@sysconfdir@
|
||||
confs.commands = ./install_conf_file
|
||||
help.path = /$(DESTDIR)@htmldir@
|
||||
-help.path = /$(DESTDIR)@docdir@
|
||||
+help.path = /$(DESTDIR)@htmldir@
|
||||
help.files = help/*.html images/status.png images/mail-message-new.png
|
||||
|
||||
TEMPLATE = app
|
||||
diff -Naur bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:52:53.892141076 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-08 14:53:05.565349316 +0200
|
||||
--- bacula-13.0.0.old/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-20 12:39:08.041015742 +0200
|
||||
+++ bacula-13.0.0/src/qt-console/tray-monitor/tray-monitor.pro.in 2022-07-20 12:39:13.756123431 +0200
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
|
||||
|
@ -1,9 +0,0 @@
|
||||
diff --git a/scripts/logwatch/logfile.bacula.conf.in b/scripts/logwatch/logfile.bacula.conf.in
|
||||
index 22b6e98..5d257ca 100644
|
||||
--- a/scripts/logwatch/logfile.bacula.conf.in
|
||||
+++ b/scripts/logwatch/logfile.bacula.conf.in
|
||||
@@ -1,3 +1,3 @@
|
||||
# What actual file? Defaults to LogPath if not absolute path....
|
||||
-LogFile = @logdir@/bacula.log
|
||||
+LogFile = @logdir@/*.log
|
||||
|
25
bacula.spec
25
bacula.spec
@ -25,21 +25,19 @@ Source17: %{name}-sd.sysconfig
|
||||
Source19: https://salsa.debian.org/bacula-team/bacula/-/raw/master/debian/additions/bacula-tray-monitor.png#/bacula-tray-monitor.png
|
||||
|
||||
Patch1: %{name}-openssl.patch
|
||||
Patch2: %{name}-bat-build.patch
|
||||
Patch3: %{name}-seg-fault.patch
|
||||
Patch4: %{name}-logwatch.patch
|
||||
Patch5: %{name}-non-free-code.patch
|
||||
Patch6: %{name}-desktop.patch
|
||||
Patch7: %{name}-compile-options.patch
|
||||
Patch8: %{name}-install.patch
|
||||
Patch9: %{name}-docker-plugin.patch
|
||||
Patch10: %{name}-traceback-man.patch
|
||||
Patch2: %{name}-seg-fault.patch
|
||||
Patch3: %{name}-non-free-code.patch
|
||||
Patch4: %{name}-traceback-man.patch
|
||||
Patch5: %{name}-compile-options.patch
|
||||
Patch6: %{name}-install.patch
|
||||
Patch7: %{name}-desktop.patch
|
||||
Patch8: %{name}-docker-plugin.patch
|
||||
# Original patch removed by mistake, upstream is not willing to add it again:
|
||||
# http://www.bacula.org/git/cgit.cgi/bacula/commit/?h=Branch-7.0&id=51b3b98fb77ab3c0decee455cc6c4d2eb3c5303a
|
||||
# Without this, there is no library providing the correct shared object name
|
||||
# required by the daemons.
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch11: %{name}-autoconf.patch
|
||||
Patch9: %{name}-autoconf.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-generators
|
||||
@ -284,7 +282,6 @@ cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} .
|
||||
|
||||
# Regenerate configure
|
||||
pushd autoconf
|
||||
sed -i -r 's/(hardcode_into_libs)=.*$/\1=no/' libtool/libtool.m4
|
||||
aclocal -I bacula-macros/ -I gettext-macros/ -I libtool/
|
||||
popd
|
||||
autoconf -I autoconf/ -o configure autoconf/configure.in
|
||||
@ -350,11 +347,6 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
%make_build
|
||||
%make_build -C examples/nagios/check_bacula
|
||||
|
||||
pushd src/qt-console/tray-monitor
|
||||
%{?qmake_qt5}%{!?qmake_qt5:qmake-qt5} tray-monitor.pro
|
||||
%make_build
|
||||
popd
|
||||
|
||||
%install
|
||||
%make_install
|
||||
%make_install -C examples/nagios/check_bacula
|
||||
@ -371,6 +363,7 @@ install -p -m 755 -D src/qt-console/.libs/bat %{buildroot}%{_sbindir}/bat
|
||||
install -p -m 644 -D manpages/bacula-tray-monitor.1 %{buildroot}%{_mandir}/man1/bacula-tray-monitor.1
|
||||
install -p -m 644 -D %{SOURCE19} %{buildroot}%{_datadir}/pixmaps/bacula-tray-monitor.png
|
||||
install -p -m 644 -D scripts/bacula-tray-monitor.desktop %{buildroot}%{_datadir}/applications/bacula-tray-monitor.desktop
|
||||
install -p -m 755 -D src/qt-console/tray-monitor/.libs/bacula-tray-monitor %{buildroot}%{_sbindir}/bacula-tray-monitor
|
||||
|
||||
# Logrotate
|
||||
mkdir -p %{buildroot}%{_localstatedir}/log/bacula
|
||||
|
Loading…
Reference in New Issue
Block a user