Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/bacula.git#e10f3c96b2c52f90d9408371a62a46d02d36680f
This commit is contained in:
parent
a6a1b25fa9
commit
4940420f99
43
bacula-build-cdp-plugin.patch
Normal file
43
bacula-build-cdp-plugin.patch
Normal file
@ -0,0 +1,43 @@
|
||||
diff -Naur bacula-11.0.0.old/src/plugins/fd/Makefile.in bacula-11.0.0/src/plugins/fd/Makefile.in
|
||||
--- bacula-11.0.0.old/src/plugins/fd/Makefile.in 2021-01-15 14:28:41.375718846 +0100
|
||||
+++ bacula-11.0.0/src/plugins/fd/Makefile.in 2021-01-15 14:37:51.212066769 +0100
|
||||
@@ -22,7 +22,7 @@
|
||||
.c.lo:
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I${SRCDIR} -I${FDDIR} -DTEST_PROGRAM -c $<
|
||||
|
||||
-all: bpipe-fd.la test-plugin-fd.la test-deltaseq-fd.la pluglib.lo
|
||||
+all: bpipe-fd.la cdp-fd.la test-plugin-fd.la test-deltaseq-fd.la pluglib.lo
|
||||
|
||||
example-plugin-fd.lo: example-plugin-fd.c ${FDDIR}/fd_plugins.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I../.. -I${FDDIR} -c example-plugin-fd.c
|
||||
@@ -36,8 +36,6 @@
|
||||
bpipe-fd.la: Makefile bpipe-fd$(DEFAULT_OBJECT_TYPE)
|
||||
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -shared bpipe-fd.lo -o $@ -rpath $(plugindir) -module -export-dynamic -avoid-version
|
||||
|
||||
-cdp: cdp-fd.la
|
||||
-
|
||||
cdp-fd.lo: cdp-fd.c journal.h folder-record.h file-record.h settings-record.h ${FDDIR}/fd_plugins.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -Wno-unused-function -I../.. -I${FDDIR} -c cdp-fd.c
|
||||
|
||||
@@ -47,12 +45,6 @@
|
||||
cdp-fd.la: Makefile cdp-fd$(DEFAULT_OBJECT_TYPE) journal.lo
|
||||
$(LIBTOOL_LINK) $(CXX) $(LDFLAGS) -shared cdp-fd.lo journal.lo -o $@ -rpath $(plugindir) -module -export-dynamic -avoid-version
|
||||
|
||||
-install-cdp: cdp-fd.la
|
||||
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) cdp-fd.la $(DESTDIR)$(plugindir)
|
||||
- $(RMF) $(DESTDIR)$(plugindir)/cdp-fd.la
|
||||
-
|
||||
-
|
||||
-
|
||||
test-deltaseq-fd.lo: test-deltaseq-fd.c ${FDDIR}/fd_plugins.h fd_common.h
|
||||
$(LIBTOOL_COMPILE) $(CXX) $(DEFS) $(DEBUG) $(CPPFLAGS) $(CFLAGS) -I../.. -I${FDDIR} -c test-deltaseq-fd.c
|
||||
|
||||
@@ -69,6 +61,8 @@
|
||||
$(MKDIR) $(DESTDIR)$(plugindir)
|
||||
$(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) bpipe-fd.la $(DESTDIR)$(plugindir)
|
||||
$(RMF) $(DESTDIR)$(plugindir)/bpipe-fd.la
|
||||
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) cdp-fd.la $(DESTDIR)$(plugindir)
|
||||
+ $(RMF) $(DESTDIR)$(plugindir)/cdp-fd.la
|
||||
|
||||
install-test-plugin: all
|
||||
$(MKDIR) $(DESTDIR)$(plugindir)
|
13
bacula-nagios.patch
Normal file
13
bacula-nagios.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -Naur bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in bacula-11.0.0/examples/nagios/check_bacula/Makefile.in
|
||||
--- bacula-11.0.0.old/examples/nagios/check_bacula/Makefile.in 2021-01-15 14:28:41.415719526 +0100
|
||||
+++ bacula-11.0.0/examples/nagios/check_bacula/Makefile.in 2021-01-15 15:01:26.371678793 +0100
|
||||
@@ -72,7 +72,8 @@
|
||||
(cd $(srcdir); $(RMF) Makefile)
|
||||
|
||||
install: all
|
||||
- $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(sbindir)/check_bacula
|
||||
+ $(MKDIR) $(DESTDIR)$(libdir)/nagios/plugins
|
||||
+ $(LIBTOOL_INSTALL) $(INSTALL_PROGRAM) .libs/check_bacula $(DESTDIR)$(libdir)/nagios/plugins/check_bacula
|
||||
|
||||
uninstall:
|
||||
(cd $(DESTDIR)$(sbindir); $(RMF) check_bacula)
|
17
bacula.spec
17
bacula.spec
@ -3,7 +3,7 @@
|
||||
|
||||
Name: bacula
|
||||
Version: 11.0.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Cross platform network backup for Linux, Unix, Mac and Windows
|
||||
# See LICENSE for details
|
||||
License: AGPLv3 with exceptions
|
||||
@ -40,7 +40,9 @@ Patch11: %{name}-docker-plugin.patch
|
||||
# Without this, there is no library providing the correct shared object name
|
||||
# required by the daemons.
|
||||
# http://bugs.bacula.org/view.php?id=2084
|
||||
Patch13: %{name}-autoconf.patch
|
||||
Patch12: %{name}-autoconf.patch
|
||||
Patch13: %{name}-build-cdp-plugin.patch
|
||||
Patch14: %{name}-nagios.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: perl-generators
|
||||
@ -341,6 +343,7 @@ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
%make_build
|
||||
%make_build -C src/tools/cdp-client
|
||||
%make_build -C examples/nagios/check_bacula
|
||||
|
||||
pushd src/qt-console/tray-monitor
|
||||
@ -351,9 +354,8 @@ popd
|
||||
# Convert image to png for tray monitor icon
|
||||
%install
|
||||
%make_install
|
||||
|
||||
# Nagios plugin
|
||||
install -p -m 755 -D examples/nagios/check_bacula/check_bacula %{buildroot}%{_libdir}/nagios/plugins/check_bacula
|
||||
%make_install -C src/tools/cdp-client
|
||||
%make_install -C examples/nagios/check_bacula
|
||||
|
||||
# This will be managed through alternatives, as it requires the name to NOT
|
||||
# change between upgrades, so the versioned library name can not be used.
|
||||
@ -584,9 +586,11 @@ exit 0
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/bacula-fd
|
||||
%{_mandir}/man8/bacula-fd.8*
|
||||
%{_libdir}/%{name}/bpipe-fd.so
|
||||
%{_libdir}/%{name}/cdp-fd.so
|
||||
%{_libdir}/%{name}/docker-fd.so
|
||||
%{_sbindir}/bacula-fd
|
||||
%{_sbindir}/bfdjson
|
||||
%{_sbindir}/cdp-client
|
||||
%{_unitdir}/bacula-fd.service
|
||||
|
||||
%files console
|
||||
@ -623,6 +627,9 @@ exit 0
|
||||
%{_libdir}/nagios/plugins/check_bacula
|
||||
|
||||
%changelog
|
||||
* Fri Jan 15 2021 Simone Caronni <negativo17@gmail.com> - 11.0.0-2
|
||||
- Build CDP plugin components.
|
||||
|
||||
* Tue Jan 12 2021 Simone Caronni <negativo17@gmail.com> - 11.0.0-1
|
||||
- Update to 11.0.0.
|
||||
- Enable Docker plugin.
|
||||
|
Loading…
Reference in New Issue
Block a user